Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Fehlermeldung beim Öffnen von RemoteApps beim Öffnen über Dateien aus Windows-Explorer

Mitglied: Excaliburx

Excaliburx (Level 2) - Jetzt verbinden

16.11.2011, aktualisiert 18.10.2012, 9788 Aufrufe, 10 Kommentare

Hallo zusammen,

wir haben Office 2003 auf einem Win 2008 R2 Remotedesktophost im Einsatz.
Das Office ist als RemoteApp freigegeben und per msi-Dateien ist die Option Clienterweiterungen berücksichtigen aktiviert.
Die Benutzer an den XP und Win 7 Clients starten die RemoteApps.
Die Dateierweiterungen der Clients für Office wurden nach Installation der RemoteApps-msi inkl. der Option Clienterweiterungen berücksichtigen erkannt, dies habe ich bereits auf den Clients geprüft.
Auf den Clients ist lokal kein Office installiert.
Der direkte Start des Office (Word, Execl, Outlook) über die Verknüpfung aus dem Statmenü von Windows, funktioniert ohne Schwierigkeiten.

Problem:
Startet man jedoch das Office (RemteApp) mit einem Doppelklick auf eine Word, Excel, Outlook oder PowerPoint Datei aus dem Windows-Explorer heraus, erscheint folgende Fehlermeldung:

e9cfd6907bebd5e18e85d3f5d5a4f3db - Klicke auf das Bild, um es zu vergrößern


Kennt die Meldung und deren Ursache jemand?

Was ist die Lösung dieses Problems?

Ich habe alle Einstellungen der RemteApps nochmal geprüft und konnte keine Fehleinstellung finden.

Vielen Dank für Eure Unterstützung!

Gruß
Mitglied: Ravers
16.11.2011 um 11:31 Uhr
Moin moin,

Kenne leider das RemoteApp nicht.. aber:
steht den nix in der Ereignissanzeige??

Guckst du ... mal!

Was steht in der Dateitypenverwaltung, womit soll er z.B. Word-dateien öffnen. Ist hier der Fehler zu finden??


Greetz
ravers
Bitte warten ..
Mitglied: Excaliburx
16.11.2011 um 11:32 Uhr
Hallo,

habe nun folgende Hinweise dazu gefunden:

http://www.circleofexpertise.com/forum/34-Windows-2008-Server/53913-Ser ...


Mir ist jedoch nun nicht klar, ob man, damit das mit den RemoteApps funktioniert, grundsätzlich das Laufwerksmapping lokal an den Clients für die RemoteApp-Sessions freigeben muss?



Hat jemand nähere Informationen dazu?

Gruß
Bitte warten ..
Mitglied: Excaliburx
16.11.2011, aktualisiert 18.10.2012
Hallo,

in der Ereignisanzeige ist nichts zu finden.

In der Dateitypenverwaltung stehen alle Office Dateitypen mit dem korrekten Programm, also dem RemoteApp, auch dem korrekten Symbol drin.

Ich habe eben noch folgende Thread hierzu gefunden:
https://www.administrator.de/forum/windows-server-2008-terminal-server%2 ...


Gruß
Bitte warten ..
Mitglied: DerWoWusste
17.11.2011 um 00:24 Uhr
Hi.

Geh sicher, dass am Server nicht unterbunden wird, dass lokale Laufwerke der Clients mitgenommen werden. Ist dies unterbunden, kommt der Fehler. Getestet erfolgreich mit RemoteApp Adobe Reader 10.1 und einem PDF einmal auf \\server\share, einmal auf z: (z: = \\server\share) und einmal auf einem lokalen Pfad.
Client: xp, Server: 2008/2008 R2

Fazit: es muss gehen. Was in Deinem verlinkten Artikel steht, kann ich nicht nachvollziehen. Die .rdp-Datei wird hier korrekt angelegt und zwar mit drivestoredirect:s:*
Kein editieren nötig.
Bitte warten ..
Mitglied: Excaliburx
23.11.2011 um 14:48 Uhr
Hallo,

in den RDP Einstellungen für die RemoteApps ist die Option (Haken) für Laufwerke mappen für RemoteApps gesetzt.
Trotzdem funktioniert es mit neu erzeugten und auf dem Client installierter msi-Datei nicht. Gleiche Meldung.

Nun habe ich für das RDP-Protokoll das bisher deaktivierte Mapping der Laufwerksbuchstaben aktiviert.
Trotzdem funktioniert es nicht. Gleiches Problem beim Öffnen von Dateien vom Share.

Ich werde nun in den erweiterten RDP-Einstellungen "drivestoredirect:s:" nur für die entsprechenden Netzlaufwerksbuchstaben eintragen und neue msi-Dateien erzeugen und auf dem Client installieren und testen ob es dann funktioniert.


Gruß
Bitte warten ..
Mitglied: Excaliburx
23.11.2011 um 16:37 Uhr
Hallo,

der Eintrag "drivestoredirect:s:*" in den erweiteren RDP-Einstellungen wird nicht angenommen (vom Win 2008 R2).

Hierbei handelt es sich nicht um RDP-Dateien, die für die User erstellt und auf den Clients verteilt werden, sondern um msi-Dateien, die auf dem Server anhand der RemoteApp-Programm erzeugt wurden und auf den Clients installiert wurden, um die RemoteApps so bereitzustellen.

Gruß
Bitte warten ..
Mitglied: DerWoWusste
23.11.2011 um 17:25 Uhr
Viper, schön dass Du auch mal antwortest... ist prima, sich nach einer knappen Woche wieder reinzudenken...

Nun habe ich für das RDP-Protokoll das bisher deaktivierte Mapping der Laufwerksbuchstaben aktiviert
Gut, meine Vermutung war also richtig, es war deaktiviert.

der Eintrag "drivestoredirect:s:*" in den erweiteren RDP-Einstellungen wird nicht angenommen (vom Win 2008 R2)
Prüf mal mit rsop.msc am Server, ob er die neue Einstellung für rdp-tcp korrekt übernommen hat - sieht nicht so aus. rsop darf kein Unterbinden des Alufwerksmappings mehr anzeigen.

Dann nimm Dir einen Client und geh per Vollsitzung (nicht remoteapp) rauf und nimm die Laufwerke mit - geht es da?
Bitte warten ..
Mitglied: Excaliburx
24.11.2011 um 12:01 Uhr
Hallo,

da ich auch noch andere Tätigkeiten durchführen muss, hat sich das mit der Antwort in die Länge gezogen.

Habe mit rsop.msc am Server geprüft - das deaktiverte Laufwerksmapping erscheint hier nicht mehr - somit hat der Server die lokale Richtline korrekt übernommen.

Ich werde nun nochmal neue msi-RemoteApps Dateien erzeugen und es damit testen.

In Remotdesktopsitzungen funktioniert alles - hier sind die Netzlaufwerke korrekt verbunden und das Öffnen von z.B. Office Dateien vom Share funktioniert ohne Probleme.

PS:
Grundsätzlich soll jedoch das Laufwerksmapping von lokalen Clientlaufwerken in die TS-Sessions aus Sicherheitsgründen nicht möglich sein.

Gruß
Bitte warten ..
Mitglied: Excaliburx
24.11.2011 um 14:25 Uhr
Hallo,

habe das Verhalten nun nochmals mit neu erzeugten msi-Dateien getestet - gleiches Verhalten, das Problem besteht immer noch (Fehlermeldung beim Öffnen von z.B. Office Dateien vom Client aus mit RemoteApp).

Ich habe in der durch die msi-Datei auf dem Client erzeugte rdp-Datei des RemoteApps in der RDP-Datei ersehen können, dass der Befehl "drivestoredirect:s:*" als Zeile übernommen wurde.

Ich starte heute Abend den TS mal neu, evtl. hilft das ja.

Falls jemand noch Tipps zur Lösung des Problems hat, bitte um Info.

Danke!

Gruß
Bitte warten ..
Mitglied: sunshine1907
01.11.2012, aktualisiert um 13:32 Uhr
Gibt es hierzu eigentlich nun eine hilfreiche und erfolgreiche Lösung ?. Dieses Problem scheint ja ein richtig dicker Bug des Servers zu sein, denn wenn man Google nimmt und nach Hilfe sucht, findet man viele Ansätze aber keine vernünftige und hilfreiche Lösung. Denn seit gestern melden AW die nun die RemoteApps produktiv nutzen dasselbe Problem.
Klicke ich auf ein Worddokument auf einem Netzlaufwerk, z.B: o:\daten\beispiel.doc, öffnet sich zwar durch die Verknüpfung das RemoteApp (in diesem Fall Word 2010), jedoch kommt dann die Meldung "das Programm konnte nicht gefunden werden"...
Verbinde ich dasselbe Worddokument per UNC-Pfad, also \\servername\daten\beispiel.doc öffnet sich das Dokument einwandfrei und ohne Fehler.
In der RDP-Datei und auch im paketierten MSI-Paket der App ist der Haken gesetzt, dass lokale Laufwerke in der Remotesitzung mitgenommen werden sollen, ebenso ist in der GPO die Policy auf "Nicht definiert" gesetzt. Auch wenn ich mit der Policy "rumspiele" und auf deaktiviert setze (also das er die Laufwerke auch per Policy mitnehmen soll), tut sich gar nichts. Es bleibt bei diesem Fehler. Ebenso habe ich auch schon alle dafür von Microsoft ANGEBLICH helfenden Patches installiert, den Server nun schon mehrmals neu gestartet.

Noch jemand ne Idee, oder kann man das wieder als typischen Microsoft-Schrott abstempeln, also Bug die selbst Microsoft nicht gelöst bekommt, wenn man selbst auf msdn-Seiten von MVP-Experten keine Lösung findet...
Bitte warten ..
Ähnliche Inhalte
Windows Server

Sharepoint - öffnen im Windows Explorer geht nicht

Frage von DerWoWussteWindows Server5 Kommentare

Werte Kollegen! Ich habe hier einen Sharepoint 2016 und will simpel in einer Library den Knopf "öffnen im Explorer" ...

Windows Server

Zwischenablage von Remoteapps kann nur noch Text, aber keine Dateien transportieren

gelöst Frage von DerWoWussteWindows Server7 Kommentare

Moin Kollegen. Nach Upgrade auf Server 2012 R2 spinnt die Zwischenablage ein wenig: Text macht sie noch, Dateien nicht, ...

CMS

WORDPRESS - Intranet - Explorer öffnen - nur Dateien zeigen

gelöst Frage von Ca-SchoCMS2 Kommentare

Hallo, wir haben ein kleines Intranet für unsere Firma. Wir würden gerne auch Dokumente (PDF) zum lesen zur Verfügung ...

Windows Netzwerk

Explorer schließen und öffnen

gelöst Frage von Questionmark93Windows Netzwerk5 Kommentare

Hallo, Ich möchte MEINE explorer.exe schließen und wieder öffnen. Wie lautet der befehl? Weil wenn ich es schließe via ...

Neue Wissensbeiträge
Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 14 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 20 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 1 TagSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Heiß diskutierte Inhalte
Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server25 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless22 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

SAN, NAS, DAS
Qnap TS-453S Pro - Anbindung Active Directory
Frage von JuckieSAN, NAS, DAS13 Kommentare

Hallo zusammen, ich habe hier eine Qnap TS-453S Pro die sich mal so absolut gar nicht in das Active ...