Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Fehlermeldung Unzulässige Parameteranzahl bei xcopy Batch

Mitglied: hiho

hiho (Level 1) - Jetzt verbinden

04.04.2006, aktualisiert 06.04.2006, 49225 Aufrufe, 6 Kommentare

Hallo!

Ich kenne mich nicht so gut aus mit den Computern (bin halt eine Frau ), aber ich habe versucht mich durchzuwurschteln, nachdem ich mir eine externe Festplatte zur Sicherung meiner Daten gekauft habe. Habe über den Befehl xcopy recherchiert und alles auch ganz gut verstanden, dachte ich, und dann versucht, eine solche Batch zu schreiben. Folgender Inhalt:

@echo off
xcopy c:\Dokumente und Einstellungen\Besitzer\Eigene Dateien i:\Sicherung Eigene /d /e /i /y
pause

Es gibt keine zusätzlichen Leerzeichen davor oder dahinter, alles schon kontrolliert. Aber es kommt immer diese doofe Fehlermeldung mit der unzulässigen Parameteranzahl. Ich bin schon ganz verzweifelt.

Es kann doch nciht daran liegen, dass der Ordner 'Sicherung Eigene' auf der ext. Festplatte noch nicht existiert, oder?

Wo wir gerade dabei sind: sollte ich (wenn die batch dann irgendwann mal funktioniet) auch noch den Buchstaben a/ aufnehmen? Ein Kollege hat mir irgendwas erzählt von einem Attribut, das die neuen/bearbeiteten Dateien bekommen und die dann durch a/ mit kopiert werden. Aber ist das nicht schon durch d/ abgedeckt?

Für Hilfe bin ich dankbar!

hiho

Wichtiges PS: In der Vorschau dieses Beitrags stehen meine Backslashes alle doppelt... ich weiß nicht warum und ob das auch so ist, wenn ich den Beitrag abschicke. In meiner Batch steht aber jeder Backslash nur einfach...
Mitglied: yashi
04.04.2006 um 19:12 Uhr
hiho hiho.
^^


Also Pfade mit Leerzeichen umschließen würde ich sagen.
xcopy "c:\Dokumente und Einstellungen\Besitzer\Eigene Dateien" "i:\Sicherung Eigene" /d /e /i /y
Noja. Kannst auch mal F1 drücken wenn du auf dem Desktop bist und dann xcopy eingeben - da sind alle Parameter erklärt.


mfg


/edit:
du meinst bestimmt den Parameter /d ?! Denn wenn du hinter den kein Datum schreibst, kopiert xcopy nur Dateien über die alten die NEUER sind (also seit dem letzten Backup wieder bearbeitet wurden)
Bitte warten ..
Mitglied: WithOutName
04.04.2006 um 19:24 Uhr
Ich kenne mich nicht so gut aus mit den
Computern (bin halt eine Frau ),

Bitte keine Ausreden.

@echo off
xcopy c:\Dokumente und
Einstellungen\Besitzer\Eigene Dateien
i:\Sicherung Eigene /d /e /i /y
pause

Du solltest dein Quell- und Zielverzeichnis in Anführungszeichen setzten oder generell(falls möglich) auf Leerzeichen in Datei- und Verzeichnisnamen verzichten.

Es kann doch nciht daran liegen, dass der
Ordner 'Sicherung Eigene' auf der ext.
Festplatte noch nicht existiert, oder?

Dafür hast du ja "/i".

Wo wir gerade dabei sind: sollte ich (wenn
die batch dann irgendwann mal funktioniet)
auch noch den Buchstaben a/ aufnehmen?

Nein, es sei denn du willst mit dem Archivbit arbeiten.

Aber ist das nicht schon
durch d/ abgedeckt?

Kopiert ohne Parameter nur neue Dateien.

Evtl. wirst du noch die Optionen /s /c /h benötigen.
Bitte warten ..
Mitglied: yashi
04.04.2006 um 19:37 Uhr
och.
War mein erster support. Und schon werd ich übersehen.
http://home.arcor.de/klimax/images/smileys/schnief.gif
Bitte warten ..
Mitglied: Biber
04.04.2006 um 19:44 Uhr
Moin hiho,

noch ein Schlusswort (ist ja eigentlich schon alles von yashi und WithNewName erschöpfend beantwortet worden)...

Bis Dein Batch einsetzbar ist, bau Dir vorläufig noch den Parameter "/L" mit ein.
Der zeigt dann die Dateien an, die er kopieren würde, wenn dieser xcopy mit diesen Parametern abgeschickt wird.

Und, wie auch schon geschrieben, die beiden Parameter "/a" und "/m" für Spielereien mit dem Archivbit... das ist Firlefanz. Fang da gar nicht mit an. Die sind nicht sinnvoll nutzbar, wenn Du Deine Daten immer in dasselbe Sicherungsverzeichnis sicherst (das tust Du aber, sonst wäre der "/d"-Paramater Quark).

Aber kannst ja mal Deinen Kollegen bitten, dass er mal eine sinnvolle Skizze machst, wie er denn mit dem Parameter "/a" bzw. mit dem Archivbit seine Sicherungen steuert...
Ich lese dann gerne Korrektur.. *gg

Gruß
Biber
Bitte warten ..
Mitglied: WithOutName
04.04.2006 um 20:04 Uhr
och.
War mein erster support. Und schon werd ich
übersehen.
http://home.arcor.de/klimax/images/smileys/schnief.gif

Als ich die Antwort begonnen habe, war dein Beitrag noch nicht vorhanden.
Bitte warten ..
Mitglied: hiho
06.04.2006 um 14:20 Uhr
Hallo zusammen,

danke für eure Hilfe, jetzt hat es geklappt.

Viele Grüße und schöne Ostern!

hiho
Bitte warten ..
Ähnliche Inhalte
Batch & Shell
Batch Xcopy Probleme
gelöst Frage von GtaGamerBatch & Shell3 Kommentare

Hallo Administrator Community, Zurzeit versuche ich ein Tool für GTA 5 zu entwickeln, wo beim Start mit einer Batch ...

Batch & Shell
Xcopy Batch-Datei
gelöst Frage von LauchheimerBatch & Shell3 Kommentare

Tag Leute, Ich habe in einer Batchdatei einen xcopy-Befehl. Dieser soll eine bestimmte Datei kopieren. Diesen führe ich mit ...

Windows 7

ISCSI Festplatte kann nicht initalisiert werden "Unzulässige Funktion"

Frage von metal-shotWindows 73 Kommentare

Hallo Ich habe ein kleines Bastelptrojekt nun endlich fertig. Ein HP ProLiant Microserver N54L als NAS. Darauf läst nach ...

Windows 8

Xcopy kann den Pfad nicht finden warum?

gelöst Frage von Mbrgel69Windows 86 Kommentare

Wenn ich ein Batch mit xcopy schreibe: echo off xcopy *.bat C:\test\ pause Kopiert er diese ohne Probleme! Möchte ...

Neue Wissensbeiträge
Utilities
Teamviewer 14 Verbindungsprobleme mit Proxy
Tipp von PeterleB vor 16 StundenUtilities

Nach dem Umstieg von Version 13 auf 14 wollte sich TV nicht mehr mit dem Netz verbinden, ignorierte offenbar ...

Administrator.de Feedback
Unsere Datenbank wurde umgestellt
Information von Frank vor 19 StundenAdministrator.de Feedback5 Kommentare

Hallo User, ich habe in der Nacht unsere Datenbank umgestellt. D.h. neue Version (MySQL 8) und andere Örtlichkeit. Sollte ...

Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 3 TagenSonstige Systeme6 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 3 TagenDatenschutz5 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Heiß diskutierte Inhalte
Windows 10
Programm unter Windows 10 automatisch mit administrativen Rechten starten
Frage von GrafmulderWindows 1019 Kommentare

Hallo zusammen! Zur Situation: Ich benutze Windows 10 Pro für Workstations (Build 1803) mit zwei Konten. Einem Administratorkonto und ...

Vmware
Gebrauchten ESXi- Server verkaufen: Festplatten DSGVO-konform löschen?
Frage von l.scheperVmware16 Kommentare

Hallo, wir möchten einen gebrauchten FUJITSU Server verkaufen. Auf dieser Maschine ist noch ein installiertes ESXi 5.1 und ne ...

LAN, WAN, Wireless
Empfehlung Powerline Adapter
Frage von AgilolfingerLAN, WAN, Wireless16 Kommentare

Hallo Zusammen, ich brauche eine Empfehlung von euch. Ich möchte in einem privaten Haushalt eine Powerline Lösung einrichten. Allerdings ...

Netzwerke
Server: Sporadische Netzwerk-Aussetzer
Frage von ennveeNetzwerke9 Kommentare

Liebe Community, in einer Konfiguration mit einem Windows 2016-Server (s.u.) und 8 Clients beobachten wir unregelmäßige kurze Aussetzer - ...