Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Frage zu Virtual PC und Netzwerk

Mitglied: Alien-Man

Alien-Man (Level 1) - Jetzt verbinden

15.02.2012 um 15:36 Uhr, 5171 Aufrufe, 7 Kommentare

Protokoll übergabe von Host System zum Virtuellen System

Folgendes Problem:

Ein Win3.51 System muss Virtualisiert werden.
Ich habe ein Ghost Image vom System gemacht und dieses dann unter VMWare / Virtual PC eingespielt.
VMWare machte Probleme mit VGA Karte (Treiber fehlen) also konzentriere ich mich auf Virtual PC.
Unter Virtual PC wurden alle Geräte gefunden und arbeiten normal. SUPER fertig... dachte ich
es gibt ein Problem:

Auf dem Win3.51 System läuft ein Visualisierungs Programm welches das Netzwerkprotokoll Sinec-H1 verwendet. Soweit ich weiß läuft es auf dem Laver-2.
Wie es aussieht wird es nicht übergeben vom Host-System an die Virtuelle Maschine (weder unter VMWare noch unter Virtual PC)

Nun die Frage: kennt jemand eine Möglichkeit das ich Protokolle (auch wenn sie unbekannt sind) an die Virtuelle Maschine weiter gebe?
Eine Funktion "pass-through" wie unter VMWare gibt es nicht (oder ich habe sie nicht gefunden)
(Unter VMWare hat das pass-through auch nichts gebracht.... aber wie gesagt, VMWare kommt nicht in frage. )

Ich weiß das das Win3.51 alt ist, und nein update auf neueres OS ist nicht möglich.
Mitglied: Mehonidas
15.02.2012 um 16:00 Uhr
Hallo Alien-Man,

Unter VM-Ware kann man die virtualisierte Hardware ja anpassen. Das sollte auch unter Virtual PC gehen. Dort würde ich versuchen einen geeigneten Netzwerkadapter anzulegen und in diesem dann deine fehlenden Dienste / Protokolle zu installieren. Bei VM-Ware tauchen die Adapter ganz normal in den Netzwerkoptionen als neue Geräte auf.

Bei Virtual PC hilft vielleicht der Link weiter?

Hast du mal bei Siemens angefragt ob es für das Sinec-H1-Protokoll eine Win 7 oder andere Intallation bzw. Nachfolger gibt ?

Hoffe das Hilft weiter.

Gruß Meho
Bitte warten ..
Mitglied: Alien-Man
15.02.2012 um 16:29 Uhr
Hallo Meho,

das Problem ist nicht ob Netzwerkkarte arbeitet, sondern die Übergabe des Protokolls.
Das Netzwerk arbeitet normal. Ich kann alles Pingen und alles im Netzwerk machen.
Jedoch bekommt die Virtuelle Maschine nicht die Daten vom Protokoll.
D.h. die Host Maschine (Win XP) empfängt die Daten (Konnte mit Wireshark die Daten sehen). Diese werden aber nicht (ist ja das Problem) an die Virtuelle weiter gegeben. Auch sehe ich keine anfragen von der Virtuellen Maschine an das Netzwerk.

Netzwerk -> XP (Host) -> Win3.51 (VM) -> XP (Host) -> Netzwerk (das funktioniert unter TCP/IP)
bei dem H1 Protokoll geht es nur von Netzwerk -> XP und nicht weiter
Bitte warten ..
Mitglied: Mehonidas
15.02.2012 um 18:08 Uhr
Hmmm,

unter xp (Host) Systemsteuerung --> Netzwerkverbindungen sollte deine reale Netzwerkkarte sein und die virtuelle deines Virtual PC, oder ?
dort mal bei beiden versuchen das Protokoll zu installieren.
dort mal versuchen zwischen beiden eine Netzwerkbrücke herzustellen.

Was hast du für die Virtualle Netzwerkkarte eingestellt (Bridge / NAT / ...) , im VirtualPC ?

Das meinte ich, hab aber keine Ahnung ob das was nützt. Es ist nur ein Gedankenanstoß für dich,um eventuell weiter zu machen, sollte niemand anderes eine konkrete Lösung haben.




Gruß Meho
Bitte warten ..
Mitglied: Alien-Man
16.02.2012 um 10:13 Uhr
hi,

also das mit einer weiteren Netzwerkkarte unter Systemsteuerung ist nur bei VMWare so. Virtual PC hat das nicht.
Dort habe ich die Netzwerkkarte ausgewählt die auch Physikalisch da ist. (Netzwerkadapter des physischen Computers kann man ja auswählen...)

Es muss irgendwie in den Einstellungen von Virtual PC, irgend welchen config Dateien gesagt werden das das Programm (Virtual PC) alle Protokolle (auch die unbekannten) an die Virtuelle Maschine weiter gibt...

Das Protokoll arbeitet anscheinend auf der 4ten schicht.... (http://wiki.wireshark.org/H1)
Bitte warten ..
Mitglied: DerWoWusste
20.02.2012 um 00:14 Uhr
Hi.
VMWare kommt nicht in frage
Weil Du keinen Treiber für die Graka hast? Dann installier die vmware-Tools oder gehen die nicht unter 3.51? Die regeln das mit den Treibern.
Sollte das wieder erwarten nicht laufen, dann nimm eine ältere Version von VMWare samt alten VMWare-Tools.
Bitte warten ..
Mitglied: Alien-Man
20.02.2012 um 11:01 Uhr
hey,

die vmware tools kann ich erst ab NT4.0 installieren. ich habe auch nach alten vmware versionen geguckt, aber auch da nur nt4.0

also wenn jemand eine idee für vmware hat, bin ich auch bereit dies zu probieren... aber bei vmware scheitere ich bin jetzt an den vga treibern. und ob das h1 protokoll übergeben wir weiß ich noch nicht...
Bitte warten ..
Mitglied: Alien-Man
23.02.2012 um 14:27 Uhr
Also es gibt keine Lösung für dieses Problem. Es können keine Protokolle in Virtual PC (Oder anderen Virtualisierungs Programmen) "nachinstalliert" werden. Das H1 Protokoll benutzt COTP als Transport Protokoll... dieses ist sehr alt...

Trotzdem danke für die Hilfe
Bitte warten ..
Ähnliche Inhalte
Netzwerke
Netzwerk Problem mit PC zu PC
Frage von FengShuiNetzwerke4 Kommentare

Hallo zusammen, seit kurzem habe ich ein Netzwerk Problem! Seit ich den neue Router installiert habe (Fritzbox 7490), habe ...

Windows Netzwerk
Verständniss Frage Netzwerk DHCP
gelöst Frage von racer1601Windows Netzwerk6 Kommentare

Morgen Ich habe da ein kleines Problem das ich lösen muss. Wahrscheinlich stehe nur gerade auf dem Schlauch. Einer ...

LAN, WAN, Wireless
Frage zu Apache im lokalen Netzwerk
Frage von 120735LAN, WAN, Wireless9 Kommentare

Hallo, zurzeit absolviere ich eine Weiterbildung zum Virtualisierungsadministrator. Dort beschäftigen wir uns in erste Linie mit VMware, Windows Server ...

Router & Routing
Netzwerk Routing Frage
gelöst Frage von SkullyRouter & Routing4 Kommentare

Hallo zusammen, ich hab hier mal ein kleine netzwerktechnisches Problemchen Ich hab einen Monitoring Server (MON-SRV 192.168.0.10) welcher mit ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 6 StundenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 6 StundenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Viren und Trojaner
Neue Avira Management Console Egosecure
Information von OSelbeck vor 1 TagViren und Trojaner1 Kommentar

Hallöchen zusammen, ich weiß nicht, wer von euch noch Avira einsetzt Wir haben ein paar Kunden Avira hatte ja ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 1 TagDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Heiß diskutierte Inhalte
Exchange Server
Exchange Postfach Einbindung Betriebs-rat -Arzt, Bewerbung .
Frage von YellowcakeExchange Server15 Kommentare

Hey ich habe da mal eine Denksport Aufgabe bekommen Genutzt wird ein Exchange Server 2010. hier gibt es den ...

Datenschutz
Telematikinfrastruktur Erfahrungsaustausch
Frage von MOS6581Datenschutz12 Kommentare

Moin, unter meinen Kunden befinden sich auch einige Ärzte, welche sich künftig mit der Telematikinfrastruktur-Geschichte der Gematik herumärgern dürfen. ...

Windows Server
Delgegierte OU via RDP verwalten - Objektverwaltung zuweisen
gelöst Frage von TOAOICEWindows Server12 Kommentare

Hallo, ich habe folgendes Problem. Ich möchte in meiner Domäne (Server2016), einer Gruppe (OUAdmin) Berechtigungen auf die OU Test ...

Windows Server
Downgrade von Windows Server 2016 auf 2012 - Wie vorgehen?
Frage von EstefaniaWindows Server12 Kommentare

Guten Ich habe eine Frage an Erfahrene unter euch. Durch einen InPlace Upgrade wurde Windows Server 2012 auf die ...