Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Freeradius auf ubuntu mit linksys wrt54gl und win 7

Mitglied: braindrain72

braindrain72 (Level 1) - Jetzt verbinden

31.07.2012 um 14:49 Uhr, 3636 Aufrufe, 5 Kommentare

hallo an alle,

ich habe hier auf einer minimalen ubuntu-installation nach anleitung einen freeradiusserver aufgesetzt, der hängt an einem linksys wrt54gl router. über kabel und ntradping bekomme ich ein access-accept, mit win xp funktioniert auch über wlan alles, wie es soll. nur bei den win7 rechnern kommt gar nichts am radiusserver an, er spuckt also auch keine fehlermeldung aus. wie kann das sein und wie löse ich so ein problem?
mit freundlichen grüßen aus dem rheinland,
arne
Mitglied: Dani
31.07.2012 um 15:18 Uhr
Moin Arne,
schon einige Mal diskutiert - schaust du hier. Dort findest alle Infos.


Grüße,
Dani
Bitte warten ..
Mitglied: braindrain72
31.07.2012 um 16:00 Uhr
danke für die schnelle antwort, dani, ich habe nach dieser anleitung die win7 rechner eingerichtet. es scheint, als würde der router win7 nicht durchlassen... ich sehe die mac-adresse des rechners im router, aber es kommt einfach keine verbindung zustande.
gruß, arne
Bitte warten ..
Mitglied: aqui
31.07.2012, aktualisiert um 16:28 Uhr
Hast du den FreeRadius mit NTRadPing getestet ?? Funktioniert es dort ?
Wenn du den FreeRadius im Debug Modus startest (-X) was sagt dir die Debug Konsole ??
Lass dir doch nicht alles einzeln mit 5 Nachfragen aus der Nase ziehen und lies dir die Troubleshooting Tips im Tutorial durch ! Dort sind alle Fallstricke beschrieben !
Nochwas:
Das Ubuntu FreeRadius Paket kommt ohne einkompilierten SSL Support (jedenfalls bei älteren Versionen). Damit bekommst du dann Probleme mit den Zertifikaten.
Du musst dir dann die Sourcen ggf. selber mit SSL Support übersetzen oder die SuSe Distro nutzen die gleich fertig mit SSL Support kommt !!
Wie gesagt wichtig sind die Debug Log Outputs und der NTRadping Test.
Was machst du WLAN Authentisierung oder 802.1x Switch Port Authentisierung ?
Bitte warten ..
Mitglied: braindrain72
31.07.2012 um 17:04 Uhr
hallo aqui,

schon so viel von dir gelesen... ich habe im serverraum ein blade mit ubuntu server, ssl und freeradius sowie den linksys wlan-router. alles nach dem genannten tutorial eingerichtet. an meinem schreibtisch sitze ich vor nem win7 rechner, der mit dem router verkabelt ist. starte ich ntradping an meinem rechner, bekomme ich das ersehnte access-accept. fahre ich den winxp-läppi hoch und schaue dabei gleichzeitig mit putty und radsniff -S auf den freeradius, so rattern schon die zeilen den bildschirm runter, noch bevor ich mich fertig angemeldet habe. ist der läppi oben, steht im putty-fenster unten: access-accept! die zertifikate sind richtig installiert, auch auf meinem verkabelten rechner, aber über wlan kommt bei win7 einfach nichts am freeradius an. wo ist der große unterschied zwischen xp und 7, der es ausmacht?
Bitte warten ..
Mitglied: aqui
31.07.2012, aktualisiert um 17:20 Uhr
Da gibt es auch keinen Unterschied denn es ist bei beiden Win Versionen absolut identisch ! Einzig das einspielen des Client Zertifikats ist etwas unterschiedlich mehr aber nicht !
Was aber wichtig ist: Du musst diese Authentisierung auch auf dem WLAN Adapter im Win7 Rechner aktivieren !! Das sollte dir klar sein, das steht ja auch so im Tutorial (Clients). Wenn du das nicht machst, dann macht der Accesspoint eine stinknormale WLAN Anmeldung OHNE radius !
Auch musst du zwingend im WLAN Accesspoint "WPA-Enterprise" einschalten und dort den Radius Server mit IP usw. konfigurieren ansonsten macht der WLAN AP keine Radius basierte Authentisierung !!
Ein Indiz dafür ist das keinerlei Radius Pakete am Server ankommen.
Beachte das die Absender IP des WLAN Accesspoints mit dem die Radius Requests gesendet werden nicht irgendwo in einer Firewall oder lokalen Firewall (Server) geblockt werden wenn die aus einem Fremdnetz kommen und auch das die WLAN AP IP Adresse in der client.conf am Radius Server eingetragen ist. Ggf. die Firewall am Radius Server erstmal temporär deaktivieren für die Tests.
Im ersten Step empfiehlt es sich in der clients.conf das gesamte Netz einzutragen um den o.a. Fallstrick zu umgehen.
Änderungen and der clients.conf und an der users erfordern immer einen FreeRadius Restart was dir aber vermutlich bewusst ist.
Dein Problem ist also NICHT der Radius Server (ausgeniommen ggf. dessen lokale Firewall) denn der ist OK was du an dem "Access accept" ja eindeutig siehst.
Das Problem ist der WLAN AP selber der keine Radius Pakete sendet, sei es weil du ihn nicht richtig konfiguriert hast oder weil diese Pakete irgendwo hängenbleiben.
Ping also mal vom Radius Server diese AP IP und vice versa ! Auf DAS Gerät solltest du also deine Suche fixieren !
P.S.: Deine Shift Taste ist defekt ! Solltest du mal reparieren !
Bitte warten ..
Ähnliche Inhalte
Router & Routing

Wie OpenVPN zu TorVPN mit dem Linksys WRT54GL?

Frage von 132767Router & Routing3 Kommentare

Hallo Leute! Ich bin offenbar zu blöd auf meinem Router eine VPN-Verbindung einzurichten. Seit einer Woche versuche ich es ...

Router & Routing

VPN mit zwei Linksys WRT54GL

Frage von Haegi75Router & Routing50 Kommentare

Hallo ich habe folgendes Problem: Gerne möchte ich meine Ferienhaussteuerung (Loxone) von ausserhalb steuern. Leider habe ich bei Standort ...

LAN, WAN, Wireless

Verbindung von zwei Linksys Wrt54gl zu einem Netzwerk

Frage von juhu8147LAN, WAN, Wireless2 Kommentare

Ist es möglich diese beiden Router zu einem Netzwerk zusammen zu führen? Habe derzeit einen als Wlan-Router fürs Internet ...

Router & Routing

(LinkSys WRT54GL v1.1) Datendurchsatz für OpenVPN erhöhen

gelöst Frage von mopaniRouter & Routing1 Kommentar

Hallo Freunde! Im Rahmen einer empirischen Studie an einem ILS-System haben wir einen älteren Router für OpenVPN (zu TorVPN.com) ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 2 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 3 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
VLAN - Offene Fragen
Frage von KnettenbrechNetzwerkgrundlagen16 Kommentare

Hallo zusammen, ich befasse mich derzeit mit dem Thema VLAN. Hierzu habe ich schon einige Guides gelesen, einschließlich des ...

Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement16 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware12 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...