Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst FTP-Zugriff hängt sich beim -list Befehl auf

Mitglied: Legat1808

Legat1808 (Level 1) - Jetzt verbinden

05.10.2009 um 13:42 Uhr, 8104 Aufrufe, 6 Kommentare

Hallo zusammen!
Ich habe ein Problem beim Zuriff auf mein NAS via FTP von aussen.

Ich habe ein NAS von QNAP und es funktioniert auch soweit recht gut. Nun habe ich den FTP Dienst auf diesem Gerät aktiviert und kann auch problemlos mit jedem x-beliebigen FTP-Client drauf zugreifen - allerdings nur lokal.

Mein Server ist von aussen via DynDNS und Portforwarding erreichbar. Ich kann Ihn auch anpingen usw.

Wenn ich mich nun von extern mit einem FTP-Client anmelden will, kann ich sehen dass ich Ordnungsgemäß angemeldet werde, er läuft auch durch, bis zum Befehl "-list" dann ist Schluss.


Wo könnte hier der Fehler liegen? Serverseitig habe ich dahingehend keine weiteren Einstellmöglichkeiten gefunden. Mit dem Putty kann ich mich auch connecten, jedoch kenn ich die UNIX-Befehle nicht, wo ich den FTP Dienst manuell Konfigurieren kann.

Freue mich gern über hilfe oder Tipps.
Mitglied: D3S3RT
05.10.2009 um 14:13 Uhr
Lies dich mal in aktiv und passiv bei FTP Verbindungen ein. Hier liegt der Hase begraben.
Bitte warten ..
Mitglied: Legat1808
05.10.2009 um 14:21 Uhr
Hallo!

Ich habe auch das bereits ins Auge gefasst und der Client verbindet sich im Aktiv Modus... da der Server in der Tat wohl Problem mit dem PASV - Mode hat.
Bitte warten ..
Mitglied: aqui
05.10.2009 um 14:51 Uhr
Versuch mal den Zugriff mit einem Browser wie dem Firefox ala ftp://<ftp_adresse>. Der benutzt immer den Passive Modus !

Details zum Active Passive Modus findest du hier:
http://www.alenfelder.com/Informatik/pass-akt-ftp.html
Bitte warten ..
Mitglied: Legat1808
05.10.2009 um 15:16 Uhr
Vielen Dank für den Link, jedoch habe ich bereits beid Varianten durchgespielt.
LogOn ist ja schon erfolgreich, aber egal welchen Client ich nehme, er "stirbt" bei diesem Befehl:

200 PORT command successful
LIST

Ab hier ist schluß. Auch habe ich bereits die Browser Variante Probiert, welche sich dann auch mehr oder weniger aufgehangen hat. Er fragt noch die Userdaten ab und das Wars dann auch schon. Kann es sein, das ich die FW Falsch konfiguriert habe?
Bitte warten ..
Mitglied: aqui
06.10.2009 um 11:12 Uhr
Dann bleibt fast nur noch ein Fragementierungsproblem übrig. Hast du mal versucht die MTU auf deinem DSL Router etwas zu verkleinern, z.B. auf 1440 ??
Damit solltest du mal etwas spielen. Am QNAP wirst du das ja wohl kaum customizen können.
Bitte warten ..
Mitglied: Legat1808
08.12.2009 um 15:37 Uhr
Hallo,

ich habe es nun nach einigem nachdenken selbst hinbekommen Es lag tatsächlich an der Firwall des Routers ( Speedport W701V)
Portforwarding war da zwar richtig konfiguriert, allerdings wollter diese Firewall den Server nochmal Explicit angegebne haben - keine Ahnung warum. ich werde mich mit diesem Router auch nicht weiter beschäftigen, da ich mir einen anderen zulegen werde. Besten Dank für die denkanstöße.

MFg
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Mehrere FTP Befehle nacheinander ausführen

gelöst Frage von newit1Batch & Shell6 Kommentare

Hallo zusammen, ich habe folgendes Problem Wie ist es möglich das alle Befehle des Skripts nacheinander ausgeführt werden? Aktuell ...

Batch & Shell

FTP Open Befehl unter Win2008 Server

Frage von greatmgmBatch & Shell

Hallo zusammen, ich steh gerade irgendwie auf dem Schlauch: Ich benutze seit Jahren den ftp-Befehl in einem Win2008R2-Server: ftp ...

Windows Server

FTP-Zugriff auf Server2016 Essential

Frage von angler2001Windows Server1 Kommentar

Guten Morgen, ich habe leider folgendes Problem. Ich habe einen Server2016 mit der Essential-Server-Rolle installiert. Soweit funktioniert auch alles ...

Festplatten, SSD, Raid

Server 2008 hängt sich bei Zugriff auf Laufwerk auf

Frage von e.t.chenFestplatten, SSD, Raid7 Kommentare

Moin, Ich habe hier einen Windows Server 2008r2 der eine Datenbankreplikation hält. Dieser läuft soweit fehlerfrei und unauffällig. In ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 4 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Olle Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 13 StundenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
OpenVPN Client Fehlermeldungen
Frage von chris84LAN, WAN, Wireless15 Kommentare

Hallo Zusammen, wir nutzen seit kurzem einen neuen Router und den OpenVPN Client. Die VPN Verbindung klappt; allerdings kommen ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit14 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...