Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Gentoo - Image Magick lässt sich nicht kompilieren

Mitglied: 39171

39171 (Level 1)

30.11.2006, aktualisiert 12:01 Uhr, 5093 Aufrufe, 3 Kommentare

Ich versuche auf meinem Gentoo Linux ein GNOME zu installieren.
Dabei möchte Portage das Paket media-gfx/imagemagick-6.3.0.5 emergen.
Dies endet aber immer in einem Kopilierungsfehler.
Ich verwende keine package.use oder package.keywords.

emerge imagemagick -pv
01.
These are the packages that would be merged, in order: 
02.
 
03.
Calculating dependencies... done! 
04.
[ebuild  N    ] media-gfx/imagemagick-6.3.0.5  USE="X jpeg mpeg perl png tiff xml zlib -bzip2 -doc -fpx -graphviz -gs -jbig -jpeg2k -lcms -nocxx -truetype -wmf" 0 kB 
05.
 
06.
Total size of downloads: 0 kB
Fehlermeldung
01.
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lMagick 
02.
collect2: ld returned 1 exit status 
03.
make[1]: *** [blib/arch/auto/Image/Magick/Magick.so] Error 1 
04.
make[1]: Leaving directory `/var/tmp/portage/imagemagick-6.3.0.5/work/ImageMagick-6.3.0/PerlMagick' 
05.
make: *** [all-perl] Error 2 
06.
make: *** Waiting for unfinished jobs.... 
07.
 
08.
!!! ERROR: media-gfx/imagemagick-6.3.0.5 failed. 
09.
Call stack: 
10.
  ebuild.sh, line 1546:   Called dyn_compile 
11.
  ebuild.sh, line 937:   Called src_compile 
12.
  imagemagick-6.3.0.5.ebuild, line 86:   Called die 
13.
 
14.
!!! compile problem 
15.
!!! If you need support, post the topmost build error, and the call stack if relevant.
/etc/make.conf
01.
# These settings were set by the catalyst build script that automatically built$ 
02.
# Please consult /etc/make.conf.example for a more detailed example 
03.
CFLAGS="-O2 -march=i686 -pipe" 
04.
CHOST="i686-pc-linux-gnu" 
05.
CXXFLAGS="${CFLAGS}" 
06.
GENTOO_MIRRORS="ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo" 
07.
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage" 
08.
MAKEOPTS="-j2" 
09.
# ACCEPT_KEYWORDS="~x86" 
10.
http_proxy="proxy.mms-dresden.de:8080" 
11.
LANGUAGE="49" 
12.
LINGUAS="de" 
13.
INPUT_DEVICES="keyboard mouse" 
14.
VIDEO_CARDS="mtx vesa" 
15.
ALSA_CARDS="intel8x0" 
16.
USE="-qt -qt3 -qt4 -arts -kde -ipv6 -ieee1394 -dvd -dvdr -cdr -bluetooth -wifi acpi gtk gtk2 gnome X alsa vcd apache2 ssl xml mysql ldap samba zlib icq jabber msn firefox javascript mime unicode aac mp3 mpeg ogg gif jpeg png tiff pdf nsplugin browserplugin"
Mitglied: Supaman
30.11.2006 um 10:57 Uhr
könnte sein, das da die libary für gif support fehlt. es ist noch nicht soo lange her das die pantente für gif ausgelaufen sind, aus dem grunde war das früher in dem paket nicht mit drin und musst von händisch zugefügt werden.
Bitte warten ..
Mitglied: 39171
30.11.2006 um 11:13 Uhr
Sozusagen soll ich die giflib einfach mal emergen?

# emerge -s giflib
01.
Searching... 
02.
[ Results for search key : giflib ] 
03.
[ Applications found : 1 ] 
04.
 
05.
*  media-libs/giflib 
06.
      Latest version available: 4.1.4 
07.
      Latest version installed: [ Not Installed ] 
08.
      Size of files: 591 kB 
09.
      Homepage:      http://sourceforge.net/projects/libungif/ 
10.
      Description:   Library to handle, display and manipulate GIF images 
11.
      License:       MIT
Es kommt immer noch der selbe Fehler wie zuvor.
Bitte warten ..
Mitglied: 39171
30.11.2006 um 12:01 Uhr
Ich habe jetzt einfach in die /etc/package.use eine Eintrag gesetzt.

01.
media-gfx/imagemagick -perl
Jetzt wurde das Paket ohne Komplikationen gemerged.
Bitte warten ..
Ähnliche Inhalte
Java
Java kompilieren
Frage von ZockervogelJava5 Kommentare

Hallo, leider habe ich überhaupt keine Ahnung von dem was ich jetzt schreibe :-) Ich habe hier ein .jar ...

MikroTik RouterOS
Metarouter - OpenWRT kompilieren
Frage von specialguestMikroTik RouterOS1 Kommentar

Moin, hat bereits irgendwer Erfahrungen gemacht beim Kompilieren von OpenWRT für die Metarouter-Virtualisierungsschicht? Meine ersten Versuche sind fehlgeschlagen. Die ...

Microsoft Office
Fehler beim Kompilieren
Frage von Nid1979Microsoft Office5 Kommentare

Hallo zusammen! ich bin absoluter Neuling in diesem Fachbereich. Habe folgende Codes erstellt, allerdings kommt die Fehlermeldung 'Fehler beim ...

Router & Routing
OpenWRT Paketen liste zum kompilieren
gelöst Frage von KammiiRouter & Routing6 Kommentare

Hallo Leute, ich bin nicht gerade zufrieden mit den fertigen OpenWRT Paketen die es für meinen Router, nun will ...

Neue Wissensbeiträge
Peripheriegeräte
Unterschrank für HP Drucker
Tipp von NixVerstehen vor 2 TagenPeripheriegeräte3 Kommentare

Als kurzen Freitags-Tipp möchte ich gerne meinen neuen Drucker-Unterschrank Modell Amica KS 15423W vorstellen. Das Gerät eignet sich hervorragend ...

Windows 10
Windows 10 - Probleme mit Point-And-Print
Tipp von emeriks vor 4 TagenWindows 103 Kommentare

Hi, wir kämpfen z.Z. mit einigen Druckertreibern, welche unter Win10 beim Verbinden eines Druckers von Printserver mit dem Dialog ...

Windows 10

Windows 10 1803 - Ihr Roamingbenutzerprofil wurde nicht vollständig synchronisiert

Anleitung von Deepsys vor 4 TagenWindows 101 Kommentar

Bei allen Windows 10 1803 PCs traten Probleme mit den Servergespeicherten Profilen auf. Das Abmelden dauerte sehr lange und ...

Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 6 TagenExchange Server7 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Heiß diskutierte Inhalte
Server-Hardware
DL380p Gen8 LEDs Laufwerksaktivität funktionieren nicht
gelöst Frage von Cisco7971Server-Hardware27 Kommentare

Hallo zusammen, ich habe hier ein seltsames Problem: Die LEDs an den Smart Carriern, die bei Laufwerksaktivität rotieren, tun ...

Windows Server
Leistungsindikatoren WS2012R2
Frage von Der.ITlerWindows Server20 Kommentare

Hallo Gemeinde, seit gestern habe ich auf zwei von meinem 8 Hardwareservern folgendes Problem, dass die Leistungsindikatoren nicht gestartet ...

Server-Hardware
Einsteigerfragen zu HP ProLiant DL380p Gen 8
gelöst Frage von brain2011Server-Hardware15 Kommentare

Hallo, ich habe mir einen HP ProLiant DL380p Gen 8 zugelegt, um mich grundlegend mit dieser Geräteklasse und der ...

DSL, VDSL
Profi VDSL-Modem
Frage von malikaDSL, VDSL12 Kommentare

Guten Tag, ich suche nach einem robusten (Temperaturen zw. +25-45 °C) und stabilen VDSL-Modem. Habt Ihr welche Erfahrungen mit ...