Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

GPO - Logon Script läuft nicht auf Clients

Mitglied: k-jonas

k-jonas (Level 1) - Jetzt verbinden

09.04.2005, aktualisiert 11.04.2005, 19490 Aufrufe, 6 Kommentare

Logon Script läuft über NETLOGON, über GPO nur am Server selbst aber nicht auf den Client-Rechnern

Hallo alle zusammen,

ich hatte bisher ein Anmeldescript (xxx.vbs) im NETLOGON-Verzeichnis liegen und hab die Ausführung über das USER-Profil geregelt. Alles klappte.

Mit der Zahl der Clients möchte ich nun das Script über eine Gruppenrichtlinie beim Logon ausführen lassen.
Ich hab die Richtlinie erstellt und das Script in den entsprechenden Ordner kopiert.
In den Eigenschaften zur Richtlinie habe ich gesichert, das "Authentifizierte Benutzer" und "Domänen-Benutzer" das Script Lesen/Ausführen können und die Gruppenrichtlinie übernommen wird.
Das Problem ist nun folgendes: Das Script läuft perfekt, wenn die Anmeldung direkt am Server geschieht. Erfolgt die Anmeldung über einen Client, dann passiert gar nichts.
Ich kann das Script auf dem Server aber durchaus manuell starten.

Die Clients haben Windows XP, SP2, sind in der Domäne angemeldet, der Server ist der bevorzugte DNS-Server und die Nutzer sind in der Gruppe Domänen-Benutzer.

Ich weiß einfach nicht, was ich hier nicht bzw. falsch gemacht haben könnte.
Mitglied: fritzo
09.04.2005 um 18:30 Uhr
Ich hab die Richtlinie erstellt und das Script in den entsprechenden Ordner kopiert.

In welchen? Es muß in einem Share liegen, an das alle Clients herankommen. Hast Du den Pfad in der Policy angegeben und wenn ja, ist es ein korrekter UNC-Pfad? Am einfachsten ist es, wenn Du es im Netlogon-Folder liegen hast und dann in der Policy einfach als Pfad %logonserver%\netlogon\xyz.vbs setzt.

In den Eigenschaften zur Richtlinie habe ich gesichert, das "Authentifizierte Benutzer" und
"Domänen-Benutzer" das Script Lesen/Ausführen können und die Gruppenrichtlinie übernommen wird.

"Authentifizierte Benutzer reicht, das schließt die Domänen-Benutzer mit ein. Allerdings würde ich evtl. nur die Domänenbenutzer nehmen, sonst ziehen Admins das evtl. auch.

Das Problem ist nun folgendes: Das Script läuft perfekt, wenn die Anmeldung direkt am Server geschieht.
Erfolgt die Anmeldung über einen Client, dann passiert gar nichts.
Ich kann das Script auf dem Server aber durchaus manuell starten.

Das hört sich danach an, als hättest Du einen lokalen Pfad gesetzt.. es muß aber ein UNC-Pfad sein, an den die Clients herankommen. Wie oben erwähnt, versuch mal mit dem o.g. Pfad.

Grüße,
fritzo
Bitte warten ..
Mitglied: gemini
09.04.2005 um 18:51 Uhr
wenn ja, ist es ein korrekter UNC-Pfad? Am
einfachsten ist es, wenn Du es im
Netlogon-Folder liegen hast und dann in der
Policy einfach als Pfad
%logonserver%\netlogon\xyz.vbs
setzt.
Wenn du Logonscripts über Policies verteilen willst, liegen die nicht im Netlogon sondern in anderen Ordnern
SYSVOL\sysvol\<<a>domain.tld<a>>\Policies\{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx}\User\Scripts\Logon
{xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxx} ist hierbei die SID der Policy


> In den Eigenschaften zur Richtlinie
habe ich gesichert, das
"Authentifizierte Benutzer" und
> "Domänen-Benutzer" das
Script Lesen/Ausführen können und
die Gruppenrichtlinie übernommen wird.
Wenn die Scripts in den entsprechenden Verzeichnissen liegen sind die Rechte auf die Policy und die Verzeichnisse automatisch richtig eingestellt. Da muss man eigentlich nichts anpassen.
Bitte warten ..
Mitglied: k-jonas
09.04.2005 um 23:04 Uhr
Vielen Dank für die Antwort,

ich hab die Datei in den betreffenden SYSVOL....Logon - Ordner kopiert, den man beim Erstellen der Richtlinie zum Öffnen angeboten bekommt. Ich denke, das ist richtig so.
Den Dateinamen selbst hab ich dann ohne Pfad angegeben.

Inzwischen dachte ich, es hilft vielleicht, mal einen Client-PC statt Nutzer in die Sicherheitsrichtlinien der betreffenden GPO aufzunehmen, ebenfalls mit der Option, die Richtlinien zu übernehmen.

Und siehe da, das Script lief am hinzugefügten Client-Rechner.
Weil ich dachte, dass kanns doch nicht sein, hab ich probehalber den Computer wieder aus den Sicherheitsrichtlinien entfernt und nochmal probiert.

Ich versteht zwar nicht wieso, aber es geht immer noch.

Wenn mir das mal einer erklären kann )
Bitte warten ..
Mitglied: gemini
10.04.2005 um 00:28 Uhr
Die Policy ist mit einer OU verlinkt und wirkt auf diese.
Die Policy selbst besteht aus den Bereichen Computerkonfiguration und Benutzerkonfiguration.
Einstellungen in Computerkonfiguration wirken auf die Computer in der jeweiligen OU, für Benutzer gilt es analog.
Bei Einstellungen, die für Computer und Benutzer getroffen werden können hat i.d.R. die Computereisntellung Vorrang.

Dein Logonscript wird unter Benutzerkonfiguration verwaltet und wirkt auch nur auf Benutzerkonten in der OU.

Und siehe da, das Script lief am hinzugefügten Client-Rechner.
stimmt deshalb nicht ganz; es lief bei der Anmeldung im Kontext eines Users der OU.
Das ist unabhängig vom Vorhandensein eines Computerkontos.
Bitte warten ..
Mitglied: k-jonas
10.04.2005 um 10:40 Uhr
Hallo gemini,

soweit blicke ich das Ganze ja auch.
Die Computerconfiguration wirkt, bevor ein Nutzer sich anmeldet, die Benutzerkonfiguration greift danach und beides jeweils nur auf berechtigte (in den Sicherheitsrichtlinien stehende) Objekte.

Nur dann hätte das Ganze ja auch schon funktionieren müssen, bevor ich temporär das Computerkonto in die Sicherheitsrichtlinie aufgenommen hatte.

M. E. sollte es doch so sein:
Stehen in den Sichereitsrichtlinien nur konkrete Computerkonten, wirkt die GPO auf diese Computer, egal wer sich da anmeldet.
Stehen dort nur konkrete Benutzerkonten, wirkt die GPO nur auf diese Nutzer, egal, an welchem PC sie sich anmelden.

Im meinem Fall schien es ja so, als müsse zumindest einmal Computerkonto und Benutzerkonto gleichzeitig berechtigt sein.
Bitte warten ..
Mitglied: seppo
11.04.2005 um 08:07 Uhr
ICh habe ein zusätzliches Skript beim ausführen. Ich hab das Skript ins Netlogon Verzeichniss gelegt und es bei der Gruppenrichtlinie angegeben.

Aber irgendwie führt der das nicht aus

Gruß

Seppo
Bitte warten ..
Ähnliche Inhalte
Exchange Server

GPO - Logon-Skript wird nicht ausgeführt

Frage von Der-PhilExchange Server4 Kommentare

Hallo! Seit heute werden meine Logon-Skripte, die ich über GPOs festlege nicht mehr gestartet. AD-Domaincontroller laufen unter Windows 2012 ...

Microsoft

GPO mit Logon Skript Probleme

gelöst Frage von Thor01Microsoft9 Kommentare

Hallo zusammen, ich habe eine GPO mit einem Logon Skript erstellt welches mit ganz doof per Net Use ein ...

Batch & Shell

Standarddrucker per Logon Script

gelöst Frage von QugartBatch & Shell10 Kommentare

Hallo zusammen! ich hab hier einen Drucker, den ich per Logon Script als Standard zuweisen will. Der Drucker namens ...

Windows Userverwaltung

Logon script bleibt hängen

Frage von frakaciWindows Userverwaltung4 Kommentare

Hallo Leute. Folgendes Problem: In unserer Domäne wird mit lokalen Profilen gearbeitet, damit die User auch offline arbeiten können. ...

Neue Wissensbeiträge
Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 20 StundenExchange Server3 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Suche Projektpartner

PC Recycling Projekte mit Flüchtlingen und Kids suchen Materialspenden und Mitmacher!

Erfahrungsbericht von NettePCyclePiraten vor 1 TagSuche Projektpartner7 Kommentare

Hallöchen liebe Kollegen, ich betreue zwei PC-Gruppen im Raum Dortmund: "Ne#e PCycle Pir@ten" & "PCschr@uber Br@mbauer" Wir sind eine ...

iOS
IOS 12.2 beta und OpenVPN iPad und iPhone
Erfahrungsbericht von magicteddy vor 1 TagiOS

Moin, kleiner Hinweis an die experimentierfreudigen unter Euch: Bei der aktuellen beta gibt es ein Problem im Zusammenspiel zwischen ...

Vmware
VMware Tools 10.3 verfügbar
Information von sabines vor 2 TagenVmware

Eine Sicherheitslücke wird mit den Tools der Version 10.3 geschlossen, die Tools müssen auf jeder VM aktualisiert werden. Näheres ...

Heiß diskutierte Inhalte
Windows Netzwerk
Netzwerk einrichten - wie mache ich es richtig?
Frage von gintonikWindows Netzwerk23 Kommentare

Hallo, ich bin neu hier und erhoffe mir hier ein paar Antworten für meine Umsetzung zu erhalten. Kurz zu ...

CPU, RAM, Mainboards
4x 2 GB DDR2 1066 gesucht
gelöst Frage von Windows10GegnerCPU, RAM, Mainboards17 Kommentare

Hallo, ich plane den RAM meines Rechners aufzurüsten. Motherboard: Gigabyte X48 DS5 Der FSB steht bei 259, daher soll ...

Microsoft Office
Druckdatum nur auf ausgedrucktem Dokument anzeigen
gelöst Frage von eichi18Microsoft Office16 Kommentare

Hallo zusammen Ich versuche in einem Word Dokument das Druckdatum nur auf dem eigentlichen Ausdruck auszugeben und am Bildschirm ...

Batch & Shell
Auswahlfenster Batch
gelöst Frage von FrankreichBatch & Shell12 Kommentare

Liebes Forum! Ich habe ein Batch Script geschrieben, bei welchem man die IP changen kann denn Namen und den ...