Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst GPO Diese Programme bei der Benutzeranmeldung ausführen Programm startet nicht

Mitglied: Shallowain

Shallowain (Level 1) - Jetzt verbinden

07.07.2014, aktualisiert 09.07.2014, 5435 Aufrufe, 7 Kommentare

Hallo zusammen,

wie im Titel erwähnt habe ich ein kleines Problem mit dem GPO "Diese Programme bei der Benutzeranmeldung ausführen".

Noch eine kurze (vereinfachte) Darstellung des AD:

OU Standort
+ OU Benutzer
-> Benutzer Bob

+OU Computer
->Gruppenrichtlinie IE starten
-> Computer Foo

Wenn sich Bob auf Foo anmeldet sollte der IE doch eigentlich starten, oder?
Die Richtlinie ist gültig für die authentifizierten Benutzer und es ist das GPO unter Benutzerkonfiguration

Als Programm ist "%ProgramFiles%\Internet Explorer\iexplorer.exe" angegeben. Wenn ich den Pfad im Explorer eingebe startet der Internet Explorer ohne Probleme. Unter HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer\Run ist der Pfad auch eingetragen. Woran könnte das liegen, dass der IE nicht geöffnet wird?

gpresult zeigt an, dass die Richtlinie "zieht".
BS ist W7 64Bit mit allen Updates


Falls noch Informationen fehlen bitte melden.

Ich bedanke mich für eure Bemühungen.

Gruß
Shallowain
Mitglied: emeriks
07.07.2014 um 19:21 Uhr
Hi,
Zitat von Shallowain:

Wenn sich Bob auf Foo anmeldet sollte der IE doch eigentlich starten, oder?
Die Richtlinie ist gültig für die authentifizierten Benutzer und es ist das GPO unter Benutzerkonfiguration
Nur, wenn für den Client der Loopback-Modus eingestellt ist, egal, ob "Zusammenführen" oder "Ersetzen". Also min. eine GPO muss dem Client für Loopback. einstellen.

gpresult zeigt an, dass die Richtlinie "zieht".
BS ist W7 64Bit mit allen Updates
Du hast Loopback nicht erwähnt. Sicher, dass die GPO für den Benutzer angewendet wird und nicht bloß für den Computer?


Wenn Die GPO nur auf FOO wirken soll, dann kannste das so machen aber eben mit Loopback.
Wenn Sie für Bob allgemein gelten soll, egal wo er sich anmeldet, dann solltest Du die GPO mit OU Benutzer verlinken. (Wir reden aber nicht vom Container "Usesrs" !?)

E.
Bitte warten ..
Mitglied: Shallowain
08.07.2014 um 07:16 Uhr
Guten Morgen emeriks,

Loopback ist mit Ersetzen aktiviert und die Richtlinie wird angewendet, weil andere GPOs, die in der Richtlinie definiert sind, durchaus Wirkung zeigen. Außerdem legt die Richtlinie ja den Registryschlüssel an, er wird nur nicht ausgeführt.
Nein wir reden nicht vom "Users" Container und ja die Richtlinie soll nur auf FOO wirken, egal wer sich anmeldet.

Gruß
Shallowain
Bitte warten ..
Mitglied: emeriks
LÖSUNG 08.07.2014, aktualisiert 09.07.2014
Was ist, wenn Du statt mit %ProgramFiles% den Pfadnamen "hart" einträgst?

E.
Bitte warten ..
Mitglied: Shallowain
09.07.2014 um 09:14 Uhr
Selbes Ergebnis, egal ob ich Programme oder Program Files schreibe und ob mit Anführungszeichen oder ohne.

Interessant ist jedoch, dass wenn ich cmd.exe eintrage oder eine Datei, welche in einem, manuell angelegten, Ordner auf %systemroot% liegt, alles ohne Probleme funktioniert.

Es scheint ein anderes GPO zu verhindern, dass Dateien aus %ProgramFiles% ausgeführt werden.

Kann man hier irgendwo Dateien hochladen? Dann würde ich mal die Richtlinie komplett hochladen, vllt findet jemand das störende GPO.

Gruß
Shallowain
Bitte warten ..
Mitglied: emeriks
09.07.2014 um 10:03 Uhr
Kannst Du kein anderes Programm aus %ProgramFiles% via HKCU Run starten?

E.
Bitte warten ..
Mitglied: Shallowain
09.07.2014 um 13:35 Uhr
Nicht mit der Systemvariablen %ProgramFiles%. Wenn ich c:\program files\ schreibe, dann ja. Wenn alle anderen GPOs der Richtlinie auf "Nicht konfiguriert" gestellt sind, kann ich über c:\program files\ auch den internet explorer öffnen. Werde die GPOs jetzt Stück für Stück wieder aktivieren, hoffe ich finde das störende Objekt.

%ProgramFiles% hat den richtigen Wert und wird von batch Dateien und dem Explorer richtig aufgelöst.

Gruß
Shallowain
Bitte warten ..
Mitglied: Shallowain
09.07.2014 um 15:36 Uhr
Ich bin nun leicht verwirrt, nachdem ich nun sämtliche andere GPOs wieder aktiviert habe, funktioniert der IE aufruf via c:\program files\ ohne Probleme. Was auch immer da für Probleme gesorgt hat ist nun weg.

Naja, der Computer, dass unbekannte Wesen ;)

Danke für deine Hilfe emeriks.

Gruß
Shallowain
Bitte warten ..
Ähnliche Inhalte
Windows Server

GPO - Programm bei der Benutzeranmeldung ausführen

Frage von Netsn00pWindows Server3 Kommentare

Hallo, ich habe eine Benutzer GPO erstellt, mit welcher bei der Benutzeranmeldung ein Programm gestartet werden soll. In diesem ...

Windows Server

GPO: Clients können Programme nicht mehr ausführen

gelöst Frage von CangaruuWindows Server2 Kommentare

Hallo, dies ist mein erster Beitrag und ich freue mich auf unseren gegenseitigen Erfahrungsaustausch. Nun zum Kern: Wir haben ...

Microsoft

Programm mit GUI als Dienst ausführen unabhängig von Benutzeranmeldung

Frage von thomasreischerMicrosoft3 Kommentare

Hallo, ich habe auf meinen Windows Server 2012 eine Anwendung mit GUI die durchgehend laufen sollte also auch wenn ...

Windows 10

Programm immer als anderer Benutzer ausführen

Frage von Ghost108Windows 108 Kommentare

Hallo zusammen, hatte vor kurzem noch Win 7 Prof und bin auf Win 10 Pro umgestiegen. Früher hatte ich ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 1 TagHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 2 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 2 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Router & Routing
Mikrotik: Routing zwischen Interfaces mit Geräten ohne Gateway
Frage von TonLichtVideoRouter & Routing18 Kommentare

Hallo zusammen, ich komme aus dem Veranstaltungstechnik Bereich und habe zwei Netze um verschiedene Hardware zu Remoten. CONTROL1 192.168.1.0/24 ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk14 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware10 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...