Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Group Policy LogonScript (Netzlaufwerk mappen) greift nicht richtig

Mitglied: TobiisFreaky

TobiisFreaky (Level 2) - Jetzt verbinden

07.03.2011 um 11:10 Uhr, 8748 Aufrufe, 2 Kommentare

Hallo!
ich bin gerade dabei ein Script zu schreiben und per GPO als LogonScript an den User zu binden. Mein Problem ist, dass das Script zwar ausgeführt wird, jedoch das Netzlaufwerk nicht gemappt wird. Das komische ist, dass das Script auf Computer mit Server 2003 reibungslos funktioniert. Nur auf den 2008/R2 Maschinen macht es Probleme. Sehr merkwürdig.
Hier zunächst einmal das Script:

Option Explicit
Dim NetworkObj, ShellObj, UserName
Set ShellObj=CreateObject("WScript.Shell")
UserName=ShellObj.ExpandEnvironmentStrings("%USERNAME%")
Set NetworkObj=CreateObject("Wscript.Network")
NetworkObj.MapNetworkDrive "J:", ("\\FileServer\Austausch\" & UserName)
Set NetworkObj=Nothing
Set ShellObj=Nothing


Wie zu sehen ist, existiert auf dem FileServer ein Ordner unterhalb von Austausch, der mit dem jeweiligen User gemappt werden soll. Füge ich in die Zeile z.B. ein MsgBox("HALLO") ein und melde mich an einer 2008/R2 Maschine an, dann poppt ein Fenster mit dem Text "HALLO" auf. Allerdings wird das Laufwerk nicht mit dem Buchstaben J: verknüpft. Führe ich das Skript hingegen nachträglich manuell aus, so wird es gemappt. Ist der Userordner auf dem FileServer nicht vorhanden, so erscheint eine Fehlermeldung, dass das Netzlaufwerk nicht gemappt werden kann. Das Skript läuft also auf dem 2008/R2 schon durch.

Habt Ihr eine Ahnung, warum oder woran es liegen könnte? Ich bin total ratlos....
Die GPO wird auf User verteilt, daher auch unter Benutzerkonfiguration das Skript angegeben. Sicherheitsfilter ist auf authenticated. Andere Skripte werden problemlos ausgeführt. Es handelt sich hierbei um ein vbs Skript.

Danke schon mal im Voraus und viele Grüße

Tobi
Mitglied: Kirschi
07.03.2011 um 12:30 Uhr
Hallo Tobi,

kann das an UAC liegen, mehr fällt mit erstmal auch nicht ein. Geht das aus ner DOS-Box zu mappen mit net use?

Gruß
Andreas
Bitte warten ..
Mitglied: TobiisFreaky
07.03.2011 um 15:13 Uhr
Hallo Andreas,

es liegt tatsächlich an der UAC. Ich habe diese auf Stufe 4 gesetzt und meinen Testserver neu gestartet. Anschließend wurde das Laufwerk gemappt. Danach UAC auf die Stufe 3 gesetzt und wieder rebootet. Anschließend wurde das Laufwerk nicht mehr gemappt. Nach Zurücksetzen auf Stufe 4 wurde es wieder gemappt. Hätte ich echt nicht vermutet, dass es mit der UAC zusammengehängt. Das Skript läuft sauber durch, jedoch wird das Mappen durch die UAC geblockt.... lol
Jetzt will ich aber nicht auf allen Servern UAC abschalten... und für diesesProblem habe ich auch bereits eine Lösung gefunden:

http://www.winfaq.de/faq_html/Content/tip2500/onlinefaq.php?h=tip2563.h ...

Per GPO wird auf allen 2008 + R2 Maschinen der Key hinzugefügt. Das Auslesen erfolgt via WMI (verknüpft in der GPO)

Hier mal der WMI Filter:
SELECT * FROM Win32_OperatingSystem where Version='6.1.7600' or Version='6.1.7601' or Version='6.0.6000' or Version='6.0.6001' or Version='6.0.6002'


Vielen Dank für deinen Tipp
Ich hoffe, dass dieser thread anderen auch weiterhilft.

Gruß,
Tobi
Bitte warten ..
Ähnliche Inhalte
VB for Applications

VB Netzlaufwerk trennen und mappen klappt nicht so richtig

gelöst Frage von Dr.CornwallisVB for Applications21 Kommentare

Liebe Gemeinde, ich habe ein VB Script, diese soll schauen ob ein Laufwerksbuchstabe vorhanden ist, ist dieser vorhanden, dann ...

Windows 10

Windows 10 - Group Policy Printer

gelöst Frage von gmossinWindows 104 Kommentare

Hallo zusammen Wir verwenden Windows 10 (1511) in Verbindung mit VMware Horizon 6.2 für unsere Schule. Wir haben nun ...

Windows Server

2008 GPO greift nicht richtig

Frage von minicoopWindows Server2 Kommentare

Hallo, folgende Umgebung: W2008 Domäne W2008R2 TS mit IE11 Es wird eine GPO auf domäne.local verknüpft, Benutzerkonfiguration, Richtlinien, Administrative ...

Windows Server

AGPM - Advanced Group Policy Manager

Frage von makaroniWindows Server1 Kommentar

Hallo zusammen, ich habe mir bzgl. der Delegierung von GPO Rechten einmal den AGPM installiert. Nun habe ich diverse ...

Neue Wissensbeiträge
Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 11 StundenSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 17 StundenWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

iOS
Updates für Iphone und Co
Information von sabines vor 21 StundeniOS

Gestern abend ist iOS 11.3.1 erschienen, ein kleineres Update, dass einige Lücken schließt und "Lahmlegen" nach einem Display Tausch ...

Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 2 TagenWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Heiß diskutierte Inhalte
Batch & Shell
Powershell: Im AD nach Rechnern mit bestimmten IP-Adressen suchen
gelöst Frage von Raven42Batch & Shell36 Kommentare

Hallo zusammen, ich suche nach einer Möglichkeit nach Computern im AD zu suchen , deren IP-Adresse mit 10.11.12. beginnt. ...

C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++34 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless25 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

Windows Server
Alten DC entfernen
Frage von smartinoWindows Server24 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...