Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Header abgeschnitten - Content-Transfer-Encoding fehlt

(Level 1)

28.08.2006 um 16:50 Uhr, 6264 Aufrufe

Original-Header wird in der E-Mail selbst angezeigt und Umlaute werden inkorrekt dargestellt

Moin moin

Edit: Problem ist gelöst - schuld war der MIMEsweeper, welcher beim hinzufügen eines Disclaimers die Codierung ignoriert hat...

Ich plage mich hier gerade mit einem merkwürdigen Problem herum. Auf unserer Webseite können unsere Mitglieder einen Antrag stellen. Dieser wird in Form einer E-Mail an unseren zuständigen Mitarbeiter im Haus übermittelt. Zusätzlich erhält der Antragsteller eine Kopie in CC.
Nun ist es leider so, dass die E-Mail bei unseren Mitarbeitern statt mit Umlauten in der ursprünglichen Codierung daherkommt. Dazu ist am Anfang der E-Mail ein Header vorangestellt, der reine E-Mailtext sieht dann ungefähr so aus:

Date: Thu, 24 Aug 2006 16:14:59 +0200
Message-ID: <[ID-zensiert1]@[HOSTNAME-WEBSERVER-zensiert4]>
MIME-Version: 1.0
Content-Type: text/plain; charset="utf-8"
Content-Transfer-Encoding: quoted-printable
X-Mailer: Microsoft CDO for Windows 2000
Thread-Index: [ID-zensiert2]==
Content-Class: urn:content-classes:message
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2800.1807
Return-Path: mailadmin@[WIR-zensiert3.tld]
X-OriginalArrivalTime: 24 Aug 2006 14:14:59.0109 (UTC)
FILETIME=[zensiert5]

---
Empf=C3=A4nger: [MA-Intern]@[WIR-zensiert3.tld]
Antragssteller(in): [Mitglied]
Mitgliedsnummer: xxxxx
Vertragsnummer: xxx.4.2

Beschreibung:
Dies ist ein Test f=C3=BCr die Darstellung von Umlauten: =C3=84=C3=96=C3=9C


Ferner hat die E-Mail natürlich noch einen richtigen Header, der so aussieht:

Microsoft Mail Internet Headers Version 2.0
Received: from proxy5.[WIR-zensiert3.tld] ([192.168.xxx.xxx]) by exchange5.[zensiert3.tld] with Microsoft SMTPSVC(6.0.xxxx.xxxx);
Thu, 24 Aug 2006 16:13:43 +0200
Received: from [zensiert6].[PROVIDER-zensiert7.tld] (vhost-xxx-xxx.xxx.[zensiert7.tld]) by
proxy5.[zensiert3.tld] (Clearswift SMTPRS 5.x.x) with SMTP id
<[ID-zensiert8]@proxy5.[zensiert3.tld]>; Thu, 24 Aug 2006 16:13:43
+0200
Received: from [HOSTNAME-WEBSERVER-zensiert4] ([62.xxx.xxx.xxx]) by [zensiert6].[PROVIDER-zensiert7.tld] with
Microsoft SMTPSVC(5.0.2195.6713); Thu, 24 Aug 2006 16:14:59 +0200
From: "WIR" <mailadmin@[WIR-zensiert3.tld]>
To: <[MA-Intern]@[WIR-zensiert3.tld]>
Cc: <[Mitglied]@[wieauchimmer.tld]>
Subject: Genehmigung von Einbauten: Fliesen
Return-Path: mailadmin@[zensiert3.tld]
Message-ID: <[zensiert9]@exchange5.[zensiert3.tld]>
X-OriginalArrivalTime: 24 Aug 2006 14:13:43.0513 (UTC) FILETIME=[81944C90:01C6C787]
Date: 24 Aug 2006 16:13:43 +0200
X-TM-AS-Product-Ver: SMEX-7.0.0.1345-3.6.1039-14648.002
X-TM-AS-Result: No--7.510900-8.000000-31

Warum die Umlaute nicht funktionieren ist klar: da
Content-Type: text/plain; charset="utf-8" und
Content-Transfer-Encoding: quoted-printable
im 'Header' innerhalb der Mail und nicht im richtigen Header stehen, wird die Original-Codierung und nicht die Umlaute angezeigt.
Das merkwürdige: die CC Kopie landet völlig korrekt mit Umlauten und ohne Anzeige des Headers innerhalb der Mail bei unseren Mitgliedern.

Für mich sieht das so aus, als würde der Header bereits auf dem Webserver abgeschnitten werden und anschließend neu aufgesetzt. Grund meiner Annahme: im 'Header' innerhalb der Mail ist kein Received: zu finden, d.h. die Mail dürfte noch nicht unterwegs gewesen sein, bevor der Header zerschnippelt wurde. Wie seht ihr das???
Der für die Webseite zuständige Dienstleister verweist nämlich auf uns und meint, bis die Mail das RZ verlässt wäre noch alles korrekt. Wenn man ihm nun glauben schenkt (immerhin kommen die Mails beim Empfänger von der CC ja korrekt an), müsste die Mail also entweder auf dem
  • Clearswift MIMEsweeper for SMTP, welcher die E-Mails aus dem Internet entgegennimmt und auf Spam überprüft oder
  • auf dem Exchange 2003 Server, welcher die E-Mails von MIMEsweeper bekommt
zerschnippelt werden. Angezeigt wird die E-Mail mit Outlook 2003.

Hat da vielleicht irgendjemand eine Idee bzw. kann meine Annahme bezüglich Received: bestätigen/verneinen? Bin für jede Anregung dankbar.

Gruß aus dem hohen Norden
Ähnliche Inhalte
Windows 7
Umgebungsvariablen werden abgeschnitten
Frage von tuCsen86Windows 72 Kommentare

Hallo zusammen, ich habe ein Problem mit einem User und kenne mich auf dem Gebiet nicht so gut aus. ...

Batch & Shell
Powershell XML und encoding
gelöst Frage von Forseti2003Batch & Shell3 Kommentare

Hallo, steh mal wieder mit PowerShell auf Kriegsfuß, zumindest finde ich keine passende Dokumentation. Folgende Codezeile hab ich: Die ...

Exchange Server

Ersten Buchstaben einer Mail werden abgeschnitten

Frage von Philipp.SExchange Server2 Kommentare

Hallo Admins, vereinzelnd kommt es immer wieder vor, dass bei Mitarbeitern die ersten Buchstaben einer Mail abeschnitten werden. z.B. ...

Exchange Server

Ungültiger header

Frage von HeinrichMExchange Server2 Kommentare

Hallo zusammen, hier auf einem SBS 2011 gibt es von Zeit zu Zeit Probleme mit dem POP Abruf vom ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 1 TagSonstige Systeme5 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 1 TagDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 1 TagWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 2 TagenHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless16 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL15 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Exchange Server
Outlook findet Postfach nicht
Frage von MaximaxExchange Server11 Kommentare

Hallo, und zwar haben wir auf der Arbeit ein kleines (großes) Exchange 2016 Problem. Exchange meldete gestern, dass die ...

Informationsdienste
Probleme auf dem Server
Frage von LangeLangeInformationsdienste9 Kommentare

Hallo zusammen, ich betreibe die Seite Keine Werbelinks. In der Analyse stellen wir fest, dass die Ladezeit in der ...