Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

HELO greeting

Mitglied: kerfte

kerfte (Level 1) - Jetzt verbinden

26.10.2011 um 12:13 Uhr, 3123 Aufrufe, 5 Kommentare

Falsche Reihenfolge des HELO greetings bei Kommunikation von 2 servern

Hallo liebe Admins,
folgendes Problem ereignet sich in unserem Email-System.
Wenn der Haupt-Mailserver unsere mails zu unserem mailserver weiterleiten will werden diese abgeblockt. Laut Aussage unseres providers liegt es an der Reihenfolge des HELO greetings.
Der Haupt-Mailserver (Exchange 2010) schickt den HELO command raus und fängt sofort an zu senden ohne vorher auf Antwort von unserem mailserver (Linux) zu warten. Deshalbt blockt unser mailserver die Emails aus Sicherheitsgründen ab und der provider weigert sich auch das zu ändern.
Die Frage ist jetzt, kann ich, oder wie kann ich das im Exchange abändern? Vielleicht gibt es auch eine andere Lösung?

Vielen Dank schonmal für eure Hilfe.

MfG
Kai
Mitglied: Pago159
26.10.2011 um 12:26 Uhr
Hallo Kai,
wenn ich das jetzt richtig gelesen habe, dann hast du doch gar keinen Zugriff auf den Exchange sondern nur auf den Linux-Mailserver,
wobei hier für Hilfe doch mehr angaben benötigt werden,
wie:

  • Welches Linux-Derivat wird eingesetzt,
  • Welcher Mailserver wird hierauf betrieben?
  • Gibt es eine Firewall.......?

Lg Grapper
Bitte warten ..
Mitglied: kerfte
26.10.2011 um 13:27 Uhr
Hallo Grapper,
deine Fragen kann ich dir bloß schwammig beantworten leider.

-Ich weiss das es ein Redhat Linux drauf hat aber nicht welche Version genau
-Sendmail
-Ja es gibt eine Firewall weiss aber nicht welche

Dieser server wird und kann von uns nur über ein web-interface gesteuert werden und dort auch mehr oder weniger nur domains und Emails.

Den Exchange-server verwalte nicht ich selbst sondern die IT in der Hauptstelle im Ausland und weil die da nich in die Pötte kommen will ich mich mal etwas schlau machen das ich ihm unter die Arme greifen kann.

Doch wie gesagt wird mein provider hier seine Einstellungen nicht ändern bezüglich der Annahme von mails ohne richtiges HELO greeting, was ich auch verstehen kann. Sprich die Exchange-Seite muss etwas ändern. Nur was?

LG
Kai
Bitte warten ..
Mitglied: Pago159
26.10.2011 um 13:59 Uhr
Weshalb muss die Exchange Seite etwas machen?
Ich habe aus deinem Anfangspost raus gelesen, dass der Linux-Mailserver die Mails verwirft und nicht der Exchangeserver?
Irgendwie bin ich ein bisschen verwirrt oder ich bin noch nicht ganz fit,
auch wenn wir schon Mittag haben.

Dein System ist also Folgendermaßen aufgebaut:

  • Mail-Provider (Schickt HELO-ANFRAGE und direkt DATEN) --> Exchange 2010 ruft die Daten beim Provider an und bekommt auch noch welche --> Sendmail ruft die Daten vom Exchange ab, hier entsteht jetzt das Problem, dass die Mails verworfen werden?

  • Bekommst du da eine Fehlermeldung oder wird das in eine Log-Datei eingetragen?

Lg GRapper
Bitte warten ..
Mitglied: kerfte
26.10.2011 um 14:38 Uhr
Eine Fehlermeldung bekommt man nicht. In den log steht der error das der Exchange unzulässig einfach Daten schickt.(Würde das rauskopieren aber der log liegt mir leider nicht vor). Der Exchange wartet den handshake nicht ab.

Zum Verständnis, System sieht so aus:
Mails kommen bei Exchange an(alles gut^^); Exchange leitet zu unserem provider weiter(handshake wird übersprungen)

Wenn der Exchange erst Antwort von unserem provider abwarten würde wäre alles gut, aber das passiert nicht.
Bitte warten ..
Mitglied: filippg
27.10.2011 um 00:35 Uhr
Hallo,

das würde mich total wundern, Exchange ist ziemlich sauber implementiert.
Aber das sollte sich ja gut überprüfen lassen: MS Network Monitor auf Exchange installieren und mal einen Dump der Kommunikation ziehen. Dann lässt sich damit eindeutig nachvollziehen, wer wann was sendet (okay, nach der TLS-Aushandlung kann man nischt mehr lesen, aber bei dir scheint's ja schon lange vorher zu scheitern).

Btw: Exchange sollte ein EHLO schicken, kein HELO. Wenn es ein HELO ist, dann scheint bei dir noch was ganz anderes schief zu laufen, und ich würde fast vermuten, dass nicht wirklich der Exchange sendet, sondern eher irgendein seltsamer Antispam-Proxy o.ä.

Gruß

Filipp
Bitte warten ..
Ähnliche Inhalte
DNS

FQDN mit HELO-String unter Plesk hinterlegen

Frage von matschi11DNS8 Kommentare

Hallo allerseits, ich habe bei Hetzner einen Server gemietet, auf dem Debian 8.5 läuft. Das System verwalte ich mit ...

Exchange Server

Name für HELO EHLO wird nicht übernommen auf Exchange 2010

Frage von QandAtExchange Server2 Kommentare

Hallo Zusammen, es geht mal wieder um einen Exchange 2010 SP3 RU14. Hier gibt es Probleme mit dem HELO ...

Exchange Server

Remote Mailserver meint, dass mein HELO-EHLO nicht in Ordnung ist!

Frage von RG2525Exchange Server11 Kommentare

Hallo Alle, Mein Mail Server funktioniert jetzt seit einigen Monaten ohne Probleme - viele hunderte Emails pro Tag. Jetzt ...

Neue Wissensbeiträge
Windows Server

Windows Server 2016: Achtung - ab heute gibt es wieder Express Updates

Information von kgborn vor 6 StundenWindows Server1 Kommentar

Kurze Info für Administratoren, die Windows Server 2016 per WSUS/SCCM mit Updates betanken. Ab heute gibt es für Windows ...

Windows Netzwerk
Windows Admin Center - Sagt was ihr braucht!
Tipp von Juanito vor 1 TagWindows Netzwerk16 Kommentare

Hallo zusammen, der ein- oder andere hat sicherlich schon vom Windows Admin Center gehört. - Microsoft's neue Adminkonsole welche ...

Verschlüsselung & Zertifikate

Bitlocker-Verschlüsselung und -Monitoring ohne MBAM

Tipp von DerWoWusste vor 2 TagenVerschlüsselung & Zertifikate

Der Folgende Tipp beschreibt, wie man ohne MBAM die Verschlüsselung erzwingt und monitort. MBAM ist ein Enterprise-Benefit und somit ...

Netzwerkprotokolle
IPv6 Konfiguration von Site-Site-VPN ohne feste IP
Anleitung von lcer00 vor 2 TagenNetzwerkprotokolle1 Kommentar

Hallo zusammen, vor einiger Zeit hatte ich hier eine Frage zu dem Thema gepostet: Da war noch etwas offen. ...

Heiß diskutierte Inhalte
Entwicklung
Meine Nachbarn sehen meinen Internet Trafic
gelöst Frage von beatnguEntwicklung51 Kommentare

Hallo Also ich wohne in einem Mehrparteien Haus mit 24 wohnungen. Meine nachbaren im letzten stock fummeln immer an ...

Windows 10
Windows 10 mit CRITICAL PROCESS DIED
Frage von liquidbaseWindows 1028 Kommentare

Das aktuelle Problem was ich habe steht bereits im Threadtitel. Etwas mehr zum Hintergrund soll nun folgen. Problemkind ist ...

Microsoft Office
Lizenzierung
Frage von opc123Microsoft Office27 Kommentare

Hallo, eventuell ein oft bekanntes Thema. Office 365 ist mir zu teuer, da wir als Bildungsträger andere Konditionen beim ...

Viren und Trojaner
Viren zu Testzwecken gesucht
Frage von ElHuttiViren und Trojaner20 Kommentare

Hallo, Ich suche zum rumtrollen auf einem alten PC Viren, die: - Keine Komponenten beschädigen - Keine Auswirkungen auf ...