Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

HP Layer 2 Switch 2510, m0n0wall Router, VLAN

Mitglied: 56268

56268 (Level 1)

03.03.2008, aktualisiert 10.03.2008, 8018 Aufrufe, 6 Kommentare

Hallo,

ich hatte die Problematik schon einmal, die wurde allerdings nicht vollständig & zufriedenstellend gelöst, also noch einmal:

Switch Config:

SWITCH (IP 192.168.0.10, Def. GW 192.168.0.1 (m0n0))
vlans:
1 default, no untagged 25,26 - 192.168.0.10
2 x, untagged 1-9, 11, tagged 25,26 192.168.1.10
3 y untagged, 10,12 tagged 25,26 192.168.10.10
4 z untagged 13-24 tagged 25,26 192.168.100.10

Port 25 und 26 sind Uplinks für Router, die HA machen.

Clients in Vlan 2 haben IP 192.168.1.X und als DEFAULT Gateway 192.168.1.10
Clients in Vlan 3 haben IP 192.168.10.X und als DEFAULT Gateway 192.168.10.10
Clients in Vlan 4 haben IP 192.168.100.X und als DEFAULT Gateway 192.168.100.10

Router hat die IP 192.168.0.1 und folgende statische Routen:

192.168.0.0/24 GW 192.168.0.1
192.168.1.0/24 GW 192.168.0.10
192.168.10.0/24 GW 192.168.0.10
192.168.100.0/24 GW 192.168.0.10

Das Internet ist konfiguriert und die Verbindung steht ansich.

Mein Problem besteht darin, dass die Clients in Ihren Netzen nicht ins Internet können.
Vom Router kann ich die 192.168.1,10,100.10 pingen, vom Switch kann ich die Clients pingen, vom Router kann ich die Clients NICHT pingen.
Fehlt irgendwas? Muss ich noch die VLAN-Interfaces auf dem LAN des Routers erstellen?

Skizze:

b08e3b0c231845910eb08302c65d90ff-skizze - Klicke auf das Bild, um es zu vergrößern

Vielen Dank im voraus!
Mitglied: datasearch
05.03.2008 um 08:55 Uhr
Hallo pimadaum,

mich stört die statische Route auf dem router, die in ein lokal verbundenes Netzwerk zeigt.

Könnte sein das das Probleme gibt. ich kann leider nicht genau sagen was HP alles mit dem default-vlan anstellt, eventuell kann das aber auch Probleme geben. Versuche mal folgendes:

Erstelle auf dem Switch ein neues VLAN für den Transport an den Router

VLAN-Name: trans
VLAN-ID: 30
Tagged-Ports: none
Untagged-Ports: 25,26
Route-Interface: 192.168.0.10

Wie machst du HA auf den Routern? Ist das ein Stack oder ein Active/Passive konstrukt? Kannst du mal schauen welche MAC-Adresse der Switch für die IP des Routers gelernt hat und auf welchem Interface diese liegen soll? Nicht das dein Traffic auf dem passivem Router landet.

Kannst du von einem PC aus dem .10.0/24 Netz nach .100.0/24 pingen? Also nicht direkt vom Switch, sondern von Client zu Client? Sollte das nicht möglich sein, schaue mal in der doku von deinem Switch ob du das routing explizit aktivieren musst oder eine Securitypolicy die weiterleitung der Pakete verhindert oder der Switch kein routing kann.

Ansonsten, wenn das Routing auf dem Switch funktioniert, sollte das Problem am Router liegen. Was verwendest du für Geräte und wie wird das HA realisiert?

Kannst du auch mal schauen, wenn das ein aktiv-aktiv HA ist, ob dir nicht der SpanningTree einen strich durch die Rechnung macht und genau den falschen Uplink sperrt? Oder ist der Router ein Stack und der Uplink ein Etherchannel (Aggregated Link)?

Ich habe gerade deinen anderen Beitrag gelesen. Hast du einen reinen L2 switch? Hmm, falls das der Fall ist, kannst du nicht zwischen den VLANs routen. Du müsstest dann die VLANs tagged auf die Router forwarden und dort routen. Es kann sein das diese IP's die du da konfiguriert hast, reine management-IPs sind. Ist aber bloß eine böse Vermutung. Prüfe bitte ob du zwischen den VLANs pingen kannst wie weiter oben beschrieben.
Bitte warten ..
Mitglied: 56268
06.03.2008 um 07:45 Uhr
Hallo datasearch,

vielen Dank für deine Antwort!

Es handelt sich in der Tat um einen Layer2-Switch - er kann ergo nicht routen.
Die Clients können sich untereinander nicht pingen, also vlan übergreifend.
Für HA setze ich nachher pfsense ein, da gibts eine Option für HA.
Die lassen wir jetzt aber mal außer Acht und gucken, dass es jetzt so erstmal läuft mit Port 25 oder Port 26 als Uplinks für den Router. Die beiden Ports habe ich wie oben beschrieben in den Vlans getagged, die Clients hängen alle an untagged Ports - das sollte so stimmen.
Ich habe schon überlegt, dass die getaggted Pakete von 25/26 vom Switch zum Router auch von letzterem "verstanden" werden müssen. Deswegen die Frage, ob ich die Vlans dort noch mal auf das LAN-Interface legen soll. Nur dann fehlt mir immer noch die Lösung wie ich die unterschiedliche Netze dem Router beibringe.
Andere Idee wäre 4 Subnetze zu bilden und diesen ganzen VLAN-Kram zu lassen...
Bitte warten ..
Mitglied: datasearch
06.03.2008 um 23:25 Uhr
Mit Subnetzen hast du keine saubere Trennung auf L2. Hmm, ich würde alle VLANs getaggt über die beiden Uplinks auf die Router schicken, dort wieder auseinanderpflücken und das Routing von den Kisten machen lassen. Du musst also nur pro VLAN ein Interface konfigurieren und routing aktivieren. Wie das auf der Kiste funktioniert und ob es überhaupt geht kann ich dir leider nicht sagen. Eröffne eventuell einen neuen Beitrag zb. Erstellen von VLAN Interface auf M0Nowall Router oder vieleicht geht es ja auch ganz einfach.
Bitte warten ..
Mitglied: aqui
08.03.2008 um 09:41 Uhr
Wenn der Switch ein Layer 2 Switch only ist dann hast du keine Chance das zum Laufen zu bringen !!
Wie denkst du dir sollen denn die Packete zum Internet Router kommen aus den einzelnen VLANs wenn der Switch sie nicht auf das VLAN 1 routingtechnisch forwarden kann !!!
Das ist doch unmöglich, denn auf einen Layer 2 Switch sind die VLANs vollkommen getrennt !!!
Die IP Adressen sind dann lediglich Management IP Adressen pro VLAN für den Switch !

Fazit: Technisch nicht möglich das zu lösen mit dieser Switchhardware, da die HP 2510 keine L3 Switches sind !

http://h10010.www1.hp.com/wwpc/de/de/sm/WF05a/23523-23535-23535-23535-1 ...

Einzige Chance ist den Monowall Router auf ein 802.1q tagged Link zu setzen und mit ihm zwischen den VLANs zu routen wie es hier in diesem Tutorial anhand von Windows erklärt ist:

https://www.administrator.de/VLAN_Routing_%C3%BCber_802.1q_Trunk_auf_MS_ ...

Diese Lektüre im Heise Forum erklärt wie es für Linux gemacht werden muss:

http://www.heise.de/netze/Fiktive-Netzwerke--/artikel/77832

(Seite 5)
Bitte warten ..
Mitglied: 56268
08.03.2008 um 14:13 Uhr
Danke, ich habe mir das schon gedacht. Aber die Lösungsvorschläge unten sind für Kunden inakzeptabel. Muss ein Layer3-her. Oder ich mach das erstmal mit Subnetzen, da bin ich fitter drinn.
Bitte warten ..
Mitglied: aqui
10.03.2008 um 15:48 Uhr
Das nützt dir ja nichts, egal ob du fitter bis oder nicht. Die Netze müssen L3 technisch wieder zusammengeführt werden ob du willst oder nicht.

Ob du das nun routingtechnisch mit einem L3 Switch machst oder mit einem externen Server spielt keine Rolle.
NetGear, D-Link und andere NoNames haben aber auch sehr preiswerte L3 Switches im Produktportfolio

Wenns das war bitte
https://www.administrator.de/index.php?faq=32
nicht vergessen.
Bitte warten ..
Ähnliche Inhalte
Netzwerkgrundlagen

2 VLAN auf Layer 3 Switch und 0815 Router

Frage von JejeSwissNetzwerkgrundlagen13 Kommentare

Hallo Zusammen Ich würde gerne ein zweites Gast-Netzwerk auf meinem Layer 3 Switch (Cisco SG300) einrichten. Folgende Voraussetzungen habe ...

LAN, WAN, Wireless

2 VLANs mit Layer 3 Switch und Netgear Router

gelöst Frage von minimi90LAN, WAN, Wireless70 Kommentare

Hallo liebe Wissende. Zum Thema VLANs gibt es hier bei administrator.de schon viele gute Beiträge und Tutorials. Für mein ...

Router & Routing

Layer 2 oder Layer 3 Switch

Frage von coppercableRouter & Routing6 Kommentare

Moin, eine kleine Frage, weils mir einfach nicht klar wird: Wir bekommen mehrere Uplinks, die wir gerne an einen ...

LAN, WAN, Wireless

VLAN mit zwei Subnets aber nur managed Layer 2 Switch

gelöst Frage von garlicLAN, WAN, Wireless8 Kommentare

Hi zusammen, ich habe eine kleine Frage zum Thema VLAN - und bitte seht es mir nach, das ist ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 19 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit18 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk13 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...