Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

htaccess, neue Passwörter werden nicht angenommen

Mitglied: 5960

5960 (Level 1)

25.06.2006, aktualisiert 23:57 Uhr, 4839 Aufrufe, 4 Kommentare

Hallo zusammen,

ich verzweifel gerade an htaccess und hoffe, dass jemand Rat hat ;) !

ich versuche zu einer bestehenden pwd Datei einen neuen User anzulegen.
Nicht einmal hat es bisher geklappt, immer nur mit dem anderen Account klappt es, aber bei dem neuen kein access...

Server ist ein Win 2003 Server mit apache 2 - apache ist von xampp. auch die pwd Datei wurde durch xampp erstellt.

Der neue Bereich, der geschützt werden soll ist ein vhost. Kann es damit Probleme geben, oder muss man damit was beachten? kann ich mir nicht vorstellen, da ja das andere Passwort darin funktioniert...

Hier die pwd Datei:
admin:$apr1$Ux0.....$3sy0fG.nJlu5PQwWhAijh0
minimal:PURZZXKRh6m8w

Alleine schon die länge ist seltsam.

Die .htaccess ist gleich der schon bestehenden in einem anderen Verzeichnis, die auch funktioniert.

Danke vorab...
Mitglied: 5960
25.06.2006 um 22:38 Uhr
Ich poste das mal hier öffentlich, Lonesome Walker ;)

Verzeichnis wwwroot:
C:\Inetpub\wwwroot\...

Dort sind für alle Domains jeweils ein Ordner, auch xampp, wohin ich die xampp-Seite verschoben habe. Auf der Site kann man einen htacces erstellen, für diese site. Das habe ich gemacht und funktioniert bene!

Die gleiche htaccess Datei habe ich nun in einen weiteren (domain)Ordner geschoben, um diesen auch zu schützen. Das sollte ja soweit ok sein.

Inhalt der .htaccess:
AuthName "no access w/o permission?"
AuthType Basic
AuthUserFile "C:\Program Files (x86)\xampp\security\xampp.users"
require valid-user
In der xammp.users ist wie gesagt das eine Passwort mit dem user "admin" gespeichert (Dateinhalt siehe oben). dies funktioniert.
Nun habe ich einen neuen Usereintrag erstellt. Dieser funktioniert nicht mehr!

Erstelle ich eine eigenen Passwortdatei für den neuen (Domain)Ordner, funktioniert das auch nicht ;(

Ich bin total überfragt woran das liegen kann.
Bitte warten ..
Mitglied: 16568
25.06.2006 um 22:43 Uhr
Nur mal als Information für Dich:

Webserver bekommen bei mir immer eine eigene Partition, meist W.

Danach schiebe ich alles aus dem Ordner xampp direkt auf die Partition, und lösche anschließend das xampp-Verzeichnis.


Lonesome Walker
PS: Und wieso keine .htgroups und .htpasswd? Das verkompliziert die ganze Geschichte immer nur unnötig...
Bitte warten ..
Mitglied: filippg
25.06.2006 um 23:20 Uhr
Hallo,

was steht denn in der .htaccess? Wenn da der Zugriff nur für bestimmte User erlaubt wird, dann bringt es natürlich herzlich wenig, einfach einen neuen Nutzer inder .htpasswd "einzurichten".

Filipp

Edit: tschuldige, du hast die .htaccess ja gepostet, mich hatte das irgendwie etwas verwirrt gerade. Und ich vermute mal, das Passwort von minimal ist nach dem gleichen Verfahren "verschlüsselt" (md5 bei xamp glaube ich) wie das von admin? Kopier das Pwd doch mal von admin nach minimal (und andersherum) und schau, ob das dann geht. Ansonsten fällt mir dazu auch nichts ein.
Bitte warten ..
Mitglied: 5960
25.06.2006 um 23:57 Uhr
JUHUUUUUUUUUUUUUU )

Danke Filip!
Das wars. Wusste nciht dass es unterschiedliche Verschlüsselungen für htaccess gibt!

Habe jetzt per xampp website eine neue pwd Datei mit dem gewünschten Passwort angelegt und das dann weiter verwendet, ein bisschen umständlich aber es geht!
SUPER, ICH BIN BEGEISTERT )
Bitte warten ..
Ähnliche Inhalte
Apache Server

Htaccess funktioniert nicht nach neu Installation

Frage von vServerApache Server15 Kommentare

Hallo, ich hab meinem Webserver neu installiert (Debian Jessie), meine .htaccess Dateien erkennt er aber bisher noch nicht. Apache ...

Netzwerke

Passwort vergessen, neues festlegen

Frage von Questionmark93Netzwerke14 Kommentare

Hey Leute :) gibt es eine Möglichkeit das Passwort - vom Server - zu ändern? Bei lokalen Benutzern geht ...

Linux Tools

Htaccess-Umleitung aller Seiten auf neue Domain + einzelne manuelle

Frage von rock123Linux Tools

Hallo, mit folgendem Code werden alle Unterseiten meiner alten Seite umgeleitet: Das funktioniert soweit auch ganz gut. Ich möchte ...

Windows Netzwerk

Benutzername Administrator wird nicht angenommen

gelöst Frage von garackWindows Netzwerk5 Kommentare

Hallo zusammen, In der Firma gibt es auf allen 5-6 Rechnern einen Benutzer der Administrator heißt; Dieser ist auch ...

Neue Wissensbeiträge
Peripheriegeräte
Unterschrank für HP Drucker
Tipp von NixVerstehen vor 1 TagPeripheriegeräte2 Kommentare

Als kurzen Freitags-Tipp möchte ich gerne meinen neuen Drucker-Unterschrank Modell Amica KS 15423W vorstellen. Das Gerät eignet sich hervorragend ...

Windows 10
Windows 10 - Probleme mit Point-And-Print
Tipp von emeriks vor 2 TagenWindows 103 Kommentare

Hi, wir kämpfen z.Z. mit einigen Druckertreibern, welche unter Win10 beim Verbinden eines Druckers von Printserver mit dem Dialog ...

Windows 10

Windows 10 1803 - Ihr Roamingbenutzerprofil wurde nicht vollständig synchronisiert

Anleitung von Deepsys vor 2 TagenWindows 101 Kommentar

Bei allen Windows 10 1803 PCs traten Probleme mit den Servergespeicherten Profilen auf. Das Abmelden dauerte sehr lange und ...

Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 4 TagenExchange Server7 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Heiß diskutierte Inhalte
Humor (lol)
Freitagsfrage: Was tun, wenn der Admin der DAU ist?
gelöst Frage von VoiperHumor (lol)32 Kommentare

Moin Zusammen, Eine nicht ganz ernst gemeinte Frage an die Außendienstler unter uns. Zusammenfassung: Ein Inhouse Admin ruft bei ...

Windows Netzwerk
LTE Modul - Kein Internet trotz Verbindung
Frage von killtecWindows Netzwerk19 Kommentare

Hallo, ich habe hier ein Dell 7390 2-in-1 mit W10 Pro wo ich nachträglich eine LTE-Karte (Original Dell DW5811e ...

LAN, WAN, Wireless
HP Probook 470 G4 - abbrechende Downloads
Frage von joern1LAN, WAN, Wireless19 Kommentare

Folgendes Problem, für einen Tipp wäre ich dankbar: Bei WLAN-Verbindung zum Internet (nicht LAN) kommt es bei etwas größeren ...

Router & Routing
Routing Problem mit Kaskade FritzBox und pfsense zugeriff nur von der firewall auf die clients und 0.0.0.0
Frage von ukl1967Router & Routing18 Kommentare

Hallo, ich habe ein an sich triviales Problem elches ich allerdings nicht gelöst bekomme. NAS 10.5.10.53 Mein Netz baut ...