Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst http-Link regelmäßig aufrufen

Mitglied: KHP

KHP (Level 1) - Jetzt verbinden

25.07.2007, aktualisiert 27.07.2007, 5423 Aufrufe, 9 Kommentare

Ubuntu Gusty Server i386 (ohne grafische Oberfläche)

Hallo Forum,

ich kann mir vorstellen, dass mein Problem recht einfach zu lösen ist, bin halt Linux-Anfänger.

Ich möchte regelmäßig einen HTTP-Link aktivieren (ca. alle 5 Minuten), um meine IP zu aktualisieren. Meine frisch aufgesetzte Gutsy-Server-Büchse soll das für mich erledigen.
Installiert sind Apache2, PHP, FTP, Samba...das Übliche (für Neues wäre ich auch offen).

Wie löst man das am besten? Welches Script? Und wohin damit?

Vielen Dank für Eure Hilfe - Tobias
Mitglied: SteinBeiser
25.07.2007 um 12:10 Uhr
am besten mit php wenns nur ein link ist der geladen werden muss siehst z.B. so aus

01.
<?php 
02.
$dummy = file("http://www.DieAdresse.de/Irgendwo/im/Nirgendwo.html"); 
03.
?>
shellscript zum aufrufen
01.
#!/bin/sh 
02.
php PfadZumPhPscript
shellscript in /etc/crontab eintragen
fertig
Bitte warten ..
Mitglied: SlainteMhath
25.07.2007 um 12:31 Uhr
Noch einfacher geht's mit wget

/usr/local/bin/updateip.sh:
01.
#!/bin/sh 
02.
wget http://www.DieAdresse.de/Irgendwo/im/Nirgendwo.html
crontab:
01.
/5 * * * * /usr/local/bin/updateip.sh
Bitte warten ..
Mitglied: KHP
25.07.2007 um 12:41 Uhr
Hey danke Euch,

das hört sich gut an... muss ich heute abend gleich mal ausprobieren!

Ich halte Euch auf dem Laufenden!
Bitte warten ..
Mitglied: KHP
25.07.2007 um 20:03 Uhr
Hi,

ich hab's jetzt. Ähnlich Eurer 2. Variante allerdings mit w3m im script funktionierte es - Danke!

schönen Abend - Tobias
Bitte warten ..
Mitglied: KHP
26.07.2007 um 01:13 Uhr
Hallo Leute,

mein Ping hat mich verar***t, auf meiner Dyndns-registrierten IP war nach vielem Probieren und mehreren Fritzbox-Reboots wieder wer zu erreichen. Ich dachte ich war's!

Fazit:
1) wirft eine Fehlermeldung raus : "updateip.sh: 2: php not found" -> muss ich im script für PHP einen Pfad angeben?
2) wget lädt mir eine Datei runter die sich "ipchange.php?domain=meinedomain.de" schimpft in der drin steht:+ERR Das Passwort konnte nicht gefunden werden blahblah

Der Link sieht genau genommen folgendermaßen aus: http://dyndns.anbieter.de/ipchange.php?domain=meinedomain.de&passwo ...

Gibts da eventuell Probleme mit den Frage- bzw &-Zeichen. Kann man dies übergehen???

Fragen über Fragen, vielleicht habt ihr 'ne Idee.


Achso, bei w3m war's das gleiche Problem. Da hat mein anbieter.de eine Fehlermeldung rausgeworfen, dass ich das Passwort (also die vielenlustigenzeichen) nicht angegeben hätte...

[edit] p.s. die "vielenlustigenzeichen" bestehn nur aus Buchstaben und Zahlen - keine fiesen sonderzeichen außer die "?" und "&" (oder"=")
Bitte warten ..
Mitglied: SteinBeiser
26.07.2007 um 08:10 Uhr
in scripten die als cronjob laufen sollen ist es besser pfade anzugeben.
den pfad zu php kanste mit "which php" herausbekommen.
das "?" bedeutet achtung hier kommen parameter für das php script.
das "&" bedeutet nächster parameter.
Bitte warten ..
Mitglied: bixnet
27.07.2007 um 12:13 Uhr
Hallo,

schreib diese Zeile einfach in deine Crontab:


Viel Erfolg,
Grüße Johannes
Bitte warten ..
Mitglied: KHP
27.07.2007 um 13:53 Uhr
Hallo,

bei der Eingabe von "which php" tut sich gar nix. Heißt das etwa, dass mein PHP5 nicht funktioniert? Habs aber definitiv installiert - jedoch noch nicht gebraucht.

Der Hinweis von bixnet (unten) scheint zu funktionieren. Jedenfalls gibts keine Fehlermeldung, auch nicht wenn ich SlainteMhath's Script mit den Parametern ergänze...
...ich werde aber erst heute abend herausbekommen, obs wirklich geht (kann von hier nicht meiner Fritzbox den Saft klauen).

Gruß - Tobias
Bitte warten ..
Mitglied: KHP
27.07.2007 um 18:53 Uhr
Vielen Dank Leute! Mein Server aktualisiert jetzt allein seine IP...
...ihr wart mir eine große Hilfe.

Schönes Wochenende - Gruß, Tobias
Bitte warten ..
Ähnliche Inhalte
SEO

Google Bilder Suche: Link zu "Aufrufen"

gelöst Frage von BadgerSEO9 Kommentare

Hallo Leute, folgende Frage, wo ich leider nichts passendes im www gefunden habe: Woher bezieht Google die Werte für ...

Server

Avigilon Cam: Image per HTTP ohne Authentifizierung aufrufen

Frage von beta-way-of-lifeServer3 Kommentare

Hallo Leute, ich habe ein Problem mit einer Webcam. Die Avigilon Webcam stellt per HTTP ein JPEG zur Verfügung ...

Webentwicklung

Google Suchergebnisanzeigen: Google-Link zur Website linkt auf http

gelöst Frage von bolshiWebentwicklung2 Kommentare

Moin, seit gut einem Jahr läuft unsere Site auf https ( www.hhgym.de ). Dennoch zeigt die von Google generierte ...

Exchange Server

Exchange 2013 - Verwaltungskonsole lässt sich nicht mehr aufrufen (HTTP 500)

Frage von TimolinoExchange Server4 Kommentare

Hallo zusammen, nachdem es mir gelungen ist, einen 2013 Exchange-Server zu installieren habe ich nun folgendes Problem: Die Exchange ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 3 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...