Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Hyper-V-Manager zeigt keine VMs mehr an

Mitglied: hoffi44

hoffi44 (Level 1) - Jetzt verbinden

21.12.2009, aktualisiert 30.12.2009, 17585 Aufrufe, 9 Kommentare

Hallo,

im Moment hänge ich an einem Problem mit einem Windows 2008 Server Enterprise mit aktiver Hyper-V Rolle fest. Ich hoffe ihr könnt mir helfen.

Parentsystem: Win2008 Enterprise 64bit SP2
Hyper-V Version: 6.0.6002.18005

1.Meldung im Hyper-V-Manager: "Verbindung mit dem Verwaltungsdienst für virtuelle Computer wird hergestellt" --> diese Meldung wird relativ lange (>10 Minuten angezeigt)

2. Meldung: Fehler beim Vorgang auf Computer localhost. Der Servername in der linken Spalte wird mit einem roten X gekennzeichnet.


Der Server ist seit ca. Mitte November 2009 im Produktiveinsatz und in der letzten Woche ist aufgefallen, dass im Hyper-V-Manager keine VMs angezeigt werden bzw. der Zugriff auf den Hypervisor nicht mehr möglich ist. Die VMs laufen allerdings ohne Probleme und über vmconnect.exe ist auch der Zugriff auf die Console möglich.

Gleichzeitig werden im Ereignisprotokoll die Event-ID "4096" mit Source "Hyper-V-Config" mit dem Text: "The Virtual Machines configuration <configuration> at "<path>" is no longer accessible: The system cannot find the path specified. (0x80070003)" registriert. Diese Meldung weißt aber auf die virtuelle Maschinen im alten Speicherpfad hin und nicht auf den Aktuellen.

Kurze Erklärung dazu:

Erste Installation der VMs im Pfad: D:\Virtuelle Maschinen\%Computername%.

Aufgrund von Speicherplatzproblemen wurden alle VMs exportiert, auf Laufwerk C: ein Verz. HYPER-V erstellt und die VMs unter C:\HYPER-V\%Computername% importiert.

Aufgrund eines KB-Beitrages von MS wurde der Virenscanner bereits angepasst und alle Hyper-V Verz. und Dateien aus dem Echtzeitscan ausgeschlossen.

Der KB 972045 beschreibt diese rote X auch, nur haben wir auf dem Parentsystem keine Performanceprobleme wir beschrieben, deswegen wurde Hotfix noch nicht eingespielt.

Im Moment traue ich mich auch nicht einen Neustart des Hostsystems zu machen, da ich nicht weiß ob die VMs danach noch Starten aufgrund der Einträge im Ereignisprotokoll.

Wo kann ich die Konfiguration des Hypervisors nachschauen bzw. gibt es irgendwo einen Eintrag, Datei etc. wo die Pfade zu den XML-Dateien der aktuellen VMs stehen?

Kann mir jemand zu diesem Problem weiterhelfen?

Gruß
Mitglied: joshivince
09.02.2010 um 16:09 Uhr
Ich habe selbiges Problem.
Nach einer Zeit (mal Tage, mal Wochen) wird der Physikalische Server in der linken Spalte des Hyper-V Fensters mit einem roten X markiert.
Die virtuellen Maschinen (bei uns 3 an der Zahl) sind nun nicht mehr aufgelistet.

Das geht schon Monate so. Deswegen lassen wir die Fenster der virtuellen Maschinen auch offen - zum Glück hat man da Zugriff auf die virtuellen Server ohne Probleme.

Kein dringendes problem also. Dennoch sehr nervig.

@Threadersteller: Wenn du deinen physikalischen Server neu startest funktioniert das wieder - k.A. wie lange aber es geht. So ist es jedenfalls bei uns.

Wenn dazu aber jemand eine Erklärung hat - her damit =)

Ein Neustart des Hyper-V Dienstes schafft leider keine Abhilfe.

Grüße
Vince
Bitte warten ..
Mitglied: hoffi44
10.02.2010 um 08:35 Uhr
Hallo Vince,

ich hatte mit einem Supporttechniker von Microsoft über das Partnerforum kontakt und nach etlichem Analysieren (WMIobjects, XML-Dateien etc.) kam er zum Schluss, dass mein Konfiguration stimmt und der KB972045 genau mein Problem beschreibt. Diesen werde ich Heute einspielen, hoffe dann ist das Problem behoben.

Habt Ihr den Hotfix aus KB972045 schon eingespielt?

Gruß
Bitte warten ..
Mitglied: joshivince
10.02.2010 um 13:12 Uhr
Servus hoffi,

das KB hab ich noch nicht eingespielt.
Ich schaus mir mal an und entscheide dann ob ich es installiere.

Ich melde mich auf jeden Fall wieder hier. Du ebenso bitte.

Edit: Beim Hotfixdownload wird nur Windows Vista als OS angegeben. Ich weiß zwar, dass die sich ähneln, aber sollte ich es wagen?

Grüße
Vince
Bitte warten ..
Mitglied: hoffi44
11.02.2010 um 11:08 Uhr
Hallo Vince,

ich habe den Hotfix KB972045 gestern installiert und der Server läuft im Moment ohne Probleme, alles weitere wird die Zeit bringen.

Ich hoffe das das Problem nun erledigt ist.

Gruß

Stefan
Bitte warten ..
Mitglied: joshivince
11.02.2010 um 15:01 Uhr
Danke für die Info.
Ich werde mich auch nochmals melden.

Grüße
Bitte warten ..
Mitglied: joshivince
23.03.2010 um 08:30 Uhr
Moin,

bis eben dachte ich der Fix wäre meine Rettung. Leider nicht. Seit eben (hat nun über einen Monat gehalen) werden die VMs nicht mehr angezeigt, der Server ist mit einem roten X ausgeXt...

Schade.... ich mach mich mal weiter auf die Suche nach einer Lösung.

Grüße
Bitte warten ..
Mitglied: hoffi44
23.03.2010 um 09:27 Uhr
Hi,

also bei mir geht noch alles prima...alles top.

ich hoffe bei dir wird´s auch mal klappen.

gruß
Bitte warten ..
Mitglied: joshivince
26.03.2010 um 10:32 Uhr
Servus,

habe zwei tolle Links gefunden (mittlerweile findet man auch mehr dazu im netz):

http://social.technet.microsoft.com/Forums/de-DE/virtualisierung/thread ...

http://msmvps.com/blogs/rauscher/archive/2008/10/11/HyperVVMConnect.asp ...

Toll ist, dass ich mit meinen Maschinen nun wieder connecten kann, mittels vmconnect.exe.
Sieht aus wie eine RDP, ist es aber nicht. Zu finden unter C:\Program Files\Hyper-V

Genial und verbidnet mir meine Maschinen. Damit ist zwar mein Problem nicht gelöst, aber auf alle Fälle mal besser als gar nichts!

Grüße
Bitte warten ..
Mitglied: hoffi44
29.03.2010 um 09:17 Uhr
Moin,

das mit dem vmconnect.exe hat mich damals auch schlagartig ruhiger schlafen lassen....der ersten link ist von mir, da hatte ich mit dem mssupporter kontakt und so haben wir das problem dann auch analysiert und erledigt.

aber danke für die info.

gruß
Bitte warten ..
Ähnliche Inhalte
Hyper-V
Hyper-V Manager VMs weg
gelöst Frage von EdaseinsHyper-V11 Kommentare

Hallo liebe Community, Ich habe wieder eine doofe Frage Ich habe einen Server 2016, auf dem laufen 2 VM´s ...

Xenserver
Hyper-V VMs zu XenServer
gelöst Frage von TastuserXenserver3 Kommentare

Hallo! Ist es möglich meine virtuellen Maschinen von Hyper-V zu exportieren und dann im XenServer zum laufen zu bringen? ...

Hyper-V
Änderung Hyper-V VMs
gelöst Frage von JensDNDHyper-V10 Kommentare

Hallo Admins, bin noch neu auf dem Gebiet der Virtualisierung!! Habe ich die Möglichkeit, NACHTRÄGLICH die Konfiguration der VMs ...

Windows 10
Hyper-V Manager und WinRM
Frage von NewBe93Windows 101 Kommentar

Hey! Ich sitze gerade an der ersten Konfiguration meines Windows Server 2016 als Hyper-V Host. Hab alles schon fleissig ...

Neue Wissensbeiträge
Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 1 TagWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 1 TagSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Microsoft
Folder Security Viewer-Lizenzen zu gewinnen
Information von kgborn vor 1 TagMicrosoft

Ich nehme das Thema mal in Absprache mit Frank hier auf, da es für den einen oder anderen Administrator ...

Hardware

Feueralarm killt Festplatten in Rechenzentrum - führt zu größerem Ausfall

Information von kgborn vor 1 TagHardware12 Kommentare

Noch ein kleiner Beitrag für Administratoren, die in Rechenzentren aktiv sind - so als Fingerzeig. Denn es gibt Szenarien, ...

Heiß diskutierte Inhalte
C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++27 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

Linux
Linux Server oder Windows Server - lohnt eine Umstellung auf Linux und ebenso basierende SW bei einer langfristigen Planung?
Frage von motus5Linux27 Kommentare

Wir brauchen bei uns einen neuen Server. Dieser wird als Fileserver, Domäne Controller sowie Exchange Server verwendet. Wir versuchen ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless22 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
gelöst Frage von wusa88DSL, VDSL19 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...