Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Hyper V Virtuelle Maschine wird nicht mehr angezeigt

Mitglied: floges

floges (Level 1) - Jetzt verbinden

14.01.2012, aktualisiert 00:34 Uhr, 9853 Aufrufe, 6 Kommentare

Hallo werte Kollegen

Bei mir hat sich ein Problem mit einem unter HyperV virtualisierten Exchange ergeben.
Kurz zur Umgebung:

Hostsystem:
Server 2008 R2 mit HyperV Rolle
Raid 5 für die VMS 2,7TB groß

Im HyperV sind 5 virtuelle Maschinen angelegt. Bei dem Exchange war noch ein Snapshot vorhanden, der leider schon 16GB groß war/ist. Ich habe die VM´s sauber heruntergefahren, der Exchange blieb dann ca, 1 Stunde im Zustand "beenden" hängen. Nach einer Stunde habe ich das Hostsystem dann neugestartet.
Es werden nach dem Neustart alle anderen VM´s angezeigt nur der Exchange taucht nicht mehr in der MMC auf...?!
Folgende Artikel habe ich schon abgearbeitet:

http://www.hyper-v-server.de/hypervisor/wiederherstellen-einer-nicht-ex ...

wobei ich sagen muss, dass die alten XML Dateien vom Exchange noch an den Zielorten vorhanden waren und auch richtig verknüpft sind.

Auch die Foreneinträge bezogen auf den Virenscanner habe ich abgearbeitet, TrendMicro ist jetzt so konfiguriert, dass die HyperV Verzeichnisse und der Speicherort der VMs nicht mehr gescanned werden.

Diesen Artikel möchte ich ungern in Angriff nehmen, da ich ja immer noch den Snapshot brauche http://www.necron.mcseboard.de/2008/10/26/hyper-v-vms-verschieben-und-w ...

Eine Datensicherung von dem Exchange ist zwar vorhanden, allerdings von gestern. Und ich möchte das nur als letzte Option nehmen.

Die Exchange VM und die Snapshots sind auch noch vollständig inkl. aller XML Dateien vorhanden... nur werden Sie nicht angezeigt.

Es wäre echt Super wenn noch einer einen Tipp hätte oder vielleicht sogar die Lösung, stehe hier etwas auf dem Schlauch...

Vielen Dank schon mal im Vorraus und gute Nacht!
Mitglied: floges
14.01.2012 um 11:34 Uhr
Guten Morgen,

im Ereignisprotokoll habe ich noch folgenden Eintrag zur VM gefunden.

Die Konfiguration eines virtuellen Computers kann nicht geladen werden, da sie beschädigt ist (ID des virtuellen Computers: 2117F8BB-D735-46C7-93F8-7F0E64D52BF6). Löschen Sie die Konfigurationsdatei des virtuellen Computers (XML-Datei), und erstellen Sie den virtuellen Computer neu.

Aber wie soll ich den di XML neuerstellen? Ich meine die wird doch automatisch beim erstellen einer VM erstellt?!.
Bei der ID handelt es sich um die VHD des Exchange nicht um die des Snapshots.
Bitte warten ..
Mitglied: Pjordorf
14.01.2012 um 15:03 Uhr
Hallo,

Zitat von floges:
Löschen Sie die Konfigurationsdatei des virtuellen Computers (XML-Datei), und erstellen Sie den virtuellen Computer neu.
Hast du dir diesen Satz überhaupt durchgelesen und verstanden? Dann tu es doch!

Gruß,
Peter
Bitte warten ..
Mitglied: floges
14.01.2012 um 15:10 Uhr
Hallo Peter,

ja den Satz habe ich mir richtig durchgelesen, und dass wäre ja auch einfach gemacht, aber ich bin mir nicht sicher wie es sich mit dem Snapshot verhält der ja irgendwie mit der VHD Verknüpft sein muss. Soll ich den die XML von der VHD und dem Snapshot löschen?

Wenn ich keinen Snapshot hätte, müsste ich ja nur eine neue VM erstellen, dann die VHD als vorhande Festplatte hinzufügen, ein paar Einstellungen in der Konfiguration anpassen, starten und gut ist die Sache, Aber bei der Snapshotdatei....`?!
Bitte warten ..
Mitglied: Pjordorf
14.01.2012 um 19:22 Uhr
Hallo,

Zitat von floges:
aber ich bin mir nicht sicher wie es sich mit dem Snapshot verhält
Ich habe daher mal für dich gesucht und nach 30 sekunden folgendes gefunden: http://itproctology.blogspot.com/2008/06/how-to-manually-merge-hyper-v- ...

Aber bei der Snapshotdatei
Warum benutzt du Snapshot Dateien bei einem Exchange wo du dir keinen Datenverlust leisten kannst?

Gruß,
Peter
Bitte warten ..
Mitglied: floges
14.01.2012 um 20:14 Uhr
Auf dem Exchange wurden vor einiger Zeit Updates installiert, und vorher wurde ein Snapshot gemacht... naja und der wurde danach aus irgendwelchen Gründen nicht wieder gelöscht...

Ich bin mittlerweile auf dieses Tutorial gestoßen http://www.it-cast.de/alle/videocast-hyper-v-vhds-und-avhds-zusammenfhr ...

Gut gemacht und vom Inhalt das gleiche was Peter gepostet hat.

Im Moment kopiere ich die AVHD und VHD Dateien noch aufs NAS um dann gleich mal die zusammenführung zu machen.
Bitte warten ..
Mitglied: floges
14.01.2012 um 22:04 Uhr
Das Zusammenführen der VHD hat geklappt. Ich habe dann eine neue VM erstellt und die VHD Datei angehängt. Nach der Installation der Integrationstools, ein paar Einstellungen und einem Neustart lief alles wieder.
Sogar der zickige Blackberry Enterprise Express....

@ Peter: Danke für die Hilfe, schönen Sonntag noch!
Bitte warten ..
Ähnliche Inhalte
Hyper-V

Hyper-V - Netzwerkeinstellungen IPv4 für die virtuelle Maschine?

gelöst Frage von SachellenHyper-V8 Kommentare

Hallöle liebe Damen und Herren :) Ich bin auf einer alten Win Svr2008 R2 Maschine gelandet und hab gesehen, ...

Hyper-V

Hyper-V und virtuelle Netzwerktypen

gelöst Frage von keine-ahnungHyper-V4 Kommentare

Moin miteinander, in der augenblicklichen Phase einer schöpferischen Praxisschliessung möchte ich gern ein oder zwei Windows2008R2 als neue VM ...

Backup

Windows Server Sicherung v. virtueller Maschine (HYPER-V), wie recovern?

gelöst Frage von departure69Backup3 Kommentare

Hallo. Ich sichere unsere VMs (laufen unter W2k16-HYPER-V) eigentlich mittels Veeam 9.5. Veeam zickt aber bei einer VM rum, ...

Windows Server

Einrichtung Domänencontroller als Hyper-V-Maschine

gelöst Frage von LarzWindows Server25 Kommentare

Hallo zusammen, nach Jahren der Administrativen Abstinenz bin ich momentan dazu genötigt, für einen Bekannten einen alten 2003er SBS ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...