Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IIS 6.0 Kommunikationsproblem innerhalb zweier virtueller Maschinen

Mitglied: 36278

36278 (Level 1)

04.10.2006 um 12:05 Uhr, 3099 Aufrufe, 1 Kommentar

Hallo,

ich habe mir eine Testumgebung aufgesetzt um mein Wissen über den IIS 6.0 zu verbessern. Nun habe ich eine Virtuelle Maschine (Win2003 Server) welche über den Assistenten als Anwendungsserver konfiguriert ist und somit als Webserver fungieren soll mit der IP 172.21.18.100.

Eine weitere virtuelle Maschine (IP 172.21.18.110) soll der Webclient sein. Die Kommunikatin unter beiden Maschinen funktioniert, das habe ich getestet. Als erstes habe ich eine Testseite als virtuelles Verzeichnis unterhalb meiner Standardwebseite eingerichtet. Auf diese konnte ich von meinem Client aus auch zugreifen via http://Servername/webseite/index.htm.

Jetzt wollte ich meine Testseite als richtige Testseite innerhalb des IIS anlegen. Also habe ich ihr die einzige ip gegeben, die meiner Netzwerkkarte zugewiesen ist. ich habe einen host-header vergeben (mytestweb) und das physische verzeichnis angegeben. lokal auf meinem webserver erscheint die webseite korrekt, wenn ich http://mytestweb aufrufe.

von meinem client aus erhalte ich jedoch nur die information, dass die seite nicht angezeigt werden kann. ich nehme mal an, dass er nicht korrekt am webserver anfragt oder? muss ich noch irgendwas Spezielles in den Gatewayeinstellungen oder im iis einstellen um auf eine so konfigurierte webseite zugreifen zu können?

Vielen dank im Voraus!
Enrico
Mitglied: Herbrich19
26.03.2012 um 02:27 Uhr
Hallo,

Also der Hostheader ist das Problehm, Den du musst ihn auflösen können, richte dir noch zusätzlich einen DNS-Server ein, und dort richtest du die zone mytestweb ein. ambesten mit der tld local also mytestweb.local, dan stellst du den "eigenen"-DNS-Server in der Webclient Maschine ein. Dan geht es.

Alatanativ kanst du auch die hosts datei verwenden, und dort mytestweb eingeben. Siht dan so aus

localhost 127.0.0.1
mytestweb 172.21.18.100
...usw

Aber damit kenne ich mich nicht so aus. Der Weg über den eigenen DNS-Server ist viel besser (finde ich). Du darfst (fals du weiter ins internet möchtest) aber nicht vergessen eine DNS-Weiterleitung zu Konfigurieren. Zumbeipsiel auf 8.8.8.8 und 8.8.4.4 (Google-DNS). Du kanst dann aber auch jeden beliebigen Server nehmen, haubtsache DNS.

Grüße. Herbrich17
Bitte warten ..
Ähnliche Inhalte
Vmware

ESXi zwei virtuelle Maschinen an einem vSwitch

Frage von RonjaRVmware4 Kommentare

Hallo liebe Mitkollegen, ich habe eine Frage bzgl. der korrekten Konfiguration und wahrscheinlich noch ein wenig PAT Grundinstallation ist ...

Windows Server

IIS 6.0 und Domänenanmeldung

Frage von slanskyWindows Server

Hallo Leute, ich habe eine Frage, aber erst die Umgebung: Domäne mit 3 DCs Windows Server 2008 R2 und ...

Virtualisierung

Zugriff auf Virtuelle Maschine ohne PC

gelöst Frage von EisernVirtualisierung4 Kommentare

Hallo, ich hoffe hier einigermaßen richtig zu sein und bitte um Hilfe bezüglich meiner derzeitigen Gedanken. Ich habe mir ...

Windows Netzwerk

Welche Festplattenkonfiguration für Virtuelle Maschinen

Frage von WarrenderWindows Netzwerk5 Kommentare

Hallo, nach Empfehlungen eines Users hier im Forum habe ich mein System folgender Maßen konfiguriert: Raid 1: Mit WinServer2012R2 ...

Neue Wissensbeiträge
iOS
IOS 12.2 beta und OpenVPN iPad und iPhone
Erfahrungsbericht von magicteddy vor 6 StundeniOS

Moin, kleiner Hinweis an die experimentierfreudigen unter Euch: Bei der aktuellen beta gibt es ein Problem im Zusammenspiel zwischen ...

Vmware
VMware Tools 10.3 verfügbar
Information von sabines vor 9 StundenVmware

Eine Sicherheitslücke wird mit den Tools der Version 10.3 geschlossen, die Tools müssen auf jeder VM aktualisiert werden. Näheres ...

Apple

Apple aktualisiert MacBook Pro, mit bis zu sechs Kernen

Information von Vision2015 vor 2 TagenApple

Jawohlchen das Warten hat sich gelohnt :-) Apple aktualisiert MacBook Pro Frank

Verschlüsselung & Zertifikate

In-place Upgrade verschlüsselter Windows-Systeme mittels reflectdrivers

Tipp von DerWoWusste vor 4 TagenVerschlüsselung & Zertifikate1 Kommentar

Hinter diesem sperrigen Titel verbirgt sich die Info, dass offenbar seit Win10 v1607 im Windows-Setup (setup.exe der CD/des USB-Sticks) ...

Heiß diskutierte Inhalte
Microsoft
Dringend: Nach neustart kein zugriff mehr per RDP möglich - vermutlich wegen gelöschter SID in AD
gelöst Frage von sven784230Microsoft29 Kommentare

Hallo zusammen, gerade hat ein Server 2012 (terminalserver + Active directory) einen geplanten Neustart durchgeführt, wenn ich mich jetzt ...

Hardware
Alte Hardware verkaufen
Frage von Lebowski23Hardware22 Kommentare

Hallo, durch größere Umbauten haben einiges an Hardware "rumliegen", die wir vielleicht noch verkaufen wollen. Es sind so ca. ...

Exchange Server
Exchange 2013 - Update schlägt fehlt
gelöst Frage von chb1982Exchange Server20 Kommentare

Hallo zusammen, kann sich jemand einen Reim auf die unten stehenden Fehlermeldung machen? Sie tritt auf beim Update von ...

Windows Server
Active Directory Probleme DC sieht sich nicht selbst als DC DNS Fehler?
gelöst Frage von Cisco7971Windows Server15 Kommentare

Moin zusammen, Angefangen hat die Suche damit, dass der Anmeldedienst immer angehalten wird, bei einem Neustart des DC. nach ...