Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IIS 6.0 Service unavailable bei großer Anwendung

Mitglied: ThomasR

ThomasR (Level 1) - Jetzt verbinden

20.03.2008, aktualisiert 25.03.2008, 5020 Aufrufe, 2 Kommentare

asp.net framework 3.5 Windows Server 2003 und IIS 6

Hallo,

da ich neu hier bin, möchte ich mich kurz vorstellen. Ich bin beruflich Softwareentwickler und habe jetzt privat eine Webanwendung als asp.net Anwendung entwicklet. Um diese Anwendung der Welt auch zugänglich zu habe ich einen Windows V-Server mit Windows Server 2003 als Betriebssystem angemietet. Auf dem Server ist außer dem Betriebsystem, dem IIS 6 und einem MS SQL Server Express 2005 und dem .net framework 3.5 von mir nichts installiert worden. Wenn ich einen Teil meiner Anwendung jetzt auf den Server kopiere (also nur eine default.aspx mit entsprechender Code behind Datei, eine web.config, ein paar eingebundene Assemblys und ein paar ccs files) dann funktioniert alles wunderbar. Sobald ich aber die komplette Anwendung (ca 40 Seiten) auf den Server kopiere bekomme ich nur noch ein Service unavailable ausgeliefert.

Wenn ich die Anwendung auf meinem Entwicklungsrechner starte (der deutlich stärker als der Server ist) dann dauert das Starten ca. 10 Sekunden, da zum Starten ja alles compiliert/precompiliert wird. Kann es sein, dass das Service unavailable durch einen Time out vom ISS kommt, weil der es einfach nicht schaft, die komplette Anwendung so schnell zu kompilieren?

Ich wäre für jeden Hinweis was ich tun kann dankbar.

Gruß

ThomasR
Mitglied: ThomasR
22.03.2008 um 08:11 Uhr
Noch ein Nachtrag:

im httperr1.log findet sich nach einem Aufruf der Seite immer folgender Eintrag:

2008-03-22 07:07:04 89.166.229.105 1221 87.230.89.25 80 HTTP/1.1 GET / - 2060276093 Connection_Abandoned_By_AppPool DefaultAppPool
Bitte warten ..
Mitglied: ThomasR
25.03.2008 um 14:10 Uhr
Hallo,

ich kämpfe immer noch mit dem IIS. Ich habe jetzt weil das in einem anderen Service not available Tread empfohlen wurde den IIS einmal deinstalliert und neu installiert. Das hat die ganze Situation auch etwas verändert. Ich bekomme jetzt nicht mehr die Meldung Service not available, sondern nur noch ein "Die Seite kann nicht angezeigt werden". Diese Meldung dafür aber jetzt immer wenn ich eine aspx Seite aufrufe. Nicht nur bei großen Seiten. Einfache html Seiten werden sauber ausgeliefert.

Im error.log steht aber immer noch die selbe Meldung mit connection abanndoned bei app_pool. Falls irgend jemand eine Tipp hat, auch wenn es nur ein Verweis auf ein anderes Forum ist, wäre ich wirklich dankbar.

Gruß

Thomas
Bitte warten ..
Ähnliche Inhalte
Windows Server
IIS 6.0 und Domänenanmeldung
Frage von slanskyWindows Server

Hallo Leute, ich habe eine Frage, aber erst die Umgebung: Domäne mit 3 DCs Windows Server 2008 R2 und ...

Vmware

Vmware 6.0 Lun Größe sinnvoll?

Frage von 14634Vmware2 Kommentare

Hallo, ich möchte meinen Fileserver virtualisieren, aktuell ist er noch physikalisch und hat folgende Lun`s h: 1TB P: 200 ...

Exchange Server

IIS 6.0 SMTP-Server als Relay für Exchange

Frage von Turbo-MasterExchange Server2 Kommentare

Hallo Leute, wir verwenden den SMTP-Server des IIS 6.0 als Relay für unseren Exchange-Server und haben folgendes Problem: Wenn ...

Vmware

Nach Neustart des vcenter Fehler beim vSphere Web Client: 503 Service Unavailable

Frage von inspiratioVmware6 Kommentare

Hallo liebe Community, fast jedes mal wenn unser vCenter neu gestartet wird, kann ich den vSphere Web Client nicht ...

Neue Wissensbeiträge
Microsoft

Neuigkeiten zu Server und Office 365 was läuft mit was und was nicht

Tipp von AlFalcone vor 19 StundenMicrosoft

Server Betriebssysteme auf dem die verschiedenen Offices nicht supported sind: • Office 365 ist und wird nicht supported auf Windows ...

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 20 StundenSpeicherkarten1 Kommentar

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 22 StundenSicherheit

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 1 TagHardware1 Kommentar

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Sicherheitsgrundlagen
EuGH-Urteil - Internetanschluss für die ganze Familie - Filesharer haften trotzdem
Frage von StefanKittelSicherheitsgrundlagen24 Kommentare

Hallo, In diesem Artikel geht es darum, dass Jemand aus der Familie ein Hörbuch illegal hochgeladen hat. Der Vater ...

Windows 10
Sysprep Fehler im Log kann nicht starten
Frage von grillinator95Windows 1022 Kommentare

Hallo, kann leider SYSPREP nicht mehr starten, Win10 64bit. Logfile sagt folgendes: 2018-10-17 13:44:56, Info SYSPRP 2018-10-17 13:44:56, Info ...

Apple
MacBook Pro 2018 mit 8 GB oder 16 GB
Frage von SysAdm81Apple17 Kommentare

Hallo zusammen, ich steh vor der Überlegung mir ein MacBook Pro 13 (2018) zu kaufen. Bzgl. SSD habe ich ...

DSL, VDSL
PPPOE Einwahl über Sophos UTM und FritzBox per PPPOE Passthrough
Frage von Leo-leDSL, VDSL13 Kommentare

Hallo zusammen, vielleicht habt Ihr noch eine Idee?? Ich besitze einen 1u1 Anschluss und möchte meine UTM ASG 110 ...