Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

IIS 7.5 IDN Domains mit ß - Geht oder geht nicht und wenn ja, wie

Mitglied: highmoe

highmoe (Level 1) - Jetzt verbinden

20.01.2012 um 08:56 Uhr, 4405 Aufrufe, 2 Kommentare

Hallo zusammen,

hat jemand schon mal eine Domain mit enthaltenem 'ß' auf dem IIS ans Laufen gebracht?
Ich habe jetzt 2 Tage rumgesucht, und das einzige brauchbare Ergebnis von den MS-Blogs, datiert von Juni 2011 war, dass es wohl NICHT geht.
Angeblich soll es Hosting Panels geben, die es zusammen mit IIS ermöglichen, aber konkretere Infos dazu, ob das nun konkret mit dem 'ß' klappt, konnte ich nicht finden. Umlaute - kein Problem, habe ich am Laufen.

Fakt ist, dass man den punnycode im IIS nicht bei den Bindungen eintragen kann, sondern nur Unicode - manchmal verhindert der IIS den Eintrag des punnycode wegen "verbotener Zeichen", manchmal schluckt er sie, aber stoppt sofort nach Speichern.
Die Bindungen mit 'ß' funktionieren, die Site ist aber nicht zu erreichen - HTTP Error 400. The request hostname is invalid

Bitte, bitte jetzt keine Grundsatzdiskussionen über den Sinn resp. Unsinn von Domains mit 'ß' - es ist nicht meine Domain, und mein Kunde ist sich der Problematik bewusst, setzt aber auf die Zukunft. Von den bekannteren Browsern scheint Opera überhaupt der einzige zu sein, der den Aufruf korrekt abliefert, alle anderen wandeln automatisch in 'ss' um.

Besten Dank,
Haimo Grebenstein
Mitglied: Dani
11.03.2012 um 13:35 Uhr
Hallo Haimo,
laut IIS Forum ist es bis Win2008R2 nicht möglich. Blogbeitrag über IDNA.


Grüße,
Dani
Bitte warten ..
Mitglied: highmoe
13.03.2012 um 11:49 Uhr
Hallo Dani,

das hatte ich schon gefunden und bin dort auch bereits verewigt
Dennoch herzlichen Dank!

Haimo
Bitte warten ..
Ähnliche Inhalte
Hosting & Housing
IIS 7.5 Einstellungen
gelöst Frage von mschaedler1982Hosting & Housing2 Kommentare

Hallo zusammen. Ich habe bei uns eine Webseite konfiguriert und möchte nun dass der Inhalt der Webseite über intern ...

Server
IIS 7.5 Win 2008r2
gelöst Frage von Andi2401Server

Hallo Windows Admin`s Wir verwenden Win2008r2 und IIS 7.5. läuft problemlos! Meine Frage! Beim SBS2011 gibt es die Möglichkeit ...

Informationsdienste
IIS 7.5 Probleme mit Bindung
gelöst Frage von Leo-leInformationsdienste9 Kommentare

Hallo Forum, ich hoste eine Website per IIS 7.5. Die 'Seite wird sauber per A-Record aufgelöst und ich habe ...

Windows Server
IIS 7.5 Mehrere Sites über https??!
gelöst Frage von TheFstXWindows Server1 Kommentar

Liebe Experten! Seit gestern versuche ich mit Hilfe einiger Anleitungen aus dem Netz, mehrere Sites auf unserem IIS mit ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 6 StundenHumor (lol)1 Kommentar

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 18 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 19 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 22 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...