Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst IIS Worker Process - w3wp.exe Speicherfresser

Mitglied: burg.d

burg.d (Level 1) - Jetzt verbinden

14.04.2014, aktualisiert 15:49 Uhr, 24209 Aufrufe, 7 Kommentare

Hallo Leute,

aktuell sitzen wir hier vor folgenden Problem:

Wir betreiben einen SBS 2011 auf denenen unser ISS 7 läuft. Seit nun ca. 2 Monaten habe ich den Prozess w3wp.exe mehrfach im TaskManager. Der Prozess zieht sich im Laufe des Tages dermaßen unnötig Speicher, dass alle anderen Prozesse zunehmend langsamer verarbeitet werden.

Wir haben schon den kompletten ISS Manager geprüft und konnten keinen Fehler feststellen. Habt ihr vielleicht einen Ansatz, was zu diesem Kuriosum führen kann?


5e5d44fa771d042e950049eaeef87b6e - Klicke auf das Bild, um es zu vergrößern
Mitglied: jsysde
14.04.2014 um 17:26 Uhr
N'Abend.

Ansätze? Viele.
Läuft da ein SharePoint, ein WSUS, ein wasauchimmer?

Jede dieser Webanwendungen zieht einen eigenen Prozeß nach sich, je nach Auslastung/Nutzung verbraucht dieser Prozess entsprechen Resourcen, also CPU/RAM/Plattenplatz.

Was läuft denn laut IIS-Manager so alles an Websites auf der Büchse?

Cheers,
jsysde
Bitte warten ..
Mitglied: burg.d
14.04.2014 um 17:38 Uhr
Hallo,

Da läuft ein

- SharePoint, welcher aber nicht groß genutzt wird bzw. fast gar nicht
- ein WSUS
- MS Exchange

Websits nur die fürs OWA
Bitte warten ..
Mitglied: jsysde
14.04.2014 um 17:49 Uhr
N'Abend.

Ok. Aber ich sehe da jetzt weder einen Fehler noch ein Kuriosum?!?

Cheers,
jsysde
Bitte warten ..
Mitglied: burg.d
15.04.2014 um 14:06 Uhr
Hallo,

das Problem dieses Prozesses ist, dass dieser sich immer stärker aufbläht. Der RAM wird dadurch immer mehr belastet.

Irgendwie müsste dem IIS sagen, dass der Prozess in der Nacht automatisch neugestartet werden soll!
Bitte warten ..
Mitglied: jsysde
LÖSUNG 16.04.2014, aktualisiert 05.05.2014
N'Abend.

Du solltest erst mal rausfinden, welcher Prozess zu welcher Website/-applikation gehört und dann entscheiden, ob ein automatischer Neustart nachts angebracht/durchführbar ist.

Cheers,
jsysde
Bitte warten ..
Mitglied: burg.d
17.04.2014 um 10:37 Uhr
Hallo,

ja dass werde ich erst mal probieren. Ich bin noch nicht so ganz schlüssig warum sich diese Prozesse aufblähen. Da muss ich noch mal Ursachenforschung betreiben

Schöne Ostern!
Bitte warten ..
Mitglied: burg.d
05.05.2014 um 14:52 Uhr
Hallo,

so nun nach Prüfung der einzelnen Bestandteile des IIS. Es hatte sich per Update eine SahrePoint Service gestartet. Dieser Service verursachte 3 Prozesse.
Service beendet und alles wieder okay!
Bitte warten ..
Ähnliche Inhalte
Windows Server
Speicherfresser in SYSVOL
gelöst Frage von HenereWindows Server6 Kommentare

Servus zusammen, ich hatte ja Platzprobleme auf meinem 2012 R2 Server. Nachdem ich etwa 100GB auf eine andere HDD ...

iOS
Docs at Work MobilrIron
Frage von R0nnaldiOS

Meine Firma nutzt seit längerem MobileIron, nun ist die Einrichtung von Docs@Work für den Zugriff von Mobilen Geräten auf ...

Batch & Shell
Powershell start-process
gelöst Frage von Cougar77Batch & Shell4 Kommentare

Guten Morgen, ich habe da ein kleines Problem, das ich nicht ganz verstehe. Es geht um ein kleines Powershell-Skript, ...

Windows 8
Critical Process Died
Frage von uridium69Windows 8

Nach einem Windows Update von heute wollte der PC nicht mehr starten bzw. das Windows. zuerst war er am ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs10 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Debian
Wie finde ich den betroffenen user
Frage von ProtectedDebian8 Kommentare

Hallo, Wie kann ich den User finden der dies verursacht hat? Betriebsystem ist Debian 7 your Server/Customer with the ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall8 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...