Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Installation von Packages hängt - egal ob via apper oder yast

Mitglied: diwaffm

diwaffm (Level 2) - Jetzt verbinden

01.06.2013 um 08:37 Uhr, 2680 Aufrufe, 9 Kommentare, 1 Danke

Hi Leute,

auf meinem openSUSE 12.3 Rechner möchte ich Software (hier:virtualBox) installieren.

Egal, wie ich vorgehe, ob per Suche in Yast oder per doppelklick auf das heruntergeladene .rpm-Paket oder per Klick auf "1-Klick-Installation" auf der Webseite - in allen Fällen startet die Installation und bleibt dann hängen.
Mal sofort, mal nach Installation von 2 der 5 Paketen.

Ich habe schon

zypper clean / zypper ref

durchgeführt und hatte das GEfühl, das danach ein Paket mehr installiert wurde...

Erfolgreich war die Installation aber in keinem Fall...

Any ideas?

Dirk
Mitglied: orcape
01.06.2013 um 09:14 Uhr
Hi diwaffm,

(hier:virtualBox)
...kann es sein das Du für die VM zu wenig RAM verwendest ?

Gruß orcape
Bitte warten ..
Mitglied: diwaffm
01.06.2013 um 09:18 Uhr
Zitat von orcape:
> (hier:virtualBox)
...kann es sein das Du für die VM zu wenig RAM verwendest ?


Ähm, was soll das mit der INSTALLATION von virtualBox zu tun haben?

top meint:
KiB Mem: 8193028 total, 3431172 used, 4742481 free
KiB Swap: 2104476 total, 0 used, 2104476 free

DAS sollte eigentlich genug für die Installation sein, oder?

Ciao

dirk
Bitte warten ..
Mitglied: diwaffm
01.06.2013 um 09:34 Uhr
Ich habe das jetzt noch mal genauer beobachtet:
Es sieht so aus, als hänge die Installation JEDESMAL bei

virtualbox-guest-kmp-desktop-4.2.6_k3.7.7_1,2-3.1.8.x86_64.rpm

Ciao

dirk
Bitte warten ..
Mitglied: 64748
01.06.2013 um 09:40 Uhr
Guten Morgen,

für vbox werden eigene Kernelmodule zur Verfügung gestellt. Ich weiß nicht, ob die schon im Paket enthalten sind oder auf dem System gebaut werden (wenn man das generische, also distributionsunabhängige Paket von der Oracle-Site installiert, dann werden zuerst die Module gebaut), wenn die gebaut werden müssen, dann müssen die Entwicklerwerkzeuge auf dem System vorhanden sein, als da wären (mindestens) gcc, make und Kernelheader.

Kann es sein, dass die Installation beim Erstellen der Module hängen bleibt? kannst Du mal während der Installation mit ps -e nachsehen, ob gcc und make ausgeführt werden? Ansonsten syslog.

Markus
Bitte warten ..
Mitglied: diwaffm
01.06.2013, aktualisiert um 10:54 Uhr
Wenn ich die Installation abbreche, ist danach

virtualbox-guest-kmp-default

als einige Komponente installiert.
Wenn ich das dann wieder deinstallieren will, so dauert das auch recht lange (ca. 1 Minute).

Ich habe dann mal probiert ein VirtualBox-4.1 Paket (von Oracle) zu installieren - das funktionierte.

Zumindest teilweise.
Die Verwaltungskonsole lässt sich starten.
Die VM allerdings nicht:
Hier kommt der "bewährte" Fehler mit den Kernel-Modulen.
"The VirtualBox kernel modules do not match this version of VirtualBox".

/etc/init.d/vboxdrv setup habe ich durchgeführt

hier kommt es zu einem Fehler:
"VM_RESERVED" undeclared

Kann es sein, dass da noch Reste der alten, misglückten Installtion irgendwo rumliegen und darauf zurückgegriffen wird?
Wenn ja - wie kann ich das verhindern?

Ciao

dirk
Bitte warten ..
Mitglied: diwaffm
01.06.2013 um 10:56 Uhr
Beim 4.2er Paket von Oracle läuft der Setup fehlerfrei durch.

Beim Start der VM kommt dann aber die gleiche Fehlermeldung...
Bitte warten ..
Mitglied: 64748
01.06.2013, aktualisiert um 12:35 Uhr
Der Kernel muss natürlich zur Version von vbox passen. [edit]zur Erklärung: ich meine das für ein fertiges Paket welches die fertigen Module schon mit installiert[/edit]

Lade Dir mal vbox hier die Version für "all distributions". Es ist ein Shellscript, einfach als root ausführen oder mit sudo. Dann bekommst Du auch richtige Fehlermeldungen (oder es funktioniert). Versuche, vorher die alte Installation von vbox zu deinstallieren.

Markus
Bitte warten ..
Mitglied: diwaffm
01.06.2013 um 11:13 Uhr
Merci.
Das wars.
Nun läuft die VM wieder.

Ich muss nun zwar noch ein paar Kleinigkeiten hinbekommen, wie den Autostart mit KDE (das passt irgendwie nicht mehr) - aber hauptsache ist, es läuft erst mal wieder

Ciao

dirk
Bitte warten ..
Mitglied: orcape
01.06.2013 um 12:06 Uhr
@ diwaffm

Ähm, was soll das mit der INSTALLATION von virtualBox zu tun haben?
...sorry, hatte ich wohl etwas falsch interpretiert.
Ich dachte das ganze OS läuft auf einer VM und da klappt die Installation nicht.
Deshalb meine Schlußfolgerung mit dem RAM.

Gruß orcape
Bitte warten ..
Ähnliche Inhalte
Windows Server
Installation via WDS hängt sich auf
gelöst Frage von NathalemWindows Server6 Kommentare

Hallo zusammen, ich bin seit einiger Zeit dabei in unserem Unternehmen einen WDS basierten Image Server zum laufen zu ...

Exchange Server

WIN2012R2 hängt nach Installation von Exchange 2010

gelöst Frage von Stefan007Exchange Server13 Kommentare

Hi Leute, habe in einer VM (VMware-Workstation) einen WIN2012R2 als DC laufen mit DNS und DHCP, keine Clients oder ...

Xenserver

Citrix XenServer 6.5 hängt bei der Installation

gelöst Frage von M.MarzXenserver2 Kommentare

Hallo zusammen, ich versuche den XenServer 6.5 auf der VirtualBox zu installieren. Beim starten sagt er mir "zum installieren ...

Windows 8

VMLite Xp Mode hängt sich bei der Installation auf

Frage von FragnantWindows 81 Kommentar

Mahlzeit, ich benötige einen XP Mode um auf den IE 8 zugreifen zu können. Allerdings hängt sich der VMLite ...

Neue Wissensbeiträge
Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 4 StundenSicherheit

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 14 StundenInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Erkennung und -Abwehr

Ups: Einfaches Nullzeichen hebelte den Anti-Malware-Schutzt in Windows 10 aus

Information von kgborn vor 1 TagErkennung und -Abwehr

Windows 10 ist das sicherste Windows aller Zeiten, wie Microsoft betont. Insidern ist aber klar, das es da Lücken, ...

Windows 10

Windows 10 on ARM: von Microsoft entfernte Info - Klartext, was nicht geht

Information von kgborn vor 1 TagWindows 10

Windows 10 on ARM ist ja eine neue Variante, die Microsoft im Verbund mit Geräteherstellern am Markt etablieren will. ...

Heiß diskutierte Inhalte
Server
Route-Befehl Unterstützung (unter CMD)
gelöst Frage von FKRR56Server36 Kommentare

Guten Tag , i.M. habe ich Probleme über den CMD-Route-Befehl ein Routing auf einen entfernten Server zuzulassen. Der Server ...

Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1028 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

Microsoft
TV-Tipp: Das Microsoft-Dilemma
Information von kgbornMicrosoft17 Kommentare

Aktuell gibt es in Behörden und in Firmen eine fatale Abhängigkeit von Microsoft und dessen Produkten. Planlos agieren die ...

Webbrowser
Welcher Browser ist der Beste?
Frage von justtinWebbrowser15 Kommentare

Hallo Leute Ich habe eine interessante Frage. Mich wurde mal interessieren welcher Browser ist eure meinung nach der beste? ...