Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Intel Pro 1000 MT Quad-Port-Teaming unter 2008R2 oder höher

Mitglied: C.R.S.

C.R.S. (Level 2) - Jetzt verbinden

04.09.2013 um 01:23 Uhr, 2761 Aufrufe, 6 Kommentare, 1 Danke

Hallo zusammen,

wir haben ein kleines Problem mit Kundenhardware, die nur über PCI-X-Slots verfügt:

Eigentlich sollten dort Quad-Port Intel Pro 1000 MT-Adapter im Teaming zum Einsatz kommen.
Als OS wird Windows 2008R2 oder höher benötigt.

Das unterstützt der Adapter zwar nicht offiziell, allerdings lassen sich die Erweiterten Netzwerkdienste (ANS) problemlos installieren, wenn ein Intel- anstelle des MS-Treibers vorinstalliert wird. Der Intel-Treiber wird beim Treiberupdate auch bevorzugt. Dies Konfiguration erfordert also keine "Zwangsinstallation" in irgendeiner Weise und wird auch laut einiger Foren-Berichte rege genutzt.

Bei mir allerdings scheitert das Teaming an mehreren Test-Switchen (sowohl statisch als auch dynamisch, die Switche sind schon korrekt konfiguriert), sobald mehr als zwei Adapter einbezogen werden. Bei drei oder vier Adaptern schaltet der Switch ca. alle 30 Sekunden einen Port komplett down für ca. 1-2 Sekunden.
Mit den ANS führt das zu einer inakzeptabel wackeligen Verbindung (neben normalen Pingzeiten immer mal wieder ~3000ms). Eingehend ist der Server nur sporadisch zu erreichen.
Alle ANS-Tests werden für die Einzeladapter positiv ausgeführt.

Versuchsweise habe ich Windows 2012 installiert, um die Adapter ohne ANS mit dem neueren MS-Treiber zu teamen. Dort bleibt zwar die Verbindung stabil und erreichbar, das Fehlerbild aber ansonsten das gleiche. Im dynamischen Modus wird dort eine fehlerhafte LACP-Aushandlung permanent für die Schnittstelle angezeigt, die beim Switch dann regelmäßig deaktiviert wird. Statisch gibt es keine Fehlermeldung, aber die Bandbreite des Teams geht natürlich runter, solange der Switch den Port deaktiviert.

Ich denke zwar an einen Hardware-Fehler und habe Ersatz bestellt, aber der Fehler tritt gleich bei zwei schon vorhandenen Test-Adaptern auf.

Deshalb die Frage: Hat jemand diesen Typ erfolgreich in der Konfiguration eingesetzt, so wie das Intel-Forum das suggeriert?
Oder sonst Ideen, was dahinter stecken könnte?

Vielen Dank!

Grüße
Richard
Mitglied: 108012
04.09.2013 um 09:14 Uhr
Hallo,

das ganze klingt jetzt zwar ein wenig überzogen, aber ich denke hier treffen ein paar Sachen aufeinander die die gesamte Stabilität
des Servers beeinträchtigen und auch die Datensicherheit gefährden.

Also die Karte sollte immer vom OS unterstützt werden, auch Treiber seitig sollte die Unterstützung vorhanden sein und erst recht
wenn es um ein LAG (LACP) geht!!!

Nimm bitte lieber einen Intel PWLA8494GT Netzwerkadapter denn dieser überprüft den Bus (Steckplatz)
in dem er steckt und stellt sich zum einen selber ein, das OS Server 2008R2 wird unterstützt und die Treiber von Intel
können benutzt werden!!!

Bei mir allerdings scheitert das Teaming an mehreren Test-Switchen (sowohl statisch als auch dynamisch, die Switche sind schon korrekt konfiguriert), sobald mehr als zwei Adapter einbezogen werden. Bei drei oder vier Adaptern schaltet der Switch ca. alle 30 Sekunden einen Port komplett down für ca. 1-2 Sekunden.
Das deutet darauf hin, dass Du eine Netzwerkschleife (Network Loop) kreiert hast!
Und mit unter ist dann das Spanning Tree Protokoll (STP) daran schuld.

Wenn Du ein LAG aufsetzt bzw. anlegst ist das immer ein zweigleisige Sache, und auf beiden Seiten (Server - Switch, Switch - Switch,..)
müssen zwingend die gleichen Einstellungen vorgenommen werden! Hier mal ein Beispiel:
- RSTP - RSTP
- dynamisch - dynamisch
- LAG over LACP

Dann sollte es funktionieren, aber wie schon weiter oben angesprochen,
- wenn die Hardware nicht richtig zum Bus (Steckplatz) passt
- das OS keine richtige Unterstützung für den Adapter hat
- und mittels der Treiber nicht die richtige oder volle Funktionsweise garantiert ist

steht der Server eben auch auf wackeligen Beinen und das ist doch auch nichts halbes oder ganzes.



Denn PCI-X Setckplätze sind ja wohl vorhanden so wie Du das weiter oben geschrieben hast.

Gruß
Dobby
Bitte warten ..
Mitglied: aqui
04.09.2013 um 09:41 Uhr
Sind beide LACP Seiten bei dir im "Active" Mode ??
Du solltest dann mal je eine Seite in den Passive Mode setzen, das fixt LACP Negotiation Probleme meistens !
Bitte warten ..
Mitglied: C.R.S.
04.09.2013 um 21:44 Uhr
Hallo,

danke euch beiden!

@108012

Zitat von 108012:
Nimm bitte lieber einen [http://www.alternate.de/Intel(R)/Intel(R)+PWLA8494GT,_Netzwerkadapter/html/product/48848/? Intel
PWLA8494GT Netzwerkadapter] denn dieser überprüft den Bus (Steckplatz)
in dem er steckt und stellt sich zum einen selber ein, das OS Server 2008R2 wird unterstützt und die
Treiber von Intel
können benutzt werden!!!

Neben einem MT-Ersatz warte ich gerade auf einen solchen. Meines Erachtens liegt aber der einzige Unterschied zwischen der GT- und MT-Version in der RoHS-Konformität. Die OS-Unterstützung ist laut Intel jedenfalls dieselbe wie für MT-Adapter, nämlich unter 2008R2 in Bezug auf ANS nicht gegeben.
Der "Basis-Treiber" wird jeweils schon voll unterstützt, das habe ich unpräzise ausgedrückt. Er ist nur älter als der MS-Treiber (23.09.2008 ggü. 2010). Der einzige Trick bei der Sache ist, dass das ANS-Setup den Adapter nur erkennt, wenn der Intel-Treiber schon installiert ist, und das (ANS nachinstallieren) eben nicht offiziell unterstützt ist.
Mir kam noch der Gedanke, eine ältere ANS-Version zu suchen, um keine so große Entwicklungsdiskrepanz zwischen Treiber und ANS zu haben. Habe ich bislang aber nicht verfolgt.

Wenn Du ein LAG aufsetzt bzw. anlegst ist das immer ein zweigleisige Sache, und auf beiden Seiten (Server - Switch, Switch -
Switch,..)
müssen zwingend die gleichen Einstellungen vorgenommen werden! Hier mal ein Beispiel:
- RSTP - RSTP
- dynamisch - dynamisch
- LAG over LACP

STP ist deaktiviert und Teaming mache ich eigentlich nicht zum ersten Mal.
Unsicher war ich mir bei der laut Intel-ANS "Statischen Linkaggregation": Ich gehe davon aus, dass das ein normaler 802.3ad-Modus ohne LACP ist, und keine Intel-Besonderheit (802.3ad ist in der Beschreibung nur für den dynamischen Modus explizit angegeben).
Mit zwei Adaptern funktioniert ein Team auch einwandfrei. Im LACP-Betrieb mit vier Schnittstellen kann man beim "wackeligen" Adapter das Kabel ziehen, der Fehler zieht dann auf einen der drei verbliebenen um, und das Team funktioniert, wenn man auch dort den Stecker zieht. Die Auswahl scheint egal. 2x2 läuft ebenso.


@aqui:
Auf Seiten des Switches habe ich mit Active/Passive experimentiert, ohne Erfolg. Für die Netzwerkkarte habe ich keine solche Einstellung gefunden?

Gibt es denn eine vernünftige Alternative für PCI-X-Slots? Ich habe mit einer gewissen Intel-Affinität gesucht. HP?

Danke nochmal.

Grüße
Richard
Bitte warten ..
Mitglied: 108012
04.09.2013 um 23:08 Uhr
Hallo nochmal,

STP ist deaktiviert und Teaming mache ich eigentlich nicht zum ersten Mal.
Das will ich Dir ja auch gar nicht unterstellen, aber ich kenne es nur so, das bei einem LAG (LACP)
immer zwingend ein Form des "Spanning Tree Protocolls" (STP, RSTP, MST,..) und das auch immr
auf beiden Seiten das LAGs. Ich glaube Dir das daher nicht so recht, tut mir leid, denn die Symptome
die Du weiter oben beschrieben hast (Port flapping), weisen eher auf das Du einen Netzwerkloop kreiert hast.

Gruß
Dobby
Bitte warten ..
Mitglied: C.R.S.
05.09.2013 um 19:31 Uhr
Hallo,

nachdem ich heute Ersatz-Adapter und ein zweites Kundengerät bekommen habe, hat sich herausgestellt, dass es am Mainboard liegen muss.
Kann ich mir zwar nicht erklären, aber auf dem zweiten Board funktionieren alle NICs wie es sein soll.

Grüße
Richard
Bitte warten ..
Mitglied: 108012
05.09.2013 um 20:42 Uhr
Kann ich mir zwar nicht erklären, aber auf dem zweiten Board funktionieren alle NICs wie es sein soll.
Na super da hättest Du ja noch lange suchen können und wärst nicht fündig geworden, aber gut
dass Du es wenigstens noch geschrieben hast.

Gruß
Dobby
Bitte warten ..
Ähnliche Inhalte
Server-Hardware
Intel Pro1000 PT Quad Teaming Treiber
gelöst Frage von theoberlinServer-Hardware15 Kommentare

Hallo zusammen, ich würde gern eine Intel Pro/1000 Quad pcie Karte in einer Win7x64 Workstation einsetzen. Leider findet sich ...

Windows Netzwerk

Server 2008R2 NIC-Teaming Intel zwei Switche

gelöst Frage von RalphTWindows Netzwerk4 Kommentare

Moin, ich habe eine Frage, bei der ich nicht sicher bin: Ich habe zwei HP-Switche. Ich möchte jeweils ein ...

Windows Systemdateien

NIC Teaming Windows 2008R2 HP Nics

Frage von WinLiCLIWindows Systemdateien5 Kommentare

Hallo, ich möchte gerne auf unseren Fileserver NIC Team erstellen. Wie ich aus dem Internet entnahm, bringt der 08R2 ...

Netzwerkgrundlagen

Dual-Port, NIC-Teaming und Netzwerkoptimierung - Ich betrete Neuland

gelöst Frage von DaveDaveNetzwerkgrundlagen22 Kommentare

Hallo Welt! Ich habe kürzlich festgestellt, dass mein Netzwerk eigentlich total langsam und instabil ist. Gestern mal 1GB vom ...

Neue Wissensbeiträge
Microsoft

Neuigkeiten zu Server und Office 365 was läuft mit was und was nicht

Tipp von AlFalcone vor 1 TagMicrosoft4 Kommentare

Da diese Infos scheinbar unerwünscht sind, habe ich diese wider gelöscht.

Speicherkarten

Neuer Speicherkartentyp - zunächst nur für Huawei-Smartphones (künftig auch für Notebooks u. Tablets?)

Tipp von VGem-e vor 1 TagSpeicherkarten1 Kommentar

Servus, als ob das "Chaos" i.S. Speicherkarten noch nicht groß genug wäre?! Evtl. kommt dieser neue Kartentyp bald auch ...

Sicherheit

Diverse D-Link-Router durch drei Schwachstellen kompromittierbar

Information von kgborn vor 1 TagSicherheit

Hat jemand D-Link-Router in Verwendung? Einige Modelle sind sicherheitstechnisch offen wie ein Scheunentor. Äußerst unschöne Sache, aber nichts neues ...

Hardware

100.000 Mikrotik-Router ungefragt von Hacker abgesichert

Information von 7Gizmo7 vor 2 TagenHardware1 Kommentar

Hallo zusammen, da hier ja öfters mal von Mikrotik gesprochen wird. Trotz Updates klafft eine Sicherheitslücke in Hundertausenden Mikrotik-Routern. ...

Heiß diskutierte Inhalte
Sicherheitsgrundlagen
EuGH-Urteil - Internetanschluss für die ganze Familie - Filesharer haften trotzdem
Frage von StefanKittelSicherheitsgrundlagen40 Kommentare

Hallo, In diesem Artikel geht es darum, dass Jemand aus der Familie ein Hörbuch illegal hochgeladen hat. Der Vater ...

Apple
MacBook Pro 2018 mit 8 GB oder 16 GB
Frage von SysAdm81Apple25 Kommentare

Hallo zusammen, ich steh vor der Überlegung mir ein MacBook Pro 13 (2018) zu kaufen. Bzgl. SSD habe ich ...

Off Topic
SysAdmin im öffentlichen Dienst - jemand Erfahrungen?
Frage von JohnDorianOff Topic19 Kommentare

Hallo zusammen, hat jemand Erfahrung wie es so ist als SysAdmin im öffentlichen Dienst (Landkreis) im Südwesten der Republik ...

TK-Netze & Geräte
Low budget TK-Anlage für KMU
Frage von HeinklugTK-Netze & Geräte16 Kommentare

Hallo Admins, ich bin auf der Suche nach eine kostengünstigen Telefonanlage für mein kleines Büro mit 4-5 Mitarbeitern. Dabei ...