Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Kein Bild nach Boot ohne Monitor

Mitglied: netadm

netadm (Level 1) - Jetzt verbinden

28.09.2011 um 07:52 Uhr, 3842 Aufrufe, 7 Kommentare

Hallo,

ich habe folgendes Problem,bei dem ich auch über die Suchfunktion noch nichts passendes finden konnte. Ich habe einen PC mit folgender Konfiguration:

- Asus-Desktopboard (Intel P55 Chipsatz)
- VGA Asus EN210 SILENT DI PCI-E

Installiert ist hierauf Opensuse 11.3 64bit mit Kernel 2.6.34.12. Gestartet wird das System ohne grafische Oberfläche im Runlevel 3.

Es funktioniert alles einwandfrei, solange während des Bootvorgangs ein Monitor angeschlossen ist. Wird dieser jedoch erst nach dem Bootvorgang angeschlossen, so bleibt dieser schwarz und lässt sich nicht zum Leben erwecken. Ich habe dies schon mit dem VGA- und dem DVI-Port getestet. Aber leider der gleiche Effekt.

Gibt es eine Lösung, dass der Monitor auch an geht, wenn er erst im Nachhinein angeschlossen wird?

Viele Grüße
Mitglied: 64748
28.09.2011 um 08:17 Uhr
Guten Morgen,

wichtig wäre zu wissen, woran es scheitert. Eine Idee ist, das Linux irgendein (oder mehrere) Module nur lädt, wenn ein Monitor angeschlossen ist.
Schreib das Kommando
lsmod | sort > lsmod_ohne_Monitor.txt
in eine Textdatei, und speichere das ganze so, dass Du es bei schwarzem Bildschirm ausführen kannst, oder lass es beim shutdown automatisch ausführen (chmod 755 nicht vergessen! falls Du das Kommando als Datei abspeicherst).
Dann vergleiche die geladenen Module bei schwarzem Monitor mit den Modulen mit funktionierendem Monitor.
Falls es sich jedoch um ein Feature der Grafikkarte handelt, dann wird das nichts nutzen.

Außerdem kannst Du die Xorg.log Dateien für beide Fälle vergleichen.


Markus
Bitte warten ..
Mitglied: netadm
01.10.2011 um 17:35 Uhr
Schönen guten Abend,

vielen Dank für den schnellen Tip. Ich vermute da liegt auch schon das Problem. Beim Boot ohne Monitor wird das Modul namens "nouveau" nicht geladen. Dies scheint ein nVidia- Treibermodul zu sein.

Könnte ich dies testweise während des Betriebs z.B. per ssh nachladen? Dann müsste der Monitor ja theoretisch angehen oder funktioniert das nicht? Mit welchem Kommando würde dies denn funktionieren? Mit modprobe ? Und wenn dies das Problem wäre, kann ich OpenSuSE dazu bringen, das Modul immer zu laden, unabhängig davon, ob ein Monitor angeschlossen ist?

Xorg- Logs kann ich keine finden. Aber kann es bei mir überhaupt welche geben, wenn ich im Runlevel 3 ohne grafische Oberfläche arbeite?

Viele Grüße
Bitte warten ..
Mitglied: 64748
01.10.2011 um 18:37 Uhr
Hallo,

mit
modprobe nouveau
in der rc.local sollte das Module bei jedem Systemstart geladen werden.

Die lofiles sind normalerweise in /var/log aber ich kenn mich mit Suse nicht aus.

Markus
Bitte warten ..
Mitglied: netadm
05.10.2011 um 21:43 Uhr
Hallo nochmal,

also mein Problem ist nun zur Hälfte gelöst.

Ich bekomme den Monitor mit

 
modprobe nouveau 
den Monitor wieder an. Jedoch erst nachdem ich das Modul einmal entladen und neu geladen habe.
Gibt es evtl. eine Möglichkeit, dies automatisch beim Bootvorgang zu machen?
Bitte warten ..
Mitglied: 64748
05.10.2011 um 21:44 Uhr
Du meinst, Du musst es laden, dann wieder entladen und dann nochmal laden?

Markus
Bitte warten ..
Mitglied: netadm
05.10.2011 um 22:00 Uhr
Nicht ganz.

Wenn ich ohne Monitor boote, dann wird das Modul erstmal nicht mit geladen. Somit bleibt der Monitor auch dunkel.

Mache ich nun jedoch

 modprobe -v nouveau 


so tut sich überhaupt nichts. Erst nach

 modprobe -r nouveau 

 modprobe -v nouveau 


werden das nouveau-Modul und die zugehörigen Module neu geladen und der Monitor geht an.
Bitte warten ..
Mitglied: 64748
05.10.2011 um 22:08 Uhr
Du solltest mal die Dokumentation zu Suse zu Rate ziehen. Dort steht auch, wie man bestimmte Module beim Systemstart laden kann. Ich würde es in der rc.local machen. Allerdings gibt's auch ein Verzeichnis /etc/modprobe.d in dem solche Dinge gesteuert werden. So ähnlich wird's bei Suse auch sein.

Zur Not schreibst Du ein Skript:
#!bin/sh 
modprobe nouveau 
sleep 2 
rmmod nouveau 
sleep 2 
modprobe nouveau
und lässt es in der rc.local ausführen.

Markus
Bitte warten ..
Ähnliche Inhalte
Peripheriegeräte
Bild über Netzwerk an Monitor
Frage von Ghost108Peripheriegeräte13 Kommentare

Hallo zusammen, ich möchte gerne folgendes realisieren: Ich habe 4 virtuelle Maschinen (Windows 7). Gerne möchte ich jetzt in ...

Grafikkarten & Monitore

Monitor geräusche bei Schwarz und Weiss Bildern

gelöst Frage von CamperGuyGrafikkarten & Monitore6 Kommentare

Hallo, ich habe eine Frage bezüglich meines Monitores. (Marke: Asus. Die genaue Modellnummer kann ich momentan leider nicht Angeben, ...

Grafik

Bild auf 4k Monitor vollständig anzeigen

gelöst Frage von flotautGrafik8 Kommentare

Hallo, wir haben einen 4k Monitor bei uns. Dazu haben wir ein Bild das jedoch nicht in 4k Auflösung ...

Windows 7

RDP Sitzung mit 2 Monitoren: Bild verschiebt sich

gelöst Frage von Timo0oWindows 77 Kommentare

Ich habe ein Äußerst nerviges Problem! Und zwar habe ich an einem Notebook einen externen Monitor angeschlossen. Wenn nun ...

Neue Wissensbeiträge
Sicherheit

Interessante Methode für Leute, die in einer Windowsdomäne starke Kennwörter erzwingen wollen

Information von DerWoWusste vor 39 MinutenSicherheit1 Kommentar

Dieser Artikel beschreibt, wie man auch ohne 3rd-party-tools die Kennwortsicherheit in Windows-Domänen erhöhen kann. Der Grundgedanke lautet: wir prüfen ...

Windows Server

SBS 2011: Installation von KB4457144 schlägt beim Reboot fehl - Von Dienst gesperrte Schriftart ursächlich

Tipp von the-buccaneer vor 11 StundenWindows Server1 Kommentar

Moinsen zusammen! Das hat mich einige graue Haare gekostet: Ein SBS 2011 weigerte sich schon im August, das monatl. ...

Windows Netzwerk
Browser-Lags und IPv6
Erfahrungsbericht von NixVerstehen vor 17 StundenWindows Netzwerk1 Kommentar

Hallo zusammen, wir betreiben als kleines Speditionsunternehmen ein überschaubares Windows-Netzwerk mit Win10-Clients sowie einem Server 2016 Essentials als "eierlegende ...

Humor (lol)

Erstaunlich, Windows mit extremer Laufzeit (Server) lol

Tipp von mathu vor 20 StundenHumor (lol)5 Kommentare

Was es so alles gibt. :-)

Heiß diskutierte Inhalte
Hyper-V
Windows Serer 2016 Standard virtualisieren
gelöst Frage von fritte87Hyper-V33 Kommentare

Hallo zusammen, ich muss für eine kleine Firma ein entsprechendes neues kleines Konzept bauen. Ich habe einen Server Standard ...

LAN, WAN, Wireless
Kombiniere mehrere 4G Router zu einem Netzwerk - Anwendung kleine LAN (10-20 Leute)
Frage von HulkTheHeroLAN, WAN, Wireless24 Kommentare

Guten Mittag liebes Administrator - Fourm, ich hoffe ich habe das richtige Thema ausgewählt - ansonsten bitte gerne verschieben ...

Windows Server
Fileserver von 2012 R2 auf 2012R2
gelöst Frage von ThabeusWindows Server23 Kommentare

Moin moin, leider war in der Vergangenheit der Fokus des Betriebs nicht auf Langfristigkeit ausgelegt. Daher stehe ich jetzt ...

Router & Routing
Größere Zahl VPN-Verbindungen mit Fritz-Box einrichten
Frage von miscmikeRouter & Routing15 Kommentare

Hallo Zusammen, ich supporte verschiedene Kunden mit bestehenden LAN-LAN-Kopplungen via FritzBox (7490, FritzOS 7.01) . Anwendungen sind z.B. Kaspersky-KSC ...