Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Wie komme ich an meinen Router per Telnet?

Mitglied: JoshuaTree

JoshuaTree (Level 1) - Jetzt verbinden

30.01.2010 um 17:36 Uhr, 7824 Aufrufe, 8 Kommentare

Tach,

glaube mein Problem existiert fast nicht denn "eigentlich" sollte es funktionieren.

Habe eine Fritzbox (router,modem) und dahinter eine Cisco SOHO 836

Jetzt möchte ich per Telnet ein bißchen unter der Woche wenn ich nicht zuhause bin an dem Ding rumspielen.

Habe dazu mir Dyndns eingerichtet und auf der Fritzbox Port 23 weitergeleitet auf die IP von der Cisco.
Die Cisco ist natürlich im Netz sprich hat eine Ip und ist auch in der gleichen Maske.

Im Netz funktioniert Telnet auch ohne Prob nur von außen über i-net nicht.

Hab ich was übersehen? Ich habe andere Portfreigaben laufen die Funktionieren einwandfrei.


Gruss
Andreas
Mitglied: maretz
30.01.2010 um 18:21 Uhr
moin,

bist du dir erstmal sicher das es via dyndns klappt - d.h. das deine ip auch aktuallisiert wurde? Ggf. kann ja mal jemand von extern nen ping für dich machen...

Dann kann es noch sein das du ein solches Forward nicht von innen testen kannst (sofern du das versuchst) -> da der Router erkennt das du bereits im Netz bist und dann die Forward-Regel nicht greifft... Je nachdem wie das auf der Fritz is kann das ja auch nen problem sein. Oder hast du den zugriff direkt von aussen schon getestet?

Firewall usw. gehe ich mal von aus ist auch nicht auf "blocken" von port 23 eingestellt?
Bitte warten ..
Mitglied: AndreasBrecht
30.01.2010 um 18:24 Uhr
Bist Du sicher, dass Du bei dem Forwarding das richtige Protokoll erlaubt hast?
Bitte warten ..
Mitglied: JoshuaTree
30.01.2010 um 18:46 Uhr
moin,

ja dyndns geht def.

Da ich andere Sachen darüber mache. Ich Teste natürlich per UMTS ( iphone telnetclient)
Mit RDP-Client vom Iphone komme ich rein nur eben nicht mit Telnet !?

Muß ich auf dem Cisco Router noch was konfigurieren ?
Bitte warten ..
Mitglied: manuel-r
30.01.2010 um 19:34 Uhr
Muss ich auf dem Cisco Router noch was konfigurieren?

Hast du dem Cisco als Gateway auch die FritzBox gegeben? Sonst weiß er nämlich nicht wohin mit den Paketen für den Rückweg zur deinem Client (keine Route)
Bitte warten ..
Mitglied: aqui
31.01.2010 um 12:58 Uhr
Nur mal dumm nachgefragt: Sind beide Router an einem Standort zusammengeschaltet hintereinander oder ist jeweils ein Router am jeweiliugen Standort, oder wie ist dein Beschreibung zu interpretieren ??

Eine direkte Zusammenschaltung beider Router ist NICHT möglich, da beide Router ein integriertes DSL Modem haben und damit am WAN Port nacktes DSL sprechen und kein Ethernet !!! DSL auf DSL stecken ohne DSLAM geht nicht !
Einzig was du machen kannst ist den Cisco mit seinem LAN Port (4 Port Switch) ins lokale LAN der FB zu hängen um mit ihm Stand Alone zu spielen.
Dazu gibst du ihm eine statische IP Adresse aus dem LAN der Fritzbox die außerhalb der DHCP Adressen der Fritzbox liegt wie z.B. 192.168.178.254 !
Das geht mit
enable
conf t
int eth 0
ip address 192.168.178.254 255.255.255.0
no shut
<ctrl z>
wr

Nun verbindest du LAN der FB mit dem LAN des Ciscos und lädst dir eins der klassischen telnet Programme wie Putty oder TeraTerm runter und checkst als allererstes ob die Telnet Session auf den Cisco lokal funktioniert. ACHTUNG: Dafür musst du dem Cisco ein enable und ein telnet Passwort vergeben, sonst lässt er KEINE Telnet Session aus Sicherheitsgründen zu !!! Also immer erst lokal testen !!!
So, wenn das klappt musst du nur noch ganz einfach und simpel eine Port Weiterleitung von TCP 23 auf die lokale IP des Cisco machen..fertich !!
Einfacher gehts wirklich nicht:
Tip: Damit nicht gleich jede Port Scan Attacke und jedes Script Kiddie deinen offenen Telnet Port findet und Mist damit macht solltest du besser Port Verschleierung oder Port Translation machen auf der FB.
Trage dir also in die Portweiterleitung TCP 53223 als eingehenden Port ein und dann lokal 23 auf die Cisco IP.
Von Remote gibst du dann in der telnet Applikation immer den Zielport 53223 an ala telnet meinrouter.homenet.org:53223
Bitte warten ..
Mitglied: JoshuaTree
01.02.2010 um 14:20 Uhr
Hi,

danke für die Hilfe.

Ich habe dem Cisco eine Ip aus dem lokalen Heimnetz gegeben.
Ich habe den den Cisco switch port 1 direkt in den Switch der FB gesteckt
Freigabe von der FB leider wie ich jetzt festelle 23 auf 23 gemacht.

Ich habe im Cisco eth0 ne wie gesagt ne IP und den deflault Gateway eingetragen sprich eben die IP der FB

Intern geht Telnet egal ob jetzt über den CMD-Telnet oder HyperTerminal Putty etc habe ich noch nicht weil ich es ja erst mal ohne verschlüsselung zum laufen bringen wollte.

Habe auch ein enable PW gesetzt.

wenn ich von Außen versuche darauf zuzugreifen dauert es sehr lange dann kommt ein Timeout.

Wenn ich dagegen auf meinen Webserver zugreife habe ich justintime Antwort und werde zu PW eingabe aufgefordert.
Manno
Bitte warten ..
Mitglied: aqui
02.02.2010 um 19:19 Uhr
Ob du port Verschleierung oder 23 auf 23 machst ist ja erstmal egal. Kannst ja erstmal auf TCP 23 lassen.

Du hast aber vermutlich eine Fehler bei der Port Weiterleitung gemacht.
Hast du dem Cisco eine default Route eingetragen als ip route 0.0.0.0 0.0.0.0 <lan_ip_adresse_fritzbox> ??? Das ist wichtig damit die Pakte auch den Rückweg finden.

Sonst mal mal debug ip paket auf dem Cisco (term mon nicht vergessen wenn du mit Telnet drauf bist) und prüf mal ob überhaupt TCP 23 Paktete von der FB ankommen.
Mit dem Debugger bekommst du das doch im Handumdrehen raus.
Bitte warten ..
Mitglied: JoshuaTree
03.02.2010 um 13:56 Uhr
Danke,

jetzt nach dem ich 2Tage erst mal die Finger davon gelassen habe weil ich kein Bock mehr hatte. Jetzt gehts.
Hab mich aber auch schon gefragt wie ddas mit dem Debug funktioniert also >term mon> debug ip paket -- ?
Bitte warten ..
Ähnliche Inhalte
Windows Server
Telnet Server Windows 8
Frage von EDV-SpezialistWindows Server10 Kommentare

Ich installiere regelmaessig Telnet Server unter Windows. Bis Windows 7 können die Administratoren dann zum Beispiel Dienste stoppen und ...

Batch & Shell
Automatischer Login per Telnet
Frage von 121851Batch & Shell6 Kommentare

Hallo zusammen, ich habe folgendes Problem. Erstmal bin ich nicht so fit was Programmieren angeht. Gibt es eine möglichkeit ...

PHP

Mit PHP eine Telnet abfrage machen und ausgeben

Frage von helmuthelmut2000PHP1 Kommentar

Hallo, Ich möchte folgendes machen und hätte da etwas Hilfe gebraucht. Ich habe an meiner Heizung einen Optolink Adapter ...

Windows Tools

Windows 10 und telnet

Frage von How-ToWindows Tools16 Kommentare

hallo leute, wenn ich über cmd eine telnetverbinung hertellt habe, spinnt dann cmd. ich kann dann z.b. die befehle ...

Neue Wissensbeiträge
Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 14 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 20 StundeniOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 1 TagSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Internet

Datendealing im WWW Tracking Methoden immer brutaler

Information von sabines vor 1 TagInternet

Interessanter Artikel zum Thema Tracking im WWW und die immer "besseren" Methoden des Trackings. Professor Arvind Narayanan (Princeton-Universität) betreibt ...

Heiß diskutierte Inhalte
Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server25 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless22 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

SAN, NAS, DAS
Qnap TS-453S Pro - Anbindung Active Directory
Frage von JuckieSAN, NAS, DAS13 Kommentare

Hallo zusammen, ich habe hier eine Qnap TS-453S Pro die sich mal so absolut gar nicht in das Active ...