Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Konfiguration Owncloud mit AD-Anbindung

Mitglied: Philipp711

Philipp711 (Level 2) - Jetzt verbinden

04.11.2014 um 19:39 Uhr, 6959 Aufrufe, 5 Kommentare

Hallo Leute,

vielleicht habt ihr auch eine Owncloud-Installation mit der Active-Directory (2012R2) verknüpft und könnt mir helfen.

Es geht darum, die Anmeldung auf eine bestimmte User-Gruppe zu beschränken. Dafür habe ich eine Globale-Sicherheitsgruppe "Owncloud-User" in unserer AD angelegt und 6 User hinterlegt (mein Benutzerkonto zum test nicht).

Meine LDAP-Konfig von Owncloud sieht so aus:

01.
LDAP Basic 
02.
Host = DC.dom.local 
03.
Base DN = DC=dom,DC=local 
04.
  
05.
User DN = cn=administrator,ou=Administration,dc=dom,dc=local 
06.
Password = PW von administrator 
07.
Anmeldefilter = (&(memberOf=CN=Owncloud-User,OU=Grp_Sicherheit-ACLs,OU=Unternehmen,DC=dom,DC=local)(sAMAccountName=%uid)) 
08.
Nutzer-Filter = memberof=CN=Owncloud-User,OU=Grp_Sicherheit-ACLs,OU=Unternehmen,DC=dom,DC=local 
09.
Gruppen Filter = *LEER* 
10.
 
11.
 Advanced/Ordnereinstellungen 
12.
 
13.
 Basis-Benutzerbaum = DC=dom,DC=local 
14.
 Basis-Gruppenbaum = DC=dom,DC=local 
15.
 Assoziation zwischen Gruppen und Benutzer = member (AD) 
16.
 Feld für Anzeigenamen des Benutzers = displayname 
17.
 Feld für den Anzeigename der Gruppe = cn
Leider ist es so, dass ich mich und insbesondere ganz neu angelegte User an Owncloud anmelden können. Gibts irgendwas zu beachten was ich übersehen habe? Kann ich die Benutzerabfrage irgendwie testen? Komme nicht weiter!

Danke!

Gruß
Mitglied: Dani
04.11.2014, aktualisiert um 22:57 Uhr
Moin,
hast du die Konfigration über einen Editor gebastelt oder bist du nach der Doku vorgegangen?
Wenn du "nur" die AD-Abindung ohne Einschränkungen (Gruppe, Filter, etc...) konfiguriest, geht es auch nicht?
Der Benutzer "Administrator" ist zufällig nicht gesperrt oder deaktiviert?


Gruß,
Dani
Bitte warten ..
Mitglied: Philipp711
04.11.2014, aktualisiert um 21:07 Uhr
Zitat von Dani:

hast du die Konfigration über einen Editor gebastelt oder bist du nach der
[http://doc.owncloud.org/server/6.0/admin_manual/configuration/auth_ldap.html Doku vorgegangen?

Primär bin ich nach dieser Anleitung gegangen -> https://vorkbaard.nl/add-owncloud-6-0-to-active-directory-2012-r2/ . Mir ist die Owncloud-Doku aber bei der Fehlersuche ebenfalls unter die Finger geraten - allerdings kann ich persönlich nicht feststellen was ich falsch mache. Vielleicht übersehen ich ja was....

Wenn du "nur" die AD-Abindung ohne Einschränkungen (Gruppe, Filter, etc...) konfiguriest, geht es auch nicht?
Der Benutzer "Administrator" ist zufällig nicht gesperrt oder deaktiviert?

Ganz ohne Filter geht nicht - dann wird "Konfigration unvollständig" angezeigt - (sAMAccountName=%uid) muss stehen bleiben. Wenn ich den "(Memberof=XXX)"-Kram wegglassen klappt es auch. Wie gesagt: Es klappt momentan mit allen Benutzern, auch wenn diese nicht in der Gruppe "Owncloud-User" sind. Es sollte aber anders herum sein -> nur die "Owncloud-User"-Mitglieder sollen sich anmelden können.

Der Domänen-Benutzer "Administrator" ist in der Active-Directory nicht gesperrt oder deaktiviert....
Bitte warten ..
Mitglied: Dani
LÖSUNG 04.11.2014, aktualisiert 24.12.2014
Wie gesagt: Es klappt momentan mit allen Benutzern, auch wenn diese nicht in der Gruppe "Owncloud-User" sind.
War mir so nicht ganz klar.

Hinterlege bei User Login Filter folgendes:
01.
(&(&(sAMAccountName=%uid)(objectClass=user))(memberOf=CN=Owncloud-User,OU=Grp_Sicherheit-ACLs,OU=Unternehmen,DC=dom,DC=local))
Gruß,
Dani
Bitte warten ..
Mitglied: Philipp711
05.11.2014, aktualisiert um 07:56 Uhr
Ich glaube ich komme dem Fehler näher. Ich glaube es liegt nicht wirklich an Owncloud und dem Login-Filter.

Viel mehr haben meine Benutzer in dem Attribut-Explorer des AD-Benutzerobjekts kein Attribut mit dem Namen "MemberOf". ADSedit über den DC als Domänen-Admin zeigt auch keine Attribut "Memberof" an.

Bin jetzt ein wenig verwirrt - die Active Directory läuft so eigentlich ohne Probleme.
Unsere komplette Rechteverwaltung von Fileserver über den Proxy mit SSO, CRM-Software etc basiert auf Active-Directory-Gruppen mit den entsprechenden Usern - alles läuft einwandfrei. Wo kriegt die AD denn jetzt die Infos über die Gruppenzugehörigkeit aus den Benutzerobjekten raus?!
Bitte warten ..
Mitglied: Philipp711
24.12.2014 um 13:41 Uhr
Hallo,

der Beitrag ist zwar schon etwas älter aber ich habe das Problem jetzt gelöst.

Die Login-Filter sind so gesetzt wie ich in meinem Anfangspost beschrieben habe. Ich habe kurzerhand das komplette AD-Modul deaktiviert danach aktiviert und noch einmal konfiguriert.

Jetzt klappt es!! Danke!
Bitte warten ..
Ähnliche Inhalte
Windows Server
Passwort Manager mit AD anbindung
Frage von dakoerryWindows Server6 Kommentare

Hallo ich suche einen Passwort Manager der eine Anbindung an eine AD hat so das die User von der ...

LAN, WAN, Wireless

Problem mit FreeRADIUS mit Anbindung an AD

gelöst Frage von tingelLAN, WAN, Wireless3 Kommentare

Hallo, ich habe ein Problem mit meiner FreeRADIUS-Konfiguration. Versuche mit NTRadPing und mit "radtest" funktionieren, ebenso ntlm_auth über Konsole. ...

Linux Userverwaltung

OwnCloud : neues Active Directory : gleiche AD Benutzer : neue ownCloud Benutzer

Frage von ThePcSwagTogetherLinux Userverwaltung5 Kommentare

Einen herzlichen guten Morgen, ich habe aktuell den Fall, dass wir hier eine neue Active Directory Gesamtstruktur haben (Migration ...

Windows Server

Korrekte WSUS Konfiguration ohne AD

Frage von winlinWindows Server3 Kommentare

Hallo Leute ich habe eine AD-lose Landschaft in welcher viele virtuelle Maschinen (W2K12R2) laufen. Nun habe ich einen WSUS ...

Neue Wissensbeiträge
Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 2 StundenWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 12 StundenSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Microsoft
Folder Security Viewer-Lizenzen zu gewinnen
Information von kgborn vor 12 StundenMicrosoft

Ich nehme das Thema mal in Absprache mit Frank hier auf, da es für den einen oder anderen Administrator ...

Hardware

Feueralarm killt Festplatten in Rechenzentrum - führt zu größerem Ausfall

Information von kgborn vor 13 StundenHardware11 Kommentare

Noch ein kleiner Beitrag für Administratoren, die in Rechenzentren aktiv sind - so als Fingerzeig. Denn es gibt Szenarien, ...

Heiß diskutierte Inhalte
Linux
Linux Server oder Windows Server - lohnt eine Umstellung auf Linux und ebenso basierende SW bei einer langfristigen Planung?
Frage von motus5Linux23 Kommentare

Wir brauchen bei uns einen neuen Server. Dieser wird als Fileserver, Domäne Controller sowie Exchange Server verwendet. Wir versuchen ...

DSL, VDSL
ISP Wechsel auf Vodefone Koax, Gebäudeverkabelung nur per Cat 7
solved Frage von wusa88DSL, VDSL18 Kommentare

Hallo Zusammen, ich bin momentan bei Mnet als Glasfaser Kunde und möchte Preis/Leistungs-Technisch zu Kabel Deutschland / Vodafone wechseln. ...

Windows Server
Domänencontroller trennen
Frage von Akit57Windows Server13 Kommentare

Hallo, ich hoffe das mir hier jemand meine Frage trotz der spärlichen Informationen die ich geben kann beantworten kann: ...

LAN, WAN, Wireless
Kommunikation zwischen verschiedenen IP-Bereichen
Frage von DirkHoLAN, WAN, Wireless13 Kommentare

Hallo zusammen, von Unitymedia habe ich ein neues Modem (Connect Box) erhalten, das u.a. IPv4 aber keinen Bridge Mode ...