Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Kopier-Befehl auf Netzlaufwerk in Batch-Datei wird nicht ausgeführt

Mitglied: win-lin

win-lin (Level 1) - Jetzt verbinden

08.12.2013, aktualisiert 02:25 Uhr, 7274 Aufrufe, 8 Kommentare

Ein Datenbank-Backup soll via xcopy in einer Batch-datei auf ein Netzlaufwerk kopiert werden.
Die Zeilen in der Batch sehen ungefähr so aus:
xcopy D:\Unterverzeichnis\Datenbank.bak E:\ (kopiere auf USB-Festplatte E)
xcopy D:\Unterverzeichnis\Datenbank.bak "\\NAS\Verzeichnis" (kopiere auf Netzlaufwerk NAS)
Die Batch-Datei soll als Task zu einer bestimmten Zeit starten, tut sie auch.
Es wird aber nur die erste Zeile wirklich ausgeführt, die zweite Zeile nicht. Gibt auch keine Fehlermeldung.
Wird die Batch manuell gestartet/ausgeführt, werden beide Zeilen korrekt ausgeführt.

Das Ganze wird auf Windows Server 2008 R2 mit Admin-Rechten durchgeführt.
Mitglied: colinardo
08.12.2013, aktualisiert um 10:11 Uhr
Hallo win-lin,Willkommen im Forum!

du hast sehr wahrscheinlich im Task einen Useraccount hinterlegt der keine Zugriffsrechte auf das NAS hat...
Gibt hier dazu etliche Threads.

Schönen zweiten Advent
Grüße Uwe
Bitte warten ..
Mitglied: win-lin
08.12.2013 um 23:31 Uhr
Hallo colinardo,

das war schon eine meiner Überlegungen, die ich aber nicht weiter verfolgt habe, da ich ja sonst ohne Legitimation auf das Netzlaufwerk zugreifen kann (was mich eigentlich verwundern sollte).
Und bei der Erstellung des Task wurde auch nichts abgefragt.
Aber es liegt schon nahe, daß es wohl darauf hinauslaufen wird.
Ich richte das nochmal neu ein ... mal sehen.
Danke erst mal.
Beste Grüße
Bitte warten ..
Mitglied: loonydeluxe
09.12.2013 um 19:55 Uhr
Unter welchem Benutzerkonto wird der Task ausgeführt? Wenn dein Task versucht, sich mit "SYSTEM" (bzw. seinem Domänen-Computerkonto) am Share zu authentifizieren, benötigt das Konto auch genügend Rechte. Authentifizierung mit dem Computerkonto setzt aber einen Verzeichnisdienst a la AD voraus.
Ansonsten setze eine Zeile net use \\nas\share passwortimklartext /user:benutzername davor, dann wird die anmeldung mit der gewünschten kombination benutzername/kennwort durchgeführt. Dann sollte aber niemand unberechtigtes die Batch-Datei lesen können
Bitte warten ..
Mitglied: win-lin
10.12.2013 um 04:02 Uhr
Auf der Suche nach der Fehlerbeschreibung 0x4 bin ich in einem englischsprchigem Forum ebenfalls fündig geworden: Der Task läuft als Service, muß aber als berechtigter User laufen
und man kann das mit Net Use lösen.

Auf einem Win-7 Client im gleichen Netzwerk habe ich etwas experimentiert.
Also mit der vorangestellten Zeile
net use \\nas\share passwortimklartext /user:benutzername
funktioniert der Kopiervorgang, aber nicht restlos fehlerfrei:
Es wird moniert, daß sich ein User nicht mehrmals mit einer Netzwerkfreigabe verbinden kann.

Ich habe es dann auf
net use \\nas\zielverzeichnis
reduziert, darunter
xcopy c:\quelldatei "\\nas\zielverzeichnis" /Y /E

Ergebnis: 0x0 .... fehlerfrei gelaufen

aber
auf dem Ziellaufwerk waren nun auch Verzeichnisse angelegt, die da nicht sein sollten.
Die gesamte Verzeichnisstruktur war auf dem Ziellaufwerk mit angelegt worden (ohne Dateien).
Als Ursache stellte sich heraus, daß meine Übungsdatei direkt aus dem Wurzelverzeichnis C: stammte.
Die Quelldatei/en müssen wohl aus einem Unterverzeichnis stammen.

Nächster Schritt: Testlauf auf dem Server .......
Bitte warten ..
Mitglied: win-lin
10.12.2013 um 06:12 Uhr
und läuft..

danke.
Bitte warten ..
Mitglied: loonydeluxe
10.12.2013 um 10:06 Uhr
An den Unterverzeichnissen ist der Parameter /e schuld. Der kopiert Unterverzeichnisse.
Bitte warten ..
Mitglied: win-lin
11.12.2013 um 10:33 Uhr
äh, ja.... aber nur in dieser einen, bestimmten Konstellation, sonst nicht!
Ist auch nicht relevant, nur seltsam.
Bitte warten ..
Mitglied: colinardo
11.12.2013 um 10:41 Uhr
Beitrag dann bitte noch als gelöst markieren. Danke.
Grüße Uwe
Bitte warten ..
Ähnliche Inhalte
Batch & Shell

Batch: Prüfung auf erfolgreich ausgeführten Befehl

gelöst Frage von myluridBatch & Shell2 Kommentare

Guten Morgen zusammen! Habe folgedes Problem es existiert ein Skript, welches einen Ordner auf Dateien mit Größe 0 Byte ...

Batch & Shell

Batch Datei wird per Aufgabenplanung nicht ausgeführt

Frage von CorraggiounoBatch & Shell7 Kommentare

Hi, ich hoffe ihr könnt mir weiterhelfen. Folgende Konfiguration habe ich vorgenommen um ein batch-script auszuführen: Unter Programm/Skript habe ...

Batch & Shell

Batch Datei Kopieren

gelöst Frage von FragerBatch & Shell17 Kommentare

Hallo Zusammen, ich bekomme es nicht hin ich muss aus einem Ordner (liegt auf einem Server) eine von vielen ...

Batch & Shell

Batch: Loop zum kopieren von Dateien

gelöst Frage von BiffBaffBatch & Shell1 Kommentar

Hallo zusammen, leider bin ich nicht sehr vertraut mit dem erstellen von Batch dateien daher mag die Frage vielleicht ...

Neue Wissensbeiträge
Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 10 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 11 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 14 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 1 TagWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...