Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Wie kann man eine Lexware Financial Office Pro Installation über 2 Subnetze benutzen ?

Mitglied: kraut147

kraut147 (Level 1) - Jetzt verbinden

06.11.2007, aktualisiert 10.04.2008, 33811 Aufrufe, 11 Kommentare

Die Lexware Financial Office Pro Software kann als Client/Server Installation betrieben werden in dem die Datenbank auf einem Rechner installiert wird und als Service auf diesem Rechner läuft damit die Clients von anderen Rechnern aus darauf zugreifen können. Sinnigerweise müssen laut Lexware Server UND Client im gleichen Subnetz sein damit die kommunikation funktioniert. Ist in unserem Betrieb aus Sicherheitsgründen nicht der Fall und dehmentsprechend stressig ist die Installation bis jetzt gelaufen. Da Subnetze kein revolutionäres Konzept sind und sich die Firma Lexware Marktführer schimpft kann ich kaum glauben das ich der erste ITler mit diesem Problem bin. Wenn irgenjemand eine Lösung oder einen Workaround weiss : sagt bitte bescheid.
e29e4304bbadd2b508ceb200f2d9e317-fehlermeldung - Klicke auf das Bild, um es zu vergrößern
Mitglied: Pjordorf
06.11.2007 um 12:45 Uhr
Hallo,

es scheint, das dein Client den (Lexware) Server nicht finden kann. (Namensauflösung? Freigaben für den (Lexware) Sever richtig gestzt?


Peter
Bitte warten ..
Mitglied: moswald
06.11.2007 um 12:57 Uhr
Blöde Frage: Die Route hast du im Router aber schon eingetragen, oder? Das müsste doch reichen. Habt ihr vielleicht irgendwelche Firewalls dazwischen?

Wir schlagen uns auch seit zwei Jahren mit diesem Tool rum und ich muss sagen, dass professionelle Software anders supported wird. Btw. mit welcher Lösung fahrt ihr statistische Auswertungen? Wie wir jetzt nach (fast) einem Jahr vom Support erfahren haben, wird planung+controlling von der 2007er einfach nicht mehr unterstützt.
Bitte warten ..
Mitglied: kraut147
06.11.2007 um 15:30 Uhr
Firewalls sind als Problemursache schon eliminiert worden. Die Rechner selber können sich gegenseitig pingen etc , nur Lexware kommt nicht weiter als sein eigenes Subnetz. Über statistische Auswertungen machen wir uns im Moment noch keine Gedanken. Die Software muss erstmal zum laufen gekriegt werden.
Bitte warten ..
Mitglied: moswald
07.11.2007 um 07:50 Uhr
Aus Erfahrung kann ich dir nur sagen: Lexware und "zum Laufen bringen" sind zwei Dinge, die sich wie gleichgepolte Magnetenden abstossen. Problemlos lief das Zeug bei uns erst lange nach der Einführung und ständig tauchen neue Probleme auf.

Lass doch mal Ethereal/Wireshark mitlaufen und guck, welche Pakete da nicht durchkommen. Vielleicht wird dann klarer, wo das Problem liegt. Innerhalb des gleichen Subnetzes hat es funktioniert?

Hast du schon die Datenquelle auf dem Server getauscht? Siehe hier:
http://64.233.183.104/search?q=cache:5sw-_opCxXMJ:www.lexware.de/suppor ...
Bitte warten ..
Mitglied: kraut147
07.11.2007 um 10:10 Uhr
Ich bedanke mich! Nachdem die Einstellungen die im Artikel http://www.google.com/search?q=cache:5sw-_opCxXMJ:www.lexware.de/suppor ... beschrieben waren vorgenommen wurden ist unser 2-Subnetze Problem gelöst.
Danke Herr Oswald.
Bitte warten ..
Mitglied: x-sector
10.04.2008 um 10:13 Uhr
Servus,

das thema ist zwar schon älter .. klinke mich trotzdem nochmal ein.

Hat jemand mittlweiler schon eine Lösung für das Problem gefunden ?

Meine Erfahrungen ..

Subnetze mag Lexware gar nicht. besonders dann wenn der Traffic auch noch über kaskadierte Switche rennt.

Konnte zwar die Fehlermeldungen verringern mit diversen Versuchen.
Jedoch beim Arbeiten in der Software nach wie vor Fehler bzgl. DB nicht gefunden.
Da also offensichtlich grundsätzlich eine Verbindung zur DB steht (Client lässt sich öffnen und sogar Artikel usw anlegen), geh ich davon aus das broadcasting läuft einfach fehlerhaft.

Lösung bisher war nur möglich, wenn Client + Server im selben Subnet laufen.
Dann läuft alles fehlerfrei.

Fazit .. sobald die angebliche "Netzwerk Lösung" es mit echten und komplexen Netzen zu tun bekommt .. verweigert die SW einfach ein fehlerfreies arbeiten.

Hat jemand noch ein workaround wie es dennoch möglich ist in verschiedenen Netzen zu arbeiten ?
*der link über mir funktioniert leider nicht mehr

danke vorab.

vg,
sven

*vorstellung folgt noch
Bitte warten ..
Mitglied: DocDOS
16.07.2009 um 15:57 Uhr
So wie das aussieht, wird das niemals gehen..

die Lexware-Programmierer haben offenbar noch nie was davon gehört, dass eine Client-Software seine Datenbank niemals über einen Broadcast suchen sollte. Da der Router der natürliche Feind eines jeden Broadcasts ist, funktioniert das nie reibungslos.

Wireshark hat das bei uns sogar bestätigt (wir suchen uns in dem Fall schon länger die Füße wund).

Wir haben das jetzt auf eine "relativ elegante" Weise gelöst:

Im Subnetz des Lexware-Datenbank-Servers haben wir einen VMware-Server hingestellt und einzelne VMs aufgesetzt. Mit dem VMware-Server 2 (kostenlos bei www.vmware.com) braucht man auch keine Client-PCs in dem Sinne mehr, sondern arbeitet in einem Browser, bzw. Desktop-Shortcut.

Wir haben das Glück, dass nur 3 Leute die Lexware-Software benutzen müssen, wovon Einer sich schon im "DB-eigenen Subnetz" befindet. Somit war das leicht. Die Nötige Hardware war ein Core2Duo um die 2.5 GHz mit einer schnellen Platte und 3 GB DDR2-RAM (das ganze unter einem optimierten Linux, hier Debian Etch).

Ich hoffe, das bringt euch etwas weiter.

Gruß

Doc
Bitte warten ..
Mitglied: kinken
18.11.2009 um 11:24 Uhr
Was steht in den ODBC Einträgen für Adaptive Server Anywhere auf dem Lexware-Client unter System DSN?

Gruß

Kinken
Bitte warten ..
Mitglied: DocDOS
18.11.2009 um 12:32 Uhr
Hallo,

bei uns verweisen die System-DSN-Einträge direkt auf den Server. Wir haben es mit nem FQDN und ner direkten IP-Adresse versucht.. beides erfolglos ... nur die Sache mit der VM war das Einzige, was bei uns funktioniert hatte.

In irgendeinem Thread der Lexware-Hotline wurde das auch noch bestätigt.. kann euch den Thread aber leider nicht mehr nennen... ist zu lange her

Gruß

Doc
Bitte warten ..
Mitglied: dfritz
12.01.2010 um 13:29 Uhr
Hi,

wir hatten heute selbes Problem.

Einfach in dem leeren Feld neben den TCPIP Harken im ODBC HOST=IP_DES_SERVERS;PORT=2638 einsetzen.

Dann war bei uns Ruhe.

Gruß Daniel
Bitte warten ..
Mitglied: KurtManne
14.11.2011 um 00:53 Uhr
Zitat von dfritz:
Hi,

wir hatten heute selbes Problem.

Einfach in dem leeren Feld neben den TCPIP Harken im ODBC HOST=IP_DES_SERVERS;PORT=2638 einsetzen.

Dann war bei uns Ruhe.

Gruß Daniel

Etwas ungenau formuliert:

Über den ODBC Administrator nach der DSN ->LXSYDSN suchen, dann auf den Netzwerk-Reiter gehen und alle Protokolle außer TCP/IP deaktivieren.
Im Feld neben dem TCP/IP Haken eintragen: "HOST=IP_DES_SERVERS" eintragen, also zum Beispiel "HOST=192.168.178.20"
Die Angabe des Ports ist nicht erforderlich.
Um die Sache zu Beschleunigen, kann noch der Schalter "DoBroadCast=None" mitgegeben werden.
Bitte warten ..
Ähnliche Inhalte
Datenbanken

Lexware Financial Office 2018 Markierung Zahlstatus Rückkoppelung von Buchhaltung zur Faktura

gelöst Frage von gordsveDatenbanken3 Kommentare

Bei der Software wird das Zahldatum in den Rechnungen der Faktura nach dem Buchen in der Buchhaltung nicht angezeigt. ...

Switche und Hubs

2 Subnetze verbinden

gelöst Frage von 117109Switche und Hubs6 Kommentare

Hallo Leute, wie verläuft es, wenn ich 2 Subnetze via switch (reiner Layer 2 Switch) miteinander verbinden möchte. Funktioniert ...

Windows Server

1 DHCP 2 Subnetze

Frage von technikdealerWindows Server5 Kommentare

Hay Ihr. Ich habe ein Server 2008 R2 mit konfigurierter Bereichsgruppierung. Ein Bereich der Gruppe hat 192.168.100.0 und der ...

Netzwerkmanagement

24 Subnetz mit 2 VLANs

gelöst Frage von netscratNetzwerkmanagement4 Kommentare

Moin zusammen, folgendes Szenario ergibt sich grade für ein Schulprojekt: Firma mit 3 Stockwerken und in denen sind jeweils ...

Neue Wissensbeiträge
Server-Hardware
HP iLO ist gefährdet (iLO 4))
Tipp von AlFalcone vor 8 StundenServer-Hardware

Gemäss Twitter und Heise gibt es eine Angriffsmöglichkeit auf iLO Quelle: iLO ist gefährdet

CMS
Erneut kritische Zero-Day-Lücke in Drupal
Tipp von Reini82 vor 17 StundenCMS

Laut einem Bericht auf t3n gibt es eine Schwere Sicherheitslücke in Drupal die auch schon ausgenutzt wird. Betroffen sind ...

Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 1 TagSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 1 TagWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

Heiß diskutierte Inhalte
Ausbildung
Wie gelingt ein guter Einstieg in die FiSi-Ausbildung? (Umschulung)
Frage von SiAnKoAusbildung29 Kommentare

Schönen guten Tag, ich bin SiAnKo und habe seit dem 1.04.2018 eine Umschulung als FiSi angefangen. Ich möchte natürlich ...

Windows Server
Alten DC entfernen
gelöst Frage von smartinoWindows Server27 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...

Batch & Shell
Mit Powershell den Inhalt einer Excel mit einer Text Datei abgleichen
gelöst Frage von Bommi1961Batch & Shell21 Kommentare

Hallo zusammen, ich muss den Inhalt einer Excel Datei (Mappe1) mit dem Daten einer Text Datei abgleichen. Die Daten ...

Router & Routing
Subnetzmaske vergrößern
gelöst Frage von groovesurferRouter & Routing18 Kommentare

Hallo, hat jemand schonmal getestet was passiert, wenn man die Subnetzmaske bei laufendem Betrieb (wenn user im Netzwerk verbunden ...