Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Mit Linux-Router zwei Netzwerke verbinden - WIE?! Bitte Hilfe!

Mitglied: Wolff

Wolff (Level 1) - Jetzt verbinden

01.11.2004, aktualisiert 06.10.2005, 15687 Aufrufe, 19 Kommentare

Ich habe vor mit einem Linux-Router zwei Netzwerke zu verbinden, bekomme aber Probleme.

Aufbau:

Der Router besitzt zwei Netzwerkkarten
eth0: 172.20.0.16 netmask 255.255.255.0
eth1: 192.168.90.16 netmask 255.255.255.0

Nun sollen alle PCs im Netzwerk 172.20.0.* auf einen Exchange-Mailserver im Netzwerk 192.168.90.* zugreifen können.

Ich habe bereits folgende Routen auf dem Linux-Router angelegt:
Dest ### Gateway ### Interface
192.168.90.0 ### 0.0.0.0 ### eth1
172.20.0.0 ### 0.0.0.0 ### eth0

Vom Linux-Server kann ich PCs in beiden Netzwerken anpingen, bekomme aber nur einmal eine Antwort!

Wenn ich unter Windows 172.20.0.16 als Gateway einrichte kann ich das andere Netz nicht erreichen.

Kann mir jemand weiterhelfen?!
Mitglied: BartSimpson
01.11.2004 um 12:24 Uhr
es muss heisten:
Ziel GW IF
192.168.90.0 ### 192.168.90.16## eth1
172.20.0.0 ### 172.20.0.16 ##eth0
Bitte warten ..
Mitglied: linuxadmin
01.11.2004 um 13:37 Uhr
192.168.90.0 ### 192.168.90.16## eth1
172.20.0.0 ### 172.20.0.16 ##eth0

lokale Interfaces brauchen sich selbst nicht als GW.

versuch mal:

echo "1" > /proc/sys/net/ipv4/ip_forward
Bitte warten ..
Mitglied: Wolff
01.11.2004 um 13:52 Uhr
@ BartSimpson
Vielen Dank für die Antwort...hat mir aber leider nicht geholfen...

@linuxadmin
/proc/sys/net/ipv4/ip_forward enthält bereits "1"


mittlerweile kann ich auch den Ping ohne Probleme durchführen...habe den Linux-Server jetzt unter Windows als Gateway eingetragen und versuche dann mit "tracert" einen PC im zweiten Netz zu erreichen...leider komme ich nur bis zum Linux-Server...danach "Zeitüberschreitung"...auf dem Linux-Server finde ich in /var/log/messages folgende Einträge:

Nov 1 13:15:12 mail2 kernel: Packet log: input ACCEPT eth0 PROTO=1 172.20.6.19:8 192.168.90.3:0 L=92 S=0x00 I=46012 F=0x0000 T=2 (#9)
Nov 1 13:15:12 mail2 kernel: Packet log: forward DENY eth1 PROTO=1 172.20.6.19:8 192.168.90.3:0 L=92 S=0x00 I=46012 F=0x0000 T=1 (#4)
Nov 1 13:15:13 mail2 kernel: Packet log: input ACCEPT eth0 PROTO=6 172.20.6.19:1530 172.20.0.16:23 L=40 S=0x00 I=46013 F=0x4000 T=128 (#9)
Bitte warten ..
Mitglied: BartSimpson
01.11.2004 um 13:54 Uhr
simmt da hatte mich jezt nur die schreibweise gewundert.
Haste du iptables regeln definiert. Das würde mir jetzt noch einfallen.
Bitte warten ..
Mitglied: BartSimpson
01.11.2004 um 13:58 Uhr
Das deutet eindeutig auf iptables regeln hin.
Bitte warten ..
Mitglied: Wolff
01.11.2004 um 14:18 Uhr
iptables ist nicht installiert...
Bitte warten ..
Mitglied: BartSimpson
01.11.2004 um 14:33 Uhr
Dann must du aber eine andte firewall auf der kiste haben. Denn meldunf deutet eindeutig drauf hin , das packete gefiltert werden.
Bitte warten ..
Mitglied: Wolff
01.11.2004 um 14:58 Uhr
ich habe gerade nochmal geguckt...es ist ipchains installiert und dort ist auch ein Eintrag...nur wie bekomme ich den Eintrag gelöscht? Habe gerade mal unseren Support angerufen...die konnten mir nur sagen, unser Linux SuSE sei zu alt und ich könne keinen Support für ipchains erhalten...
Bitte warten ..
Mitglied: BartSimpson
01.11.2004 um 15:02 Uhr
Das stimmt ipchains wurde schon lange durch iptables ersetzt.
unter http://people.netfilter.org/~rusty/ipchains/
findes man noch die alte doku
Bitte warten ..
Mitglied: Wolff
02.11.2004 um 07:42 Uhr
Vielen Dank für die Anleitung...
ich habe jetzt ipchains mit folgenden Befehlen "deaktiviert":

ipchains -F
ipchains -X
ipchains -P input ACCEPT
ipchains -P output ACCEPT
ipchains -P forward ACCEPT

die SuSE-Firewall habe ich auch deaktiviert. Trotzdem habe ich immer noch den o.g. Fehler.
Bitte warten ..
Mitglied: BartSimpson
02.11.2004 um 08:44 Uhr
Und was sagt ipchains -L?
Bitte warten ..
Mitglied: Wolff
02.11.2004 um 09:21 Uhr
ipchains -L

steht alles auf ACCEPT
Bitte warten ..
Mitglied: BartSimpson
02.11.2004 um 09:33 Uhr
Und stehen jetzt keine Anderen reglen mehr drinn? Was steht jetzt in deiner logdtei?
Bitte warten ..
Mitglied: Wolff
02.11.2004 um 10:33 Uhr
die log-datei ist jetzt leer...gibt keine neuen Einträge...

habe den Linux-Server jetzt unter Windows als Gateway eingetragen und versuche dann mit "tracert" einen PC im zweiten Netz zu erreichen...leider komme ich nur bis zum Linux-Server...danach "Zeitüberschreitung"
Bitte warten ..
Mitglied: BartSimpson
02.11.2004 um 11:46 Uhr
Hast du bei dem anderen netz das entspechen gateway eingertagen? Denn sonnst kommen die pakcet nur i eine richtung.
Bitte warten ..
Mitglied: Wolff
02.11.2004 um 13:25 Uhr
Danke für den Tipp jetzt funktioniert es ohne Firewall.
Sobald ich aber die SuSE-Firewall wieder einschalte, geht es nicht mehr...

Welche Ports muss ich freischalten?

Sieht bei mir jetzt so aus:

FW_SERVICES_EXTERNAL_TCP="smtp domain echo http" # Common: smtp domain
FW_SERVICES_EXTERNAL_UDP="domain" # Common: domain
FW_SERVICES_EXTERNAL_IP="" # For VPN/Routing which END at the firewall!!
FW_SERVICES_DMZ_TCP="" # Common: smtp domain
FW_SERVICES_DMZ_UDP="" # Common: domain syslog
FW_SERVICES_DMZ_IP="" # For VPN/Routing which END at the firewall!!
FW_SERVICES_INTERNAL_TCP="139 445 smtp pop3 domain http telnet ftp echo" # Common: ssh smtp domain
FW_SERVICES_INTERNAL_UDP="domain syslog" # Common: domain syslog
FW_SERVICES_INTERNAL_IP="" # For VPN/Routing which END at the firewall!!
Bitte warten ..
Mitglied: BartSimpson
02.11.2004 um 15:02 Uhr
Es kommt dauf an, was der Router weiter leiten soll.
Aber keine Ahung wie man das bei Suse machen muss.,
Ich benutze nur Redhat und Fedora.
Bitte warten ..
Mitglied: Wolff
05.11.2004 um 08:40 Uhr
Mein Netz ist folgendermaßen aufgebaut:

Es gibt ein Netzwerk 172.20.x.x das über den Router ins Netzwerk 192.168.90.x kommt.
Im Netzwerk 192.168.90.x gibt es einen VPN-Server (192.168.90.1) und dahinter gibt es ein Netzwerk 192.168.x.x (vielleicht kann man ja aus der Skizze was erkennen...wenn der Zeilenumbruch funktioniert...ich kann die Skizze dann auch per Mail verschicken)
---------------
172.20.x.x - === ROUTER
- 192.168.90.x-
172.20.0.16 ---------------
192.168.90.16 ||
||
||
---------------- ---------------
-192.168.90.1 -
VPN
- 192.168.x.x -
---------------- ---------------

Mein meiner Konfiguration funktioniert fast alles.
Ich habe eine Route für Anfragen an 192.168.x.x nach 192.168.90.1 auf dem Router eingerichtet. Vom Router kann ich auch ohne Probleme alle PCs über die VPN-Verbindung (also z.b. 192.168.1.5) anpingen. Versuche ich aber ein "tracert" vom Windows-Client, so geht dieser bis 192.168.90.1 und nicht weiter. Ein Ping an 192.168.1.5 geht auch nicht. Ich kann aber über den Windows-PC alle PCs mit der IP 192.168.90.x erreichen.

Kann mir jemand weiterhelfen?
Bitte warten ..
Mitglied: 15187
06.10.2005 um 20:19 Uhr
da kommt nix...
Bitte warten ..
Ähnliche Inhalte
Router & Routing

Zwei Router (Netzwerke) miteinander verbinden

Frage von theoBreRouter & Routing12 Kommentare

Hallo liebe IT-Wxperten, ich habe mal ein kleines Problem, das ich mit Eurer hilfe bestimmt schnell lösen kann Ausgangslage: ...

Router & Routing

Verbinden zweier Standorte mit einem Router

Frage von franksigRouter & Routing17 Kommentare

Hallo Zusammen, ich habe hier einen Kunden der hat 2 Standorte 1. Standort ca. 150 User und 2. Standort ...

Router & Routing

Zwei FitzBox-Netzwerke verbinden?

Frage von McLionRouter & Routing9 Kommentare

Hallo, stehe aktuell auf nem Schlauch und komme nicht weiter. Also ich habe eine FB-A und FB-B, die wie ...

Router & Routing

Netzwerk Szenario mit zwei Routern

Frage von jsiegfriedRouter & Routing4 Kommentare

Hallo liebe Administrator-Kollegen, ich habe ein Problem mit zwei Routern in einem Netzwerk (siehe beigefügtes Bild). Wir haben mehrere ...

Neue Wissensbeiträge
Sonstige Systeme
Es war einmal ein BeOS - Wer erinnert sich noch?
Information von BassFishFox vor 20 StundenSonstige Systeme4 Kommentare

Hallo, Bin gerade ueber Haiku gestolpert, von dessen Existenz als "Nachfolger des BeOS" ich wusste nur mich nie wirklich ...

Datenschutz

Microsoft und DSGVO - ob das wohl jemals klappt (Probleme beim Datenabfluss für Office Pro Plus)?

Tipp von VGem-e vor 23 StundenDatenschutz3 Kommentare

Servus Kollegen, siehe Aber wer setzt schon MS Office Pro Plus ein? Wie dann der Stand beim "normalen" MS ...

Windows 10

Macht Windows 10.1809 Probleme mit gemappten Netzlaufwerken (betrifft wohl insbes. AMD-Hardware und Trend Micro AV-Produkte)?

Tipp von VGem-e vor 1 TagWindows 103 Kommentare

Moin Kollegen, grad dazu gefunden und Hatten wir dies nicht bei früheren W10-Upgrades ebenfalls? Da bleibt nur, das Upgrade ...

Humor (lol)

Das neue Miniatur Wunderland OFFICIAL VIDEO - worlds largest model railway - railroad

Information von StefanKittel vor 1 TagHumor (lol)2 Kommentare

Hallo, wer noch nie im Miniatur Wunderland war, sollte es dringend mal nachholen. Es gibt eine neues Video. Viele ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
Werksreset HP 1920S-24G
gelöst Frage von HenereNetzwerkgrundlagen14 Kommentare

Servus zusammen, ich habe mir 2 neue Switche zugelegt, doch ich komme damit nicht ganz klar. Waren Vorführgeräte zum ...

DSL, VDSL
DSL Monitoring Tool - Quick and dirty?
Frage von george44DSL, VDSL14 Kommentare

Liebe Gemeinde, ich suche ein einfaches und vor allem schnell zu installierendes Monitoring-Tool zur kontinuierlichen Dokumentation (nur) der Internetanbindung. ...

Firewall
Sophos UTM 9.5 Firewall Log-File durchsuchen
gelöst Frage von Leo-leFirewall13 Kommentare

Hallo zusammen, weiß jemand von Euch, ob man bei der Sophos die Firewall logs noch etwas besser filtern kann? ...

LAN, WAN, Wireless
Gäste-WLAN durch DD-WRT AP nach einem MikroTik Routerboard
Frage von NukolarLAN, WAN, Wireless12 Kommentare

Hallo, wie der Titel schon sagt möchte ich gerne ein Gäste-WLAN innerhalb eines bestehenden LANs einrichten. Dass die Gäste ...