Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Linux, Samba, Robocopy - Es klappt fast...

Mitglied: FlintX

FlintX (Level 1) - Jetzt verbinden

28.03.2006, aktualisiert 30.03.2006, 8980 Aufrufe, 5 Kommentare

Hi zusammen,

Vorneweg die Gegebenheiten:

Ein Fileserver, Suse Linux 10, Samba 3.xx, usw.
Dazu eine NAS-Box - Buffalo Terastation...
und ein Client, rennt mit WinXPSP2...

Was soll passieren:
Der WinXP Client soll mittels Robocopy die Daten von der NAS-Box auf den Fileserver spiegeln... Klappt Prima, aber:

Wenn ich jetzt hingehe und auf der NAS-Box ein Verzeichniss lösche, bleibt das, nach dem Robocopy Durchlauf, auf dem Fileserver bestehen, die Dateien darin werden aber gelöscht...
Verblüffend daran ist - es gibt keinerlei Fehlermeldungen oder Log-Einträge (Weder auf der Windows-Büchse, noch auf dem Server...)
Händisches löschen der Verzeichnisse auf dem Fileserver funktioniert...
Wenn ich das spielgeln auf die Platte von dem XP Client oder ne USB-Platte mache, klappts...
Nehme ich einen anderen Client zum spiegeln, ist das Ergebnis das gleiche - Verzeichnisse bleiben leer "übrig"...

Hat jemand eine Idee, woran das liegen kann?

Gruß
Roman
Mitglied: ketchup
28.03.2006 um 22:42 Uhr
kannst du mal deinen robocopy-befehl posten?

j.
Bitte warten ..
Mitglied: FlintX
28.03.2006 um 22:49 Uhr
klar...

ROBOCOPY P: J: /MIR /FFT /W:1 /R:3

unter P: ist die NAS gemappt, unter J: folglich der Samba Share...
Bitte warten ..
Mitglied: 27631
29.03.2006 um 20:08 Uhr
also ich hab genau des gleiche Problem.

Auszug aus der den Windows-Resource-Tools beiliegendem robocopy.doc:
/E Copies all subdirectories (including empty ones).
/PURGE Deletes destination files and directories that no longer exist in the source.
/MIR Mirrors a directory tree (equivalent to running both /E and /PURGE).

selbst mit all diesen Optionen gleichzeitig gesetzt bleibt das leere Verzeichnis im Ziel
liegen. Komischerweise ist im log von robocopy das leere Verzeichnis als Quelle auch
garnicht geführt - es wird anscheinend einfach übersprungen.

jetzt aber feierabend
huha
Bitte warten ..
Mitglied: rrr1
30.03.2006 um 13:03 Uhr
Moin,

ich meine mich erinnern zu können, dass Robocopy Probleme hat, wenn Verzeichnisse in der Root eines Laufwerks liegen. Evtl. wird das Share \\host\share auch so gedeutet.

HTH rrr1
Bitte warten ..
Mitglied: 27631
30.03.2006 um 17:43 Uhr
ich hab das jetzt so ausprobiert:

das Verzeichnis temp hatte ich in der quelle [eigene dateien] gelöscht und nach [H:]
gesynct; unter [H:] gab es dann weiterhin ein leers temp Verzeichnis.
Ich habe es dann eine Ebene weiter unten als temp\testdir\ probiert aber auch dieses
Verzeichnis bleibt in Ziel leer liegen!
Ich hatte in dieses "testdir" sogar daten reinkopiert. Nach dem Sync ist das Verzeichnis zwar noch da, aber es liegt nichts mehr drin, wenn ich in der Quelle Verzeichnis samt Inhalt lösche.

soweit meine Beobachtungen
grüße huha

PS: habs noch ein zweites mal mit anderem verzeichnis und anderen dateien probiert - selbes ergebnis
Bitte warten ..
Ähnliche Inhalte
Samba

Linux SAMBA Vererbbare Berechtigungen des Übergeordneten Ordners Einschließen klappt nicht

gelöst Frage von bonkersdeluxe1Samba8 Kommentare

Guten Tag, Ich hoffe das Ihr mir helfen könnt den Irgendwie stehe ich auf dem Schlauch. Ich möchte gerne ...

Debian

Windows 7 Samba Domänen beitritt klappt nicht, mit Ubuntu, Samba u. Zimbra

gelöst Frage von ckedingDebian12 Kommentare

Hallo zusammen, ich versuche seit Tagen mich an einer Samba3 Domäne anzumelden, mit der Fehlermeldung: "Ein an das System ...

Windows Netzwerk

Linux Samba Freigaben können "angeblich" nicht gemoutet werden

Frage von Der-DudeWindows Netzwerk5 Kommentare

Es ist mir aufgefallen, dass irgendwie niemand eine Lösung oder Erklärung für ein Phänomen hat, welches ich seit einiger ...

Samba

Nach Xenserver Update geht Samba auf Linux nicht mehr

Frage von WinLiCLISamba3 Kommentare

Hallo zusammen, wir haben 2 Linux Maschinen auf 2 unterschiedlichen Xen 6.5 Servern. Gestern lief das Update über den ...

Neue Wissensbeiträge
Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 1 TagExchange Server4 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Suche Projektpartner

PC Recycling Projekte mit Flüchtlingen und Kids suchen Materialspenden und Mitmacher!

Erfahrungsbericht von NettePCyclePiraten vor 2 TagenSuche Projektpartner7 Kommentare

Hallöchen liebe Kollegen, ich betreue zwei PC-Gruppen im Raum Dortmund: "Ne#e PCycle Pir@ten" & "PCschr@uber Br@mbauer" Wir sind eine ...

iOS
IOS 12.2 beta und OpenVPN iPad und iPhone
Erfahrungsbericht von magicteddy vor 2 TageniOS

Moin, kleiner Hinweis an die experimentierfreudigen unter Euch: Bei der aktuellen beta gibt es ein Problem im Zusammenspiel zwischen ...

Vmware
VMware Tools 10.3 verfügbar
Information von sabines vor 2 TagenVmware

Eine Sicherheitslücke wird mit den Tools der Version 10.3 geschlossen, die Tools müssen auf jeder VM aktualisiert werden. Näheres ...

Heiß diskutierte Inhalte
Windows Netzwerk
Netzwerk einrichten - wie mache ich es richtig?
Frage von gintonikWindows Netzwerk23 Kommentare

Hallo, ich bin neu hier und erhoffe mir hier ein paar Antworten für meine Umsetzung zu erhalten. Kurz zu ...

CPU, RAM, Mainboards
4x 2 GB DDR2 1066 gesucht
gelöst Frage von Windows10GegnerCPU, RAM, Mainboards17 Kommentare

Hallo, ich plane den RAM meines Rechners aufzurüsten. Motherboard: Gigabyte X48 DS5 Der FSB steht bei 259, daher soll ...

Microsoft Office
Druckdatum nur auf ausgedrucktem Dokument anzeigen
gelöst Frage von eichi18Microsoft Office16 Kommentare

Hallo zusammen Ich versuche in einem Word Dokument das Druckdatum nur auf dem eigentlichen Ausdruck auszugeben und am Bildschirm ...

Samba
Samba-NAS Zugriff verweigert
gelöst Frage von VernoxVernaxSamba15 Kommentare

hallo ich schaffe es einfach nicht meinem User Rechte zum schreiben zu geben. Ich habe dies alles auf nem ...