Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Lokale IP ohne Netzwerkkabel oder wLAN

Mitglied: gracom

gracom (Level 1) - Jetzt verbinden

10.02.2006, aktualisiert 11.02.2006, 9470 Aufrufe, 13 Kommentare

Hallo,

stehe gerade vor dem Problem, dass WindowsXP sich keine IP zuweißen lässt, solange es keine Netzwerkverbindung (= Netzwerkkabel) hat.

Vorraussetzung: Ich benötige für meine XAMPP-Konfiguration (muss so bleiben, wie sie ist!!!) eine fest zugewießene IP-Adresse (192.168.168.192) auf meinem Notebook.

Solange ich ein Netzwerkkabel im Notebook stecken habe, aktiviert WinXP den Netzwerkadapter und damit die benötigte IP-Adresse. XAMPP funktioniert problemlos.

Sobald das Netzwerkkabel entfernt wird, wird der Netzwerkadapter und auch die IP-Adresse deaktiviert und XAMPP lässt sich nicht mehr zum funktionieren überrreden.

Da ich XAMPP auch mobil nutzen möchte, suche ich eine Lösung, die Deaktivierung des Netzwerkadapters beim Entfernen des Kabels zu umgehen ...

Vielleicht kann mir ja jemand weiterhelfen? Danke!
--
GraCom
Mitglied: PLONK
10.02.2006 um 13:17 Uhr
Hallo,
also wenn das wirklich so ist, was ich nicht wirklich weiss da ich mich mit XAMP überhaupt nicht aus kenne, könnstest Du dir für unterwegs einen Netzwerk Loop-Stecker bauen.

Damit kannst Du ein gestecktes Kabel vorgaukeln.


mfg
PLONK



Hier noch ein Link dazu, offenbar gibts die Dinger schon fertig:
http://www.odints.com/pages/prod/access/cables/loop.htm
Bitte warten ..
Mitglied: IceBeer
10.02.2006 um 13:30 Uhr
Hallo,

insofern du in deinem XAMPP keine VHost's nutzt kannst du deinen Rechner IMMER per 127.0.0.1 ansprechen...

Desweiteren wundert es mich sehr, dass sich bei nicht gestecktem Kabel die LAN-Karte deaktiviert, das ist nicht Windows like..

Bei mir, XP SP2, ist so wenn ich kein Kabel dran hab und DHCP aktiviert ist bekomm ich ne apapi (apipa, weiß nie wies genau heißt) adresse. Wenn ich aber eine feste IP hab, so bleibt hab...

Ein weiterer Lösungsansatz wäre vielleicht, habs nicht geprüft, wenn du deinen Rechnernamen mit IP in die HOSTS-Datei einträgst....

MfG IceBeer
Bitte warten ..
Mitglied: Ragazzo
10.02.2006 um 13:31 Uhr
Der richtige Lösungsansatz für einen Netzwerk-LOOP:

Den Loopback-Adapter von Microsoft


PS:
Wie soll das mit dem Loop-Adapterkabel eigentlich mit 2 Steckern funktionieren ???
Braucht man einen Switch oder einen zweiter Netzwerkkarte (dann brauche ich auch keine Spezialkabel)
oder ist das ein Fake ????
Bitte warten ..
Mitglied: IceBeer
10.02.2006 um 13:54 Uhr
Hi,

also wenn ich das richtig verstehe ich das nichts anderes als ein kurzes Crossover-Kabel um zwei LAN-Karten in einem Rechner zu verbinden und hat nur indirekt mit dem Loopback-Adapter zu tun, denn der ist völlig softwaresimuliert.

Gruß IceBeer
Bitte warten ..
Mitglied: Hondafreund
10.02.2006 um 14:11 Uhr
Desweiteren wundert es mich sehr, dass sich
bei nicht gestecktem Kabel die LAN-Karte
deaktiviert, das ist nicht Windows like..

Hi,

ist das nicht so eine Stromspareinstellung? Das bei entferntem Kabel das (Netzwerk)Gerät abgeschaltet wird? Solltest du prüfen, ob Standardmäßig die Abschaltung zum stromsparen aktiviert ist...
Grüße
der Hondafreund
Bitte warten ..
Mitglied: PLONK
10.02.2006 um 14:12 Uhr
Hallo,
nein das sit kein Fake, solche Stcker gibt es wirklich, leider kann ich zu der genauen Belegung des Steckers nichts sagen, die Funktion ist jedoch einfach.

Dei Netzwerkkarte sendet quasi an sich selbst, dies wird erreicht durch eine Schleife im Kabel, das heisst das Paar das sendet wird mit dem paar daas normaler weise empfängt verbunden.


mfg
PLONK

P.S. werde die genaue belegun und bauanleitung raussuchen und hier posten
Bitte warten ..
Mitglied: gracom
10.02.2006 um 15:48 Uhr
Hallo,

ich benutze in meinem XAMPP mehrere virtuelle Hosts, darum reicht mir ein einfaches Loopback (127.0.0.1) nicht.

Ein ipconfig auf der Eingabeaufforderung bringt mir folgende Ausgabe, obwohl die feste IP 192.168.168.1 für den Ethernet-Adapter eingetragen ist.

Ethernetadapter LAN-Verbindung:
Medienstatus. . . . . . . . . . . : Es besteht keine Verbindung

PPP-Adapter Txxxxxxx Bluetooth:
Verbindungsspezifisches DNS-Suffix:
IP-Adresse. . . . . . . . . . . . : 1xx.2xx.2xx.2xx
Subnetzmaske. . . . . . . . . . . : 255.255.255.255
Standardgateway . . . . . . . . . : 1xx.2xx.2xx.2xx

Das mit der Hosts-Datei und dem Stromsparmodus werd' ich gleich mal probieren...
Bitte warten ..
Mitglied: IceBeer
10.02.2006 um 16:00 Uhr
Hallo,

"wo" brauchst du denn die IP??

Auf dem DSL-Adapter(Bluetooth) oder auf dem Ethernetadapter??

Arbeitest du mit Host- oder IP-basierten Vhosts??

MfG IceBeer
Bitte warten ..
Mitglied: meinereiner
10.02.2006 um 16:08 Uhr
Der Loopback Adapter den ragazzo anspricht könnte schon die Lösung sein. Das ist eine virtuelle Netzwerkkarte, die man über "Hardware" in der Systemsteuerung installieren kann (Steht unter Microsoft).

Ich glaube nicht das die die IP verliert wenn kein Kabel dran ist.
Ist nur di Frage ob XAMPP damit klar kommen. Die Software kenne ich nicht.
Bitte warten ..
Mitglied: IceBeer
10.02.2006 um 16:17 Uhr
Hallo,

@ meinereiner...
XAMPP ist ein Paket aus Apache, MySQL, Perl und PHP, sprich der Apache muss damit klar kommen, und ich denke (nutz das Ding selbst) dass sich das Problem spätestens mit der HOSTS lösen lässt.

Da gracom genau die eine IP will, geh ich davon aus, dass er mit Name-Based VHOSTS arbeitet...

Somit muss der die HOSTS eigentlich nur, so hab ich getestet, um folgenden Einträge erweitern:

192.168.168.192 vhost1.domain
192.168.168.192 vhost2.domain
192.168.168.192 vhost3.domain
192.168.168.192 vhost4.domain
192.168.168.192 domain

Somit gehen alle Rechner die er anspricht zu seinem apachen und anhand des Namens springt der zu den Vhosts..

MfG IceBeer
Bitte warten ..
Mitglied: gracom
11.02.2006 um 10:01 Uhr
Guten Morgen,

das Problem mit dem XAMPP-Apachen ist jedoch, dass er nicht startet, wenn die IP, auf die er "hören" soll, nicht existiert.

Und da der LAN-Adapter sich deaktiviert, hat er keine IP und Apache kann nicht "lauschen".

Außerdem:
Host-Eintrag hat nicht gegeht.
Stromspar-Haken weg ging auch nicht.

Viele Grüße und immer noch auf der Suche,
--
GraCom
Bitte warten ..
Mitglied: meinereiner
11.02.2006 um 10:04 Uhr
Viele Grüße und immer noch auf
der Suche,


Hast du mal versucht den Loopbackudapter von Microsoft zu installieren?
Wird als Netzwerkkarte unter Microsoft aufgeführt und muss händisch installiert werden.
Bitte warten ..
Mitglied: gracom
11.02.2006 um 10:10 Uhr
Nochmal guten Morgen,

habe soeben den Microsoft Loopback-Netzwerkadapter installiert und es funktioniert!!!

Systemsteuerung -> Hardware -> Gerät hinzufügen -> Netzwerkadapter -> M$ -> M$-Loopback-Adapter

Diesem noch die gewünschte IP zugewießen und jetzt startet auch der XAMPP-Apache.

Vielen Dank für alle Hinweise und besonders für den Hiweis auf den Loopback-Adapter!!

Schönes Wochenende,
--
GraCom
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

Mit WLAn-Router per Netzwerkkabel surfen.

Frage von MxyptlkLAN, WAN, Wireless7 Kommentare

Hallo Forum, ich surfe derzeit über meinen Laptop und einer kabellosen Verbinundung zu meinem (Unitymedia)- Router Technicolor 7200 U ...

LAN, WAN, Wireless

Netzwerkkabel zu langsam?

gelöst Frage von benq-simensLAN, WAN, Wireless25 Kommentare

Hallo, wir haben im Haus ein geschätzt 10 Jahre altes Netzwerkkabel verlegt. Da wir nun zu einem schnelleren Internet ...

LAN, WAN, Wireless

Netzwerkkabel Überlänge

gelöst Frage von CT-LegendLAN, WAN, Wireless16 Kommentare

Hallo liebe Administratoren, Ich habe eine Frage bezüglich Netzwerkkabel. Die Spezifikation gibt ja vor, dass eine Maximale Länge von ...

LAN, WAN, Wireless

IP Adresse lokal nicht erreichbar

Frage von fundave3LAN, WAN, Wireless13 Kommentare

Guten Tag zusammen, Ich habe heute mal wieder ein Rätsel dabei wo Ich jetzt mal garnicht hinterblicke. Folgendes: Ich ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 11 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 20 StundenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit17 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...

Windows Installation
Kleines Büro - wie PCs einrichten? Domaincontroller sinnvoll?
Frage von Jonas42Windows Installation13 Kommentare

Hallo zusammen, ich überlege derzeit mal wieder, ob ich unsere IT ändern sollte. Es handelt sich um ein Ingenieurbüro ...