Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Mails an eigene Domain trotzdem über Relay schicken

Mitglied: wiseguy

wiseguy (Level 1) - Jetzt verbinden

26.09.2012, aktualisiert 10:31 Uhr, 8300 Aufrufe, 6 Kommentare

Mein Szenario:
  • Windows Server 2008 R2
  • Exchange 2010
  • Vorgelagerter Mailserver (Linux Server im Internet) der über IMAP/SMTP angesprochen wird
  • Externe Domain: meinedomain.de
  • Interne Domain (das ist auch die Windows Domäne): meinedomain.intern

  • Nicht alle Mailbenutzer der Domain meinedomain.de nutzen den Exchange; Einige nutzen ausschließlich den IMAP/SMTP Server im Internet

Ich möchte, dass der Exchange Mails an meinedomain.de NICHT intern abfrühstückt. Er soll dafür den Connector zu dem vorgelagerten Linux Server im Internet nutzen.

Dafür habe ich einen Connector eingerichtet mit Adressraum *, der alle Mails über das externe Mailrelay schicken soll.

Wenn ich nun aber eine Mail an z.B. mailadresse@meinedomain.de schicke, versucht der Exchange die intern zuzustellen. Da kein Benutzer im AD diese Mailadresse hat, bekommt der Versender eine entsprechende Fehlermeldung.
Die Mailadresse gibts auch tatsächlich nur auf dem vorgelagerten Linux Server. Ich würde nun wollen, dass der Exchange alle Mails an meinedomain.de über den Relay Server versendet, unabhängig davon, ob der Empfänger auch ein Konto im AD ist/hat. (Die Mail wird dann vom Pop3 Connector halt wieder her geholt).

Wenn ich tatsächlich nur innerhalb meines Exchange Servers bleiben will, könnte ich ja die meinedomain.intern Mailadressen verwenden. Diese existieren tatsächlich nur für User des ADs.

Kann mir hier jemand weiterhelfen?

Lieben Gruß
Wiseguy
Mitglied: d4shoerncheN
26.09.2012 um 10:48 Uhr
Hallo,

schreib bitte noch dazu, wie du den neuen Sendeconnector konfiguriert hast.

Gruß
Bitte warten ..
Mitglied: wiseguy
26.09.2012, aktualisiert um 11:18 Uhr
Sendeconnector ist wiefolgt eingerichtet:
Registrierkarte "Adressraum":
Adressraum wie bereits genannt: *
Typ davon ist "SMTP" und Kosten "1". Er gillt für alle Subdomains. "Sendeconnector mit Bereich" ist nicht aktiviert (kenn die Option nicht).

Registrierkarte "Netzwerk":
Email über einen Smarthost leiten. Zugangsdaten dort entsprechen denen für den Linux Mailserver im Internet. "Die Einstellung für externes DNS-Lookup auf dem Transportserver verwenden" ist nicht aktiviert (Auch hier kenn ich die Option erstmal nicht bzw. weiß nicht was dieser Punkte genau bewirken würde).

Registrierkarte "Quellserver":
Hier ist einzig und allein mein Exchange Server eingetragen.


Ergänzungen:
"Sendeconnector mit Bereich":
Alle von Ihnen erstellen Sendeconnectors können standardmäßig von allen Hub-Transport-Servern in der Exchange-Organisation verwendet werden. Sie können jedoch den Bereich jedes beliebigen Sendeconnectors so einschränken, dass er nur von anderen Hub-Transport-Servern verwendet werden kann, die am gleichen Active Directory-Standort vorhanden sind. Wählen Sie zum Einschränken des Gültigkeitsbereichs des Sendeconnectors die Option Sendeconnector mit Bereich aus.
(Q: http://technet.microsoft.com/de-de/library/bb629503.aspx)

-> Da hier ja mehr eingeschränkt wird, hatte ich nicht angenommen, dass diese Option mein Problem lösen würde (und habs auch nicht ausprobiert). Was das alerdings genau ist, weiß ich nicht bzw. verstehe ich nicht ganz.


"Die Einstellung für externes DNS-Lookup auf dem Transportserver verwenden":
-> Auch hier klingt es nach einer Einschränkung und ohnehin nicht zu meinem Problem. Daher habe ich auch diese Option nicht ausprobiert.

Soweit ich auch gelesen habe, verhält sich der Exchange so, dass er interne Mails nicht über die Connectoren versendet; Diese Einstellung müsste sich also irgendwie verändern lassen. Oder alternativ irgend eine notlösung geschaffen werden (was natürlich nicht gerade toll wäre)
Bitte warten ..
Mitglied: Bap02-2
26.09.2012 um 11:26 Uhr
Hallo,

hier die Lösung. Ich hoffe Du kommst klar.

Problem 1: Zitat: "Wenn ich nun aber eine Mail an z.B. mailadresse@meinedomain.de schicke, versucht der Exchange die intern zuzustellen. Da kein Benutzer im AD diese Mailadresse hat, bekommt der Versender eine entsprechende Fehlermeldung."

Lösung 1: Stelle den Exchangeserver in der Verwaltungskonsole (Organisationskonfiguration)-HubTransport-Akzeptierte Domänen-Neue akzeptierte Domäne meinedomain.de auf Interne Relaydomäne. Dann im gleichen Fenster nochmal eine akzeptierte Domäne meinedomain.intern auf autorisierend. Somit schickt er alle Mails, die an Mailadressen gehen die nicht in der Domäne vorhanden sind, über den Sendeconnector nach draussen an den Linux Mailserver. Hab ich auch bei einem Kunden und das funktioniert wunderbar.

Problem 2: Zitat: "Ich würde nun wollen, dass der Exchange alle Mails an meinedomain.de über den Relay Server versendet, unabhängig davon, ob der Empfänger auch ein Konto im AD ist/hat. (Die Mail wird dann vom Pop3 Connector halt wieder her geholt)."

Lösung 2: Alle Mails ist unmöglich! Der Exchangeserver schaut schon aus Prinzip immer zuerst bei sich selber nach und Du bräuchtest dann auch keinen Exchangeserver
Bitte warten ..
Mitglied: Lochkartenstanzer
26.09.2012, aktualisiert um 12:45 Uhr
Moin,

Du könntest aber auch subdomains verwenden:

user@exchange.domain.tld
user@linux.domain.tld

Der exchange nimmt nur die Mails für exchange.domain.tld an und alles andere schickt er an linux.domain.tld als smarthost.

Dieser wiederum macht Address rewriting und schickt die mails mit user@domain.tld raus, bwz sortiert diese in den Postfächern der user bei sich ein wo sie dann der exchange und die externen user wieder abholen können.

Funktioniert bei einem Kunden vom mir einwandfrei. (Der hat zusätzlich noch historisch bedingt notes.domain.tld und david.domain.tld ).

lks


Edit: Leichte Ergänzungen/Korrekturen.
Bitte warten ..
Mitglied: wiseguy
26.09.2012 um 14:13 Uhr
@Bap02-2: "Lösung 1"; Super, das hat erstmal geklappt

Mit dem anderen Problem (Problem 2) werd ich also leider leben müssen

Danke euch
Bitte warten ..
Mitglied: Bap02-2
04.03.2013 um 02:19 Uhr
Hallo, könntest Du bitte das Thema abschließen und meine Antwort als die richtige kennzeichnen. Wäre echt nett von Dir.
Bitte warten ..
Ähnliche Inhalte
E-Mail
Mail von eigener Domain - trotz SPF
gelöst Frage von HenereE-Mail8 Kommentare

Hallo, hatte ja die Tage SPF auf meinem Postfix eingerichtet. Laut Logfile wurden auch etliche Mails deswegen rejected. Soweit ...

E-Mail

Mails von eigener Domain werden als Spam angesehen

gelöst Frage von KnightE-Mail11 Kommentare

Hallo, seit kurzem habe ich eine eigene .com-Domain mit Hosting von godaddy.com. Schicke ich Mails an meine GMX-Adresse, werden ...

Exchange Server

Wie Mails blockieren die angeblich aus der eigenen Domain sind?

gelöst Frage von Wern2000Exchange Server3 Kommentare

Hallo, hab hier ein kleines Problem das in letzter Zeit sehr viele mails von nicht exestierenden Benutzern per SMTP ...

Outlook & Mail

Outlook: Kann mir selbst keine Mail schicken.

gelöst Frage von Mike-MOutlook & Mail8 Kommentare

Hallo Outlook Profis, ich habe ein sonderbares Problem. Wenn ich in Outlook meine eigene Mailadresse eingebe und mir die ...

Neue Wissensbeiträge
Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 15 StundenSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 21 StundenWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

iOS
Updates für Iphone und Co
Information von sabines vor 1 TagiOS

Gestern abend ist iOS 11.3.1 erschienen, ein kleineres Update, dass einige Lücken schließt und "Lahmlegen" nach einem Display Tausch ...

Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 2 TagenWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Heiß diskutierte Inhalte
Batch & Shell
Powershell: Im AD nach Rechnern mit bestimmten IP-Adressen suchen
gelöst Frage von Raven42Batch & Shell36 Kommentare

Hallo zusammen, ich suche nach einer Möglichkeit nach Computern im AD zu suchen , deren IP-Adresse mit 10.11.12. beginnt. ...

C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++34 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless25 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

Windows Server
Alten DC entfernen
Frage von smartinoWindows Server24 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...