Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst MAYDAY! Win 2003 X64 ständiger Verbindungsabbruch

Mitglied: LeXe

LeXe (Level 1) - Jetzt verbinden

20.12.2007, aktualisiert 11.01.2008, 6766 Aufrufe, 4 Kommentare

Windows Server 2003 x64 Standart, Verbindungsprobleme

Hallo,

ich habe Seit einer Woche ein problem mit meiner IT.

Die Umgebung:

Windows Server 2003 x64 Standart
- AD, DNS, FileServer

WinXP Client & Win Vista Client

Alle Rechner (Server & Client) neu installiert!!

Das Problem:

Wenn ich man sich am Client anmeldet ist eig. alles top. Die Laufwerke werden verbunden ich kann die Freigaben auf dem Server sehen.
Wenn ich aber jetzt auf dem Server auf eine Datei zugreife(ich lade mir ein CD-Image auf die lokale Platte) dann fängt er an mit kopieren, aber nach kurzer Zeit... variiert zwischen 5 und 50 Sekunden bricht die Verbindung ab und ich kann nix mehr machen. Auf den Freigabe kann ich zwar meist noch die Struktur sehen, meiner Meinung nach ist das aber aus dem Cache. Das Problem ist eig. so richtig erst ans Licht gekommen als ich gesagt habe er soll mir z.B. den Ordner Musik Offline verfügbar machen. Dann fängt er an die Daten zu syncronisieren.. und dann ist es wieder vorbei. Bei Vista meldet er entsprechend zum Inhalt Sync-Fehler und bricht ab. In Vista stürzt dann zudem im gleichen Zuge noch der Explorer-Prozess ab. Teilweise gibt es die Meldung er könne die Verbinung nicht ereichen bzw. auflösen. und ähnliches.. die KB-Seiten geben auch nichts her. Wenn ich mit NSLOOKUP den DNS prüfe funktionier dieser Prima.
Selbst wenn ich mit Linux auf die Freigabe zugreife kommt eine Fehlermeldung er könne nicht .. ect.


Das schlimme ist, auf dem Server sind Produktiv-Daten.. somit mache ich nichts anderes als das Problem in den Griff zu bekommen.. leider ohne Erfolg.

Kann mir jemand helfen?

EDIT:

Hier ein Bild mit der Fehlermeldung wie sie unter XP erscheint. Bei Vista praktisch das gleiche nur siehts besser aus ;-P

2ca045a417d1cf4255803f955569b07f-fehlerserver - Klicke auf das Bild, um es zu vergrößern
Mitglied: Rafiki
20.12.2007 um 09:50 Uhr
Windows Server 2003 x64 Standard läuft problemlos und sehr zuverlässig auch wenn ich mal schnell 100GB kopiere.

Ich vermute durch magisches hellsehen ein Netzwerkproblem. Entweder der Treiber der Netzwerkkarte, die Netzwerkkarte selber, das Netzwerkkabel oder der Switch oder auch nur ein Port von dem Switch verursachen das Problem. Nach meiner Erfahrung ist meistens das Netzwerkkabel die Ursache. Häufig gibt es dann noch Probleme mit dem aushandeln der Geschwindigkeit (10/100Mbit oder gigabit) in half oder full duplex.

Prüfe mit einem ping vom Client zum Server und umgedreht vom Server zu einem der Clients ob die Verbindung zuverlässig arbeitet.
ping 192.168.1.15 –t -l 1200
ping, mit „Dauerfeuer“ –t und in unterschiedlichen Paket Größen –l 1200 für 1200 Byte.
Wenn bei diesem Test unterschiedliche Paket Laufzeiten auftreten, also etwas anderes als 1ms, dann hast du definitiv an Problem mit dem Netzwerkkabel oder dem Switch.

Vergleiche das mit einem ping mit normalen kleinen Paketen, also ohne –l 1200
Wenn das problemlos geht ist ein schlecht gecrimptes Netzwerkkabel oder Störungen auf dem Kabel die Ursache.

Um Probleme mit Windows und dem Treiber auszuschließen kannst du von einer Knoppix CD booten und erneut mit ping in alle Richtungen prüfen ob es an der Hardware oder an Windows liegt.


gruß Rafiki
Bitte warten ..
Mitglied: LeXe
20.12.2007 um 11:40 Uhr
Hi,

danke für die schnelle Antwort.

Das mit den Pings hatte ich schoneinmal getestet. Läuft alles Problemlos. Da der Server auch noch eine 2. NIC hat habe ich auch alles nochmal mit einem anderen Switch, Kabeln ect. getestet.

Das einzige was ich mir vorstellen kann das es ectl. noch am DNS liegen könnte... damit hab ich keine Erfahrung. ... aber eig. kann es das ja nicht sein.

Leider geben die Logs auf Server und Client überhaupt nichts her wo man ansetzten könnte
Bitte warten ..
Mitglied: Rafiki
20.12.2007 um 19:34 Uhr
Deine Fehlerbeschreibung: Windows bricht das kopieren von Dateien ab.
Du sagst Netzwerkkarte, Kabel und Switch gewechselt. Problem bleibt und ping, mit goßen und kleinen Paketen geht zuverlässig.

Das macht auch auf mich den Eindruck für ein gutes Netzwerk aber es erklärt leider nicht woher der Fehler kommt.

Ich weiß nicht wo dein Fehler liegt aber hier sind meine Vorschläge:

1) Du könntest einen FTP oder http dienst entweder auf dem Server oder auf einem Client einrichten um dann testweise große Datenmengen zu übertragen. Wenn das nicht geht dann zurück zur Netzwerkdiagnose. Wenn das geht liegt das Problem definitiv bei der Windows Installation.
Als einfachen Webserver verwende ich gerne den Abyss Web Server X1, http://www.aprelium.com/
Kostenlos, einfach einzurichten und auch sauber wieder zu entfernen. Dort einige große Dateien z.B. ISO Image, ablegen und downloaden.

2) Wäre es möglich das das Netzteil zu schwach ist und bei hoher Belastung der Festplatte(n) und CPU die Spannung nicht stabil hält? Stürzt der Server auch mal ab?

3) Verwende den Process Explorer (www.sysinternals.com -> landet dann bei Microsoft) um festzustellen ob Deferred Procedure Calls - DPC eine sehr hohe CPU Last verursachen. Ursache kann ein Fehlender Chipset Treiber sein.

Ich wünsche viel Erfolg und würde mich freuen wenn du den Fehler findest und kurz berichtest was die Ursache war.

Gruß Rafiki
Bitte warten ..
Mitglied: LeXe
11.01.2008 um 11:32 Uhr
So...

ich denke das Problem endlich in den Griff bekommen zu haben. Ich werde etwas ausholen denn ich habe ja nun immerhin 2 geschlagene Wochen damit kaputt gemacht...

Die ganze Sache Softwareseitig zu lösen schlug ja leider schon vor Weihnachten aus. Nachdem ich die gesamt Netwerkhardware (Switch, Kabel, ect.) einzelln getestet hatte entschied ich mich den Server inkl. einem Client in eine isolierte Umgebung zu stecken und habe via VLAN die Trennung hergestellt... mein ursprünglicher Gedanke war, das sich der Windows DNS sich mit dem DNS auf der Linux-Firewall nicht vesteht... denkste... das war es nicht.

Nach einigen Neuinstallationen und dem Test mit einem Extra Webserver war ich nicht weiter mit der Problemlösung vorrangeschritten... immernoch das gleiche... Datentransfer läuft kurz an und dann bricht die ganze Verbinung ab und er Client will nicht mehr richtig.

Nun ging es dann doch wohl in Richtung das evtl. ein Chipsatztreiber oder so etwas den Fehler verursachen könnte.
Glücklicherweise habe ich einen Baugleichen Server in der nähe um meine Systemplatte einfachmal dort testen zu können... und siehe da... System bootet ohne Probleme und der Tranfer ist auch möglich ohne das etwas abbricht.

GUT. schonmal sicher das es nicht das System oder ein Treiber ist... denn war ja exakt gleiche Hardware. Erster Erfolg stellt sich ein.

Was is nun aber defekt?

Speichertest mit Linux --> Passed
CPU test mit prime95 --> Passed
Netzteil getauscht .. keine Veränderung
Netzteil gemessen --> Passed
ok... neues Mainbord gekauft...
-> nur Probleme , RAID ging nicht ect. -> Board umgetauscht gegen ein anderes
... teilweiser erfolg... Alles bootet... aber ... Problem besteht weiterhin... ok..

nun den Baugleichen Server runtergefahren und Stück für Stück die Komponenten getauscht.
nach vielen seltsamen Erscheinungen ... erster fehler gefunden...
( Ich kann nun im Schlaf den Server starten, mich anmelden, testen, runterfahren, .. do loop)
einer der 4 RAM-Riegel scheint trotz positem Test defekt zu sein. Zur Sicherheit noch alle Sockel geprüft. Dies hat dann auch div. Fehler auf dem neu gekauften Board erklärt welche im nachhinein betrachtet keine 2GB Riegel unterstützt... obwohl es das sollte... wie auch immer
weiter am Testen fällt auf das das alte Board eine Macke haben muss...

Ende vom Lied:

Board hat defekt, 1x 2GB Riegel defekt. beides wird eingeschickt...

momentan läuft jetzt alles Provisorisch mit dem anderen Bord, jedoch nur mit einem drittel des RAM's.

Habe noch einige Test's gefahren... Problem scheint gelöst. Was eine Geburt und ein Kostenaufwand... aber MurphysLaw wurde bestätigt... denn an dem Abend war sogar noch die Squashhalle ausgebucht . :-P
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

Problem mit WLAN und Smartphone ständige Verbindungsabbrüche

Frage von TestsubjektXLAN, WAN, Wireless19 Kommentare

Hallo alle miteinander, ich habe ein seltsames Problemchen mit meinem Smartphone und meinem WLAN zuhause. Router: Sagemcom FAST 5460 ...

LAN, WAN, Wireless

LAN Hyper-V - ständiger Verbindungsabbruch Netzwerk

Frage von T-Cip17LAN, WAN, Wireless11 Kommentare

Hallo liebe Mitglieder, meine Konfig: - Windows Server 2012 R2 - Hyper-V - Auf der Hyper-V ist das virtuelle ...

Windows 7

RDP Verbindungsabbruch

gelöst Frage von hajoweWindows 77 Kommentare

Hallo Forengemeinde. IST: Ich habe ein Problem mit RDP. Ich mache innerhalb eines Netzes eine RDP Session von einem ...

Windows 10

Update von Win 7 x86 auf Windows 10 x64

gelöst Frage von fiffi1Windows 105 Kommentare

Hallo Leute Ist es möglich kostenlos von einem 32-Bit Windows 7 System auf ein 64-Bit Windows 10 System zu ...

Neue Wissensbeiträge
Drucker und Scanner
HP-MF-Drucker per Fax angreifbsr
Information von Lochkartenstanzer vor 1 TagDrucker und Scanner3 Kommentare

Endlich eine sinnvolle Verwendung für Faxe: Damit kann man offensichtlich den Drucker übernehmen. lks

Router & Routing

Das pfSense Buch ist jetzt für jeden kostenlos zu beziehen

Tipp von magicteddy vor 2 TagenRouter & Routing2 Kommentare

Bisher war das Buch nur für zahlende Unterstützer verfügbar, jetzt steht für Jedermann kostenlos zur Verfügung. Siehe auch The ...

Firewall

Möglicherweise neue Sicherheitslücke in Mikrotik-Firmware

Information von LordGurke vor 4 TagenFirewall3 Kommentare

Hallo zusammen, vor ein paar Monaten gab es ja bereits eine Sicherheitslücke in der Firmware von Mikrotik-Routern, über welche ...

Erkennung und -Abwehr
Rechner hacken mit Cortana, auch Remote
Information von Lochkartenstanzer vor 5 TagenErkennung und -Abwehr3 Kommentare

heise berichtet über den Vortrag von der Blackhat Open Sesame: Picking Locks with Cortana. Einige Fehler sind schon gefixt, ...

Heiß diskutierte Inhalte
Windows 10
WIN 10 1803 - LTE Stick kein Internetzugriff
Frage von killtecWindows 1023 Kommentare

Hallo, ich habe mit einem Windows 10 1803 Probleme mit einem LTE-Stick. Das gleiche Problem ist bei mehreren Rechnern ...

CPU, RAM, Mainboards
Xeon E5620: noch schnell genug?
Frage von ahussainCPU, RAM, Mainboards19 Kommentare

Hallo allerseits, ich habe die Möglichkeit, aus Restbeständen einen Tower mit Xeon E5620 CPU und 24 GB RAM zu ...

Datenbanken
MySQL Datenbank Import Aufgabe für mehrere .csv dateien
Frage von Marcel1989Datenbanken18 Kommentare

Hi, ich komm nicht weiter. Ich hab auf einem Windows Server 2012 r2 eine MariaDB/MySQL laufen. Nun soll diese ...

Windows Server
Remote Desktop Services User Profile Disk - DFS
Frage von einzelkindWindows Server16 Kommentare

Hallo Miteinander, ich richte gerade eine neue RDS Farm auf Basis von Windows Server 2016 ein. Von Server 2012 ...