Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

mehrere bonds (6 NICS)

Mitglied: Schranzer23

Schranzer23 (Level 1) - Jetzt verbinden

16.01.2007, aktualisiert 21.01.2007, 5257 Aufrufe, 3 Kommentare

mehr als ein NIC Team einrichten

Hallo liebes Forum :=)

Dachte eigentlich das wäre kein Problem, nun muss ich mich doch an euch wenden *nerv*

In meinem lieben Linux Server sind liebe kleine 8 netzwerkkarten drin, 2 für ein GB netz die hier keine
relevanz darstellen.

Unter anderem auch DREI Dualport 10/100 Ethernet NICS (macht insgesamt sechs liebe kleine NICS =) )

ifconfig liefert folgendes (gekürzt):

bond0 192.168.16.5 > mein VLAN1
eth0 192.168.112.5 > mein VLAN5
eth1 192.168.160.5 > mein VLAN6
eth2 gerade nix
eth3 gerade nix 2 und 3 sollten das bond 1 sprich 32er subnetz bilden
eth4 gerade nix
eth5 gerade nix 4 und 5 sollten das bond2 sprich 48er subnetz bilden
eth6 für bond0
eth7 für bond0

alle netzmasken sind auf 255.255.255.240

--

So da ihr gelesen habt, ist das bond0 interface richtig konfiguriert dieses kann ich auch von meiner WKS anpingen

--
Zusatzinfos:
Netzwerkswitch1 - Nortel Baystack 350 T /24

Port 1 und 3 bilden das MLT TRUNK 1 >> das 16er Subnetz
Port 10 und 12 bilden das MLT TRUNK 2 >> das 32er Subnetz
Port 21 und 24 bilden das MLT TRUNK 3 >> das 48er Subnetz

Für jede NIC DUAL PORT wurden jeweils 2 SFTP Cat.5e Kabel an den Switch zu den jeweiligen Ports angebracht

Verwendetes System > Ubuntu Linux (vorgestern runtergeladen) die Server Variante
Kernel: > 2.6.17-10-server (MIT SMP)
--

Jetzt kommt der kasus knacktus, ich habe jegliche konfigurationsdatei angepasst
- /etc/modutils/aliases
- /etc/modutils/actions
- /etc/modules.conf
- /etc/network/interfaces

Der verfluchte kleine Tux will mir kein bond1 und kein bond2 einrichten!!
ich habs schon folgendermaßen versucht:
entweder hab ich
                                                        1. modprobe bonding max_bonds=3
                                                        eingegeben

                                                        oder direkt in der /etc/modutils/aliases
                                                        folgende abschnitte konfiguriert:


                                                        alias bond0 bonding
                                                        alias eth6 e100
                                                        alias eth7 e100
                                                        options bond0 mode=0 miimon=100 max_bonds=3

                                                        alias bond1 bonding
                                                        alias eth4 e100
                                                        alias eth5 e100
                                                        options bond1 mode=0 miimon=100

                                                        alias bond2 bonding
                                                        alias eth3 e100
                                                        alias eth2 e100
                                                        options bond2 mode=0 miimon=100

                                                        So jetzt würd ich gerne wissen ob ich einen Fehler in den Konfigs gemacht habe oder wodran es liegen mag, ich
                                                        bin fürs erste mal ratlos

                                                        Für diejenigen die sich meine /etc/network/interfaces anschaun mögen, hier die datei>>>

                                                        1. 112 Subnet

                                                        iface eth0 inet static
                                                        address 192.168.112.5
                                                        netmask 255.255.255.240

                                                        auto eth0

                                                        1. 160 Subnet

                                                        iface eth1 inet static
                                                        address 192.168.160.5
                                                        netmask 255.255.255.240

                                                        auto eth1

                                                        1. ------------------------------------------------
                                                        2. >> BONDING SETTINGS <<
                                                        3. 48er - include NIC 2 - 3
                                                        4. bond2

                                                        iface eth2 inet static

                                                        auto eth2

                                                        iface eth3 inet static

                                                        auto eth3

                                                        auto bond2
                                                        iface bond2 inet static
                                                        address 192.168.48.5
                                                        netmask 255.255.255.240
                                                        network 192.168.48.0
                                                        broadcast 192.168.48.15
                                                        hwaddress ether 00:50:8B:68:80:94
                                                        up ifenslave bond2 eth2 eth3
                                                        down ifenslave -d bond2 eth2 eth3

                                                        1. 32er - include NIC 4 - 5
                                                        2. bond1

                                                        iface eth4 inet static

                                                        auto eth4

                                                        iface eth5 inet static

                                                        auto eth5

                                                        auto bond1
                                                        iface bond1 inet static
                                                        address 192.168.32.5
                                                        netmask 255.255.255.240
                                                        network 192.168.32.0
                                                        broadcast 192.168.32.15
                                                        hwaddress ether 00:50:8B:64:03:E3
                                                        up ifenslave bond1 eth4 eth5
                                                        down ifenslave -d bond1 eth4 eth5

                                                        1. 16er - include NIC 6 - 7
                                                        2. bond0

                                                        iface eth6 inet static

                                                        auto eth6

                                                        iface eth7 inet static

                                                        auto eth7

                                                        auto bond0
                                                        iface bond0 inet static
                                                        address 192.168.16.5
                                                        netmask 255.255.255.240
                                                        hwaddress ether 00:50:8B:68:AD:28
                                                        gateway 192.168.16.1
                                                        network 192.168.16.0
                                                        broadcast 192.168.16.15
                                                        dns-nameservers 192.168.16.1
                                                        up ifenslave bond0 eth6 eth7
                                                        down ifenslave -d bond0 eth6 eth7

                                                        1. end of file
Mitglied: Weiricth
16.01.2007 um 21:28 Uhr
hi,

also mit zwei leitungen im gleichen ip netzt auf einen switch ohne das er loadbalancer ist. Keine chance des geht nicht.

2. find ich das deine subnetzte etwas komisch sind. weil die nicht alle die gleich submask haben können.
das 16er Subnetz = 255.255.255.240 also 192.168.x.x/28
das 32er Subnetz = 255.255.255.224 also 192.168.x.x/27
das 48er Subnetz = 255.255.255.192 also 192.168.x.x/26

3. wenn du schon vlans hast dann nutz sich auch weil die ganze subnetz zeug ist total nervig und ist sicherheits technisch totaler müll da man immer noch snivern kann.

Grüße

TomTom
Bitte warten ..
Mitglied: Schranzer23
17.01.2007 um 00:42 Uhr
Der Baystack hat 24 Ports, davon bilden 6 Ports jeweils ein VLAN
1. VLAN 16er Subnetz
2. VLAN 32er Subnetz
3. VLAN 48er Subnetz
4. VLAN 80er Subnetz (not used)

Danke für die Antwort, ich hatte die Geschichte mit den Subnetzen Schon in einem andere Thread geklärt, dort wurde mir die Subnetzmaske wie folgt angegeben.

Der Switch Kann Multilink Trunking und somit bis zu 4 Ports zu einem Trunk zusammenschalten, ich habe für jede DualNic am Server 2 Cat.5 SFTP Kabel gelegt, das macht zusammen Sechs Kabel die nur für das 100MB Netzwerk auf den Switch laufen, jede Dualnic erhält am Switch ein Trunk pro VLAN. SOmit wäre die Sache am Switch geklärt. Wie gesagt für das 16er NETZ (VLAN 1) funkt die sache auch, jedoch muss ich bond1 und bond2 irgendwie aktivieren. Die BOnds sind so konfiguriert, dass die Übertragungsrate der beiden Nics (DualNics) verdoppelt wird.

--
Edit:
Mir geht es in meinem Netzwerk nicht um SIcherheit, sondern da drum dass ich möglichst viele virtuelle Maschinen (VMware) in verschiedene Segmente einspeisen kann. Zu Testzwecken, für Arbeitszwecke und für Rechenintensive Anwendungen (3DSmax , backburner, etc.. [Render Clients])

Somit finden sich zwar zwei physische Leitungen in einem VLAN, jedoch immer nur eine logische, ein bond spielt ja den Stellvertreter für beliebig viele NICS (in dem Fall immer 2 pro VLAN).
Bitte warten ..
Mitglied: Schranzer23
21.01.2007 um 10:30 Uhr
Sodalie problem gelöst

  1. rmmod bonding
  2. modprobe bonding max_bonds=3
  3. update-modules

  1. nano /etc/modutils/aliases >> eintrag options_bonding max_bonds=3
  2. nano /etc/modules.conf >> eintrag options_bonding max_bonds=3

voila bond0, bond1 und bond2 erscheinen mit den richtigen ip infos, jetzt kann
ich nur noch nich 32.5 und 48.5 von einem anderen client anpingen, ich
vermute ich hab mich bei der verkabelung vertan.


danke für alle leser
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Netzwerkfehler: Bond
Frage von sebastian2608Router & Routing17 Kommentare

Hallo Leute, mich plagt seit längerem ein Problem - Folgendes: Ich habe auf einem meiner Proxmox Host-Servern ein (Debian) ...

Netzwerkgrundlagen

Zwei NICs in einem Rechner, Verbindung ins Internet

gelöst Frage von CoreknabeNetzwerkgrundlagen5 Kommentare

Moin, für die Netzwerk-Cracks hier wahrscheinlich eine einfache Frage Ich hingegen komme hier nicht weiter bzw. habe mich da ...

Vmware

Vmware esxi 6 pc bootet nach speicherproblem nicht mehr

Frage von letstryandfindoutVmware5 Kommentare

Hallo zusammen, nachdem es auf einem esxi 6 ein speicherproblem gab mit einer virtuellen Maschine, wurde diese auf einen ...

Router & Routing

Server mit 2 NICs - NAT vom Router

Frage von survial555Router & Routing6 Kommentare

Hallo Community, ich habe 2 WAN Router. Router A nutzt einen SDSL für VPN ins Firmen LAN und bezieht ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 1 TagWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 1 TagSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 2 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein Beitrag bei Heise (siehe Link folgend). Behörden ignorieren Sicherheitsbedenken gegenüber ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 2 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL13 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs10 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...

Firewall
RB2011 Firewall Rule eine bestimmte Mac oder IP Adresse nicht zu blockieren
Frage von lightmanFirewall10 Kommentare

Hallo liebes Forum mit ihren Spezialisten. Ich habe meine Firewall so konfiguriert das kein Endgerät ohne meine Speziellen Erlaubnis ...

Voice over IP
Vodafone IP Anlagenanschluss - TK-Anlage einrichten
Frage von BytedreherVoice over IP8 Kommentare

Moin Zusammen, wir hatten gestern bei uns die Umstellung auf den neuen IP Anschluss bei Vodafone. Vodafone IP Anlagenanschluss ...