Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst MS SQL2005 und ODBC - Passwortabfrage alle 5 Minuten

Mitglied: Ongelino

Ongelino (Level 1) - Jetzt verbinden

12.11.2008, aktualisiert 14.11.2008, 3758 Aufrufe, 5 Kommentare

Hallo

Habe eine neue Instanz auf dem SQL2005 (nicht Express) installiert und die entsprechende Datenbank mit Tabellen + Spalten angelegt - alles wunderbar. Auf einem Rechner läuft ein Logging-Client, welcher Daten von der Telefonanlage per ODBC in die SQL-DB schreiben soll.

Also ODBC Verbindung angelegt - auch alles wunderbar - findet DB Server + DB - Verbindungstest - wunderbar.

Nun den Logging-Client gestartet - den ODBC Namen eingetragen, die IP des TK-Messaage-Server angegeben + PWD der TK - alles schön - Start - PWD Abfrage für den DB-User - eingegeben läüft - der Logging-Client bekommt alle Daten von der TK und schriebt diese in die Datenbank!

Aber: Nun kommt es. Alle 5 Minuten bekomme ich auf dem Logging-Rechner eine Passwortabfrage für den DB-Server. Ich kann nicht finden woran es liegt. Habe die ODBC Verbindung auch schon mehrfach neu angelegt und auf der DB geschaut ob irgendwo ein Timeout ist.

Ich bin für alle Hinweise sehr dankbar!!
Gruß Frank
Mitglied: problemsolver
12.11.2008 um 11:48 Uhr
Hallo,

ich bin mir zwar nicht 100%tig sicher, aber ich meine, dass man das Passwort der ODBC-Verbindung in der Registrierung hinterlegen kann.
Ich vermute einfach mal, dass Du im ODBC-Datenquellen-Administrator unter System-DSN die Einrichtung vorgenommen hast.
Die Einstellungen werden unter
01.
HKLM\Software\ODBC\ODBC.INI
abgespeichert.
Wenn Du nun deine ODBC-Verbindung hier mal raussuchst und eine neue Zeichenfolge "PWD" anlegst und diese dann mit deinem Passwort füllst, könnte es klappen. (Unter UID müsste der Benutzername eingetragen werden)

Kannst ja nochmal schreiben, ob das zu einem Erfolg geführt hat.

Gruß

Markus
Bitte warten ..
Mitglied: Ongelino
14.11.2008 um 14:21 Uhr
Hallo, danke für die Antwort.

Ich habe es als System-DSN eingerichtet.

Habe auch Deinen Vorschlag umgesetzt - es scheint zu laufen. Werde es aber mal über ein paar Tage beobachten

Vielen Dank für den Hinweis.

Nun kann ich eine eigene Dokumentation verfassen und dem Hersteller der Telefonanlage mal zukommen lassen.

Beste Grüße
Frank
Bitte warten ..
Mitglied: Ongelino
14.11.2008 um 14:36 Uhr
So ... nun dachte ich, dass es läuft - jetzt kam die PWD-Abfrage - aber nun sind mehr als 5 oder 10 Minuten vergangen - das ganze ist ein Mysterium
Bitte warten ..
Mitglied: Ongelino
14.11.2008 um 15:18 Uhr
Wenn ich im Aktivitätenmonitor des SQL schauen steht bei dem Prozess immer "ASYNC_NETWORK_IO" - habe dem Hersteller des kleinen Logging-Programms nun einen Screenshot usw. zukommen lassen. Es ist so, dass dieses kleine Ding die Verbindung komplett abbricht und neu aufbauen will und dann nach dem PWD fragt.
Bitte warten ..
Mitglied: problemsolver
14.11.2008 um 19:01 Uhr
Hi,

vielleicht liegt die Ursache des Problems auch tiefer. Es scheint anscheinend etwas mit der Authentifizierung am Zielsystem zu tun zu haben.
Sagt dein Ereignisprotokoll (quelle und ziel) etwas bestimmtes aus? Was steht dort zum Zeitpunkt des Fehlers?
Was ist, wenn Du beim SQL Server einen zusätzlichen Benutzer anlegst und dich hiermit authentifizierst? Ggf. mal auch die Windows integrierte Authentifizierung ausprobieren? Was sind die Ergebnisse?

Passiert der Fehler auch, wenn Du dauerhaft Daten abfragst oder ist es 100%tig eine TImeout Angelegenheit? (Vielleicht auch mal die Zeit messen...)

Du siehst schon... es verliert sich das Ganze so leicht in Spekulation

Gruß

Markus
Bitte warten ..
Ähnliche Inhalte
Entwicklung
Iframe reload nach 5 Minuten
gelöst Frage von Thomas91Entwicklung3 Kommentare

Hallo Community, ich versuche gerade ein <iframe> dazu zu bringen das es alle 5 Minuten sich selbst neuläd. Leider ...

Utilities
Teamviewer - Zugriff nur 5 Minuten
gelöst Frage von ZockervogelUtilities9 Kommentare

Hallo, ich versuche, wenn ich krank bin bzw. im Urlaub bin, auf den Computer in der Firma zu kommen. ...

Windows 8

Passwordeingabe - Login-Screen nach 5 Minuten abstellen oder ändern

Frage von joeyschweizWindows 87 Kommentare

Guten Morgen Forum, ich hänge gerade an einem komischen Problemchen. Wir haben drei Aussendiestler mit Notebooks die nicht in ...

Windows Server

Drucken aus der Remoteapp braucht teilweise 5-10 Minuten

Frage von d-g-l-80Windows Server5 Kommentare

Hallo, ich habe da ein etwas merkwürdiges Problem mit den Ausdrucken aus einer RemoteApp. Es handelt sich dabei um ...

Neue Wissensbeiträge
Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 5 StundenHumor (lol)1 Kommentar

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 18 StundenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 18 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 21 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server40 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing19 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...