Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

MX record und die Subdomains - DNS Verständnisfrage

Mitglied: Makina

Makina (Level 1) - Jetzt verbinden

19.08.2014 um 20:25 Uhr, 4112 Aufrufe, 8 Kommentare

Hallo,

ich baue mir gerade einen Mail-Server auf Basis eines Macs mit 10.9 auf.
Jetzt wurde mir eine neue Firewall installiert und jetzt komme ich nicht ganz weiter, da mir an manchen Stellen das Wissen fehlt. Ich hoffe ihr könnte mir helfen und meinen Knoten im Kopf zum Platzen bringen.

Standleitung mit 4er Netz ist vorhanden. (QSC)
Meine Webseite wird bei 1und1 gehostet und auch dort bleiben.
Der Mac soll als Mailserver arbeiten.

Für meinen Server habe ich bei 1und1 eine Subdomain angelegt, die auf meine öffentliche IP zeigt.
( server.domain.de)

Dann habe ich eine weitere angelegt, die für den MX sein soll
(mx.domain.de)

Den MX-Eintrag habe ich in den 1und1 Domaineinstellungen für meine domain.de angelegt.
(mx.domain.de, Prio 10)

Frage: Ist das unnötig/falsch, dass ich extra für den MX einen Eintrag angelegt habe, obwohl ich schon eine Subdomain habe?
Ich kann bei jeder Subdomain bei 1und1 wieder Mailserver definieren... Verwirrt mich etwas...

In den DNS-Einstellungen habe ich den MX-Eintrag auf meinem Server angelegt.
Prinizipiell funktioniert der Mailversand, den ich bis jetzt über den relay von 1und1 sende. Und auch das Empfangen klappt.

Jetzt möchte ich einen reverse-mapping Eintrag für den MX anlegen lassen. Nur bin ich mir nicht sicher wo.

Frage: Mache ich das bei 1und1 oder bei QSC? Ich denke bei QSC, denn der MX verweist ja auf meine öffentliche IP. Oder habe ich einen Denkfehler?
Dann sage ich denen, dass ich gerne von meiner IP auf mx.domain.de zeigen lassen möchte?

Da ist aber noch etwas:
wenn ich mit mit telnet mit meinem Mailserver verbinde, meldet sich nun die Firwall. (firewall.domain.local).
Die verdirbt mir doch meinen MX-Eintrag...

Den Versand über den Relay kann ich doch nach erfolgreicher Implementierung des reverse lookup deaktiveren? Oder denke ich falsch?

Ich hoffe ihr könnt mir folgen.
Ich bin für jede Hifle dankbar!

Makina
Mitglied: wiesi200
19.08.2014 um 20:34 Uhr
Hallo,
Zitat von Makina:

Hallo,

Den MX-Eintrag habe ich in den 1und1 Domaineinstellungen für meine domain.de angelegt.
(mx.domain.de, Prio 10)

Frage: Ist das unnötig/falsch, dass ich extra für den MX einen Eintrag angelegt habe, obwohl ich schon eine Subdomain
habe?
Ich kann bei jeder Subdomain bei 1und1 wieder Mailserver definieren... Verwirrt mich etwas...
Jupp, das passt schon so. Für ne Subdomain könntest du dann das gleiche Spiel wieder machen.

In den DNS-Einstellungen habe ich den MX-Eintrag auf meinem Server angelegt.
Prinizipiell funktioniert der Mailversand, den ich bis jetzt über den relay von 1und1 sende. Und auch das Empfangen klappt.

Jetzt möchte ich einen reverse-mapping Eintrag für den MX anlegen lassen. Nur bin ich mir nicht sicher wo.

Frage: Mache ich das bei 1und1 oder bei QSC? Ich denke bei QSC, denn der MX verweist ja auf meine öffentliche IP. Oder habe
ich einen Denkfehler?
Dann sage ich denen, dass ich gerne von meiner IP auf mx.domain.de zeigen lassen möchte?

Genau, nicht mehr oder weniger.

Da ist aber noch etwas:
wenn ich mit mit telnet mit meinem Mailserver verbinde, meldet sich nun die Firwall. (firewall.domain.local).
Die verdirbt mir doch meinen MX-Eintrag...

Tja für den Mailserver brauchst du einen Telnet auf Port 25. Den du bestenfalls auf ein vorgeschaltetes Mailgateway leitest oder direkt auf den Mailserver. Dann Meldet sich auch das richtige.

Den Versand über den Relay kann ich doch nach erfolgreicher Implementierung des reverse lookup deaktiveren? Oder denke ich
falsch?

Nö eigentlich nicht.

Ich hoffe ihr könnt mir folgen.
Ich bin für jede Hifle dankbar!

Makina
Bitte warten ..
Mitglied: Makina
19.08.2014 um 20:54 Uhr
Zitat von wiesi200:

Hallo,
> Zitat von Makina:
>
> Hallo,
>
> Den MX-Eintrag habe ich in den 1und1 Domaineinstellungen für meine domain.de angelegt.
> (mx.domain.de, Prio 10)
>
Jupp, das passt schon so. Für ne Subdomain könntest du dann das gleiche Spiel wieder machen.


Prima!


> Da ist aber noch etwas:
> wenn ich mit mit telnet mit meinem Mailserver verbinde, meldet sich nun die Firwall. (firewall.domain.local).
> Die verdirbt mir doch meinen MX-Eintrag...

Tja für den Mailserver brauchst du einen Telnet auf Port 25. Den du bestenfalls auf ein vorgeschaltetes Mailgateway leitest
oder direkt auf den Mailserver. Dann Meldet sich auch das richtige.

OK, das habe ich über den Port 25 gemacht. Dann stimmt die Weiterleitung in der Firewall nicht? Ich denke, dass sich mein Mailserver melden sollte.


> Den Versand über den Relay kann ich doch nach erfolgreicher Implementierung des reverse lookup deaktiveren? Oder denke
ich
> falsch?

Nö eigentlich nicht.

OK. Dann leitet also der 1und1-Server die Emails weiter. Das kann ich im smtp-log sehen. Das soll also so?
Was passiert denn, wenn ich das relayen in der Einstellung vom Mailserver deaktiviere?
Möchte evtl. 1und1 nur ein Weiterleiten über sie selbst?

Was mir gerade aufgefallen ist: Von hier aus funktioniert kein Ping auf mx.domain.de. Das sollte aber funktionieren, oder?

Auf jeden Fall schon einmal danke!

Makina
Bitte warten ..
Mitglied: wiesi200
19.08.2014 um 21:05 Uhr
Sorry, von mir ein Fehler.

Natürlich kannst du das mit dem Relay deaktivieren.

Das mit dem Ping.
Eine gute Firewall sollte auch nicht auf den Ping antworten.
Bitte warten ..
Mitglied: schmitzi
20.08.2014 um 00:20 Uhr
Hi,

server.domain.de hättest bzw kannst Du Dir komplett sparen

Den Reverse lässt Du bei QSC eintragen oder machst es dort selber in Deinem Kundenportal,
sofern die das unterstützen (wie zB bei Telekom bzw T-Systems)
Wenn ein empfangender Server von Deinem mx.domain.de "angesprochen" wird (eine Mail empfangen soll),
dann hinterfragt (nslookup) dieser Empfänger halt bei QSC die IP und muss als Antwort wieder den DNS-Namen mx.bla erhalten)

"In den DNS-Einstellungen habe ich den MX-Eintrag auf meinem Server angelegt."
auf Deinem lokalen DNS-Server ?

Auf Deiner Firewall musst Du einen Static einrichten für SMTP-Port, auf Deinen internen Mailserver. zeigend.
Aber das scheint ja schon, weil Du sagst der Mailempfang geht..... (?)
Das ist komisch, dass sich Deine Firewall auf den telnet meldet....das widerspricht sich.
telnet mx.domain.de 25 ja ?
Was ist denn das dür eine Kiste ?

Gruss RS
Bitte warten ..
Mitglied: schmitzi
20.08.2014, aktualisiert um 00:30 Uhr
Zitat von wiesi200:

Das mit dem Ping.
Eine gute Firewall sollte auch nicht auf den Ping antworten.

Hi,
naja, das galt mal vor 20 Jahren bzw war auch damals nur eine Kontroverse
Nicht anpingen können, das ist in meinen Augen kein Sicherheitsfeature.
Und auch keine Info, ob jemand eine gute oder schlechte Firewall hat.
Ist ja letztendlich nicht Firewall- sondern Konfigurationssache

Wenn ich Dich abscannen will schaue ich nicht nur ob Du auf Deiner IP anpingbar bist.
Ich werde auch noch eine weitere Millisekunde bei Dir bleiben und mind. noch 50 weitere,
übliche Verdächtige (Ports) abscannen und Dich so so oder so sehen.
Alle Scantools machen das als Minimum bzw bieten das an

Und wenn Du zB Mails über Deine IP versendest oder einen MX darauf hast,
was ja auch eine gerne verwendete Quelle zum IP-Scannen ist, dann gehe ich auf das System los.
Egal, ob ich es anpingen kann oder nicht, juckt mich gornit

Und würde ich sagen, wer nicht auf ICMP antwortet, der hat was zu verbergen, den schau ich mir gaaaanz genau an :o)

Gruss RS
Bitte warten ..
Mitglied: wiesi200
20.08.2014 um 06:55 Uhr
Zitat von schmitzi:

Hi,

server.domain.de hättest bzw kannst Du Dir komplett sparen

Lässt 1und1 meines Wissens nach nicht anders zu.
Bitte warten ..
Mitglied: Makina
20.08.2014 um 07:53 Uhr
Ich danke euch erst einmal für die vielen Anregungen!
Heute morgen geht´s bei mir weiter...

Auch mit neuen Erkenntnissen:

- Ein Ping oder Telnet (25) auf mx.domain.de findet keinen Host. ?!
- Ein Telnet auf server.domain.de auf Port 25 sagt mir heute morgen: connected to server.domain.de ! (Vom selben Netzwerk aus. Dann zeigt sich die Firewall nur auf dem externen Netz). Ist das richtig so?

Dann war wohl mein Gedankengang falsch und ich sollte lieber den MX Record nennen: server.domain.de
Denn der Hostname meines Servers ist ja auch server.domain.de.

Sollte man also generell den MX-Namen gleich anlegen wie den Hostnamen des Servers?

Jetzt müsste ich nur den Reverse-Lookup auf server.domain.de anlegen lassen und das wäre es?
Ich möchte es halt auch verstehen.


Firewall ist eine Securepoint UTM.

Merci
Makina
Bitte warten ..
Mitglied: Makina
20.08.2014 um 08:12 Uhr
Ein Check mit mxtoolbox zeigt mir:
220 firewall.domain.local ESMTP Sendmail

Wäre das meine Lösung?
http://www.andysblog.de/securepoint-helo-aendern

Makina
Bitte warten ..
Ähnliche Inhalte
DNS

Versändnisfrage zu MX Records im DNS

gelöst Frage von Poba88DNS12 Kommentare

Hallo zusammen Nehmen wir an wir haben folgendes Beispiel: nslookup mx.meindomain.de -> zeigt die IP Adresse meines Mail Servers ...

DNS

DNS Konfiguration und MX-Lookup Verständnisfrage

Frage von MMWebdesignDNS1 Kommentar

Hallo, ich habe aktuell folgendes Szenario und bräuchte ein wenig Unterstützung bei der Konfiguration, da ich mit dem Thema ...

Exchange Server

Office 365 - MX Record

gelöst Frage von 109424Exchange Server4 Kommentare

Hallo zusammen, ich stehe vor einem Problem bei dem mir einfach keine geeignete Lösung einfallen will. Ich hoffe ihr ...

DNS

MX Record wird in der Zonedatei nicht übernommen, hilfe!

gelöst Frage von Poba88DNS5 Kommentare

Hallo zusammen, unten seht ihr meine Zonedatei. Ich habe gestern meinen MX Record geändert, jedoch scheint er die Änderung ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 2 TagenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 2 TagenRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 3 TagenSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 3 TagenWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Netzwerkgrundlagen
VLAN - Offene Fragen
Frage von KnettenbrechNetzwerkgrundlagen16 Kommentare

Hallo zusammen, ich befasse mich derzeit mit dem Thema VLAN. Hierzu habe ich schon einige Guides gelesen, einschließlich des ...

Netzwerkmanagement
Netzwerkmanagment im Haus mit Switch, Panel und pfsense
gelöst Frage von CorraggiounoNetzwerkmanagement16 Kommentare

hi zusammen, wir sind gerade dabei das ganze Haus bzw. die einzelnen Zimmer mit netzwerkdosen zu versorgen. Vom Keller ...

Google Android
Empfehlung: Android Ortungsapp
gelöst Frage von certifiedit.netGoogle Android13 Kommentare

Guten Morgen, grundsätzlich vorweg, ich wollte mich eben schlau machen, bzgl einer Ortungsapp, welche Androidbasiert einem anderen Androidsmartphone mitteilt, ...

Vmware
Server 2008 r2 vmware terminalserver
Frage von MasterCVmware12 Kommentare

Guten Abend zusammen, ich hoffe , dass einer von euch mir weiterhelfen kann ,bei meinem kack Problem ! Ist ...