Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Namen der Netzwerk-Geräte ändern (ab SuSE 9.1)

Mitglied: holle100

holle100 (Level 1) - Jetzt verbinden

28.01.2006 um 01:42 Uhr, 5194 Aufrufe

Beim Initialisieren der Netzwerkschnittstellen ändert sich die Zuordnung der Namen. Das LAN-Device hat mal die Bezeichnung eth1, mal eth0...

Es gibt Projekt, bei denen man in einem Server zwei oder mehr Netzwerkkarten betreiben muss.
Ab SuSE 9.1 gibt es leider den Effekt, dass sich die Devicenamen zum Interface sporadisch ändern.
eth0 wird mal zu eth1, eth1 mal zu eth0, usw.

Abhilfe:
1. Installieren vom Paket "wireless-tools"
2. Konfiguriert wird das ganze über eine Datei /etc/iftab welche in etwa so aussieht:

---schnipp------------------------------------------------------------------------------------------------
lan0 mac 00:12:34:56:78:90
lan1 mac 00:98:76:54:32:11
---schnapp------------------------------------------------------------------------------------------------

Wobei lan0 oder lan1 auch xyz sein darf.
Allerdings sollten die orig. Device-Namen wie eth0 und eth1 nicht verwendet werden!

Man muss also nur den gewünschten Namen eintragen und die jeweilige MAC-Adresse eintragen. Wirklich einfach.
Nun muss noch das Programm vor dem initialisieren der Netzwerk-Karten aufgerufen werden. Am besten macht man das, in dem man das Programm in die /etc/init.d/boot.local einträgt:

---schnipp------------------------------------------------------------------------------------------------
if [ -x /usr/sbin/ifrename ] && [ -r /etc/iftab ]; then
echo -n "Remapping network interfaces name: "
/usr/sbin/ifrename -p
echo "done."
fi
---schnapp------------------------------------------------------------------------------------------------

3. reboot
Ähnliche Inhalte
Batch & Shell
Laufwerk Name ändern
gelöst Frage von ShanksBatch & Shell6 Kommentare

Hallo Zusammen, ich hoffe ihr könnt mir helfen bei meinem Problem. Erstmal möchte ich sagen, dass ich ein Absoluter ...

Windows Tools
Intranet Namen ändern
gelöst Frage von MarcysWindows Tools2 Kommentare

Hallo Zusammen, auf eine w2k8 habe ich den IIS laufen und eine normale Intranet aktiviert. Der Hostname des Servers ...

Windows 10

Im Netzwerk werden auf einmal nicht mehr alle Geräte angezeigt

Frage von KlumandaWindows 109 Kommentare

Hallo Leute Habe folgendes Problem und zwar wird mir seit ein paar Tagen im Netzwerk nur mehr mein eigener ...

Windows 10

Finde keine Geräte im Netzwerk über WLAN

Frage von mixmastertobsiWindows 105 Kommentare

Hallo Zusammen, ich habe ein sehr komisches "Problem" mit dem Netzwerk und habe eigentlich bereits alles versucht. Nun erstmal ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 11 StundenWindows 103 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 14 StundenAdministrator.de Feedback10 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 1 TagHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 1 TagGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Server-Hardware
Welche Rolle spielt Design bei Enterprise IT Hardware?
Frage von ApolloXServer-Hardware17 Kommentare

Ich arbeite für einen internationalen Elektronikhersteller in der Forschung und meine Aufgabe ist es, Feedback von Nutzern in Hinsicht ...

Windows Netzwerk
WSUS4 und Windows 10 Updates automatisch installieren
Frage von sammy65Windows Netzwerk15 Kommentare

Hallo miteinander, ich habe mit einen neuen WSUS Server aufgesetzt Server 2016 darauf einen aktuellen WSUS. Grund, wir stellen ...

Speicherkarten
Vergessliche USB-Sticks?
Frage von hanheikSpeicherkarten14 Kommentare

Ich habe in den letzten Tagen 500 USB-Sticks mit Bilddateien bespielt. Obwohl ich die Dateien mit größter Sorgfalt kopiert ...

Switche und Hubs
Cisco SG350X-48 AdminIP in anderes VLAN
Frage von lcer00Switche und Hubs14 Kommentare

Hallo zusammen, ich habe ein Problem mir einem Cisco SG350X-48 bei der Erstinstallation wurde eine IP 192.168.0.254 (Default VLAN ...