Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NAT und Remoterouter-Problem

Mitglied: lcer00

lcer00 (Level 1) - Jetzt verbinden

25.11.2010 um 10:01 Uhr, 2915 Aufrufe, 5 Kommentare

Hallo liebes Forum,

leider wurde ich über Google&Co nicht fündig:

Folgende Situation:

Ich betreibe ein Netzwerk zwischen 2 Standorten über ein VPN. Nun möchte ich eine zusätzliche ISDN-Einwahlverbindung, die physikalisch in Standort 1 lokalisiert ist auch in Standort 2 nutzen. Leider klappt das nicht. Mein Netzwerk sieht wie folgt aus:

Standort 1:
Windows 2003 R2 PDC (multi-homed)
Adapter 1: 192.168.0.10/24 für internes Netzwerk
Adapter 2: 192.168.12.254/24 für externes Netzwerk inkl. Standartgateway/Router ins Internet.

Standort 2:
Windows 2003 R2 DC (multi-homed)
Adapter 1: 192.168.1.10/24 für internes Netzwerk
Adapter 2: 192.168.9.10/24 für externes Netzwerk inkl. Standartgateway/Router ins Internet.

Die zwei Internetrouter stellen eine LAN-LAN PPTP Verbindung zwischen 192.168.12.0 und 192.168.9.0 her.

Die 2 DCs stellen eine bidirektionale VPN-Verbindung über Remoterouter zwischen 192.168.12.254 und 192.168.9.10 her. Über diesen Remoterouter wird der Zugriff von 192.168.0.0 <-> 192.168.1.0 geroutet. NAT ist für diese Verbindung aus.

An Standort 1 existiert eine ISDN-Karte, die eine Einwählverbinung über Remoterouter in ein fremdes Netz (192.168.104.0) herstellt. NAT ist aktiviert.

Von allen Rechnern an Standort 1 (192.168.0.0) kann ich auf das Netz 192.168.104.0 zugreifen.

Auf DC2 (192.168.1.10) habe ich eine statische Route auf 192.168.104.0 auf den Zwischenstandort-Remoutouter gesetzt.

Vom DC2 an Standort2 kann ich auf das Netzwerk 192.168.104.0 zugreifen (Ping + Https).

Von den anderen Rechnern in 192.168.1.0 kommt Ping und Tracert fehlerfrei an, nicht jedoch der https-Zugriff.

Woran könnte das liegen? Ich vermute ein Problem mit dem NAT.

Grüße

lcer
Mitglied: john-doe
25.11.2010 um 10:35 Uhr
Hi,

Bekommst du eine Fehlermeldung zurück wennst mit dem Browser zugreifen willst?

hast du eventuell schon einen Portscan versucht?

Ich gehe davon aus das die Namensauflösung passt.

Mich schaut das so an als ob ein Problem beim Portforwarding von https ist.
Hast du ein DNAT gesetzt ?

LG
Bitte warten ..
Mitglied: lcer00
25.11.2010 um 11:10 Uhr
Hallo,
Bekommst du eine Fehlermeldung zurück wennst mit dem Browser zugreifen willst?

nein einfach einen Timeout. Die BasicFirewall auf der ISDN-Schnittstelle ist übrigends nicht aktiviert.

Ich gehe davon aus das die Namensauflösung passt.

nicht erforderlich, Zugriff erfolgt über IP-Addressen. Funktioniert aber im übrigen.

Mich schaut das so an als ob ein Problem beim Portforwarding von https ist.
Aber wie stelle ich das denn ein?

Hast du ein DNAT gesetzt ?
Ich habe einfach das Häkchen "NAT aktivieren" gesetzt. Ein IP-Adresspool ist nicht eingestellt.

Grüße

lcer
Bitte warten ..
Mitglied: aqui
25.11.2010 um 11:47 Uhr
Router in diese Netze sind immer die Server. Da du das PPTP VPN nicht auf den Routern selber terminierst sondern auf die Server per Port Forwarding sind die beiden Server die zentralen Router für alle internen Netze.
DC-1 benötigt keinerlei statische Routen, DC-2 hingegen schon, denn der kennt ja das .104.0 /24 er Netz nicht. In sofern ist deine statische Route auch korrekt was der erfolgreiche Ping und Traceroute ja auch zeigen.
Hilfreich wäre mal eine Traceroute oder Pathping Output um zu sehen das auch die Wegewahl korrekt verläuft.
Die zentrale Frage ist jetzt WO genau das NAT aktiviert ist. Ob es direkt am ISDN Dialin Interface gemacht wird, vermutlich ja.
Mit NAT kann das aber niemals was zu tun haben, denn HTTPS nutzt nur einen Port TCP 443 und keinerlei dynamische Ports. Ein HTTPS Paket also was von einem Host im 192.168.1.0er Netz abgesendet wird z.B. 192.168.1.100 wird dann ja am ISDN Interface geNATet, erhält also z.B. die 192.168.104.254 (angenommen das ISDN Interface hat die .104.254) als neue Absender IP Adresse ebenfalls mit dem Port TCP 443.
Endgeräte im 192.168.104er Netz oder in IP Netzen dahinter sehen als Absender IP also immer 192.168.104.254 mit dem Port TCP 443 und antworten dann entsprechend auch auf diese IP und den TCP Quellport.
Was natürlich ganz klar sein sollte ist das sich keine .0.0 /24, 1.0 /24, .9.0 /24 und .12.0 /24er Netze hinter dem .104er netz befinden dürfen ! Tun sie vermutlich auch nicht, denn sonst wäre auch schon Ping oder Traceroute aufs Ziel gescheitert !
Fazit: Es kann sich logisch gesehen nur um ein Firewall Problem handeln ! ICMP rennt ja fehlerfrei durch nur eben TCP 443 nicht was in irgendeiner der Firewalls sei es auf dem Server oder dem Endgerät hängenbleibt.
Sinnvoll wäre hier mal ein Wireshark Trace im .104.0er Netz mit einem HTTPS Paket bei Verbindungsaufbau.
Da sieht man dann sofort anhand der Source und Destination IP wo der Hase im Pfeffer liegt und kann entsprechend reagieren !
Bitte warten ..
Mitglied: lcer00
25.11.2010 um 12:54 Uhr
Hm,
Fazit: Es kann sich logisch gesehen nur um ein Firewall Problem handeln ! ICMP rennt ja fehlerfrei durch nur eben TCP 443 nicht
was in irgendeiner der Firewalls sei es auf dem Server oder dem Endgerät hängenbleibt.
Vom 192.168.1.0 Clients komme ich aber gut über den Standartgateway auf HTTPS-Seiten im Internet. Das Routing ist bis auf die Standartroute 192.168.104.0 -> Remoterouter das gleich.... und da ist eine Firewall nicht aktiv - soweit ich das erkenne

Grüße

lcer
Bitte warten ..
Mitglied: aqui
25.11.2010 um 14:57 Uhr
Da hilft dann nur den Wireshark mal rauszuholen und mal zu sehen was genau da ankommt. Am NAT selber kann es eigentlich niemals liegen !
Bitte warten ..
Ähnliche Inhalte
Router & Routing
Sonicwall NAT-Problem
Frage von SuperAggyRouter & Routing

Hallo zusammen. Ich weis nicht ob ich hier im richtigen Forum bin. Ich fand es am passendsten zu meiner ...

Router & Routing
Problem mit 2 NAT
gelöst Frage von mzda1234Router & Routing5 Kommentare

Liebe Forumgemeinde, Wir setzen seit langem ein zyxel firewall. Dort sind alle firewall und nat regeln schon hinterlegt. Nun ...

Netzwerkgrundlagen
Multi NAT Problem
gelöst Frage von Gr33n93Netzwerkgrundlagen13 Kommentare

Guten Tag die Damen und Herren, ich habe leider ein evtl etwas größeres Problem in meinem privaten Netzwerk. Problem: ...

Linux Netzwerk

Fritzbox: VPN-Problem nach Zwangstrennung mit NAT

gelöst Frage von Mitch123Linux Netzwerk9 Kommentare

Ich benutze 2 Fritzboxen an verschiedenen Standorten, um einen VPN-Tunnel herzustellen und die Remotenetze mittels LAN-LAN-Kopplung miteinander zu verbinden. ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 3 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...