Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Net use auf W2K8 Server

Mitglied: lotus

lotus (Level 1) - Jetzt verbinden

16.09.2009 um 10:49 Uhr, 7525 Aufrufe, 8 Kommentare

Wo leg ich den script an?

hallo Admins

ich habe 1 Server und ein NAS.
Muss vom NAS auf den Server ein Netzlaufwerk verbinden mit net use.
Frage: Wo lege ich den script an?

Unter gpedit.msc Compterkonfiguration/Windows-Einstellungen/Scripts/Starten
oder
Unter gpedit.msc Benutzerkonfiguration/Windows-Einstellungen/Scripts/Anmelden

Das ganze sieht so aus:

Computerkonfiguration:
C:\Windows\System32\GroupPolicy\Machine\Scripts\Startup
oder
Benutzerkonfiguration:
C:\Windows\System32\GroupPolicy\User\Scripts\Logon

script:
net use L: \\IP\test Kennwort /user:User /persistent:no

Kann mir da jemand den Unterschied vielleicht noch erklären? Nach meiner logik sage ich doch bei Computerkonfiguration einfach:" Wenn die Maschiene startet dann soll sich das Netzlaufwerk verbinden es ist gleich wer sich anmeldet. Bei einem Server ist eh der Admin.


Gruss und Danke

lotus
Mitglied: runcmd
16.09.2009 um 12:03 Uhr
hallo,

deine logik passt.

Computerkonfiguration:
C:\Windows\System32\GroupPolicy\Machine\Scripts\Startup
= script wird ausgeführt, wenn maschine hochfährt

Benutzerkonfiguration:
C:\Windows\System32\GroupPolicy\User\Scripts\Logon
=skript wird ausgeführt, wenn jemand sich anmeldet

grüße
Bitte warten ..
Mitglied: lotus
16.09.2009 um 17:34 Uhr
hallo

ja das ist gut.

Das Problem ist nur das der batch über die Computerkonfiguration nicht geht. Die Netzlaufwerke werden zwar angezeigt sind aber alle getrennt. Ich habe auch spezifisch gesagt man soll zuerst auf das Netzwerk warten bevor die scripts laufen aber das macht das System scheinbar nicht.

Gruss
lotus
Bitte warten ..
Mitglied: 60730
16.09.2009 um 17:44 Uhr
Servus,

deine Logik passt zwar, hat aber eine Lücke...

Wenn der Computer das Laufwerk mappt - sieht das gemappte Laufwerk?

Rischdisch - der Computer und nicht der User, der evtl. irgendwann davor sitzt.

Ergo - braucht ein Script/Job das Laufwerk - beim Computer eintragen
Brauchts der User, der eigentlich nie vorm Server sitzen sollte - dann der User.

Gruß
Bitte warten ..
Mitglied: runcmd
16.09.2009 um 18:24 Uhr
sorry dr.house,

leider kann ich nur fühlen was du gemeint hast, semantisch verstehen nicht so ganz. du hast wohl ganz recht, meldet man sich nachträglich an, "sieht" man die laufwerke nicht, der "besitzer" der verbunden laufwerke ist wohl "system".

lotus,
woher weisst du, dass du in deinem skript die laufwerke nicht ansprechen kannst,? versuchst du was zu kopieren ? warum müssen die laufwerke eigentlich schon vorher verbunden sein, dh. noch bevor sich ein anwender anmeldet? vielleicht kannst du etwas genauer berichten, was du eigentlich vor hast...
Bitte warten ..
Mitglied: lotus
17.09.2009 um 19:22 Uhr
hallo zusammen

Es ist so!
Da ich ein NAS im Netzwerk habe und ich diese Freigaben einfach auf den Server legen will damit diese Stadard auf dem Server sind wen ich mich als Administrator anmelde habe ich gedacht: Da diese ja niemand braucht ausser der Admin werde ich den script dementsprechend unter Computerkonfiguration machen.
Dies geht jedoch nicht denn die Laufwerke werden im System zwar angezeigt aber als getrennt.
Habe die Option aktiviert die sagt "Immer auf das Netzwerk warten das hilft damit man jegliche Ausführung der scripts unterbinden kann bis das Netzwerk steht.
Denkste! Es scheint dass, das System nicht auf das Netzwerk wartet und die scripts einfach ausführt was natürlich dann zu dieser Ursache führt.
Ich kann es nicht beweisen momentan aber ich denke das ich richtig liege. Denn wenn ich den script manuell ausführe dann geht das ohne Problem, auch wenn ich pber die Bentzerkonfig gehe geht das.

Versteht mich richtig, das Problem ist gelöst nur nimmt es mich wunder wieso das nicht unter der Computer konfig. und wenn es doch gehen sollte dann wie?
Der normale Weg ist unter dem Profil des User einfach ein login script zu machen und dann hätte er ja alles was er braucht.
mfg
Bitte warten ..
Mitglied: lotus
17.09.2009 um 19:28 Uhr
hallo TimoBeil

nehmen wir dann einmal an ich bin ein Typ dem die Microsoft RDP Verbindung nicht gefällt und ich mich mit z.B. mit VNC au den Server bewegen möchte was dann?
Sicher, der admin ist sowieso angemeldet und ich sehe die Laufwerke aber.. es muss doch einen Weg geben das der Rechner unabhängig vom User diese Laufwerke mappt... oder!?

Gruss
und Danke.
Bitte warten ..
Mitglied: runcmd
18.09.2009 um 09:44 Uhr
dein vnc/rdp hinkt.

wenn ich dich nun richtig verstehe:

egal welcher user sich anmeldet, die freigabe sollen zu sehen sein, weil das system sie vorher gemapped hat?

da ist die antwort zum glueck mal klar:

nein, so geht das nicht.

es fühlt sich so an, als wenn du einfach nur ein problem mit der sichtweise hast. da dein problem ja gelöst ist, kannst du ja auch mal nen haken dran machen.

grüße
Bitte warten ..
Mitglied: 60730
18.09.2009 um 18:50 Uhr
Zitat von lotus:
hallo TimoBeil

nehmen wir dann einmal an ich bin ein Typ dem die Microsoft RDP Verbindung nicht gefällt und ich mich mit z.B. mit VNC au den Server bewegen möchte was dann?
Servus,
Kennst Du den Spruch "Jacke wie Hose?"

Sicher, der admin ist sowieso angemeldet

Autsch Am Server ist grundsätzlich niemand angemeldet..

und ich sehe die Laufwerke aber.. es muss doch einen Weg geben das der Rechner unabhängig vom User diese Laufwerke mappt... oder!?

Ich sags mal so:

  • ein Laufwerksmapping mache ich grundsätzlich nur mit einem Script.
  • Ob ich in dem Script nun "nur" ein Laufwerk mappe oder nach dem mappen auch gleich via Robo oder xyzcopy das "backup" mache und danach das Laufwerk wieder dismounte
  • Und das ganze Script dann per AT / schtasks unter einem gewissen User / der dann auch mal Adminrechte / nicht unbedingt Domainadminrechte haben darf

Das ist dann wiederum nicht Jacke wie Hose.

Wobei ich ehrlicherweise nicht wirklich verstehe -warum ein Domainadmin das machen sollen muß, wenn das NAS nicht in der Domain ist.
(wäre das Nas in der Domain reichte sicherlich auch ein \\nasname -\\NASIP\freigabe)


Gruss
und Danke.

zurück
Bitte warten ..
Ähnliche Inhalte
Windows 7
Net use mit gui
Frage von Lebowski23Windows 71 Kommentar

Hallo, folgendes Problem: In einem Netzwerk existiert ein LDAP-Server mit Samba, der für einige Rechner auch als Domain-Server dient. ...

Windows Netzwerk

Printerumleitung mittels net use wollen nicht

Frage von orrybeachWindows Netzwerk6 Kommentare

Ich habe einige Arbeitsstationen von Windows XP auf Win 7 umgestellt. Leider läuft noch ein altes DOS-Programm, welches unter ...

Windows Netzwerk

Fehler bei Net use Script

Frage von ischbindebaetmaenWindows Netzwerk8 Kommentare

Hallo Admins, folgende Frage: Ich habe gerade ein Problem mit meinem Logonscript: Ich habe eine NAS-Platte, einen Windows 2003 ...

Windows Server

Netzlaufwerk mit net use verbunden, aber doch nicht?!

Frage von jlrantWindows Server3 Kommentare

Hallo zusammen, und zunächst mal vielen Dank für Euer hilfreiches Forum. Ich habe bisher ausschließlich Linux-Server administriert, muss mich ...

Neue Wissensbeiträge
Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 4 StundenGoogle Android2 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Sicherheit

Intel gibt neue Spectre V2-Microcode-Updates frei (20.02.2018)

Information von kgborn vor 5 StundenSicherheit

Intel hat zum 20. Februar 2018 weitere Microcode-Updates für OEMs freigegeben, um Systeme mit neueren Prozessoren gegen die Spectre ...

Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 8 StundenMicrosoft3 Kommentare

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 1 TagWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

Heiß diskutierte Inhalte
Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server39 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Router & Routing
ISC DHCP 2 Subnetze
gelöst Frage von janosch12Router & Routing18 Kommentare

Hallo, ich betreibe bei mir im Netzwerk einen ISC DHCP Server auf Debian, der DHCP verwaltet aktuell ein /24 ...

CPU, RAM, Mainboards
32 gb RAM zu wenig?
Frage von pcguyCPU, RAM, Mainboards13 Kommentare

Hallo zusammen, mein PC verfügt über 32GB Ram. Nun kriege ich bei grossen Dateien im Illustrator die Fehlermeldung das ...