Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Netwerkgeschwindigkeit sinkt beim Kopieren im Gigabit-Lan plötzlich auf weniger als 2 Mbit

Mitglied: heparus

heparus (Level 1) - Jetzt verbinden

24.06.2010, aktualisiert 11:02 Uhr, 7813 Aufrufe, 8 Kommentare

Hallo zusammen,

bei uns in der Firma habe ich folgende Infrastruktur:

1. Netgear GSM7224R 24 Port Gigabit Layer 2 Managed Switch with Static Routing Firmware V7
2. Netgear GS748T 48 Port Gigabit mit Firmware V.3
3. Netgear GS748T 48 Port Gigabit mit Firmware V.2 (angeblich lässt sich diese ältere Version, nicht auf Firmware Version 3 updaten)

Die Patchfeld-Verkabelung ist durch die Bank Cat. 5e sämtliche Server sind am GSM7224R angeschlossen. Der ältere GS748T ist mit 2 Kabeln über eine statische LAG (Link Aggregation Group), der neuere GS748T ist mit 2 Kabeln über eine dynamische LAG angebunden (beide Lags verwenden Kupfer). Unser Datenbankserver und unser Fileserver sind jeweils über eine dynamische LAG ebenfalls am GSM7224R angeschlossen.

Wir haben nun folgendes Problem, wenn wir vom oder auf den Fileserver größere Dateien - z.B. ein 50GB Datenbankdatei - kopieren wollen startet der Kopiervorgang bei 50% der Netzwerkgeschwindigkeit und fällt dann nach ca. 2-3 Minuten auf 0,2% der Geschwindigkeit. Dieses Problem passiert sowohl zur Hauptarbeitszeit aber auch mitten in der Nacht, wenn nur ich armer Tropf noch am Testen bin. Zur Zeit bemerken unsere normalen Mitarbeiter diese Schwankungen im Netzwerk noch nicht, da das Problem nur bei größeren Dateien auffällt. Auch größere Datenbankabfragen - wie z.B. für die automatische Briefgenerierung - dauern jetzt länger.

Ich habe zur Zeit per Port Mirroring einen Wireshark am GSM7224R mitlaufen und hoffe, dass dieser ein paar Probleme aufzeigt, aber bis jetzt ist mir noch nichts aufgefallen.

Was ist noch zusagen? Flow-Control ist auf den Switchen aktiviert, ebenso bei den Servern, die MTU ist klassich bei 1500 d.h. Jumboframes verwenden wir nicht. SPT und andere Protokolle, welche auf den Switchen vorhanden sind, sind deaktiviert. Auch ein QoS ist zur Zeit nicht aktiv, das ändert sich aber in den nächsten Wochen wegen VoIP.

Ich hoffe jemand hat eine Idee, was es sein könnte, da mich das Problem echt die Haare raufen lässt.

Mit freundlichen Grüssen

Elmar
Mitglied: sniffnase
24.06.2010 um 12:19 Uhr
sind es physische oder virtuelle server?
wenn virtuell hilft es meistens der CPU eine Fixe geschwindigkeit zuzuordnen (zb 2GHz). Standardmäßig ist das ja variabel.
Was für Platten sind im File/ DBServer - sind raids konfiguriert?
wie sind die switches miteinander verbunden (switchingloop) - aber du sagst alle server sind am GSM7224R angeschlossen, somit sind die anderen beiden switches ja wurscht

was passiert wenn du von einem laptop am einen ende des netzwerks zu einem laptop am anderen ende kopierst, verhält es sich dann genauso?
Bitte warten ..
Mitglied: Bright
24.06.2010 um 12:27 Uhr
Hallo Elmar,

hast du mal gecheckt ob es nicht an den Platten am Server liegt?
hatte das schonmal mit schlechten Raid-Controllern
bei dem fehler damals sind schlicht die Controller in die Knie gegangen

Kannst du mal so eine große Datei auf dem Server kopieren und checken was die performance macht?

gruß
bright
Bitte warten ..
Mitglied: heparus
24.06.2010 um 16:46 Uhr
Es handelt sich um physische Server. Das Thema Virtualisierung steht bei uns noch nicht zur Debatte. Sämtliche Server sind mit min. Raid 10 bzw. Raid 5 beim Fileserver eingerichtet.
Bitte warten ..
Mitglied: heparus
24.06.2010 um 16:55 Uhr
An ein Problem mit dem Raid bzw. den Platten habe ich auch schon gedacht, schließe es aber zur Zeit noch aus. Werde es aber heute aber auch noch per Benchmark prüfen.

Ich vermute ein Netzwerkproblem, da mein eigener PC nicht mehr vom neueren GS748T aus auf unsere Watchguard per https zugreifen kann, welche am GSM7224R angeschlossen ist. Sobald ich es von einem unserer Server versuche geht es sofort.
Bitte warten ..
Mitglied: dog
24.06.2010 um 17:05 Uhr
Ich würde mal wild raten und sagen nach 2-3 Minuten ist bei irgendeinem Gerät die Paket-Queue so überlastet, dass es anfängt Pakete zu droppen, was auch immer die gesamte Verbindung verlangsamt.
Bitte warten ..
Mitglied: aqui
25.06.2010 um 18:13 Uhr
....deshalb mal Flow Control abschalten, das löst ggf. das Problem. Allerdings darf man von NetGear Geraffel auch keine Wunderperformance erwarten. Bei kleinen Paketen wie sie bei Windows CIFS Kopierereien die Regel sind legen die sich oft die Karten.
Daraus resultiert dann der Unterschied zwischen NetGear und Herstellern mit leistungsfähigerer Hardware. Denn wenn NetGears Switchports auf GiG negotiaten sagt das noch lange nix über des Packet Forwarding Performance aus....das böse Erwachen kommt dann später.... Beim Kopieren z.B.
Versuchs aber mal ohne Flow Control !
Bitte warten ..
Mitglied: heparus
25.06.2010 um 20:58 Uhr
@aqui: Mir wäre ein großer ProCurve auch lieber als die Netgear Switche, aber die wurden leider vor meiner Zeit gekauft und die GF hat nicht nur eine Bärenfalle um das Budget-Konto. Mein Vorgänger hatte irgendwie das Talent aus einem Haufen Schrauben und Blechen eine "funktionierende" Lösung zubauen und an solch geringen Ausgaben hat man sich gewöhnt. Mir wäre auch lieber, wenn ich auf Substorages, Blades, ESX, etc. zurückgreifen könnte und nicht nur auf aufgemotzt PC-Hardware, welche noch treu ihren Dienst tut aber längst nicht mehr ausreichend ist.

Aber mit/ohne FlowControl werde ich mal am Montag testen, ob es eine Verbesserung bringt.


An alle erstmals danke für eure Anregungen.
Bitte warten ..
Mitglied: heparus
01.07.2010 um 14:40 Uhr
Hab das Problem gefunden, uns scheint durch eine Überspannung ein Switch beschädigt worden zu sein. Deswegen hat dieser ständig seine Ports für einen Bruchteil der Sekunde zurück gesetzt und seine Log nicht geschrieben.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless
Nur ca. 200 Mbits über Gigabit?
Frage von AdminKnechtLAN, WAN, Wireless8 Kommentare

Hallo, da ich hier einen Gigabit-Switch tauschen musste, habe ich das brandneue Gerät von DLINK, ein DGS-1210-24, mal zum ...

Netzwerkgrundlagen
Gigabit LAN
gelöst Frage von remospNetzwerkgrundlagen8 Kommentare

Hallo zusammen Ich möchte ein Gigabit Netzwerk einrichten und habe nun eine Frage. Mein Netzwerk umfassst einen Gigabit Router, ...

LAN, WAN, Wireless
Plötzlich kein GB LAN mehr
gelöst Frage von bigeasyLAN, WAN, Wireless6 Kommentare

Hallo an alle Habe ein Problem, bei dem ich nun nicht mehr weiter weiss, eventuell hat hier ja jemand ...

LAN, WAN, Wireless
LAN Plötzlich langsam
gelöst Frage von KodaCHLAN, WAN, Wireless12 Kommentare

Hallo zusammen Ich habe seit heute Plötzlich das Problem, dass mein Netzwerk langsam ist. Alle Geräte sind per GB ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 3 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...