Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzlaufwerke per GPO verbinden nicht

Mitglied: robbox

robbox (Level 1) - Jetzt verbinden

03.12.2010 um 21:20 Uhr, 17401 Aufrufe, 8 Kommentare

Server OS: W2K8 R2
Client OS: Win7 Pro

Hallo, ich verwende dieses einfache Skript um per GPO einem User seine entsprechenden Netzlauferwerke zuzuweisen.

Server OS: W2K8 R2
Client OS: Win7 Pro

Hallo, ich verwende dieses einfache Skript um per GPO einem User seine entsprechenden Netzlauferwerke zuzuweisen.


if exist f: net use f: /DELETE
net use f: \\SERVER\USER /persistent:no

if exist g: net use g: /DELETE
net use g: \\SERVER\DATEN /persistent:no

Dies hat bisher eigentlich immer geklappt.
(W2K3, W2K8R2 jedoch mit XP Clients)

Das Script habe ich unter "Benutzereinstellungen / Windows-Einstellungen / Skripts (Anmelden/Abmelden) / Anmelden" in den vorgeschlagenen Ordner gepackt:

\\domain.local\SysVol\domain.local\Policies\{SID}\User\Scripts\Logon

Die Netzlaufwerke werden am Client sowie, wenn ich mich lokal bzw. remote am Server anmelde, nicht automatisch verbunden.

Wenn ich das Script jedoch manuell ausführe, wird die Verbindung zu den Laufwerken korrekt hergestellt und diese eingebunden

Alle anderen GPOs werden ordnungsgemäß ausgeführt!

Hat jemand einen Tipp für mich? Dreh bald durch

Gruß und Danke!
Mitglied: knut4linux
03.12.2010 um 21:57 Uhr
Mahlzeit,

da ich zu diesen Thema heute schon mal was geschrieben hab und es genauso auf deins zutrifft, hier der LINK:

Problem beim mappen von Laufwerken bei Windows Server 2003


TIPP
Zum Thema GPO. Wenn du der Meinung bist, dass eine GPO nicht richtig angewendet wird, dann überprüfe das am client mittels gpresult mit den entsprechenden Schalter. Das was du beschreibst ist ein simpler Anmeldescript, der über die Standard DomainPolicies verteilt wird.

Knut
Bitte warten ..
Mitglied: robbox
03.12.2010 um 22:55 Uhr
Zitat von knut4linux:
Mahlzeit,

da ich zu diesen Thema heute schon mal was geschrieben hab und es genauso auf deins zutrifft, hier der LINK:

Problem beim mappen von Laufwerken bei Windows Server 2003


TIPP
Zum Thema GPO. Wenn du der Meinung bist, dass eine GPO nicht richtig angewendet wird, dann überprüfe das am client
mittels gpresult mit den entsprechenden Schalter. Das was du beschreibst ist ein simpler Anmeldescript, der über die Standard
DomainPolicies verteilt wird.

Knut

Trifft leider nicht ganz auf mein Problem zu...
Selbst wenn ich das Skript in NETLOGON kopiere und das Skript beim Benutzer ohne Pfad direkt angebe, wird es nicht ausgeführt. Erst per Doppelklick verbindet das Script.
Bitte warten ..
Mitglied: knut4linux
03.12.2010 um 23:20 Uhr
Na dann, gpresult und prüfe, welche GPO's nicht angewendet bzw. Ignoriert werden.

Knut
Bitte warten ..
Mitglied: robbox
03.12.2010 um 23:34 Uhr
Zitat von knut4linux:
Na dann, gpresult und prüfe, welche GPO's nicht angewendet bzw. Ignoriert werden.

Knut

Laut gpresult wird das Script ausgeführt?! Kapiers net...
Bitte warten ..
Mitglied: knut4linux
04.12.2010 um 00:09 Uhr
Naja, ich habe in deinem Script gesehen, dass du den Schalter /Delete nutzt und prüfst ob die Laufwerke existieren. Mach es doch mal billig und lass zu Fehlerüberprüfung mal die IF-Amweisung weg. Das nächste ist, das doch durch die persist Anweisung das Laufwerk nach Abmeldung anhält/löscht. Demzufolge nach existiert das Laufwerk bei der nächsten Anmeldung nicht mehr, was aber an dieser Stelle sein muss, weil du in deinem Script nicht sagst, was er machen soll, wenn IF nicht erfüllt wird.

Knut
Bitte warten ..
Mitglied: robbox
04.12.2010 um 00:22 Uhr
Hab das Script nun mal editiert.
Einfach nur:

net use f: \\SERVER\Users

Ergebnis das selbe. Verbindet nicht...
Bitte warten ..
Mitglied: dog
04.12.2010 um 01:32 Uhr
Die Netzlaufwerke werden am Client sowie, wenn ich mich lokal bzw. remote am Server anmelde, nicht automatisch verbunden.

Och, die werden sicher ganz prima verbunden.
Allerdings gibt es bei Windows 7 die UAC und ein Geheimnis ist das auch nicht: http://www.faq-o-matic.net/2008/02/22/benutzerkontensteuerung-uac-richt ...

Dort gibt es einen extra Absatz zu diesem "Problem". Ganzen Artikel lesen!
Bitte warten ..
Mitglied: Ausserwoeger
05.12.2010 um 14:11 Uhr
Ich glaub das ist das alte Problem mit windows 7 ! Hast du noch einen alten XP Client ?
Wenn ja funktionierts da ?

Ich bin mir sicher das das Problem von den GPOs kommt. Windows 7 hat eingebaut das man sich trotz dem das die Netzwerktreiber noch nicht geladen wurden man sich trotzdem schon anmelden kann.

Wenn du den Client 10 min am Loginfenster stehen lässt und dich dann anmeldest sollten die Loginscrips abgearbeitet werden.

Es gibt in den GPOs 2 Punkte die das Problem beheben.
1.) Bei Windows Start auf das Netzwerk warten.
2.) Skrips und GPO sollen zur selben zeit abgearbeitet werden.

Wenn du das in den GPOs einstellst und auf den Clients ein Gpupdate /force machst und dann neustartest solltest du die laufwerke kriegen.


LG Andreas Ausserwöger
Bitte warten ..
Ähnliche Inhalte
Windows Server
Netzlaufwerke verbinden sich nicht
Frage von MyBRis4ShotWindows Server6 Kommentare

Hallo, wie der Titel schon sagt, habe ich aktuell Probleme mit dem automatischen Verbinden von Netzlaufwerken. Der Kunde arbeitet ...

Windows Server
Active Directory Netzlaufwerke verbinden
gelöst Frage von Florian86Windows Server2 Kommentare

Hallo, beim Netzlaufwerke verbinden über die AD im 2012 Server bekomme ich beim Anmelden immer die Fehler ID:1055 Fehler ...

SAN, NAS, DAS

Netzlaufwerk verbinden - komisches Verhalten

Frage von duschgasSAN, NAS, DAS15 Kommentare

Guten Tag, ich habe einen root-Server bei einem Hoster und dort einen Ordner freigegeben. Mit meinem Laptop im WLAN ...

Windows Netzwerk

Netzlaufwerk außerhalb Domäne verbinden

Frage von daMopsiWindows Netzwerk3 Kommentare

Hallo Zusammen, ich möchte über GPO ein Netzlaufwerk verbinden lassen, das nicht in der Domäne hängt. Für die Anmeldung ...

Neue Wissensbeiträge
Microsoft
ARD-Doku - Das Microsoft Dilemma
Tipp von Knorkator vor 41 MinutenMicrosoft

Hallo zusammen, vor einigen Tagen lief in der ARD u.a. Reportage. Das Youtube Video dazu dürfte länger verfügbar sein. ...

Windows 10

Neue Sicherheitslücke in Windows 10 (Version 1709) durch Google öffentlich geworden

Information von kgborn vor 18 StundenWindows 10

Vor ein paar Tagen haben Googles Sicherheitsforscher vom Projekt Zero eine Sicherheitslücke im Edge-Browser publiziert. Jetzt wurde eine weitere ...

iOS
IOS 11.2.6 verfügbar
Information von sabines vor 1 TagiOS

Mit dem Update soll der Bug behoben werden, bei dem eine bestimmte Zeichenkette IOS zum Absturz gebracht hat.

Sicherheit
Sicherheitsrisiko: Die Krux mit 7-Zip
Information von kgborn vor 1 TagSicherheit8 Kommentare

Bei vielen Anwendern ist das Tool 7-Zip zum Entpacken von Archivdateien im Einsatz. Die Software ist kostenlos und steht ...

Heiß diskutierte Inhalte
Router & Routing
LANCOM VPN CLIENT einrichten
Frage von Finchen961988Router & Routing27 Kommentare

Hallo, ich habe ein Problem und hoffe ihr könnt mir helfen, wir haben einen Kunden der hat einen Speedport ...

Windows Server
AD DS findet Domäne nicht, behebbar?
Frage von schapitzWindows Server25 Kommentare

Guten Tag, ich habe bei einem Kunden ein Problem mit den AD DS. Umgebung ist folgende: Windows Server 2016 ...

LAN, WAN, Wireless
VPN Cisco ASA5505 PaloAlto PA-200
gelöst Frage von YannoschLAN, WAN, Wireless22 Kommentare

Hallo zusammen, ich würde gerne ein Site-to-Site VPN zwischen den beiden Standorten aufbauen. PaloAlto PA200 Internetanschluss Deutsche Telekom GK ...

SAN, NAS, DAS
Qnap TS-453S Pro - Anbindung Active Directory
Frage von JuckieSAN, NAS, DAS13 Kommentare

Hallo zusammen, ich habe hier eine Qnap TS-453S Pro die sich mal so absolut gar nicht in das Active ...