Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NETZWERK BANDBREITE - WO IST MEIN GIGABIT HIN

Mitglied: onkeldave

onkeldave (Level 1) - Jetzt verbinden

30.03.2011 um 13:58 Uhr, 7368 Aufrufe, 10 Kommentare

Netzwerkbandbreite nie über 30MBit/s wobei 1GigaBit LAN

Hallo liebe comu,

ich habe das Problem das ein Netzwerk, was gefüllt mit Macs , Linux und Windowsrechnern nieemals über 30MBit/s kommt!
in der praxis müssten ja eigentlich 80MBit/s drin sein!!!!

Habe schon test gefahren mit IPERF
da erstelltm man einen Server und testet dann die verbundenen Clients auf Bandbreite from Point-To-Point.

ergebniss immer 1GBit/s - aber leider geht das nur auf Linux.
Wenn ihr gute Tester für Netzwerkbandbreite kennt, für windows und mac - immer raus damit bitte ;)


Woran kann es liegen????

Das einzige was im Netzwerk ist, bis auf die ganzen clients, sind die Full-Managed-Swicthe die auf 1GigaBit lafuen - der test zeigt es ja auch mit iperf!

Festplatten sind alle Sata - egal wo! - also kein Flaschenhals!
Switches können es selbst nicht sein....

vermute inzwischen schon das es an Samba oder NFS Protokollen liegt zwisschen Unix und Windows zumnidest...


WÄRE FÜR TIPS SEHR DANKBAR

p.s. wireshark lasst bitte aus dem spiel! Die switche leiten nur pakete weiter die für eine bestimmte MAschiene addressiert sind - also kann man hier nicht alles mitsniffen!

DANKEEEE im vorraus für eure Müh!!!!
Mitglied: MrNetman
30.03.2011 um 14:10 Uhr
Hallo onkeldave,

iperf 1.7.0 von 2007 gibt es auch für Windows.
Aber es gibt möglicherweise Einträge in den Treibern, die den Geschwindigkeitsverlust verursachen. Flusssteuerung (802.1p) und Duplexität sind Parameter auf die man achten muss. Vollduplexeinstellungen sind immer kritisch. Auto sollte am Besten funktionieren.

Viel Erfolg
Bitte warten ..
Mitglied: manbar
30.03.2011 um 14:15 Uhr
Auch (und speziell bei den Windowskisten) sind die Antivirensoftwarekits eine immerwieder gern genutzte Performancebremse. Symantec scannt mit dem "Netzwerkbedrohungsschutz" beispielsweise den kompletten Netzwerktraffic.

Schau mal ob du evtl solche Software laufen hast und deaktivier sie testweise mal.
Bitte warten ..
Mitglied: onkeldave
30.03.2011 um 14:18 Uhr
da sag ich dochmal THX!!
das wird sofort getestet!!!

mir ist gerade aufgefallen, probier es gleichmal bei windows in der registry einzustellen als default, naja aufjedenfall bei copy handlern gibt es ab und zu die option den puffer fürs netzwerk zu erhöhen!
habs mal von 128kb auf 1MB gestellt - ist gleich doppelt so schnell 30-50MBit/s :D
Bitte warten ..
Mitglied: harald21
30.03.2011 um 14:30 Uhr
Hallo,

für Windows gibt es jperf (ich glaube Version 2.0). Das ist Open Source und praktisch ein iperf mit einer Java-Oberfläche.
Schau mal hier: http://www.nwlab.net/know-how/JPerf/

mfg
Harald
Bitte warten ..
Mitglied: aqui
30.03.2011 um 15:03 Uhr
NetIO ist auch ein guter Kandidat zum testen und funktioniert unter Winblows und Linux:
http://www.nwlab.net/art/netio/netio.html

Wenn das Ergebnis dort für ein GiG Netzwerk volle Performance zeigt also ~600-800 Mbit/s was dann ~75 bis 100 Mbyte/s entspricht dann ist deine Infrastruktur absolut in Ordnung. Alle Werte über 800 Mbit/s wären dann sehr gut.

Ein typisches Problem was in schlechter Netzwerk Performance resultiert ist ein aktiviertes Flow Control. Wenn du managebare Switches hast, was ja bei dir glücklicherweise der Fall ist, dann solltest du in jedem Falle global Flow Control auf ALLEN Switches generell abschalten.
Hat man dumme Billigswitches, die nicht mangebar sind, dann muss man das im Treiber der Endgeräte selber abschalten. Die Mühe kannst du dir also ersparen.
In 90% aller dieser Fälle löst das dann die Netzwerkbremse ! Aktives Flow Control ist in kleinen Ethernets generell überflüssig.
Eine anderer möglicher Fehler ist eine falsche Autonegotiation am Switch. Du solltest also sicher klären, das alle relevanten Switch Ports auf 1GiG und auch Full Duplex stehen !!

Von SMB/CIFS als Übertragungsprotokoll darfst du allerdings nicht allzuviel Performance erwarten. Dieses Protokoll nutzt immer sehr kleine Pakete und ist damit sehr ineffizient. Das ist aber Protokoll spezifisch und hat mit der Infrastruktur nichts zu tun.
Für max Durchsatztests nutzt man also besser ISCSI, FTP oder NFS.
Bedenka das dann aber immer auch Festplattenperformance, Busperformance, sprich Anbindung der GiG Karten an den Systembus oder Chipsatz, und Ethernetkarten Performance mit einfliesst. Also eine Menge weiterer Faktoren die NICHT Netzwerk spezifisch sind !
Deine laienhaften Aussagen wie "...alle Sata - egal wo! - also kein Flaschenhals!" ist Blödsinn, denn GiG Netzwerke können schneller sein als SATA Durchsatz und damit sind langsame SATA Platten oder SATAs die im BIOS auf den falschen SATA Mode oder schlimmer PATA Emulation gesetzt sind sehr wohl ein Flaschenhals !
Ebenso sind dein Mbit Angaben oben "...eigentlich 80MBit/s drin sein!!!!" unsinnig... Wie kommst du auf sowas in einem GiG Netzwerk ?? So ein Wert spricht eher für ein 100 Mbits/s Netzwerk !
Bitte warten ..
Mitglied: onkeldave
30.03.2011 um 15:36 Uhr
TCP connection established.
Packet size 1k bytes: 65.35 MByte/s Tx, 64.75 MByte/s Rx.
Packet size 2k bytes: 66.38 MByte/s Tx, 66.60 MByte/s Rx.
Packet size 4k bytes: 67.43 MByte/s Tx, 69.61 MByte/s Rx.
Packet size 8k bytes: 68.54 MByte/s Tx, 73.62 MByte/s Rx.
Packet size 16k bytes: 67.40 MByte/s Tx, 76.07 MByte/s Rx.
Packet size 32k bytes: 68.61 MByte/s Tx, 72.78 MByte/s Rx.
Done.


scheint gut zu funktionieren!
das war jetzt mit NetIO
mit iperf ist genau so

aber ein copy vorgang ist trotzdem langsamer in der praxis...der kommt max auf 30mbit und das jetzt schon sehr hoch angesetzt

wird wohl an den eingesetzten tools liegen oder an den antiviren scannern

weis nicht mehr weiter!
test alles ok
mehr kannm man ja nicht tun als admin..

DANKE für euren fetten tipps!
Bitte warten ..
Mitglied: aqui
30.03.2011 um 15:58 Uhr
Ja, deine Infrastruktur ist damit absolut sauber und bringt die Performance wie du ja selber sehen kannst.
Das Problem liegt also nur an deinen Endgeräten.

Leider sagst du wieder gar nichts dazu ob du...
  • Das Problem mit aktiviertem Flow_Control IEEE 802.3x gecheckt hast und das abgeschaltet hast
  • Ggf. Duplex Problematiken überprüft hast !
  • Tests mit unterschiedlichen Protokollen und gleicher Dateigröße probiert hast.
  • Treiber aller Netzwerkkarten auf dem aktuellsten Stand sind bzw. die direkt vom NIC Chipsatz Hersteller sind.
  • Billige GiG Netzwerkkarten einsetzt wie z.B. solche mit Relatek Chipsatz die das Paket Assembling und Deassembling extern über die Rechner CPU machen.

Ohne Feedback dazu können wir hier logischerweise auch nicht mehr weiterwissen.
Zudem ist deine Shift Taste defekt.
Bitte warten ..
Mitglied: onkeldave
30.03.2011 um 16:15 Uhr
Hab sie repariert!

Flow Package Caputre kann man hier leider nicht testen bzw einsetzen!

Dublex Modes sind alle auf Auto! Wenn ich auf Full mach, ändert sich nix!

Protokollvielfalttests habe ich schon gemacht....das schnellste ist NFS und danach SMB und dann AFP

Arbeiten eigentlich alle für CIFS over SMB = Windows
Linux immer NFS

Sind aber einfach zu viele MAschienen und Systeme um alle auf dem neusten Stand zu halten Treibertechnisch! KAnn sie auch gar nicht vom Netznehmen, da entsteht großer Schaden hier!

Netzwerkkarten sind alle Top! Hab ich gekauft ;)

Sorry liegt echt an der vielzahl unterschiedlicher Protokolle und der Endmaschienen bzw AntiVirus Tools like ZoneAlarm oder Norton und ähnliche
die bremsen das ganze schon um 20MBit aus .- unfassbar!
Selbst mein Proxy mit integrietem AntiVirus HttpScanner verlangt nicht so viel Bandwidth - man kann da trotzdem noch mit 1.6 MBit über ALice downloaden


THX für tipps bin ich offen...ohhh meine geliebte ShiftTaste
Bitte warten ..
Mitglied: aqui
30.03.2011 um 16:30 Uhr
Ja, Zone Alarm ist ein übler Vertreter wie all diese zusätzlichen und sinnlosen externen Firewalls.
Du kannst immer mal einen Referenztest machen indem du 2 Rechner mit einem Back to Back Kabel direkt verbindest und damit mal Durchsatztests macht.
Am besten dann mal ohne den ganzen Overhead.
Da hat man dann wenigstens mal einen Anhaltspunkt.

Sehr wichtig ist bei Windows XP z.B. noch die TCP Windowsize. Die anzupassen ist ein Muss in schnellen GiG Netzwerken:
http://www.heise.de/netze/TCP-IP-Tuning--/artikel/97619
http://www.psc.edu/networking/projects/tcptune/
Bei Vista oder Win 7 ist das nicht mehr nötig.
Apple Mac kann man diesbezüglich auch noch etwas beschleunigen. Dazu gibt es diverse Infos im Netz wenn man Dr. Google dazu befragt.
Bitte warten ..
Mitglied: onkeldave
30.03.2011 um 17:46 Uhr
SUPER AQUI!!!
dafür sei dir mal ganz fett gedankt!!!

sowas ist immer gut!

werd ich gleich mal testen....

meld mich!
Bitte warten ..
Ähnliche Inhalte
Switche und Hubs
Netzwerk-Bandbreite zu niedrig
Frage von Fenris14Switche und Hubs12 Kommentare

Hallo, habe jetzt vor kurzem mehere Switche in Betrieb genommen. Mein Setup besteht aus zwei Brocade ICX-7250-24 als "Core-Switche" ...

Hyper-V
Langsames Netzwerk trotz Gigabit
gelöst Frage von lupitaHyper-V1 Kommentar

Hallo zusammen Ich bin ein wenig Ratlos. Ich habe gerade einen Hyper-V Server installiert und darauf befindet sich ein ...

LAN, WAN, Wireless

Netzwerk funktioniert nur in eine Richtung mit Gigabit

gelöst Frage von DrChiwagoLAN, WAN, Wireless28 Kommentare

Guten Tag zusammen, da ich leider, auch nach ausgiebiger Suche, keine Lösung für mein Problem finden konnte wende ich ...

LAN, WAN, Wireless

Gigabit Netzwerk kopieren mit 15MB pro Sekunde

gelöst Frage von Maik20LAN, WAN, Wireless5 Kommentare

Hallo, ich habe mal eine Frage. Ich kopiere gerade eine Datei 4GB von meinem Laptop auf meinen PC. Beide ...

Neue Wissensbeiträge
Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 2 StundenWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

iOS
Updates für Iphone und Co
Information von sabines vor 5 StundeniOS

Gestern abend ist iOS 11.3.1 erschienen, ein kleineres Update, dass einige Lücken schließt und "Lahmlegen" nach einem Display Tausch ...

Windows 7

Windows 7 - Server 2008 R2: Exploit für Total Meltdown verfügbar

Information von kgborn vor 1 TagWindows 7

Kleine Information für Administratoren, die für die Updates von Windows 7 SP1 und Windows Server 2008 R2 SP1 verantwortlich ...

Sicherheit

Zero Day-Schwachstelle im Internet Explorer - wird von APT bereits ausgenutzt

Information von kgborn vor 2 TagenSicherheit

Im Kernel des Internet Explorer scheint es eine Zero Day-Lücke zu geben, die von staatlichen Akteuren (APT) im Rahmen ...

Heiß diskutierte Inhalte
C und C++
Frage1 C Programmierung-Makefile Frage2 PHP-Programmierung HTTP-Fehler 404
Frage von KatalinaC und C++28 Kommentare

Hallo, ich habe 2 Fragen, die nichts miteinander zu tun haben aber mit denen ich mich gerade beschäftige: 1. ...

LAN, WAN, Wireless
Watchguard T15 VPN Einrichtung
gelöst Frage von thomasjayLAN, WAN, Wireless25 Kommentare

Hallo zusammen, wir möchten gerne über unsere Watchguard T15 einen VPN-Tunnel (Mobile VPN with IPSec) einrichten! Als Client nutzen ...

Windows 10
Unter Windows 10 Home 64Bit (1709) kommt Fehler beim Aufruf von verschiedenen Systemprogrammen wie z.B. Gerätemanager
Frage von bitshopWindows 1017 Kommentare

Hallo, beim meinem Onkel haben wir seit längerem das Problem, dass z.B. beim Aufruf des Gerätemanagers eine Fehlermeldung kommt ...

Hyper-V
HyperV DC + DNS + AC
gelöst Frage von HardstylesHyper-V16 Kommentare

Hallo kann mir jemand sagen wieso meine Domänen Computer kein Internetzugang erhalten? Ich hab hier ein Server wo die ...