Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerkdurchsatz Windows Server2012 R2 unterschiedlich

Mitglied: netzwerk

netzwerk (Level 1) - Jetzt verbinden

14.11.2014, aktualisiert 13:10 Uhr, 726 Aufrufe, 3 Kommentare

Hallo,

ich habe hier ein (zumindest für mich) merkwürdiges Phänomen und vielleicht hat der ein oder andere hier ja noch eine Idee, woran es liegen könnte...

Das Problem ist, dass die Netzwerkübertragung unterschiedlich ist, je nachdem, welche Maschine die Übertragung anstösst!

Das Testszenario ist wie folgt:
Zwei physikalische Server, identische Hardware (Dual XEON, 32GB RAM, SSD RAID 10), 4* Gigabit LAN mit statischer Link-Aggregation.
Ein Server läuft mit 2008R2 und der andere mit 2012R2 (Terminalserver). Wenn nun Daten von einem zum anderen Server übertragen werden, passiert folgendes:
2816a4f1ad5ab7c271f551a6ef53d379 - Klicke auf das Bild, um es zu vergrößern
Das ist der LAN Durchsatz, wenn ein 4GB File wie folgt kopiert wird:
1. (rot) vom 2008R2 Server zum 2012R2 Server - per Explorer auf dem 2008er Server angestossen
2. (gelb) vom 2012R2 Server zum 2008R2 Server - per Explorer auf dem 2008er Server angestossen
3. (rot) vom 2008R2 Server zum 2012R2 Server - per Explorer auf dem 2012er Server angestossen
4. (gelb) vom 2012R2 Server zum 2008R2 Server - per Explorer auf dem 2012er Server angestossen

1. und 2. zeigen, dass netzwerktechnisch alles OK ist, volle 1GBit/s sowohl bei lesen wie auch schreiben.
Wenn das ganze aber vom 2012er Server aus angestossen wird, bricht die Leistung stark ein, wie 3. und 4. zeigen!
HDD/RAID-Subsystem und CPU scheiden hier sicherlicherlich als Ursache aus.

Ich habe dann mit einer dritten Maschine (virtuelles Windows 8.1) quergecheckt...
...zunächst die Performance zwischen 8.1 VM und 2008R2 Server:
2d07d3346e16e6c5be3a6666fceb417b - Klicke auf das Bild, um es zu vergrößern
Und dann zwischen 8.1VM und 2012R2 Server:
ba74c5a8c9a4a4f99bbb12ebf7cb5399 - Klicke auf das Bild, um es zu vergrößern
Dass hier die Performance beim schreiben auf die VM einbricht liegt am HDD-System in der VM.
Aber: Identische Werte, egal auf welcher Maschine man die Übertragung anstösst! So sollte es sein.

Hat jemand vielleicht einen Tipp, wo das Problem ursächlich zu suchen ist?
Warum tritt das Problem nur zwischen 2008R2 und 2012R2 auf, wenn vom 2012er Server angestossen?
Die Messungen sind reproduzierbar und unabhängig von der Filegröße.
Beim schreiben auf den 2012er Server nutzt er nur knapp 2/3 der 1GBit Leitung aus.

Bin für jeden Tipp dankbar!!

Vielen Dank

Ein verzweifelnder Netzwerker...
Mitglied: DerWoWusste
14.11.2014, aktualisiert um 13:21 Uhr
Hi.

Du machst einen Kardinalfehler: Du benchmarkst ein Netzwerkproblem mittels Dateitransfers. Benchmarke es ausschließlich über die Netzwerkkarte mit geeigneten Tools. So werden dann Festplattenperformance und Virenscanner als Ursache wirklich ausgeschlossen.

Nimm http://www.ars.de/ars/ars.nsf/docs/netio
Bitte warten ..
Mitglied: netzwerk
14.11.2014 um 14:03 Uhr
Hallo DerWoWusste,

Danke für den Hinweis, gesagt, getan. NETIO zeigt identische Werte um 100-110MB/s für "alle 4 Möglichkeiten".
Aber das bringt mich jetzt leider nicht wirklich weiter ... das Problem bleibt ja auf "normaler Applikationsebene" bestehen.
Virenscanner gibt es nicht und die 100MB/s schaffen die SSDs auf beiden Systemen mehr als locker, was ja auch 1. und 2. im oberen Bild belegen...
Bitte warten ..
Mitglied: DerWoWusste
14.11.2014 um 14:10 Uhr
Teste bitte noch einmal Deine Explorertests mit 2 leeren 2012 R2 untereinander in einer VM. Nur 2012 R2 mit Update 1 installieren, und sonst nichts.
Mein Verdacht wäre eine seltsame Software, die auf den 2012ern drauf ist, ist die Ursache.
Bitte warten ..
Ähnliche Inhalte
Windows Server

Windows Server2012 R2 Verbindungsversuch zu vortex-win.data.microsoft.com

gelöst Frage von brause76Windows Server5 Kommentare

Hallo zusammen! Ich habe hier ein WindowsServer2012R2 System als Virtuelle Maschine auf einer vSphere5.5 laufen. Das System läuft im ...

Windows Server

Wbadmin HyperV Sicherung unter Windows Server2012 R2 auf Netzwerkfreigabe

Frage von derBadnerWindows Server12 Kommentare

Hallo, ich stehe zur Zeit vor folgendem Problem: - 1 x HyperV Server Windows 2012R2 - 2 x virtuelle ...

Windows Server

Suche MOC Unterlagen 70-410,411,412 (Server2012 R2)

gelöst Frage von GravenWindows Server4 Kommentare

Hi Leute, hat vielleicht noch jemand seine Kursunterlagen parat bzw. digital vorhanden? Ich bin auf der Suche nach MOC ...

Windows Server

Server2012 R2 Radius Richtlinien bestimmten Clients zuordnen

Frage von MichaelW84Windows Server6 Kommentare

Hallo zusammen, ich habe einen Radius Server (NAP) unter Server 2012R2 für den Wlan Access konfiguiert und der funktioniert ...

Neue Wissensbeiträge
Windows 10
Zero-Day-Lücke in Microsoft Edge
Information von kgborn vor 2 TagenWindows 10

In Microsofts Edge-Browser klafft wohl eine nicht geschlossene (0-Day) Sicherheitslücke im Just In Time Compiler (JIT Compiler) für Javascript. ...

Sicherheit
Microsoft und Skype: Sicherheit
Information von kgborn vor 2 TagenSicherheit

Die Tage gab es ja einige Berichte zur Sicherheit des Skype-Updaters. Der Updater von Skype läuft unter dem Konto ...

Datenschutz

Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10

Information von Penny.Cilin vor 3 TagenDatenschutz8 Kommentare

Hallo, passend zum Thema Ablösung LIMUX in München ein interessanter Beitrag dazu: Behörden ignorieren Sicherheitsbedenken gegenüber Windows 10 Anscheinend ...

Sicherheit
Information Security Hub Munich airport
Information von brammer vor 3 TagenSicherheit

Hallo, Neues Center für Cyber Kriminalität am Münchener Flughafen brammer

Heiß diskutierte Inhalte
Windows 10
Windows 10 (1709) Tastur und Maus wieder einschalten?
Frage von LochkartenstanzerWindows 1015 Kommentare

Moin, Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert ...

DSL, VDSL
Mindestgeschwindigkeiten DSL Telekom
Frage von justlukasDSL, VDSL14 Kommentare

Hallo zusammen, Seit diesem Jahr habe ich Verständnisprobleme mit dem Verhalten der Telekom. Wir haben seit einem Jahr VDSL ...

Humor (lol)
Was könnte man mit einem Server machen? Idee gesucht
Frage von 2SeitenHumor (lol)11 Kommentare

Hey Zusammen Ich habe einen alten HP G2 Rackserver zu Hause rumliegen. 28GB Ram, 1xAMD Prozi mit etwa 2GHz. ...

Switche und Hubs
LANCOM-Switch: Probleme (no link) mit SFP-Modulen?
Frage von THETOBSwitche und Hubs11 Kommentare

Hi zusammen, ich habe folgendes Problem: Und zwar habe ich an einem Standort drei Switche verbaut - LANCOM GS-2326P+, ...