Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Netzwerktopologie - mehrere Werke

Mitglied: Dragan123

Dragan123 (Level 1) - Jetzt verbinden

22.01.2018 um 15:26 Uhr, 1297 Aufrufe, 58 Kommentare

Hey Leute,

möchte mich an dieser Stelle wieder mal an Euch wenden und um eure Hilfe bitten.
Heute hat mich eine Störung bei der Telekom wieder mal ins Nachdenken gebracht.

Einige kennen mich wahrscheinlich bereits wegen meiner vielen Fragen.
Ich danke Euch an dieser Stelle vielmals für euren Support.

Situationsbeschreibung:
Wir haben mehrere Hallen. In jeder Halle gibt es einen Internetzugang per Fritzbox und DSL. (Glasfaser soll erst Mitte 2019 kommen).
Zu jeder Fritzbox habe ich mit der Zeit jeweils einen Mikrotik installiert, damit ich die Netze trennen kann.
In Halle 1 steht der Server, auf den aus jeder Halle zugegriffen werden muss.

Folgendes Problem stellt sich mir:
Heute ist der Internetzugang in Halle 1 gestört gewesen.
Glücklicherweise sind dort nur 12 Rechner im Netz, die ich alle von Hand umkonfiguriert habe und so den Internetzugang auf Halle 2 gelegt habe, damit die Leute weiter arbeiten können.
Sollte die Telekom die Störung gleich beheben, müsste ich wieder an jeden Rechner.

Wie würdet ihr das Ganze sauber aufbauen.
Bin auch für eine Neugestaltung des Ganzen offen, wenn ihr mir sagt: "so ist es deutlich besser".
Das Ganze ist nämlich mit der Zeit gewachsen.

Freue mich über eure Anregungen...

Gruß Andy
unbenannt - Klicke auf das Bild, um es zu vergrößern
58 Antworten
Mitglied: aqui
22.01.2018, aktualisiert um 18:21 Uhr
einen Mikrotik installiert, damit ich die Netze trennen kann.
Wie ist das zu verstehen ??
Generell brauchst du ja keinen MT dafür, denn das kann ja auch die nackte FritzBox erledigen ?!
Oder hast du pro Standort mehrere IP Netze die du mit dem MT bedienst ?
Dieser Punkt ist unklar.
Heute ist der Internetzugang in Halle 1 gestört gewesen.
Kann ja mal vorkommen...
die ich alle von Hand umkonfiguriert habe und so den Internetzugang auf Halle 2 gelegt habe,
Oha...das sind ja absolute Steinzeit Techniken !!
Das liegt aber an deinem laienhaften Design. Normal sollte sowas natürlich vollkommen automatisch passieren.
Mit den MTs wäre das ja auch kein Thema das umzusetzen.
Du müsstest beide FBs der Halle 1 und 2 in ein gemeinsames "Internet VLAN" bringen.
Vermutlich hast du jetzt ein falsches Design und jeweils in Halle 1 und 2 die FBs in irgendeinem der Produktivnetze laufen was natürlich kontraproduktiv ist.
Auch wäre es etwas "unintelligent", denn wenn du schon MTs hast hast du ja alle Voraussetzungen für ein erheblich besseres Design als statisches Routing ohne Failover.
Mit denen könntest du sogar dynamisch ein Failover schalten bei Halle 1 und 2.
Das ist kinderleicht wenn du OSPF aktivierst und dynmaisch routest. Alle MTs redistribuieren eine statische Default Route als External 1 Typ die damit wechselnde Cost bekommt.
Lokal pro Halle gilt also imm die dortige FB als Gateway ins Internet. Fällt die aus wir der Internet Anschluss mit der besten Cost (dem kürzesten Hop) genommen.

Das sinnigste wäre in dem ganzen Konstrukt dynamisch zu routen und eine oder 2 Default Routen zu injizieren.
Fällt jetzt irgendwo in einer der Hallen das Internet aus müsstest du nur einen einzigen Mausklick machen um das umzurouten. Und auch das könnte man über ein Script im MT noch vollständig automatisieren.
Man fragt sich wozu du diese Teile hast wenn du das alles nicht nutzt was sie dir bieten und sie in einem relativ dummen Netzwerk Verbund schaltest wie Oma Gretes Zuhausenetz anno dunnemals.
Wie würdet ihr das Ganze sauber aufbauen.
Intelligent mit dynmaischem Routing und Failover. Du müsstest gar nicht mal so viel ändern.

Noch eine Frage: Die Bridge zw. Halle 2 und Halle 3 und 4, ist das (hoffentlich) eine geroutete Punkt zu Punkt verbindung oder machst du hier etwa ein einfaches Layer 2 Bridging ?
Bitte warten ..
Mitglied: Dragan123
22.01.2018 um 19:17 Uhr
Hallo,
Die MTs habe ich installiert, um die Netze in Subnetze zu unterteilen.

Leider habe ich nicht die Erfahrung mit Netzwerken, deshalb arbeite ich mich da ein.

Die Aufteilung ist im Moment so, dass die Fritzboxen, der Server und die WLAN-Brücken in einem Netz sind.
Außerdem sind in diesem Netz ein paar Clients, die ich noch nicht umgezogen habe.

Hinter jedem MT gibt es min 1 Subnetz mit Routen zu den Fritzboxen und natürlich dem Server.
Bitte warten ..
Mitglied: aqui
23.01.2018, aktualisiert um 13:03 Uhr
Die MTs habe ich installiert, um die Netze in Subnetze zu unterteilen.
Es bleibt weiter unklar ?
Welche Netze ??
  • Mehrere Subnetze pro Halle ?
  • oder die Subnetze der Hallen selber ?
  • Oder beides
Solange die IP Adressierung nicht klar ist ist das dann Raterei.
Versteht man deinen Text jetzt aber richtig, dann hast du pro Halle mehr als nur 1 Netz was die geroutete Bridge Verbindung ja auch schon erszwingt.
deshalb arbeite ich mich da ein.
Ist ja auch kein problem, das bekommen wir schon gewuppt mit dir wenn ein Grundverständniss über IP Adressierung und Routing da ist ?!
Die Aufteilung ist im Moment so, dass die Fritzboxen, der Server und die WLAN-Brücken in einem Netz sind.
Nicht optimal !
Schon aus dem Grunde da du damit die GESAMTE Broadcast Last des Server Netzwerkes in dem sich vermutlich auch alle Clients befinden ?!, so auf die WLAN Bridge bringst und deren Bandbreite beschneidest. Die WLAN Bridges solltest du auf eine Punkt zu Punkt Verbindung auf den MTs isolieren.
Die FBs solltest du auch isolieren. Dann alles mit OSPF routen mit E1 Injektion der Default Routen pro Halle und das wäre dann die Basis.
Damit ist dann eine Lösung schnell gemacht das zu dynamisieren.
Bitte warten ..
Mitglied: Dragan123
23.01.2018 um 17:28 Uhr
Hallo aqui,
zu den Netzen nochmal:

Der Server, die Fritzboxen und die WLAN-Brücken hängen in einem Netz: 192.168.20.0/24

In Halle 1 gibt es ein VLAN für Clients, die nur Internetzugriff haben, aber sonst keinen Serverzugriff benötigen (10.10.80.0)

In Halle 2 gibt es 2 Netze
10.10.10.0/24 (Zugriff ins Servernetz und Internet)
10.10.11.0/24 (nur Zugriff auf einen NAS im 10.10.10.0/24 und kein Internet)

In Halle 3 gibt es ein Netz
10.10.20.0/24 (Zugriff ins Servernetz und Internet)

In Halle 4 gibt es ein Netz
10.10.30.0/24 (Zugriff ins Servernetz und Internet)

Hoffe das ist erst mal klar

Das Thema OSPF war mir bis heute komplett unbekannt. Ich versuche das jetzt erst zu verstehen...

Ansonsten zum Thema WLAN Brücken:
Ich nutze jeweils 2 Stück ubiquiti loco m2, um die Hallen zu verbinden. Warum muss ich die routen? Wegen dem Broadcast? D.h. ich muss die am besten in ein sep. Netz legen und dann da den Traffic durchrouten?

Vielen Dank an dieser Stelle nochmal für die Hilfe!!!

Gruß Andy
Bitte warten ..
Mitglied: aqui
24.01.2018, aktualisiert 07.02.2018
OK, du müsstest dein Netz ein klein wenig umbauen von der Segmentadressierung.
Der Internet Link auf die FBs muss isoliert werden um die verschiedenen Routing Kosten der Internet Verbindungen abbilden zu können.
Grob sähe das so aus für Halle 1 bis 3. Halle 4 hab ich mal ausgespart, denn die ist identisch zu Halle 3 und musst du nur kopieren.

ospf-hallen - Klicke auf das Bild, um es zu vergrößern

Die IP Netze musst du ggf. etwas umstellen wenn sie nicht in dein Konzept passen.
Die Koppelnetze zwischen den Hallen habe ich mal als /29er Netze ausgelegt. So hast du in jedem dieser Netze 6 Hostadressen.
Das reicht dann im Koppelnetz Halle 1 zu Halle 2 für die 3 IP Adressen MT1, MT2 und Server, Im Koppelnetz Halle 2 zu Halle3 für die IPs MT2, MT3 und die Management IPs der beiden Ubiquity Bridges.
So elimiierst du auch gleich das Broadcast Problem von den WLAN Bridges.

Was du machst ist jetzt eine ganz banale OSPF Konfig.
Unter Routing OSPF trägst du auf dem jeweiligen Router die IP Netze und Interfaces ein die OSPF machen sollen als da sind die lokalen Netze und die jeweiligen Koppelnetze am Router. Die lokalen trägst du als "passive" ein. Passive deshalb damit dir hier keiner die Router ärgern kann mit einem "wilden" OSPF Router. Passive Interfaces akzeptieren keine OSPF Router dort so das sichergestellt ist deine Updates gehen nur via Koppelnetz raus.

Im OSPF konfigurierst du dann auf jedem Router das Redistribuieren der Default Route und zwar als "Typ E1 if present". Si injizieren die MTs 4 Internet Routen unterschiedlicher Cost. Lokal wir immer die mit mit der besten Cost genommen also die lokale.
Fällt die aus nimmt das Netz einen der anderen. So hast du quasi eine 4-fach Redundanz.
Bitte warten ..
Mitglied: Dragan123
24.01.2018 um 19:16 Uhr
Danke für die ausführliche Anleitung!
Muss jetzt nur noch umgesetzt werden...

Werde mir mal 3 Router besorgen und spielen - Kann mir nicht erlauben in dem Produktivnetz zu testen.

Übrigens:
Was hälst du von dem Edge Router von ubiquity als Alternative zum Mikrotik?
Die grafische Oberfläche spricht mich sehr an (bin ein Windows-Kind), habe das Teil aber noch nicht getestet...
Bitte warten ..
Mitglied: aqui
25.01.2018 um 13:49 Uhr
Muss jetzt nur noch umgesetzt werden...
So ist es !
3 Router besorgen und spielen
Das ist eine gute Idee und der richtige Weg um das vorher wasserdicht zu testen.
Was hälst du von dem Edge Router von ubiquity
Gegenfrage: was würdest du von einem Fahrradhersteller halten der mit einmal Autos baut ??
Die können WLAN gut und alles andere müssen sie noch zeigen.
Bleib besser bei etablierten Herstellern in dem Bereich.
Die grafische Oberfläche spricht mich sehr an
Damit fängt man alle Klicki Bunti Knechte wie immer ein.
Die merken dann leider zu spät was für eine Mogelpackung dann oft dahintersteht.
Außerdem gilt immer noch: "Real networkers do CLI !"
Bitte warten ..
Mitglied: Dragan123
28.01.2018 um 08:37 Uhr
Guten Morgen,

Leider sind die Router immer noch nicht da, aber ich habe noch eine Frage:
Ist es möglich, im Router einen Eintrag zu machen, der den dns Namen des Servers für die Subnetze auflöst? Es geht um DATEV, die Anwendung von denen läuft nur mit dem Hostnamen und nicht mit der IP-Adresse.

Aktuell trage ich den in die hosts Datei bei jedem Client ein, der auf den Server zugreifen muss und nicht im Netzwerk des Servers ist ( z.b. die Rechner in dem Netz 10.10.20.0)

Es funktioniert einwandfrei, nur vielleicht ist es auch eine Steinzeitlösung...
Bitte warten ..
Mitglied: Dragan123
29.01.2018 um 09:09 Uhr
Habe es eingetragen, scheint aber nicht zu klappen, oder ich habe etwas falsch verstanden oder falsch erklärt...

ich habe in ip dns static einen Eintrag angelegt:
Name: ptpsrv
Address: 192.168.20.150

Wen ich von client ping ptpsrv ausführe, kommt die Fehlermeldung: Ping-Anforderung konnte Host "ptpsrv" nicht finden.
Bitte warten ..
Mitglied: aqui
29.01.2018 um 13:28 Uhr
Vermutlich musst du die komplette Domain dort angeben und nicht nur einfach den Hostnamen wie du das gemacht hast.
Prüfen kannst du das immer besser mit nslookup.
Bitte warten ..
Mitglied: Dragan123
30.01.2018 um 09:29 Uhr
Danke für deine Hilfe, aber leider komme ich so nicht weiter.

nslookup ptpsrv zeigt folgendes:

Server: fritz.box
Address: 192.168.20.1

Name: ptpsrv
Address: 192.168.20.150

bis hier scheint alles richtig

Wenn ich ping ptpsrv ausführe, kommt die Meldung ... konnte host "ptpsrv" nicht finden
Bitte warten ..
Mitglied: aqui
30.01.2018, aktualisiert um 11:03 Uhr
nslookup ptpsrv zeigt folgendes:
Klar, da fehlt wie oben schon mehrfach bemerkt die komplette Domain. Hier musst du den vollen FQDN Namen angeben !
Was noch tödlich ist:
nslookup sagt ja das die FritzBox !! der DNS Server ist ! Da hast du ja aber keinen Hosteintrag gemacht ! Logisch also das die nicht auflösen kann.
Wenn ich ping ptpsrv ausführe, kommt die Meldung ... konnte host "ptpsrv" nicht finden
Ist doch auch logisch !!! Denk doch bitte nur mal ein klein wenig nach !
Ping muss ja auch zuerst per DNS den Hostnamen auflösen BEVOR es ein ICMP Echo an die IP Adresse losschickt. Das Internet kennt keine Namen sondern nur IP Adressen, das sollterst auch du wissen !
Das das scheitert kannst du ja oben schon am nslookup sehen.
Wenn der schon nicht auflösen kann wie sollte es dann Ping schaffen ?!
Bitte warten ..
Mitglied: Dragan123
30.01.2018 um 14:12 Uhr
Klar, da fehlt wie oben schon mehrfach bemerkt die komplette Domain. Hier musst du den vollen FQDN Namen angeben !
Ich denke wir reden an einander vorbei.
Wenn ich die komplette Domain eingebe funktioniert alles, ich will das aber genauso haben, wie wenn ich im Hauptnetz bin. Dort gebe ich ping ptpsrv ein und alles geht.
Das geht auch, wenn ich in dem Subnetz bin und in der hosts - Datei den Eintrag setze.

Was noch tödlich ist:
nslookup sagt ja das die FritzBox !! der DNS Server ist ! Da hast du ja aber keinen Hosteintrag gemacht ! Logisch also das die nicht auflösen kann.
Ich habe jetzt weder in der FritzBox noch im Mikrotik den DNS Eintrag drin. Es hat sich nichts geändert, ob ich den drin habe oder nicht.

Ich habe alle Möglickeiten als DNS Server durchprobiert: die FritzBox, den Router, und den Server selber.
Im Router habe ich es in der DNS Route mit und ohne komplette Domain probiert.
Bitte warten ..
Mitglied: aqui
31.01.2018 um 11:19 Uhr
Ich denke wir reden an einander vorbei.
Das mag sein Auffällig ist nur das du immer nur den Hostnamen postest statt der vollständigen FQDN.
ich will das aber genauso haben, wie wenn ich im Hauptnetz bin.
Das kann deshalb nicht gehen, da dann vermutlich der DNS Server seine Default Domain an den Hostnamen anhängt und der dann nicht stimmt. Entweder änderst du dann also die Dewfault Domain oder gibst den FQDN an.
Ich habe jetzt weder in der FritzBox noch im Mikrotik den DNS Eintrag drin.
Dann kann es ja logischewrweise niemals gehen, denn wie sollen denn die FB oder der MT das auflösen können wenn SIE als DNS Server angegeben werden.
Wenn du einen lokalen DNS Server hast dann gibst du immer logischerweise auch DIESEN als DNS Server bei den Endgeräten an und richtest dem DNS Server selber dann eine Weiterleitung auf FB und /oder MT ein.
Der DNS Server bringt dir ja weitreichende Konfig Möglichkeiten das entsprechend anzupassen das es fehlerfrei klappt.
MT und FB sind nur Proxies in denen das nur sehr eingeschränkt geht.
Fazit: Passe deine DNS Konfig an...aber richtig !
Bitte warten ..
Mitglied: Dragan123
07.02.2018 um 12:34 Uhr
So, habe die Router mal konfiguriert, es läuft aber nicht
Von jedem Router komme ich ins Internet, aber ich sehe die Nachbarrouter nicht.
Ein Ping z.B. von Router 3 an die Adresse 10.253.1.241 geht nicht, obwohl das eigentlich das Koppelnetz ist.
ich hänge mal alle Konfigurationen hier an, vielleicht findet jemand den Fehler?

Ich habe zu der Ausgangssituation (Zeichnung von aqui) folgende Adressen geändert:
Router1 Internet: 10.10.30.5
Router2 Internet: 192.168.1.38
Router3 Internet: 192.168.20.32

Die Lokalen Adressen haben alle eine 11.x.x.x statt der 10.x.x.x

01.
/ip pool 
02.
add name=dhcp_pool0 ranges=11.10.80.20-11.10.80.200 
03.
/ip dhcp-server 
04.
add address-pool=dhcp_pool0 disabled=no interface=ether3 name=dhcp1 
05.
/routing ospf instance 
06.
add distribute-default=if-installed-as-type-1 name=ospf1 router-id=10.253.1.254 
07.
/ip address 
08.
add address=11.10.80.1/24 interface=ether3 network=11.10.80.0 
09.
add address=10.10.30.5/24 interface=ether1 network=10.10.30.0 
10.
add address=10.253.1.249/29 interface=ether5 network=10.253.1.248 
11.
/ip dhcp-server network 
12.
add address=11.10.80.0/24 dns-server=8.8.8.8 gateway=11.10.80.1 
13.
/ip dns 
14.
set allow-remote-requests=yes 
15.
/ip firewall nat 
16.
add action=masquerade chain=srcnat out-interface=ether1 
17.
/ip route 
18.
add distance=1 gateway=10.10.30.1 
19.
/routing ospf interface 
20.
add interface=ether3 network-type=broadcast passive=yes 
21.
/routing ospf network 
22.
add area=backbone network=10.253.1.248/29 
23.
add area=backbone network=10.253.1.240/29 
24.
/system clock 
25.
set time-zone-name=Europe/Berlin 
26.
/system identity 
27.
set name="MikroTik Router 1"
01.
/ip pool 
02.
add name=dhcp_pool0 ranges=11.10.10.20-11.10.10.200 
03.
/ip dhcp-server 
04.
add address-pool=dhcp_pool0 disabled=no interface=ether3 name=dhcp1 
05.
/routing ospf instance 
06.
add distribute-default=if-installed-as-type-1 name=ospf1 router-id=10.253.1.246 
07.
add distribute-default=if-installed-as-type-1 name=ospf2 router-id=10.253.1.249 
08.
/ip address 
09.
add address=11.10.10.1/24 interface=ether3 network=11.10.10.0 
10.
add address=192.168.1.38/24 interface=ether1 network=192.168.1.0 
11.
add address=10.253.1.254/29 interface=ether2 network=10.253.1.248 
12.
add address=10.253.1.241/29 interface=ether5 network=10.253.1.240 
13.
/ip dhcp-server network 
14.
add address=11.10.10.0/24 dns-server=8.8.8.8 gateway=11.10.10.1 
15.
/ip dns 
16.
set allow-remote-requests=yes 
17.
/ip firewall nat 
18.
add action=masquerade chain=srcnat out-interface=ether1 
19.
/ip route 
20.
add distance=1 gateway=192.168.1.1 
21.
/routing ospf interface 
22.
add interface=ether3 network-type=broadcast passive=yes 
23.
/routing ospf network 
24.
add area=backbone network=10.253.0.248/29 
25.
add area=backbone network=10.253.1.240/29 
26.
/system clock 
27.
set time-zone-name=Europe/Berlin 
28.
/system identity 
29.
set name="MikroTik Router2"
01.
/ip pool 
02.
add name=dhcp_pool0 ranges=11.10.20.20-11.10.20.200 
03.
/ip dhcp-server 
04.
add address-pool=dhcp_pool0 disabled=no interface=ether3 name=dhcp1 
05.
/routing ospf instance 
06.
add distribute-default=if-installed-as-type-1 name=ospf1 router-id=10.253.1.240 
07.
/ip address 
08.
add address=11.10.20.1/24 interface=ether3 network=11.10.20.0 
09.
add address=192.168.20.32/24 interface=ether1 network=192.168.20.0 
10.
add address=10.253.1.246/29 interface=ether2 network=10.253.1.240 
11.
/ip dhcp-server network 
12.
add address=11.10.20.0/24 dns-server=8.8.8.8 gateway=11.10.20.1 
13.
/ip dns 
14.
set allow-remote-requests=yes 
15.
/ip firewall nat 
16.
add action=masquerade chain=srcnat out-interface=ether1 
17.
/ip route 
18.
add distance=1 gateway=192.168.20.1 
19.
/routing ospf interface 
20.
add interface=ether3 network-type=broadcast passive=yes 
21.
/routing ospf network 
22.
add area=backbone network=10.253.1.240/29 
23.
/system clock 
24.
set time-zone-name=Europe/Berlin 
25.
/system identity 
26.
set name="MikroTik Router3"
LG Andy
Bitte warten ..
Mitglied: aqui
07.02.2018, aktualisiert um 14:00 Uhr
Hi Andy !

Du hast da noch irgendwo einen Kinken in deiner OSPF Konfig drin. Hier mal die wichtigsten Schritte zusammengefasst für die richtige Konfig:

1. Schritt: Interface für OSPF definieren:
Als Beispiel hier den ersten MT bei dir. Da müssen bei dir mit Klick auf + dann rein:
  • Port zur FritzBox 10.253.1.0 /30
  • Port zum Koppelnetz 10.253.1.248 /29
  • Port zum lokalen Netz 10.10.80.0 /24
o1 - Klicke auf das Bild, um es zu vergrößern
(Hier der Einfachheit halber nur mal mit 2 Ports)

2. Schritt: IP Netzwerke für OSPF eintragen:
Bei dir wieder mit Klick auf + :
  • 10.253.1.0 /30
  • 10.253.1.248 /29
  • 10.10.80 /24
o2 - Klicke auf das Bild, um es zu vergrößern

3. Schritt: In der OSPF Instance das Redistribuieren der statischen Route E1 aktivieren:

o3 - Klicke auf das Bild, um es zu vergrößern
Hier kannst du jetzt auch sehen das die OSPF Instance nach Konfig der Interfaces UND IP Netzwerke in den Status Running geht und somit aktiv ist !

4. Schritt: Check ob die OSPF Nachbar Router angezeigt werden:
Da kannst du natürlich nur was sehen wenn schon ein anderer Router mit OSPF rennt !
o4 - Klicke auf das Bild, um es zu vergrößern

5. Schritt: Check der Routing Tabelle ob alle Netze richtig bekannt gemacht werden:

o5 - Klicke auf das Bild, um es zu vergrößern

Das wars !
Diese Prozedur musst du auf allen deinen 3 Mikrotiks genau so machen.
Dann kannst du unter Neighbors auch alle anderen OSPF Router sehen und unter IP -> Routes dann auch deine vollständige Routing Tabelle inklusive aller 3 Internet Gateways. Blau und ein "o" bedeutet das diese IP Routen über OSPF gelernt wurden.
Bitte warten ..
Mitglied: Dragan123
07.02.2018 um 14:35 Uhr
Hab's probiert.

Überall steht unter instances "running"
Ich sehe auf Router 1 unter neighbours keinen, auf dem Router 2 nur den Router 3 und auf Router 3 nur Router 2.
Unter Routes sehe ich keine einzige Route mit einem o
Bitte warten ..
Mitglied: Dragan123
07.02.2018 um 14:40 Uhr
In Router 2 steht unter OSPF->Interfaces
ether 2 (Verbindung zu Router 1) der State auf down
ether 5 designated router

Bei router 1 ist Port 5 auch als deignated router
Bitte warten ..
Mitglied: aqui
07.02.2018, aktualisiert um 17:19 Uhr
Ich sehe auf Router 1 unter neighbours keinen
Dann ist es doch eindeutig das du auf dem Koppelport zum Router 2 also dem 10.253.1.248er Netz das Interface NICHT definiert hast oder unter OSPF Networks ein falsches Netz oder falsche Maske !!
Das bedeutet das über den Koppellink 10.253.1.248 keine oder nur einseitig OSPF Updates kommen !
ether 2 (Verbindung zu Router 1) der State auf down
Ist das das 10.253.1.248er Netz was diese beiden Router MT1 und MT2 verbindet ???
Wenn ja besteht physisch keine Verbindung da das Interface auf Down ist, also keinen Link hat ! Dann ist es doch klar das die sich nicht sehen.
Da stimmt also am Kabel irgendwas nicht ! Check das !
Überall steht unter instances "running"
Das schützt dich aber nicht vor falscher Interface Zuweisung oder Tippfehlern bei der IP Netzwerk Angabe oder den Subnetz Masken !! Bitte genau kontrollieren. Dort ist garantiert ein Fehler.
Hast du im OSPF Setup auch wirklich die Netzwerk Adressen eingegeben: (Hostbits auf 0)
MT1:
  • 10.253.1.0 /30 (passiv) (Achtung: Hier ist ein Adressfehler in der Skizze)
  • 10.253.1.248 /29
  • 10.10.80 /24 (passiv)
MT2:
  • 10.253.1.4 /30 (passiv) (Achtung: Hier ist ein Adressfehler in der Skizze)
  • 10.253.1.248 /29
  • 10.10.80 /24 (passiv)
und nicht irgendwelche Hostadressen ?

Achtung: Leider hat sich in der Skizze oben ein Adressfehler eingeschlichen in den Koppelnetzen zu den FritzBoxen !!!
Du siehst ja das alle IP Netze dort GLEICH sind. Das ist natürlich komplett falsch und beim Cut and Pasten passiert. Gleiche IP Netze darf es natürlich niemals geben wie jeder Netzwerker weiß !! Shame on me....

Die richtigen Netze lauten folgendermaßen:
MT1:
  • 10.253.1.0 /30 (passiv) (FritzBox: .1.1, MT: .1.2)
MT2:
  • 10.253.1.4 /30 (passiv) (FritzBox: .1.5, MT: .1.6)
MT3:
  • 10.253.1.8 /30 (passiv) (FritzBox: .1.9, MT: .1.10)
Sorry für den Fauxpas !!
Zeichnung ist jetzt korrigiert oben !!
Bitte warten ..
Mitglied: Dragan123
07.02.2018 um 17:38 Uhr
Ich schaue es mir morgen in Ruhe an.
Die Koppelnetze zu den Fritzboxen sind bei mir alle unterschiedlich.
Bitte warten ..
Mitglied: Dragan123
08.02.2018 um 08:39 Uhr
Moin Zusammen,

ich kann einen Teilerfolg berichten!
Es war ein Tippfehler in meinen OSPF->Networks. Ich habe das Koppelnetz falsch eingegeben.
Die NachbarRouter werden erkannt, es scheint erst mal alles richtig zu sein.

Jetzt zum Verständnis was die Routen angeht:
Ich habe aktuell eine static route zum Internet (0.0.0.0/0 -> GW 192.168.20.1 (FritzBox 3. Router)

Wenn ich an dem Router den Internetzugang abziehe, sollte doch eine neue Route eingetragen werden, um ins Internet zu kommen, oder?

Anbei 2 Bilder - mit und ohne Internetzugang.

Lg Andy
routelist - Klicke auf das Bild, um es zu vergrößern
routelist-internet-down - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
08.02.2018, aktualisiert um 10:42 Uhr
es scheint erst mal alles richtig zu sein.
Das hört sich gut an und so sollte es auch sein
Wenn ich an dem Router den Internetzugang abziehe, sollte doch eine neue Route eingetragen werden,
Jein...!
Die 3 Router redistribuieren ja ins OSPF 3mal ihre Default Routen ins Internet. Im Normalfall siehst du also 3 Default Routen im OSPF. Allerdings haben die eine unterschiedliche Metrik (Distance).
Klar, denn denn die distribuierten Default Routen die von den anderen Routern kommen haben eine schlechtere Metrik als die die direkt lokal ist. Das siehst du an den Metrik (Distance) Werten bzw. am Index der die aktuell aktive Default Route am Router anzeigt.
Ziehst du den Port mit der FritzBox ab, dann geht das Interface auf Down und diese default Route wird dann aus der Routing Tabelle rausgenommen. Klar, denn der Port ist down und die Route damit ungültig.
Nach kurzer Zeit (max 10 Sek,) siehst du das und dann greift die Default Route in der Tabelle mit der zweitbesten Metrik(Distance).
Bei deinen Screenshot oben kann das ja so nicht gehen weil du ja derzeit nur einen aktiven Router mit nur einer aktiven Default Route hast.
Ziehst du den ab ist natürlich nix mehr weil es nur eine gibt...logisch.
Bitte warten ..
Mitglied: Dragan123
08.02.2018 um 11:23 Uhr
OK, soweit klar.
Heißt das für mich, ich muss die Routen alle manuell anlegen?
Bitte warten ..
Mitglied: aqui
08.02.2018, aktualisiert um 11:27 Uhr
Die Default Route in den jeweiligen MTs die zur der dort adaptierten FB gehen JA....aber auch nur DIE !!!
Bitte warten ..
Mitglied: Dragan123
08.02.2018 um 11:39 Uhr
OK, die hatte von Anfang an drin.
Dann scheint etwas noch nicht richtig zu funktionieren...

Eine neue Route für die Adresse 0.0.0.0/24 wird nicht automatisch aktiviert.
Bitte warten ..
Mitglied: Dragan123
09.02.2018 um 10:16 Uhr
Hey aqui,

hast du zufällig noch eine Idee, was ich falsch gemacht habe?
Wie gesagt, ich habe die Standardroute zur Fritzbox immer drin, eine zusätzliche wird aber nicht automatisch angelegt, wenn die Fritzbox weg ist.
Bitte warten ..
Mitglied: aqui
09.02.2018 um 17:52 Uhr
Eine neue Route für die Adresse 0.0.0.0/24 wird nicht automatisch aktiviert.
Die ist auch vollkommen falsch !! Die Default Route lautet 0.0.0.0 /0 und dann die Gateway IP (=lokale FritzBox) !!
noch eine Idee, was ich falsch gemacht habe?
Ja, falsche default Route ! Siehe oben !

Wenn du die 3mal korrigiert hast dann solltest du in der Routing Tabelle außer der lokalen immer noch 2 andere Default Routen sehen mit schlechterer Metrik die via OSPF kommen.
Das sind dann immer die jeweiligen Backup Routen.
Dazu nicht vergessen IMMER in der OSPF Instance Konfig überall auf den MTs das Redistribute Default as E1 einstellen !
Bitte warten ..
Mitglied: Dragan123
10.02.2018 um 15:25 Uhr
Eine neue Route für die Adresse 0.0.0.0/24 wird nicht automatisch aktiviert.
Die ist auch vollkommen falsch !! Die Default Route lautet 0.0.0.0 /0 und dann die Gateway IP (=lokale FritzBox) !!
Das war ein Tippfehler hier im Post.

Wie man im Post weiter oben sehen kann, hatte ich mal Screenshots gepostet, in dem die Routen stehen. Da ist die 0.0.0.0/0 mit dem entsprechenden Port. Der ist aber wie schon gesagt als Einziges drin. Die anderen Einträge mit der 0.0.0.0/0 zum Nachbar-Router stehen nicht drin.

Auch das redistribute as E1 habe ich meiner Meinung nach drin.

Liegt es vielleicht daran, daß ich im Prinzip an dem selben Gateway in Internet hänge?
Ich habe die Testumgebung wie folgt aufgebaut:
OSPF-Router 1 hängt an meiner Fritzbox
OSPF-Router 2 hängt hinter einem Mikrotik, der an der Fritzbox hängt, mit dem ich ein anderes Subnetz erzeugt habe
OSPF-Router 3 hängt an einem kleinen Ubnt Router, den ich am an der Fritzbox habe und dahinter ein neues Netz habe.

Tatsache ist, daß ich mit jedem meiner Router über die "Bastellösung" ins Internet komme, nur sobald ich das Internet an meinen OSPF-Routern abklemme, werden die Nachbarrouten nicht angelegt.
Bitte warten ..
Mitglied: aqui
10.02.2018 um 19:33 Uhr
Auch das redistribute as E1 habe ich meiner Meinung nach drin.
Hast du oder meinst du nur das du es hast ?! Kontrolliere das. Das MUSS auf allen 3 MTs so eingestellt sein !
Liegt es vielleicht daran, daß ich im Prinzip an dem selben Gateway in Internet hänge?
Nein, das stimmt ja auch nicht ! Du hängst ja an drei unterschiedlichen Internet Gateways durch die 3 FritzBoxen.
Ich habe die Testumgebung wie folgt aufgebaut:
Eine kleine Skizze wäre hier hilfreicher
das Internet an meinen OSPF-Routern abklemme, werden die Nachbarrouten nicht angelegt.
Die werden auch nicht "angelegt" !
Die sind immer da ! Dort müsstest du 3 ! Internet Routen sehen in der Routing Tabelle. Allerdings 2 immer mit schlechterer Metrik als die lokale. Ist ja auch klar, denn die werden vom OSPF ja mit schlechteren Metriken bekannt gemacht. Tauchen aber in der Routing Tabelle auf. Die aktuell aktive Route ist immer farblich gekennzeichnet !
Bitte warten ..
Mitglied: Dragan123
12.02.2018 um 08:05 Uhr
Danke für deine Mühe, aqui!!!

Anbei die Skizze des Testaufbaus.
Du hast mich nicht richtig verstanden. Ich habe im Moment keine Möglichkeit die 3 Fritzboxen zu nutzen, weil ich halt erst auf dem Tisch alles durch haben wollte.

Ausserdem habe ich die Screenshots für jeden Router angehängt, wo die Routen und das E1 zu sehen sind.
router1 - Klicke auf das Bild, um es zu vergrößern
router2 - Klicke auf das Bild, um es zu vergrößern
router3 - Klicke auf das Bild, um es zu vergrößern
testaufbau - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: aqui
12.02.2018, aktualisiert um 14:32 Uhr
Als Workaround sollte das erstmal so gehen das alle an einer FritzBox hängen und die jeweilige Default Route so simuliert wird.
Allerdings hast du laut Skizze einen gravierenden Fehler gemacht, der dir auch hätte sofort auffallen müssen !:

Alle 3 Router "sehen" die jeweils anderen beiden nicht. Es gibt keinerlei Querverbindungen zw. den 3 Routern Router 1 bis ""Router 3// ! Das kann nicht gehen.
Damit ist es ja vollkommen klar das du keinerlei Backup Default Routen siehst.
Jeder einzelne Router ist also so eine isolierte OSPF Insel für sich und kennt damit keinen der Nachbar Router und auch nicht deren Routen. OSPF kann also keine Routen Kalkulation über das gesamte Netz machen und zeigt deshalb logischerweise immer nur eine Default Route !
Wo sollten die anderen Routen auch her kommen wenn die Router nicht verbunden sind ??
Fazit: Verbinde Router 1 mit Router 2 mit einem Point to Point Netz und auch Router 2 und Router 3. Dann sollte das sofort zum Fliegen kommen !
Bitte warten ..
Mitglied: Dragan123
12.02.2018 um 15:31 Uhr
Das habe ich nur vergessen einzuzeichen! Sorry!

Ich habe es mit den Netzwerkadressen verbunden und angelegt, wie du es im ersten Post skizziert hast! Das geht auch aus den Bildern hervor, die ich zuletzt gepostet habe.
Da sind die Netzwerke 10.253.1.248/29 und 10.253.1.240/29 als "Verbindungsnetzwerke drin.
Bitte warten ..
Mitglied: Dragan123
13.02.2018 um 14:44 Uhr
So sieht die Umgebung aus.
Hoffe ich habe dieses mal nichts vergessen...
testumgebung - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: Dragan123
13.02.2018 um 15:57 Uhr
So habe noch einige Versuche gemacht und Folgendes festgestellt:
Ich spreche nur von Router 2 und 3.

Ich habe nur den Wert "Redistribute Default Route" verändert - und zwar wie folgt:

An Router2 und Router3 -> always as type 1 = beide Router haben keine zus. Route zu 0.0.0.0/0
Router2 -> never und Router3 -> always as type1 = nur an Router 2 wird die zus. Route angelegt.
Router3 -> never und Router2 -> always as type1 = nur an Router 3 wird die zus. Route angelegt.
wenn beide auf never stehe, bekommen beide Router keine zus. Route.

Ich habe jetzt noch an den anderen Parametern rumprobiert, verstehe aber die Logik nicht.
Bitte warten ..
Mitglied: Dragan123
13.02.2018 um 20:30 Uhr
ich habe nochmal versucht das Mikrotik Wiki zum Thema OSPF zu verstehen..
Da steht folgender Satz drin:
01.
As you can see router-id is 0.0.0.0, it means that router will use one of router's IP addresses as router-id. In most cases it is recommended to set up loopback IP address as router-id. Loopback IP address is virtual, software address that is used for router identification in network. The benefits are that loopback address is always up (active) and can’t be down as physical interface. OSPF protocol used it for communication among routers that identified by router-id. Loopback interface are configured as follows:
Kann es sein daß das mein Problem ist, wieso ich bei gleichen Einstellungen auf 2 Routern keine Routen ins Internet mehr habe?
Die Routen zu Nachbarroutern sind ja alle drin, deshalb gehe ich davon aus, daß das Meißte richtig eingestellt ist.

Naja, werd's morgen mal testen.
Bitte warten ..
Mitglied: Dragan123
14.02.2018 um 07:17 Uhr
Ne, das hat leider auch nicht das gewünschte Ergebnis geliefert...

Hat einer noch ne Idee?
Bitte warten ..
Mitglied: aqui
14.02.2018 um 09:19 Uhr
verstehe aber die Logik nicht.
Welche Logik genau verstehst du nicht ? Kannst du das etwas präzisieren ?
Mit dedm Loopback hat das nichts zu tun und auch nicht mit der Router ID. Die muss man nicht zwingend konfigurieren.
Ich checke das mal in einem Test zusammen mit Cisco OSPF und gebe dir ein Feedback.
Bitte warten ..
Mitglied: Dragan123
14.02.2018 um 09:30 Uhr
Zitat von aqui:

verstehe aber die Logik nicht.
Welche Logik genau verstehst du nicht ? Kannst du das etwas präzisieren ?
Mit dedm Loopback hat das nichts zu tun und auch nicht mit der Router ID. Die muss man nicht zwingend konfigurieren.

Ich meinte an der Stelle die einzelnen Parameter, die man dort einstellen kann:
static Routes, connected routes, default routes usw.

es ist halt seltsam, daß das, was du meinst (es werden mehrere 0.0.0.0/24 Einträge angelegt, die inaktiv sind) nur dann agelegt werden, wenn ich unterschiedliche Einstellungen in den Routern vornehme.
Sobald die Einstellungen gleich sind, verschweinden diese zusätzlichen Routen.

Ich checke das mal in einem Test zusammen mit Cisco OSPF und gebe dir ein Feedback.
Vielen DANK!
Bitte warten ..
Mitglied: aqui
14.02.2018, aktualisiert um 16:07 Uhr
.static Routes = Das sind zusätzlich statische Routen in andere IP Netze die du via OSPF weiter verteilen willst.
connected routes = Das sind die lokalen LAN Netze an den Interfaces. Ist eigentlich automatisch immer aktiv wenn diese Interfaces aktiv sind.
default routes = Das ist das was du oben machst !
nur dann agelegt werden, wenn ich unterschiedliche Einstellungen in den Routern vornehme.
Das sollte in der Tat NICHT so sein.
Bitte warten ..
Mitglied: Dragan123
15.02.2018 um 21:25 Uhr
hey aqui,

hast du nochmal testen können?
Bitte warten ..
Mitglied: aqui
16.02.2018 um 09:32 Uhr
Zeit...sorry. Bitte Geduld. Übers Wochenende sollte es klappen....
Bitte warten ..
Mitglied: Dragan123
19.02.2018 um 16:07 Uhr
hey aqui, wie war dein Wochenende

Spaß bei Seite! Hast du evtl. Zeit gehabt dich um mein Problem zu kümmern?
Bitte warten ..
Mitglied: aqui
20.02.2018, aktualisiert um 17:32 Uhr
Ja, habs hier am Laufen mit MT und Cisco Routern aber noch kleine Kinken gefunden. Ggf. ist eine E2 Distribution doch besser als E1.
http://blog.ine.com/2011/04/04/understanding-ospf-external-route-path-s ...
Das muss ich nochmal wasserdicht testen.

Soviel kann man aber schon sagen das der MT beide Routen in seiner OSPF Database nicht anzeigt, der Cisco schon. Du siehst also immer nur eine Gateway IP in der MT Routing Tabelle.
Man kann aber deutlich sehen wie sich in der MT Routing Tabelle die Default Gateways der Router ändern die die Default Route propagieren wenn man den lokalen Internet Link abklemmt.
Ich habe nur manchmal den Fall das die Route nicht zurückschwenkt. Da muss ich nochmal genau sehen woran das liegt.
Stay tuned...
Bitte warten ..
Mitglied: aqui
22.02.2018, aktualisiert 24.02.2018
So, hier der finale Labor Aufbau. Ums gleich vorweg zu nehmen es klappt fehlerlos und es ist auch egal ob man mit E1 oder E2 redistribuiert. Das Failover Verhalten klappt mit beiden Varianten ebenfalls fehlerlos.
Hier ist der Labor Aufbau:

ospf2 - Klicke auf das Bild, um es zu vergrößern

Cisco C1 Konfig:
router ospf 1
log-adjacency-changes
auto-cost reference-bandwidth 10000
passive-interface default
no passive-interface Ethernet1
network 10.25.14.0 0.0.0.255 area 0
network 10.222.222.31 0.0.0.0 area 0
<-- (Loopback Interface mit /32 Hostmaske)
default-information originate metric-type 1
!
ip route 0.0.0.0 0.0.0.0 10.99.1.254
!

Cisco C2+3 Konfig:
router ospf 1
log-adjacency-changes
auto-cost reference-bandwidth 10000
passive-interface default
no passive-interface Ethernet0
no passive-interface Serial0
no passive-interface Serial1
network 0.0.0.0 255.255.255.255 area 0


Hier siehst du die Routing Tabelle von C1 wenn der Internet Link aktiv ist. 10.99.1.254 ist der "Internet Router:
 Gateway of last resort is 10.99.1.254 to network 0.0.0.0 
 
     10.0.0.0/8 is variably subnetted, 8 subnets, 3 masks 
O       10.222.222.14/32 [110/1001] via 10.25.14.254, 00:07:41, Ethernet2 
O       10.99.99.0/30 [110/3500] via 10.25.14.254, 00:07:41, Ethernet2 
O       10.1.1.0/24 [110/3600] via 10.25.14.254, 00:07:41, Ethernet2 
O       10.99.99.4/30 [110/3500] via 10.25.14.254, 00:07:41, Ethernet2 
O       10.222.222.26/32 [110/3501] via 10.25.14.254, 00:07:41, Ethernet2 
C       10.222.222.31/32 is directly connected, Loopback0 
C       10.25.14.0/24 is directly connected, Ethernet2 
C       10.99.1.0/24 is directly connected, Ethernet1 
S*   0.0.0.0/0 [1/0] via 10.99.1.254  <--- (Default Route statisch) 
Statische Route hat hier Priorität !
Entsprechend zeigt der Screenshot MT auch diese Route zum Internet:
ospf1 - Klicke auf das Bild, um es zu vergrößern

Zieht man jetzt dort an C1 das Kabel zum Internet am WAN Port um eine Störung zu simulieren dann wird die vorher statische Route inaktiv und die vom rechten Mikrotik im Netz per OSPF distribuierte Default Route wird installiert:
Gateway of last resort is 10.25.14.254 to network 0.0.0.0 
 
     10.0.0.0/8 is variably subnetted, 7 subnets, 3 masks 
O       10.222.222.14/32 [110/1001] via 10.25.14.254, 00:08:57, Ethernet2 
O       10.99.99.0/30 [110/3500] via 10.25.14.254, 00:08:57, Ethernet2 
O       10.1.1.0/24 [110/3600] via 10.25.14.254, 00:08:57, Ethernet2 
O       10.99.99.4/30 [110/3500] via 10.25.14.254, 00:08:57, Ethernet2 
O       10.222.222.26/32 [110/3501] via 10.25.14.254, 00:08:57, Ethernet2 
C       10.222.222.31/32 is directly connected, Loopback0 
C       10.25.14.0/24 is directly connected, Ethernet2 
O*E1 0.0.0.0/0 [110/3601] via 10.25.14.254, 00:00:41, Ethernet2  <--- (Default Route vom MT) 
Entsprechend sieht man das auch sofort am MT der jetzt den anderen Router als Gateway anzeigt:
ospf2 - Klicke auf das Bild, um es zu vergrößern

Sieht man sich das auf C2 auch nochmal sieht man dort in der Routing Tabelle folgendes:
--> C1 Default Route aktiv:
O*E1 0.0.0.0/0 [110/1001] via 10.25.14.1, 00:02:56, Ethernet0 
(Traffic geht via C1 ins Internet)
--> C1 ohne Internet, Kabel gezogen:
O*E1 0.0.0.0/0 [110/2601] via 10.99.99.5, 00:00:30, Serial1 
               [110/2601] via 10.99.99.1, 00:00:30, Serial0 
Wo man beim MT aufpassen muss ist der Fakt, das der in der Database und in der Routing Tabelle nicht die Alternativen anzeigt. Bei letzterer ist das normal denn die zeigt immer nur die aktuell aktive Route. In der OSPF Database unter Routes sollten eigentlich immer beise stehen, insbesondere bei der E2 Redistribution, aber das zeigt er nicht im Gegensatz zum Cisco. M.E. ein kosmetischer Fehler im MT.
Aber letztlich egal, zeigt es doch das generell das Design mit der Gateway Redundanz so sauber funktioniert !!
Bitte warten ..
Mitglied: Dragan123
23.02.2018 um 15:27 Uhr
Hey aqui,
danke für die Hilfe.
Bei mir klappt es leider immer noch nicht, ich sehe aber einige Unterschiede zu deinen Screenshots:

routes-router1 - Klicke auf das Bild, um es zu vergrößern
Die Route 0.0.0.0/0 hat überhaupt kein Gateway.

Ausserdem wird der 1. Eintrag (192.168.1.0/24) aus der Liste entfernt, wenn ich an Router 2 das Internet abziehe. Das wäre meiner Meinung nach nämlich der Eintrag der eigentlich 0.0.0.0/0 heißen müsste und die Alternativroute ins Internet stellt.

Hoffe du kannst mir folgen.
Bitte warten ..
Mitglied: aqui
23.02.2018 um 20:21 Uhr
Ich werde im Testaufbau den C1 nochmal durch einen MT ersetzen und testen. Das entspricht dann eher deinem Setup.
Bitte warten ..
Mitglied: Dragan123
02.03.2018 um 15:41 Uhr
Hey aqui,
Ich hoffe du denkst noch an mich....
Bitte warten ..
Mitglied: aqui
02.03.2018 um 16:49 Uhr
Ja, Zeitmangel...Wochenende klappt es
Bitte warten ..
Mitglied: aqui
17.03.2018 um 17:46 Uhr
So...was lange währt... Sorry für die Wartezeit.
Wie erwartet verhält sich der Mikrotik identisch zum Cisco. ! Auch er schlatet das Gateway dann entsprechend auf das mit der besseren Cost (weniger Hops).
Ich habe das sogar in einem VRRP Umfeld getestet mit OSPF:
https://www.administrator.de/wissen/mikrotik-vlan-konfiguration-router-o ...
Auch da rennt das mit OSPF wie oben beschrieben sauber und ohne Probleme.
Bitte warten ..
Mitglied: Dragan123
19.03.2018, aktualisiert um 07:36 Uhr
Zitat von aqui:
So...was lange währt... Sorry für die Wartezeit.
Kein Problem, ich habe zu danken!


Zitat von aqui:
Auch da rennt das mit OSPF wie oben beschrieben sauber und ohne Probleme.
Dann verstehe ich nicht, was bei mir falsch läuft... Bin mit meinem Latein am Ende.

Vielleicht könntest du mal die komplette Konfig der beiden Router einstellen??

Gruß Andy
Bitte warten ..
Mitglied: Dragan123
27.03.2018 um 12:11 Uhr
@aqui

Hättest du mal Zeit, mir eine Konfig für die Mikrotiks zu schicken?
Ich habe heute alle Updates auf die Mikrotiks eingespielt - in der Hoffnung daß sich dann das Problem erledigt - aber leider hat das nichts gebracht.

Ich habe echt keine Ahnung, wo ich noch suchen soll...

Gruß Andy
Bitte warten ..
Mitglied: aqui
27.03.2018, aktualisiert um 19:22 Uhr
Du hast irgendwo noch einen Kinken in der Konfig.
Ich schicke dir die Konfigs morgen. Test Setup ist das obige nur das das 2te Internet dann am Mikrotik 2 (der am Cisco 1) hängt.
Bitte warten ..
Mitglied: Dragan123
10.04.2018 um 16:28 Uhr
freundliche Erinnerung...
Bitte warten ..
Mitglied: aqui
10.04.2018 um 17:37 Uhr
Kommt...bitte Geduld. Wetter ist zu gut
Bitte warten ..
Mitglied: Dragan123
31.05.2018 um 08:43 Uhr
Ich hoffe du hast nicht von meinem Problem vergessen....
Trotz schönem Wetter ;)
Bitte warten ..
Mitglied: aqui
31.05.2018 um 09:52 Uhr
Hi Dragan,
Nein ist immer noch auf der ToDo Liste und macht mir jeden Tag ein schlechtes Gewissen.
Du kannst aber sicher davon ausgehen das das auch in einer reinen MT Umgebung klappt, denn OSPF ist ein weltweiter Standard und millionenfach im Einsatz.
Irgendwo ist in deiner Konfig noch ein Kincken. Hier klappt es ja wie es soll.
Aber nichtsdesdotrotz, ich habe das auf dem Radar und werde das die kommenden Tage nochmal genau austesten. Am besten natürlich wenn das Wetter macl schlechter ist
Ich versuche es im Laufe der kommenden Woche....
Bitte warten ..
Ähnliche Inhalte
Firewall

Netzwerktopologie Heimnetzwerk: Firewall und Hausautomation

Frage von andihomeFirewall3 Kommentare

Hallo Administratoren, ich habe seit Jahren einen ipcop am laufen und bin sehr zufrieden damit weil er stabil läuft. ...

Voice over IP

Netzwerktopologie bei Einsatz von 3CX PBX-Server

gelöst Frage von Sailor77Voice over IP4 Kommentare

Moin Forum. Ich beabsichtige in meinem privaten Netz die kostenlose Variante des 3CX Server einzusetzen, allerdings bin ich mir ...

Microsoft

Surface wiederherstellen (Werks-Reset) - Erstellen des RecoveryDrive

gelöst Frage von Winfried-HHMicrosoft15 Kommentare

Hallo in die Runde! Von unserem Hausmeister habe ich eine nicht startende Surface RT bekommen und wollte bei dem ...

Notebook & Zubehör

Lenovo ideapad 110S: Angeblich auf der Festplatte zu wenig Platz für Werks-Reset

gelöst Frage von Winfried-HHNotebook & Zubehör23 Kommentare

Hallo in die Runde! Nach unserem Hausmeister, dem ich mit eurer Hilfe ja schon helfen konnte, hat mir nun ...

Neue Wissensbeiträge
Backup

2016 - Restore mit WBAdmin - iSCSI Device als Sicherungsziel

Erfahrungsbericht von Henere vor 2 TagenBackup1 Kommentar

Servus zusammen, was mich eben einige graue Haare gekostet hat Server 2016. Ich habe meinem Server eine weitere M2 ...

Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 4 TagenHumor (lol)10 Kommentare

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 4 TagenExchange Server9 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 5 TagenErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Heiß diskutierte Inhalte
E-Mail
Deutsche e-Mail Adresse auf iPhone in Katar. Nur Probleme
gelöst Frage von vanTastE-Mail32 Kommentare

Moin, ich habe hier in Deutschland auf einem Exchange 2013 eine e-Mail Adresse (name@domain.de) für einen Kollegen in Katar ...

Windows Server
Domäne beitreten nicht möglich, unter VMWare windows Server 2016 Core
Frage von AmanuelWindows Server19 Kommentare

Ich habe auf meinem Mac unter VMWare Windows Server 2016 Core und Windows Server 2016 Desktopversion installiert. Beide Systeme ...

Windows Server
Server verliert Dateien und Ordner
gelöst Frage von routeserverWindows Server18 Kommentare

Hallo Freunde, ich habe hier ein Problem, das mich an meine Grenzen treibt und ich würde gerne wissen, ob ...

Windows Tools
User Self Service und Client Management
Frage von OrkansonWindows Tools14 Kommentare

Hallo zusammen, ich hab ein paar verschiedene Fragen: 1. Was benutzt ihr um Software im Unternehmen zu verteilen? 2. ...