Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Netzwerkverbindung langsam - wireshark-Capture unklar

Mitglied: mt11341

mt11341 (Level 1) - Jetzt verbinden

13.01.2014 um 08:56 Uhr, 2743 Aufrufe, 10 Kommentare

Hallo zusammen,

ich öffne eine Datei (z.B. TEST.doc) mit einem Windows 7 (64 Bit)-Client (IP: 192.168.218.151) auf einer Freigabe auf einem Server (Server 2003) (IP: 192.168.218.204) im Netzwerk.
Das Öffnen dauert viel zu lang (ca. 3 Sekunden). Irgendetwas macht die Verbindung langsam. ich habe bereits alle möglichen Einstellungen geprüft (IP, DNS etc.). Nun habe ich wireshark bemüht und folgende unnormale Zeilen geben mir ein Rätsel auf:

No. Time Source Destination Protocol Length Info
145 2.31417300 192.168.218.204 192.168.218.151 SMB 630 Read AndX Response, FID: 0xc00b, 512 bytes
146 2.31435500 192.168.218.151 192.168.218.204 SMB 117 Read AndX Response, FID: 0xc00b, 2 bytes at offset 544
147 2.31460900 192.168.218.204 192.168.218.151 SMB 120 Read AndX Response, FID: 0xc00b, 2 bytes
148 2.31476600 192.168.218.151 192.168.218.204 SMB 117 Read AndX Response, FID: 0xc00b, 2 bytes at offset 574
...
12073 4.87261400 192.168.218.204 192.168.218.151 SMB 97 Read AndX Response, FID: 0xc00b
12074 4.87278700 192.168.218.151 192.168.218.204 SMB 99 Close Request, FID: 0xc00b
12075 4.87306900 192.168.218.204 192.168.218.151 SMB 93 Close Response, FID: 0xc00b

Die beiden letzten Zeilen wiederholen sich Inhaltlich danach tausendfach. Dadurch wohl auch die Verzögerung.
Kann mir jemand diese Zeilen erklären? Wieso dauert die Übertragung so lang?

Besten Dank im Voraus.
Mitglied: colinardo
13.01.2014, aktualisiert um 11:29 Uhr
Hallo mt11341,
hast du mal alle QoS Dienste auf deinen Geräten (Router, Switch, etc) in deinem Netzwerk deaktiviert. Vor allem aber auch den QoS-Paketplaner in den Eigenschaften der Netzwerkverbindung des Windows 7 Clients. Ist der Server 2003 die einzige Gegenstelle die so langsam reagiert, bzw. ist es anders herum Server 2003 => WIN7 genauso ?
Was du noch testen kannst ist das Autotuning in Windows 7 zu deaktivieren, das macht manchmal Probleme:
netsh interface tcp set global autotuning=disabled
wenn das keine Besserung bringt stellst du es so wieder zurück:
netsh interface tcp set global autotuning=normal
Normalerweise wird nach einem Read AndX Response der Servers ein Block an Daten übertragen, bevor ein erneuter Request des Client den nächsten Block vom Server anfordert, was hier nicht der Fall ist. Irgendwie können sich Client und Server nicht einigen bzw. eventuell gehen Pakete auf dem Weg verloren, so dass eine erneute Anfrage des Client über die Leitung geht. Überprüfe auch mal die MTU-Size in den Eigenschaften der Netzwerkkarte. Die sollte ja bei normalen LANs 1500 bytes betragen.

Grüße Uwe
Bitte warten ..
Mitglied: mt11341
13.01.2014 um 14:50 Uhr
Hallo Uwe,

QoS im Win7 habe ich auch schon abgeschalten.
Autotuning habe ich auch schon ausgeschalten.
MTU war 1500. Habe ich auch schon mit anderen Werten getestet.
Es geht zu einem anderen Server 2003 auch langsam. Aber zu einem Server 2008 gehts schnell und zu einem weiteren Server 2008 langsam.
Alle Server befinden sich hinter dem gleichen Switch.

Gruß
mt
Bitte warten ..
Mitglied: colinardo
13.01.2014, aktualisiert um 16:32 Uhr
  • Netzwerkkartentreiber aktuell ?
  • mal SMB2 auf Windows 7 deaktiviert / danach Neustart ?
  • Virenscanner (On-Acess-Scanner) deaktiviert ?
  • testweise IPv6 deaktiviert ?
  • Server mal an einen anderen Switchport geklemmt ?

Kannst du das PCAP File mal irgendwo hochladen, das wir mal reinschauen können?
Bitte warten ..
Mitglied: mt11341
14.01.2014 um 07:16 Uhr
Guten Morgen,

Zitat von colinardo:

  • Netzwerkkartentreiber aktuell ?
ja
* mal SMB2 auf Windows 7 deaktiviert / danach Neustart ?
ja, ohne Erfolg
* Virenscanner (On-Acess-Scanner) deaktiviert ?
ja, ohne Erfolg
* testweise IPv6 deaktiviert ?
ja, ohne Erfolg
* Server mal an einen anderen Switchport geklemmt ?
meine Vermutung, das es an der Hardware liegt. Das kann ich erst morgen testen.

Kannst du das PCAP File mal irgendwo hochladen, das wir mal reinschauen können?
Hier habe ich das PCAP-File hochgeladen.

So langsam gehen mir die Nerven durch

Gruß
mt
Bitte warten ..
Mitglied: colinardo
14.01.2014, aktualisiert um 12:45 Uhr
Hallo mt,
hab mir das PCAP-File mal angeschaut, und denke die Verzögerung hat mit dem Opportunistic File Locking des SMB-Protokolls zu tun. Mehr Info dazu findest du hier:
http://www.dataaccess.com/whitepapers/opportunlockingreadcaching.html

Grüße Uwe
Bitte warten ..
Mitglied: 108012
15.01.2014 um 06:01 Uhr
Hallo,

eventuell hast Du die Datei im Explorer in der Vorschau und dann gilt sie mitunter auch schon "als in Benutzung"
und daher kommen diese Latenzen.

Gruß
Dobby
Bitte warten ..
Mitglied: mt11341
15.01.2014, aktualisiert um 08:08 Uhr
Hallo Uwe,
"Opportunistic File Locking" funktioniert nur mit SMB?
Ich habe SMB ausgeschalten - Problem besteht immernoch

Hallo D.o.b.b.y,
kurrios ist aber, dass der Zugriff auf einen anderen Server funktioniert oder in anderen Teilen (hinter anderen Switchen, nicht Subnetze) funktioniert es auch.


Gruß
mt
Bitte warten ..
Mitglied: colinardo
15.01.2014, aktualisiert um 09:01 Uhr
Ich habe SMB ausgeschalten - Problem besteht immernoch
Wie kommst du dann im Explorer auf die Datei ?? wenn du smb komplett abschaltest; wenn das überhaupt geht ...?!
Bitte warten ..
Mitglied: mt11341
15.01.2014 um 13:03 Uhr
Zitat von colinardo:
Wie kommst du dann im Explorer auf die Datei ?? wenn du smb komplett abschaltest; wenn das überhaupt geht ...?!

Ich habe nur SMBv2 ausgeschalten. Komplett abschalten geht auch, dann ist natürlich der Zugriff auf Freigaben nicht möglich.
Bitte warten ..
Mitglied: mt11341
28.01.2014 um 13:03 Uhr
Ich habe die vermutliche Ursache gefunden. Zumindest funktioniert danach ein schneller Zugriff auf Dateien ;)

Ich habe die Office-Dateiüberprüfung (Office File Validation) per regedit ausgeschalten und siehe da, es läuft.

Trotzdem ein Dankeschön an alle.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

Netzwerkverbindung nach Kabelwechsel langsamer

gelöst Frage von Herbiems89LAN, WAN, Wireless4 Kommentare

Hallo, folgende Situation: Arbeitsplatz A: Dose Cat6 + Kabel Cat7 Arbeitsplatz B: Dose + Kabel Cat6 Laptop: Fujitsu Siemens ...

LAN, WAN, Wireless

Langsame Netzwerkverbindung zu bestimmtem Server

Frage von UNIPROLAN, WAN, Wireless7 Kommentare

Hallo Community, mir ist bekannt, dass es zum Thema "langsames Netzwerk" schon so einige Einträge im www gibt. Leider ...

Hyper-V

Netzwerkverbindung einer VM sehr langsam

Frage von 118080Hyper-V13 Kommentare

Ich habe eine VM in Hyper-V erstellt, auf welche ich via RDP zugreifen. Jedoch ist die Verbindung via RDP ...

Google Android

Wireshark für Android

Frage von ReinartzGoogle Android5 Kommentare

Hallo Gemeinde, ich suche eine App die wie Wireshark unter Windows funktioniert nur eben als App auf einem Android ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 3 TagenHumor (lol)5 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...