Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

NTBACKUP Befehlszeile Problem bei Migration von NT4 Server zu Windows2000 Server

Mitglied: chaka

chaka (Level 1) - Jetzt verbinden

14.10.2004, aktualisiert 17.02.2005, 18146 Aufrufe, 13 Kommentare

Befehlszeilen orientierte Sicherung über NTBACKUP funktioniert unter Windows 2000 nicht, bzw. das Skript das unter Windows NT 4 gelaufen ist kann leider nicht unter WINDOWS 2000 zum laufen gebracht werden.

In unserem kleinen Betrieb haben wir einen NT 4 Server eingesetzt der um 22:00h die DB heruntergefahren hat und der Streamer (HP SCSI) diese gesichert hat. Nach beendigung wurde das Band rausgeworfen. Jetzt mußten wir auf Windows 2000 Server migrieren, leider besteht ein Problem mit NTBACKUP unter Windows 2000. NTBACKUP sichert nicht über den Befehlscode noch schmeist es das TAPE raus. Folgendes Skript wurde unter WIN NT 4 genutzt (Aufruf der .BAT Datei über AT):

@echo off
cls
echo BRZ-Datenbank wird geschlossen....
echo:
date /T >e:\tmp\2.txt
time /T >e:\tmp\4.txt
e:\brz32\dbsrv\stopsb.exe
echo:
echo Sicherung von e:\brz32\*.* beginnt....
echo:
ntbackup backup e:\brz32 /d"SicherungBRZ" /hc:on
echo:
echo Sicherung beendet....
echo:
echo Auswurf des Bandes....
ntbackup eject
echo:
time /T >e:\tmp\6.txt
echo:
ECHO Starting Sybase Database Server .....
E:\brz32\Dbsrv\dbsrv8.exe -xTCPIP -ti 4320 -n BRZSERVER E:\Brz32\Daten\Brzdatmp.db

Was muß geändert werden damit dieses Skript unter WINDOWS 2000 Server lauffähig wird ?

Ich möchte nur ein Verzeichnis komplett sichern. Am Montag wird das erste Band eingelegt, am DI das 2te. usw. bis MO wieder das 1ste. eingelegt wird. (Gegen 22h wurde bisher gesichert und nach Sicherung das Band ausgeworfen)
Mitglied: Atti58
14.10.2004 um 10:43 Uhr
Die einzige Zeile, die das Backup anstößt, ist ja:

ntbackup backup e:\brz32 /d"SicherungBRZ" /hc:on

Wenn ich mir die Hilfe ansehe, stelle ich bei den Beispielen nur fest, dass ein Leerzeichen zwischen der Option und dem Optionstext ist, also

ntbackup backup e:\brz32 /d "SicherungBRZ" /hc:on

Was passiert, wenn Du diese Befehlszeie direkt an der Eingabeaufforderung eingibst, bekommst Du eine Fehlermeldung?

In der Batchprogrammierung habe ich mir immer zum "debuggen" hinter jede "aktive" Zeile einen "Pause"-Befehl eingebaut, so konnte ich sehen, wo es hängt ...

Gruß

Atti
Bitte warten ..
Mitglied: Atti58
14.10.2004 um 10:49 Uhr
... vergessen:

Den "eject".Befehl sehe ich in der Hilfe gar nicht, es kann sein, dass der ganz weggefallen ist ...

Gruß

Atti
Bitte warten ..
Mitglied: chaka
14.10.2004 um 11:54 Uhr
...genau

den eject befehl sehe ich auch nicht mehr sondern bin auf auf den befehl rsm gestossen.
Bitte warten ..
Mitglied: Atti58
14.10.2004 um 12:28 Uhr
Hast Du das denn mal mit der Eingabeaufforderung probiet?

Atti
Bitte warten ..
Mitglied: chaka
14.10.2004 um 12:35 Uhr
ja unter der der cmd-zeile habe ich schon so einiges versucht
Bitte warten ..
Mitglied: Pengo
14.10.2004 um 13:34 Uhr
Wir führen das Backup der W2K-Server auch mit Windows-Bordmitteln durch.
Dazu benutzen wir 2 Dateien; einmal das Batchskript backup.cmd, sowie für die zu sichernden Partitionen backup.bks.
Beide Dateien stehen in diesem Beispiel im Verzeichnis c:\backup.
Im Skript muß das Sicherungsmedium ggf. angepaßt werden - Schalter /p, hier mit "DLT".
In der BKS-Datei natürlich die gewünschten Partititonen eintragen.
Gestartet wird der Job zeitgesteuert mit "Geplante Tasks" durch Aufruf der backup.cmd.

backup.cmd
C:\WINNT\system32\NTBACKUP.EXE backup "@C:\backup\backup.bks" /d "Backup Server XYZ" /v:yes /r:yes /rs:no /hc:on /m normal /j "Serverbackup" /l:f /um /p "DLT"


backup.bks
C:\
E:\
F:\
SystemState
Bitte warten ..
Mitglied: chaka
14.10.2004 um 14:00 Uhr
i Pengo,

d.h. du hast mit der GUI die backup.bks erstellt? Oder kann die backup.bks als Textdatei wie du angegeben hast editiert werden ?

Des weiteren würde mich noch der Schalter /P interessieren. Ich habe hier einen HP DAT SCSI C5683 (auf ID3) mit dem Windows Treiber 4mmdat.sys (Ver. 5.00.2195.6655). Was müßte dabei beachtet / geändert werden?

Laut Hilfe:
/P {"Poolname"}
Gibt den Medienpool an, aus dem die Medien entnommen werden sollen. In der Regel ist dies ein Teilpool des Sicherungsmedienpools, beispielsweise 4-mm-DDS. Wenn Sie diesen Parameter verwenden, dürfen die folgenden Parameter nicht eingesetzt werden: /A /G /F /T.

Könnte mich darüber jemand etwas aufklären ?

Vielen Dank.
Bitte warten ..
Mitglied: Pengo
14.10.2004 um 14:28 Uhr
d.h. du hast mit der GUI die backup.bks
erstellt? Oder kann die backup.bks als
Textdatei wie du angegeben hast editiert
werden ?

Beim ersten Test bzw. Server hab ich's mit der GUI erstellt. Man kann die aber problemlos mit Hand editieren.

Des weiteren würde mich noch der
Schalter /P interessieren. Ich habe hier
einen HP DAT SCSI C5683 (auf ID3) mit dem
Windows Treiber 4mmdat.sys (Ver.
5.00.2195.6655). Was müßte dabei
beachtet / geändert werden?

Ich denke, Du müßtest /p "4mm DDS" eingeben.
Starte mal die Sicherungs-GUI. Auf der Registerkarte "Sichern" kannst Du unten bei "Sicherungsziel" Dein Bandlaufwerk oder "Datei" auswählen. Das ist genau die Bezeichnung, die der Schalter /p benötigt.
Bitte warten ..
Mitglied: Maximon
14.10.2004 um 17:28 Uhr
... vergessen:

Den "eject".Befehl sehe ich in der
Hilfe gar nicht, es kann sein, dass der ganz
weggefallen ist ...

Gruß

Atti

jau.. den cmd gibts nich mehr.. läuft jetzt alles über rsm ... lautet wie folgt für eject:

rsm.exe eject /PF"Name - 1" /astart

"Name" muss in diesem Fall durch deinen Mediennamen ersetzt werden

funktioniert wunderbar

Gruß

Thorsten
Bitte warten ..
Mitglied: pate4ever
19.10.2004 um 11:48 Uhr
Das Hauptproblem liegt nicht bei deiner Befehlszeile, sondern im RSM. RSM verwaltet die Bänder und schafft es leider nicht, ein ausgeworfenes Band auch als solches zu erkennen bzw. auch bei Refresh wird nicht erkannt welches Band eingelegt ist.

Erst mit einer Backupaufforderung erfolgt der eigentliche Refresh und das Programm erhält eine Fehlermeldung zurück und startet nicht das Backup. Darum benötigt man zu Beginn eine zusätzliche Befehlszeile um diese FM zu umgehen. Erst der 2. Backup Aufruf wird tatsächlich durchgeführt.

Um ein problemloses Erkennen des Bandes zu gewährleisten, sollte man auch nach dem Auswerfen den RSM-Dienst stoppen und wieder starten (mit Sleep.exe kurz warten und den Befehl auch in die LOG-Datei umleiten).

Wenn Du nicht selbst zu einer Lösung kommst, schreibe ein Mail an "n-o.b-o-d-y-@-a-1.n-e-t" jeweils ohne dem Bindestrich (es handelt sich um eine Alias-Adresse, wenn zuviel Spam kommt werde ich sie wieder löschen ) und ich kann Dir meine Lösung schicken (hat aber ein anderes Sicherungskonzept und Du mußt es noch umschreiben, ist aber dokumentiert).

Trotzdem noch viel Spaß
Bitte warten ..
Mitglied: chaka
17.11.2004 um 08:41 Uhr
Hi Pate,
könntest du mir dabei helfen ?
Ich hatte dir eine email geschrieben, leider ohne erfolg..
Bitte warten ..
Mitglied: chaka
25.11.2004 um 16:07 Uhr
Habe auch die folgenden Zeilen versucht:

C:\WINNT\system32\NTBACKUP.EXE backup "@D:\Sicherungsprofil.bks" /n "Medium am 25.11.2004 um echo Auswurf des Bandes....
rsm.exe eject /PF"4mm DDS - 1" /astart

Er startet zwar das Programm, es geschieht dann jedoch nichts mehr (
Bitte warten ..
Mitglied: pate4ever
17.02.2005 um 17:48 Uhr
Die Namen funktionieren nicht 100%ig, besser man verwendet immer die GUIDs, also auch:

rsm.exe eject /PG%BandGUID% /astart

Wobei %BandGUID% eine Variable ist, zu Beginn vom Script mit dieser Zeile die GUID eingelesen wird:

FOR /F " usebackq delims==" %%i IN (`rsm view /Tphysical_media /CG%TapeLibGUID% /B /GUIDDISPLAY`) DO set medGUID=%%i

Am besten immer alle Befehle zuerst in einem DOS-Fenster testen und sehen, welche Meldungen kommen und wie danach die Variablen gesetzt sind (abfragen mit "set").

Auch bei jedem Bandwechsel den Dienst "Wechselmediendienst" stoppen und neu starten, danach ein Inventory (mir fällt die deutsche Bezeichnung nicht ein) durchführen und erst dann hat rsm mit großer Wahrscheinlichkeit das Band richtig erkannt
Bitte warten ..
Ähnliche Inhalte
Exchange Server
Exchange Migrations Problem
gelöst Frage von DanielZ87Exchange Server4 Kommentare

Hallo Zusammen, folgendes Problem: Ich habe eine Migration von Exchange 2003 auf 2010 durchgeführt. Jedoch habe ich Probleme mit ...

Vmware

Problem mit Migration von Workstation auf vSphere

gelöst Frage von MLubrichVmware3 Kommentare

Hallo Leute, ich habe ein Problem, dass sich nach der Migration eines Servers zeigte. Die Migration erfolgte aus der ...

TK-Netze & Geräte

Wählfunktion MyPortal Befehlszeile Telekom

Frage von OSelbeckTK-Netze & Geräte2 Kommentare

Hallo, ich möchte per Befehlszeile aus unserem ERP Programm die CTI Funktion von myPortal benutzen. geht das überhaupt bei ...

Batch & Shell

Ungewolltes Ausgabeformat in CMD (Befehlszeile+ Befehl)

Frage von DerArneBatch & Shell3 Kommentare

Guten Tag liebes Forum, an sich war mein Anliegen diverse Fragen zu meiner Batch zu klären. Nun hat sich ...

Neue Wissensbeiträge
Peripheriegeräte
Unterschrank für HP Drucker
Tipp von NixVerstehen vor 2 TagenPeripheriegeräte3 Kommentare

Als kurzen Freitags-Tipp möchte ich gerne meinen neuen Drucker-Unterschrank Modell Amica KS 15423W vorstellen. Das Gerät eignet sich hervorragend ...

Windows 10
Windows 10 - Probleme mit Point-And-Print
Tipp von emeriks vor 3 TagenWindows 103 Kommentare

Hi, wir kämpfen z.Z. mit einigen Druckertreibern, welche unter Win10 beim Verbinden eines Druckers von Printserver mit dem Dialog ...

Windows 10

Windows 10 1803 - Ihr Roamingbenutzerprofil wurde nicht vollständig synchronisiert

Anleitung von Deepsys vor 3 TagenWindows 101 Kommentar

Bei allen Windows 10 1803 PCs traten Probleme mit den Servergespeicherten Profilen auf. Das Abmelden dauerte sehr lange und ...

Exchange Server
Exchange - Fehler mit 2018-07 Sicherheitsupdate
Tipp von ArnoNymous vor 5 TagenExchange Server7 Kommentare

Hallo, es gibt mal wieder Freude mit den MS-Updates. KB4338814 führt dazu, dass der Exchange keine Mails mehr zustellt. ...

Heiß diskutierte Inhalte
LAN, WAN, Wireless
HP Probook 470 G4 - abbrechende Downloads
Frage von joern1LAN, WAN, Wireless19 Kommentare

Folgendes Problem, für einen Tipp wäre ich dankbar: Bei WLAN-Verbindung zum Internet (nicht LAN) kommt es bei etwas größeren ...

Server-Hardware
DL380p Gen8 LEDs Laufwerksaktivität funktionieren nicht
Frage von Cisco7971Server-Hardware17 Kommentare

Hallo zusammen, ich habe hier ein seltsames Problem: Die LEDs an den Smart Carriern, die bei Laufwerksaktivität rotieren, tun ...

Server-Hardware
Einsteigerfragen zu HP ProLiant DL380p Gen 8
gelöst Frage von brain2011Server-Hardware15 Kommentare

Hallo, ich habe mir einen HP ProLiant DL380p Gen 8 zugelegt, um mich grundlegend mit dieser Geräteklasse und der ...

Windows Server
Leistungsindikatoren WS2012R2
Frage von Der.ITlerWindows Server11 Kommentare

Hallo Gemeinde, seit gestern habe ich auf zwei von meinem 8 Hardwareservern folgendes Problem, dass die Leistungsindikatoren nicht gestartet ...