Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst NTLM-Proxyauth funktioniert unter Windows Server 2003 nicht

Mitglied: tikayevent

tikayevent (Level 3) - Jetzt verbinden

17.11.2009 um 16:33 Uhr, 6837 Aufrufe, 3 Kommentare

Moin,

ich habe hier einen Proxyserver unter Debian Lenny, welcher gegen mein AD die Benutzer authentifiziert. An den Clients funktioniert es wunderbar. Auf meinem Terminalserver (Windows Server 2003 Enterprise x86) leider nicht. Dort kommt keinerlei Nachfrage nach einem Passwort, sondern der Internet Explorer bricht die Anforderung einfach mit einer Standardfehlerseite ab.

Sobald ich eine Ausnahmeregel für den Anwendungsserver einrichte, komm ich damit problemlos ins Internet.

Die Integrierte Windows-Anmeldung ist im Internet Explorer aktiviert.

Proxyserver:

Debian Lenny x86
Squid 2.7
Samba3/Winbind
squidGuard
havp
Auth erst über NTLM, danach über Basic gegen Active Directory

Anwendungsserver

Windows Server 2003 Enterprise x86
Internet Explorer 7
aktuelle Updates sind installiert

Das Problem tritt auch bei meinem Domänencontroller auf (Windows Server 2003 Standard x86), da ist es mir aber egal, der ist nicht zum surfen da.

Die Konfiguration findet über eine wpad.dat statt und funktioniert auch. Die Konfigurationsdatei kann ich mit dem Anwendungsserver aufrufen und lesen.

Hat einer eine Idee, wie ich das Problem lösen kann? Gerade auf dem Anwendungsserver ist es mir wichtig, dass ich eventuellen Bullshit einem Benutzer zuordnen kann.

MfG

Kochi
Mitglied: dog
17.11.2009 um 17:08 Uhr
Nur so als Idee: Sind DNS-Name/IP des Proxies im IE in der Zone "Lokales Intranet"?

Grüße

Max
Bitte warten ..
Mitglied: tikayevent
17.11.2009 um 17:11 Uhr
Jop, sindse

Ich hab das ganze jetzt auch mal mit dem Firefox probiert, da gehts auch nicht.

Ich habe u.a. auch noch die Sharepoint-Services in Benutzung und da funktioniert die Anmeldung (die meines Wissens auch per NTLM läuft) einwandfrei und wunderbar.
Bitte warten ..
Mitglied: tikayevent
19.11.2009 um 23:01 Uhr
So, ich hab das Problem jetzt gelöst.

Squid nutzt mit der mitgelieferten Version von ntlm_auth nur die LM-Auth, welche vergleichbar mit NTLM ist, aber halt nicht identisch. Bei Windows XP war es noch so, dass die LM-Auth standardmäßig nutzbar war, bei 2003 war aber nur noch NTLM und NTLMv2 Standard.

Mit einem kleinen Eingriff in die Registry

1. In HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
If it doesn’t exist, create a DWORD value named LmCompatibilityLevel and set
the value to 1 to use LM NTLM and NTLMv2 if is negociated, this is
Also it works establishing the value to 0, and 3 though for more safety the
value using 3 though with old operating systems it will not work on having
used obligatorily NTLMv2.

2. Reboot

Wie bin ich darauf gekommen? Das Problem besteht auch bei Windows 7 (und sicher auch bei Vista)
Bitte warten ..
Ähnliche Inhalte
Windows Netzwerk
NTLM in Domäne deaktivieren
Frage von StefanK007Windows Netzwerk

Hallo, wir haben vor Kurzem unsere Windows 2008 R2 Domänencontroller durch Windows 2012 R2 DCs ersetzt und schauen nun ...

Windows Server
Windows Server Sicher funktioniert nicht
Frage von W1n5t0nWindows Server4 Kommentare

Hallo, Wir haben zurzeit das Problem das bei unserem Server die Windows Server Sicherung nicht richtig läuft. Wir haben ...

Outlook & Mail

Outlook Netzwerksicherheit NTLM verstellt sich immer wieder

Frage von pastorOutlook & Mail

Hallo ich bräuchte mal etwas hilfe ;-) Folgende Umgebung vorhanden: - Server 2008 - Exchangeserver 2010 Client: - Outlook ...

Windows Server

Windows server 2012r2 windows server sicherung funktioniert nicht

Frage von meister00Windows Server3 Kommentare

hallo, ich habe eine Windows 2012 r2 failovercluster, das backup habe ich mit der Windows Server Sicherung gemacht. seit ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 2 TagenWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 2 TagenAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Router & Routing
Router auf Orginal Firmware zurück flashen mit Tftpd
Frage von ILeonardRouter & Routing21 Kommentare

Hallo, Ich habe zwei Router, einmal TP-Link 841n v11 und TP-Link 940N v5. Ich wollte fragen, ob jemand mir ...

Router & Routing
WRT keine Verbindung zum Web Interface
gelöst Frage von ILeonardRouter & Routing18 Kommentare

Hallo, Ich habe einen TP-Link WR841n mit wrt geflasht, das Problem ist ich kann mich mit 192.168.1.1 nicht verbinden. ...

TK-Netze & Geräte
Telefonie zweier Fritzboxen mit je eigenem DSL Anschluss verbinden
Frage von hannsgmaulwurfTK-Netze & Geräte10 Kommentare

Hallo zusammen, ich habe hier einen Haushalt mit zwei Anschlüssen. Einmal ISDN, einmal DSL. An jedem Anschluss hängt eine ...

Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...