Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

OpenVPN Dienst startet mit falscher Config

Mitglied: Sniffer

Sniffer (Level 1) - Jetzt verbinden

26.01.2009, aktualisiert 14:11 Uhr, 3363 Aufrufe, 1 Kommentar

Hallo zusammen,

ich hab seit heute mal wieder ein Problem, und zwar setz ich grad nen OpenVPN Server auf. Die Verbindung an sich klappt wunderbar, jedoch muss ich die Serverdatei ständig mit dem Befehl openvpn --config server.conf starten.

Wenn ich den OpenVPN Server über den Dienst (/etc/init.de/openvpn start) starte bekomme ich als Rückmeldung nur failed. Wenn ich dann in die Log Datei sehe, sieht man dass er einige Dateien oder Zertifikate nicht findet die in meiner Config nicht verwendet werden, daher gehe ich davon aus, dass der Server mit der falschen server.conf startet. Jedoch weiß ich jetzt nicht wo ich den entsprechenden Eintrag ändern kann.

Um Hilfe wäre ich sehr dankbar

Gruß Christian
Mitglied: TB-Master
21.02.2009 um 13:12 Uhr
Hallo Christian,

ich weiß nicht welche Distri du verwendest, aber unter gentoo arbeitet das init script mit symlinks.
Also wenn deine Config server.conf heißt müsstest du in /etc/init.d einen symblink mit dem gleichen namen auf /etc/init.d/openvpn anlegen. (ln -s openvpn server). Dann sollte die richtige config verwendet werden. Ansonsten wird versucht die standardconfig openvpn.conf zu verwenden.

Toni
Bitte warten ..
Ähnliche Inhalte
Netzwerkprotokolle

OpenVPN selbe config funktioniert an einem Rechner nicht

gelöst Frage von PharITNetzwerkprotokolle4 Kommentare

Hallo, hat jemand vielleicht noch eine Idee für mich? Ich nutze ein und dieselbe config Datei testweise an einem ...

Windows Server

Dienst startet nicht automatisch

Frage von steftsWindows Server1 Kommentar

Hallo zusammen, auf einem SBS 2011 System gibt es einen Dienst, der nach Neustarts nicht immer automatisch startet. Es ...

Windows Server

Dateireplikation Dienst startet nicht

gelöst Frage von skahle85Windows Server2 Kommentare

Detecting this machine's domain role Domain Controller (PDC) Processing File Replication Service Event Log 38 itemsDone! Processing Application Event ...

Apache Server

Nach mod.auth.sspi - Dienst startet nicht mehr

gelöst Frage von -s-v-o-Apache Server

Hallo zusammen Habe aktuell ein dringendes Problem welches ich bis morgen gelöst haben sollte. Ich muss ein neues Dokuwiki ...

Neue Wissensbeiträge
Server-Hardware
HP iLO ist gefährdet (iLO 4))
Tipp von AlFalcone vor 8 StundenServer-Hardware

Gemäss Twitter und Heise gibt es eine Angriffsmöglichkeit auf iLO Quelle: iLO ist gefährdet

CMS
Erneut kritische Zero-Day-Lücke in Drupal
Tipp von Reini82 vor 17 StundenCMS

Laut einem Bericht auf t3n gibt es eine Schwere Sicherheitslücke in Drupal die auch schon ausgenutzt wird. Betroffen sind ...

Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgborn vor 1 TagSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Windows 10

Microcode-Updates KB4090007, KB4091663, KB4091664, KB4091666 für Windows 10

Information von kgborn vor 1 TagWindows 101 Kommentar

Kurze Information für Administratoren von Windows 10-Systemen, die mit neueren Intel CPUs laufen. Microsoft hat zum 23. April 2018 ...

Heiß diskutierte Inhalte
Ausbildung
Wie gelingt ein guter Einstieg in die FiSi-Ausbildung? (Umschulung)
Frage von SiAnKoAusbildung29 Kommentare

Schönen guten Tag, ich bin SiAnKo und habe seit dem 1.04.2018 eine Umschulung als FiSi angefangen. Ich möchte natürlich ...

Windows Server
Alten DC entfernen
gelöst Frage von smartinoWindows Server27 Kommentare

Hallo zusammen, ich habe hier eine Umgebung übernommen und erstmal einen DCDIAG gemacht. Dabei fällt auf, daß eine ganze ...

Batch & Shell
Mit Powershell den Inhalt einer Excel mit einer Text Datei abgleichen
gelöst Frage von Bommi1961Batch & Shell21 Kommentare

Hallo zusammen, ich muss den Inhalt einer Excel Datei (Mappe1) mit dem Daten einer Text Datei abgleichen. Die Daten ...

Router & Routing
Subnetzmaske vergrößern
gelöst Frage von groovesurferRouter & Routing18 Kommentare

Hallo, hat jemand schonmal getestet was passiert, wenn man die Subnetzmaske bei laufendem Betrieb (wenn user im Netzwerk verbunden ...