Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst OpenVPN mit OpenSuse 10.3 als Server und Win2000 als Virtuelle Maschine

Mitglied: Abu

Abu (Level 1) - Jetzt verbinden

22.04.2008, aktualisiert 10.07.2008, 6190 Aufrufe, 1 Kommentar

Hallo Forum!

Ich versuche seit Tagen OpenVPN zum laufen zu bringen aber leider ohne vollständigen Erfolg.

Folgende Systeme habe ich:

Host-System: OpenSuse 10.3
Gast-System: Windows2000 auf ner Virtuellen Maschine (Innotek VirtualBox)

Auf der Suse läuft der Server einwandfrei.

Unter Windows2000 und der OpenVPN-Gui bekomme ich es nicht hin.

Habe diese HowTo Installationsanweisung unter anderem probiert:
http://www.pronix.de/pronix-935.html

Ich habe schon dutzende Male die Zertifikate erstellt aber leider gibt mir Windows immer einen "Handshake failed" und einen "soft-tls" Fehler aus.

Meine config-datei auf dem Server sieht so aus:


port 443
proto udp
dev tun

tun-mtu 1492
fragment 1300
mssfix

ca vpn-ca.pem
cert servercert.pem
key serverkey.pem
dh dh1024.pem
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt

push "route 192.168.0.0 255.255.255.0"

keepalive 10 120
auth SHA1

cipher AES-256-CBC

comp-lzo

user nobody
group nobody

persist-key
persist-tun

verb 3


Die Config des clients sieht so aus:



client
float
dev tap
;tun-mtu 1492
fragment 1300
mssfix
  1. Der Name des tun/tap Devices in der
  2. Netzwerkkonfiguration.
  3. Ich habe das Device my-tap genannt.
dev-node my-tap
proto udp
;remote 1.1.1.1 443
remote 10.8.0.4 443
  1. Wir erlauben nur eine Verbindung zu
  2. unserem Server. Wir haben bei der
  3. Zertifiakt Erstellung dem Server
  4. den Common Name server gegeben und
  5. erzwingen so, dass sich auch der Server
  6. beim Client authentifizieren muss
tls-remote server
ca 01.pem
cert ca.crt
key ca.key
auth SHA1
cipher aes-256-cbc
nobind
comp-lzo
persist-key
persist-tun
verb 3


Ich habe die Zertifikate schon x-mal manuell und auch mit easy-rsa erstellt aber immer wieder kommt folgender Fehler im Windows OpenVPN-Gui:

Tue Apr 22 00:33:31 2008 OpenVPN 2.0.9 Win32-MinGW [SSL] [LZO] built on Oct 1 2006
Tue Apr 22 00:33:31 2008 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA. OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Tue Apr 22 00:33:32 2008 LZO compression initialized
Tue Apr 22 00:33:32 2008 Control Channel MTU parms [ L:1594 D:138 EF:38 EB:0 ET:0 EL:0 ]
Tue Apr 22 00:33:32 2008 Data Channel MTU parms [ L:1594 D:1300 EF:62 EB:135 ET:32 EL:0 AF:3/1 ]
Tue Apr 22 00:33:32 2008 Fragmentation MTU parms [ L:1594 D:1300 EF:61 EB:135 ET:33 EL:0 AF:3/1 ]
Tue Apr 22 00:33:32 2008 Local Options hash (VER=V4): 'c5058fa7'
Tue Apr 22 00:33:32 2008 Expected Remote Options hash (VER=V4): '4e321a9f'
Tue Apr 22 00:33:32 2008 UDPv4 link local: [undef]
Tue Apr 22 00:33:32 2008 UDPv4 link remote: 1.1.1.1:443
Tue Apr 22 00:34:32 2008 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Tue Apr 22 00:34:32 2008 TLS Error: TLS handshake failed
Tue Apr 22 00:34:32 2008 TCP/UDP: Closing socket
Tue Apr 22 00:34:32 2008 SIGUSR1[soft,tls-error] received, process restarting
Tue Apr 22 00:34:32 2008 Restart pause, 2 second(s)


Das wiederholt sich immer wieder. Sad

Der Server rührt sich kein Stück. Der läuft und läuft und läuft...
Spuckt also keine Meldung aus.

Was muß ich tun um OpenVPN dazu zu bringen sich mit den beiden Rechnern zu unterhalten und eine Verbindung aufzubauen???

Vielen Dank im Voraus für Eure Hilfe.

Gruß aus Köln
Mitglied: michalsw
10.07.2008 um 15:07 Uhr
Welche Adresse hat der Suse server? Es sieht aus als wenn sich der Client auf die 1.1.1.1 443 verbinden möchte.
Versuch mal die Einträge in der Config unter Windows mit einer "#" auszukommentieren und nicht mit ";" - Vielleicht hilfts...
Bitte warten ..
Ähnliche Inhalte
Windows Server
Virtuelle Maschine auf Foundation-Server
gelöst Frage von SarekHLWindows Server13 Kommentare

Hallo zusammen, eine Kundin hat einen Microsoft Server 2008 R2 Foundation (läuft ohne Domäne). Darauf benötigt sie jetzt eine ...

Suse

SSH-Key-Authentifizierung über openSUSE 10.3

gelöst Frage von 98500Suse7 Kommentare

Hey@ALL Folgendes ist vorhanden: - Server mit openSUSE 10.3 - SSH Version: OpenSSH_4.6p1, OpenSSL 0.9.8e 23 Feb 2007 In ...

Virtualisierung

Zugriff auf Virtuelle Maschine ohne PC

gelöst Frage von EisernVirtualisierung4 Kommentare

Hallo, ich hoffe hier einigermaßen richtig zu sein und bitte um Hilfe bezüglich meiner derzeitigen Gedanken. Ich habe mir ...

Windows Netzwerk

Welche Festplattenkonfiguration für Virtuelle Maschinen

Frage von WarrenderWindows Netzwerk5 Kommentare

Hallo, nach Empfehlungen eines Users hier im Forum habe ich mein System folgender Maßen konfiguriert: Raid 1: Mit WinServer2012R2 ...

Neue Wissensbeiträge
Backup

2016 - Restore mit WBAdmin - iSCSI Device als Sicherungsziel

Erfahrungsbericht von Henere vor 16 StundenBackup1 Kommentar

Servus zusammen, was mich eben einige graue Haare gekostet hat Server 2016. Ich habe meinem Server eine weitere M2 ...

Humor (lol)
(Part num your Hacked phone. +XX XXXXXX5200)
Erfahrungsbericht von Henere vor 2 TagenHumor (lol)7 Kommentare

Mein Handy hat aber ne ganz andere Endnummer. Muss ich mir jetzt Sorgen machen ? :-) Vielleicht betrifft es ...

Exchange Server

Letztes Update für Exchange 2016 CU9 war in gewisser Weise destruktiv

Erfahrungsbericht von DerWoWusste vor 2 TagenExchange Server8 Kommentare

Kurzer Erfahrungsbericht zu Exchange2016-KB4340731-x64 Der Exchangeserver hat wie gewöhnlich versucht, es in der Nacht automatisch zu installieren - abgesehen ...

Erkennung und -Abwehr

Neue Sicherheitslücke Foreshadow (L1TF) gefährdet fast alle Intel-Prozessoren

Information von Frank vor 3 TagenErkennung und -Abwehr3 Kommentare

Eine neue Sicherheitslücke, genannt Foreshadow (alias L1TF) wurde auf der Usenix Security 18 von einem Team internationaler Experten veröffentlicht. ...

Heiß diskutierte Inhalte
Windows Server
Server 2016 Autotiering Storage Space
Frage von HenereWindows Server10 Kommentare

Servus, ich habe jetzt ein StorageSpace auf einem Server 2016 in Betrieb zum Testen. 1x M2 mit 512GB (970pro) ...

Hyper-V
Hyper-V keinen Zugriff auf USB Gerät über USB Server
Frage von Barns83Hyper-V10 Kommentare

Normal bin ich ein stiller Leser und wühle mich im normal Fall durch Foren oder schau durch meine Bücher. ...

Netzwerke
SSH - Wieso werde ich nach VPN Verbindung rausgeschmissen?
Frage von VernoxVernaxNetzwerke10 Kommentare

Hallo, ich habe es endlich geschafft mein Handy mit einer VPN Verbindung an meinen Router anzuschließen. Nach der Login ...

Multimedia
Live TV mit Raspberry
Frage von honeybeeMultimedia9 Kommentare

Hallo, ich bin relativ neu im Umgang mit Raspberry und habe folgendes Problem: Ich habe keinen Fernsehanschluss über Kabel ...