Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Outlook Application ItemSend funktioniert nicht bei Senden an E-Mail-Empfänger

Mitglied: problemsolver

problemsolver (Level 2) - Jetzt verbinden

19.06.2006, aktualisiert 20.09.2006, 10599 Aufrufe, 2 Kommentare

Ich habe das Problem, dass die eingebaute Routine in Outlook es nicht ermöglicht, das Mail-Objekt abzufangen. Habt Ihr Alternativen bzw. eine Lösung?

Hallo zusammen,

kurz und knapp:
mein Code:
01.
Private Sub Application_ItemSend(ByVal Item As Object, Cancel As Boolean) 
02.
    Cancel = OrdnerKopieSetzen(Item) 
03.
End Sub
Leider funktioniert der Code nicht, sobald ich im Explorer "Senden an" --> "E-Mail-Epfänger" auswähle und die Mail abschicke.

Gibt es eine Möglichkeit das Object-Item auf einem anderen Weg abzufangen und zu manipulieren? Am liebsten wäre mir eine globale Möglichkeit. (evtl. Überwachung von allgemeinen Events in Outlook)

Wer hatte schon einmal dieses Problem gelöst und will mir kurz helfen? Hab schon Stunden damit verbracht und habe ohne Ende Foren gewälzt...

Vielen vielen Dank schon einmal im Voraus!

Gruß

Markus
Mitglied: problemsolver
20.06.2006 um 07:56 Uhr
Hallo noch einmal!

gibt es hier denn wirklich niemanden, der dieses Problem schon einmal gehabt hat?
Es würde auch schon an dieser Stelle reichen, eventuelle Erfahrungen zu diskutieren bzw. wie und wo man schon nach Lösungen gesucht hat.
Gibt es evtl. schon COM-Addins oder andere Lösungen, die dieses Problem nicht besitzen?

Einfach mal wild drauf los schreiben!!!

Vielen Dank!

Gruß

Markus
Bitte warten ..
Mitglied: problemsolver
20.09.2006 um 18:47 Uhr
Hi Belmondo,

ich habe einen Workaround benutzt... Hilft zwar nicht nicht komplett bei allen Dingen aber für mich hat es gereicht...

Private Sub Application_ItemSend(ByVal Item As Object, Cancel As Boolean)

kennst du ja sicherlich mittlerweile In und Auswendig. Es greift aber nur, wenn innerhalb von Outlook etwas geschieht....

dazu benutze ich noch das hier, um den Gesendeten Objekte Ordner zu überwachen.

Public Sub Application_Startup()


Set myOlItems = Outlook.Session.GetDefaultFolder(olFolderSentMail).Items

End Sub

Sobald etwas im Gesendete Objekte Ordner erscheint, wird dieses automatisch ausgeführt:

Private Sub myOlItems_ItemAdd(ByVal Item As Object)

End Sub

Allerdings gibt es hierbei kein "Cancel" und es greift erst, nachdem das Objekt im Gesendeten Ordner erscheint (also schon verschickt ist...)


Ich hoffe ich konnte dir trotzdem helfen und allen anderen, die nach dieser Lösung suchen.

Schreib doch mal, ob du damit was anfangen konntest.

Gruß

Markus
Bitte warten ..
Ähnliche Inhalte
Windows 7

Windows 7 "Senden an - E-Mail-Empfänger" funktioniert nicht

Frage von FalaffelWindows 73 Kommentare

Guten Morgen, ich habe an einem Rechner das Problem, dass unter Windows 7 sehr sporadisch bei Klick auf "Senden ...

Outlook & Mail

Thunderbird Senden an E-Mail-Empfänger

gelöst Frage von DasWombat1993Outlook & Mail3 Kommentare

Liebe Administratoren, Ich habe folgendes Problem mit Thunderbird 52.1.1 unter Windows 7 64 bit: Wenn ich auf einer Datei ...

Windows 10

Senden an E-Mail-Empfänger - Windows 10-1709

gelöst Frage von MiStWindows 109 Kommentare

Hallo, seit dem 1709er-Update kann ich keine Dokumente mehr aus anderen Programmen per Outlook 2010 (mit Exchange) versenden. Auch, ...

C und C++

E-Mails Senden und Empfangen mit C-Sharp

Frage von leon123C und C++1 Kommentar

Hallo zusammen, ich möchte gerne eine kleine Applikation schreiben, die nichts anderes macht wie E-Mails über IMAP oder POP ...

Neue Wissensbeiträge
Humor (lol)
IoT-Gefahr: Smartes Aquarium leckt!
Information von Lochkartenstanzer vor 17 StundenHumor (lol)3 Kommentare

Moin, Die IoT-Manie hat weitere Opfer gefunden. Ein Casino-Leck durch ein smartes Aquarium: Allerdings haben sie kein Wasser, sondern ...

Router & Routing

Alte Fritzbox 7270 mit VPN und SIP-Telefonie hinter O2 Homebox 6641 als "Modem"

Erfahrungsbericht von the-buccaneer vor 1 TagRouter & Routing3 Kommentare

Nun war es soweit: Auch O2 hat mich mit VOIP zwangsbeglückt. Heute am Privatanschluss, in 2 Wochen ist das ...

Sicherheit

Ungepatchte Remote Code Execution-Lücke in LG NAS

Information von kgborn vor 1 TagSicherheit

Nutzt wer LG NAS-Einheiten? In den NAS-Einheiten der LG Network Storage-Einheiten gibt es eine sehr unschöne Schwachstelle, die einen ...

Windows Update

Neue Version KB4099950 NIC Einstellungen gehen verloren

Information von sabines vor 1 TagWindows Update2 Kommentare

Es ist eine neue Version des KB4099950 verfügbar, die das Problem mit den verlorenen Netzwerkeinstellungen lösen soll. Das Datum ...

Heiß diskutierte Inhalte
Sicherheit
Verbindliche Zustellung per E-Mail?
Frage von ahussainSicherheit18 Kommentare

Hallo allerseits, ein Kunde von mir nutzt intensiv Fax. Hauptgrund: zusammen mit einer Empfangsbestätigung ist eine verbindliche Zustellung gewährleistet. ...

Sonstige Systeme
Wie Normenkataloge im Unternehmen bereit stellen?
Frage von MuzzepuckelSonstige Systeme14 Kommentare

Hallo Kollegen, ich lese schon lange hier mit, nun mein ersrer Beitrag, bzw. Frage. :-) Wir benötigen für unsere ...

Linux Netzwerk
Raspberry Pi 3: WLAN Power save deaktivieren
Frage von nordie92Linux Netzwerk13 Kommentare

Moin moin, mein Raspberry Pi 3 Model B benötigt eine dauerhaft aktive WLAN-Verbindung. Leider bricht die WLAN-Verbindung nach einigen ...

SAN, NAS, DAS
Entscheidung SAN Dell oder HP
Frage von VincorSAN, NAS, DAS13 Kommentare

Hallo, wir wollen uns für unsere Hyper V Umgebung eine neue SAN Anschaffen. Es laufen 30 VM's darunter, DC; ...