Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Owncloud unter Server 2008 - iis 7 installieren

Mitglied: Xaero1982

Xaero1982 (Level 4) - Jetzt verbinden

26.02.2014 um 19:38 Uhr, 3312 Aufrufe, 9 Kommentare

Hallo Zusammen,

ich versuche gerade owncloud auf einem W2k8 Server mit ii7 zu installieren.

Mysql ist installiert und läuft
php ist ebenfalls installiert und läuft

Beim Aufruf bekomme ich:
01.
HTTP-Fehler 500.0 - Internal Server Error 
02.
Die Seite kann aufgrund eines internen Serverfehlers nicht angezeigt werden. 
03.
 
04.
Ausführliche FehlerinformationenModul	FastCgiModule 
05.
Benachrichtigung ExecuteRequestHandler 
06.
Handler	PHP_via_FastCGI 
07.
Fehlercode	0x00000000 
08.
Angeforderte URL	http://192.168.xxx.xxx:8000/index.php 
09.
Physikalischer Pfad	C:\inetpub\xxxxx\index.php 
10.
Anmeldemethode	 Negotiate 
11.
Angemeldeter Benutzer	servername\administrator
Nun hab ich schon diverse Seiten durchforstet und versucht, aber nichts hilft.

  • Berechtigungen stimmen
  • FastCGI ist installiert
  • CGI und ISAPI sind installiert
  • config.php von Owncloud ist angepasst mit dbname,pw,user - installed ist true
usw.

Noch jemand eine Idee wie ich das beheben kann?

Gruß
Mitglied: wiesi200
26.02.2014 um 19:43 Uhr
Hallo,
Teste mal bitte ob php überhaupt verarbeitet wird.
Ich sag das etwas mit FastCGI nicht stimmt nach der fehlermeldung
Bitte warten ..
Mitglied: Xaero1982
26.02.2014, aktualisiert um 19:58 Uhr
Hi wiesi,

deswegen schrieb ich ja:

01.
php ist ebenfalls installiert und läuft
Es läuft bereits joomla auf dem Server und das ohne Probleme.

Gruß
edit:

01.
System 	Windows NT XXXXXXX 6.0 build 6002 (Windows Server 2008 Enterprise Edition Service Pack 2) i586  
02.
Build Date 	Dec 10 2013 22:04:40  
03.
Compiler 	MSVC9 (Visual C++ 2008)  
04.
Architecture 	x86  
05.
Configure Command 	cscript /nologo configure.js "--enable-snapshot-build" "--enable-debug-pack" "--disable-zts" "--disable-isapi" "--disable-nsapi" "--without-mssql" "--without-pdo-mssql" "--without-pi3web" "--with-pdo-oci=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8-11g=C:\php-sdk\oracle\instantclient11\sdk,shared" "--with-enchant=shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet=shared" "--with-mcrypt=static" "--disable-static-analyze"  
06.
Server API 	CGI/FastCGI  
07.
Virtual Directory Support 	disabled  
08.
Configuration File (php.ini) Path 	C:\Windows  
09.
Loaded Configuration File 	C:\Program Files\PHP\php.ini  
10.
Scan this dir for additional .ini files 	(none)  
11.
Additional .ini files parsed 	(none)  
12.
PHP API 	20090626  
13.
PHP Extension 	20090626  
14.
Zend Extension 	220090626  
15.
Zend Extension Build 	API220090626,NTS,VC9  
16.
PHP Extension Build 	API20090626,NTS,VC9  
17.
Debug Build 	no  
18.
Thread Safety 	disabled  
19.
Zend Memory Manager 	enabled  
20.
Zend Multibyte Support 	disabled  
21.
IPv6 Support 	enabled  
22.
Registered PHP Streams 	php, file, glob, data, http, ftp, zip, compress.zlib, https, ftps, phar  
23.
Registered Stream Socket Transports 	tcp, udp, ssl, sslv3, sslv2, tls  
24.
Registered Stream Filters 	convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk, zlib.*
edit2: php läuft auch in dem virtuellen Verzeichnis in dem owncloud läuft.
Bitte warten ..
Mitglied: aqui
26.02.2014, aktualisiert um 20:18 Uhr
Setze eine Textdatei in das Verzeichnis mit dem Inhalt
<?php 
phpinfo(); 
?> 
und ruf die im Browser auf dann weisst du ob PHP dort sicher rennt.
"interner Serverfehler" hört sich nicht wirklich gesund an....
Bitte warten ..
Mitglied: Xaero1982
26.02.2014 um 20:36 Uhr
*hust*

was meinste denn woher ich diese infos habe aus dem Post davor?

PHP rennt zu 1000%. Wie bereits gesagt: joomla läuft. Auch im virtuellen Verzeichnis läuft PHP.

Also weitere Ideen?

Gruß
Bitte warten ..
Mitglied: sk-it83
27.02.2014 um 08:17 Uhr
Ich betreibe owncloud unter Linux kann dir da leider nicht weiterhelfen.

Ich gehe zwar von aus das du ne Anleitung verwendet hast, aber vllt. hilft dir ja dieses Tutorial
bei der Fehlersuche:


http://forum.owncloud.org/viewtopic.php?t=2370
Bitte warten ..
Mitglied: Xaero1982
27.02.2014 um 08:52 Uhr
Inzwischen hab ich es über den Webinstaller zum Laufen bekommen.


Danke

Gruß
Bitte warten ..
Mitglied: aqui
27.02.2014 um 09:59 Uhr
Mit Linux als OS und dem Apachen wär das auch gar nicht nicht erst passiert.....
"Linux is like a Wigwam: No Windows, no Gates, Apache inside..."
Bitte warten ..
Mitglied: Xaero1982
27.02.2014 um 12:25 Uhr
Nu ja ich hab hier nen windows server laufen über den dann auch die ad nutzeranbindung läuft. ..also von daher nix linux...

Gruß
Bitte warten ..
Mitglied: sk-it83
27.02.2014 um 13:11 Uhr
Naja ob das ein Argument ist sei mal dahingestellt. Die Nutzeranbindung unter Linux klappt auch wunderbar mit LDAP.
Bitte warten ..
Ähnliche Inhalte
SAN, NAS, DAS

OwnCloud auf Synology DS415+ installieren

gelöst Frage von konstantin90SAN, NAS, DAS5 Kommentare

Hallo zusammen, ich habe ein Problem und zwar ownCloud auf meiner DS415+ zu installieren. Ich habe es schon versucht ...

Tipps & Tricks

Windows Server 2008 R2 IIS 7 härten

Frage von pencilTipps & Tricks4 Kommentare

Guten Tag Ich möchte zwei IIS Server härten. Anbei habe ich eine kleine Liste mit Möglichkeiten. Da diese Liste ...

Apache Server

Raspberry Pi 3 Owncloud installieren

gelöst Frage von bestelittApache Server4 Kommentare

Hallo zusammen! Ich habe vor mir einen Dropboxersatz zusammenzustellen, also habe ich mir ein RPi3 und eine WD PiDrive ...

Hosting & Housing

Owncloud 7 externer FTP Storage

Frage von fisi90Hosting & Housing

Hallo Miteinander, habe ein kleines Problem mit Owncloud. Bei verschienenen Benutzern wurde ein externer FTP Speicher eingerichtet, was soweit ...

Neue Wissensbeiträge
Windows 10

USB Maus und Tastatur versagen Dienst unter Windows 10

Erfahrungsbericht von hardykopff vor 1 TagWindows 105 Kommentare

Da steht man ziemlich dumm da, wenn der PC sich wegen fehlender USB Tastatur und Maus nicht bedienen lässt. ...

Administrator.de Feedback
Update der Seite: Alles zentriert
Information von Frank vor 1 TagAdministrator.de Feedback18 Kommentare

Hallo User, die größte Änderung von Release 5.8 ist das Zentrieren der Webseite (auf großen Bildschirmen) und ein "Welcome"-Teaser ...

Humor (lol)

WhatsApp-Nachrichten endlich auch per Bluetooth versendbar

Information von BassFishFox vor 2 TagenHumor (lol)4 Kommentare

Genau darauf habe ich gewartet! ;-) Der beliebte Messaging-Dienst WhatsApp erhält eine praktische neue Funktion: Ab dem nächsten Update ...

Google Android

Googles "Android Enterprise Recommended" für Unternehmen

Information von kgborn vor 3 TagenGoogle Android3 Kommentare

Hier eine Information, die für Administratoren und Verantwortliche in Unternehmen, die für die Beschaffung und das Rollout von Android-Geräten ...

Heiß diskutierte Inhalte
Windows Server
Standortvernetzung zu einem Strato VServer (Windows)
Frage von matzefratze81Windows Server10 Kommentare

Moin, ich komme aus einem Enterprise-Umfeld und habe den Fehler gemacht, dass ich mich auf ein kleines Unternehmen eingelassen ...

Grafikkarten & Monitore
4k EIZO Monitor, Fernseher und Splitter
Frage von LerxxeyGrafikkarten & Monitore9 Kommentare

Hallo Zusammen, vielleicht könnt ihr mir bei einem Problem helfen wo ich einfach nicht mehr weiterkomme Und zwar haben ...

Microsoft Office
Freitagsfrage? Excel und CSV - Import statt öffnen
gelöst Frage von KraemerMicrosoft Office7 Kommentare

Moin zusammen, entweder fallen mir heute nicht die richtigen Wörter für Google ein, oder es geht schlicht nicht. Gibt ...

Entwicklung
Batch - Überprüfung
gelöst Frage von apex.predator24Entwicklung6 Kommentare

Hallo Zusammen Gibt es eine Möglichkeit, einen Prozess im TaskManager über eine Batch-Datei zu überprüfen ob dieser läuft oder ...